d0d8fbce3b
Resolves: #1991593
91 lines
2.8 KiB
Diff
91 lines
2.8 KiB
Diff
From ac21bd0c50584a1905a0da65d4bf9a6926ecd483 Mon Sep 17 00:00:00 2001
|
|
From: Felipe Borges <felipeborges@gnome.org>
|
|
Date: Wed, 11 Aug 2021 14:32:53 +0200
|
|
Subject: [PATCH] build: Downgrade meson dependency
|
|
|
|
Format strings got added in meson 0.58. This allows the meson
|
|
dependency to be downgraded to 0.56.
|
|
|
|
See https://mesonbuild.com/Syntax.html#string-formatting
|
|
---
|
|
gnome-autoar/meson.build | 12 ++++++------
|
|
meson.build | 4 ++--
|
|
2 files changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/gnome-autoar/meson.build b/gnome-autoar/meson.build
|
|
index 30533a1..8852da8 100644
|
|
--- a/gnome-autoar/meson.build
|
|
+++ b/gnome-autoar/meson.build
|
|
@@ -3,7 +3,7 @@
|
|
|
|
src_inc = include_directories('.')
|
|
|
|
-libname = f'@gnome_autoar_name@-@gnome_autoar_api_version@'
|
|
+libname= '@0@-@1@'.format(gnome_autoar_name, gnome_autoar_api_version)
|
|
|
|
headers = files(
|
|
'autoar-compressor.h',
|
|
@@ -31,8 +31,8 @@ enum_types = 'autoar-enum-types'
|
|
enum_sources = gnome.mkenums(
|
|
enum_types,
|
|
sources: headers,
|
|
- h_template: f'@enum_types@.h.template',
|
|
- c_template: f'@enum_types@.c.template',
|
|
+ h_template: '@0@.h.template'.format(enum_types),
|
|
+ c_template: '@0@.c.template'.format(enum_types),
|
|
install_header: true,
|
|
install_dir: gnome_autoar_includedir / libname / gnome_autoar_name,
|
|
)
|
|
@@ -86,7 +86,7 @@ if enable_introspection
|
|
namespace: api_ns,
|
|
nsversion: gnome_autoar_api_ns_version,
|
|
identifier_prefix: gnome_autoar_api_prefix,
|
|
- export_packages: f'@api_ns@-@gnome_autoar_api_ns_version@',
|
|
+ export_packages: '@0@-@1@'.format(api_ns, gnome_autoar_api_ns_version),
|
|
install: true,
|
|
)
|
|
|
|
@@ -104,7 +104,7 @@ if not enable_gtk
|
|
subdir_done()
|
|
endif
|
|
|
|
-libname_gtk = f'@gnome_autoar_name@-gtk-@gnome_autoar_api_version@'
|
|
+libname_gtk = '@0@-gtk-@1@'.format(gnome_autoar_name, gnome_autoar_api_version)
|
|
|
|
headers = files(
|
|
'autoar-gtk-chooser.h',
|
|
@@ -161,7 +161,7 @@ if enable_introspection
|
|
namespace: api_ns,
|
|
nsversion: gnome_autoar_api_ns_version,
|
|
identifier_prefix: 'AutoarGtk',
|
|
- export_packages: f'@api_ns@-@gnome_autoar_api_ns_version@',
|
|
+ export_packages: '@0@-@1@'.format(api_ns, gnome_autoar_api_ns_version),
|
|
install: true,
|
|
)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 2c26cde..fe9afd5 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -6,7 +6,7 @@ project(
|
|
version: '0.4.0',
|
|
license: 'LGPL2.1+',
|
|
default_options: 'buildtype=debugoptimized',
|
|
- meson_version: '>= 0.58.0',
|
|
+ meson_version: '>= 0.56.0',
|
|
)
|
|
|
|
gnome_autoar_name = meson.project_name()
|
|
@@ -96,7 +96,7 @@ gtk_dep = dependency(
|
|
'gtk+-3.0',
|
|
version: gtk_req_version,
|
|
required: get_option('gtk'),
|
|
- not_found_message: f'GTK+ support requested but gtk+-3.0 @gtk_req_version@ could not be found',
|
|
+ not_found_message: 'GTK+ support requested but gtk+-3.0 @0@ could not be found'.format(gtk_req_version),
|
|
)
|
|
enable_gtk = gtk_dep.found()
|
|
|
|
--
|
|
2.31.1
|
|
|