4.8.2-1
This commit is contained in:
parent
01c6d18afa
commit
5652b86227
1
.gitignore
vendored
1
.gitignore
vendored
@ -85,3 +85,4 @@
|
||||
/gcc-4.8.1-20130909.tar.bz2
|
||||
/gcc-4.8.1-20130915.tar.bz2
|
||||
/gcc-4.8.1-20130920.tar.bz2
|
||||
/gcc-4.8.2-20131017.tar.bz2
|
||||
|
45
gcc.spec
45
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130920
|
||||
%global SVNREV 202765
|
||||
%global gcc_version 4.8.1
|
||||
%global DATE 20131017
|
||||
%global SVNREV 203741
|
||||
%global gcc_version 4.8.2
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 10
|
||||
%global gcc_release 1
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -819,7 +819,7 @@ tar xjf %{SOURCE10}
|
||||
|
||||
%patch1100 -p0 -b .isl-aarch64~
|
||||
|
||||
sed -i -e 's/4\.8\.2/4.8.1/' gcc/BASE-VER
|
||||
sed -i -e 's/4\.8\.3/4.8.2/' gcc/BASE-VER
|
||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||
|
||||
%if 0%{?fedora} >= 16 || 0%{?rhel} >= 7
|
||||
@ -966,6 +966,7 @@ cd ../..
|
||||
CC=gcc
|
||||
OPT_FLAGS=`echo %{optflags}|sed -e 's/\(-Wp,\)\?-D_FORTIFY_SOURCE=[12]//g'`
|
||||
OPT_FLAGS=`echo $OPT_FLAGS|sed -e 's/-m64//g;s/-m32//g;s/-m31//g'`
|
||||
OPT_FLAGS=`echo $OPT_FLAGS|sed -e 's/-mfpmath=sse/-mfpmath=sse -msse2/g'`
|
||||
OPT_FLAGS=`echo $OPT_FLAGS|sed -e 's/ -pipe / /g'`
|
||||
%ifarch sparc
|
||||
OPT_FLAGS=`echo $OPT_FLAGS|sed -e 's/-mcpu=ultrasparc/-mtune=ultrasparc/g;s/-mcpu=v[78]//g'`
|
||||
@ -1065,12 +1066,21 @@ CC="$CC" CFLAGS="$OPT_FLAGS" \
|
||||
%ifarch %{ix86} x86_64
|
||||
--with-tune=generic \
|
||||
%endif
|
||||
%if 0%{?rhel} >= 7
|
||||
%ifarch %{ix86}
|
||||
--with-arch=x86-64 \
|
||||
%endif
|
||||
%ifarch x86_64
|
||||
--with-arch_32=x86-64 \
|
||||
%endif
|
||||
%else
|
||||
%ifarch %{ix86}
|
||||
--with-arch=i686 \
|
||||
%endif
|
||||
%ifarch x86_64
|
||||
--with-arch_32=i686 \
|
||||
%endif
|
||||
%endif
|
||||
%ifarch s390 s390x
|
||||
%if 0%{?rhel} >= 7
|
||||
--with-arch=z10 --with-tune=zEC12 --enable-decimal-float \
|
||||
@ -3009,12 +3019,33 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Thu Oct 17 2013 Jakub Jelinek <jakub@redhat.com> 4.8.2-1
|
||||
- update from the 4.8 branch
|
||||
- GCC 4.8.2 release
|
||||
- PRs c++/57850, c++/58633, libstdc++/58191
|
||||
|
||||
* Thu Oct 10 2013 Jakub Jelinek <jakub@redhat.com> 4.8.1-12
|
||||
- update from the 4.8 branch
|
||||
- PRs c++/58568, fortran/55469, fortran/57697, fortran/58469,
|
||||
libstdc++/57465, libstdc++/57641, libstdc++/58659, target/58460,
|
||||
tree-optimization/58539
|
||||
- fix asm goto handling (#1017704, PR middle-end/58670)
|
||||
|
||||
* Wed Oct 2 2013 Jakub Jelinek <jakub@redhat.com> 4.8.1-11
|
||||
- update from the 4.8 branch
|
||||
- PRs c++/58535, libstdc++/58437, libstdc++/58569, middle-end/56791,
|
||||
middle-end/58463, middle-end/58564, target/58330,
|
||||
tree-optimization/56716
|
||||
- fix s390x z10+ chunkification (#1012870, PR target/58574)
|
||||
- disable ppc{,64} -mvsx-timode by default (#1014053, PR target/58587)
|
||||
|
||||
* Fri Sep 20 2013 Jakub Jelinek <jakub@redhat.com> 4.8.1-10
|
||||
- update from the 4.8 branch
|
||||
- PRs ada/58264, c++/58457, c++/58458, libstdc++/58358,
|
||||
tree-optimization/58088
|
||||
- on RHEL7, configure on ppc/ppc64 with default -mcpu=power7 and
|
||||
on s390/s390x with default -march=z10 -mtune=zEC12 (#805157)
|
||||
- on RHEL7, configure on ppc/ppc64 with default -mcpu=power7,
|
||||
on s390/s390x with default -march=z10 -mtune=zEC12 and
|
||||
on i?86 default to -march=x86-64 -mtune=generic (#805157)
|
||||
- on Fedora 20+ and RHEL7 default to -fdiagnostics-color=auto
|
||||
rather than -fdiagnostics-color=never, if GCC_COLORS isn't
|
||||
in the environment; to turn it off by default, set GCC_COLORS=
|
||||
|
@ -6,17 +6,6 @@
|
||||
* doc/invoke.texi (-fdiagnostics-color*): Adjust documentation
|
||||
of the default.
|
||||
|
||||
PR testsuite/57605
|
||||
libstdc++-v3/
|
||||
* testsuite/lib/libstdc++.exp (libstdc++_init): Prepend
|
||||
-fdiagnostics-color=never to cxxflags.
|
||||
libmudflap/
|
||||
* testsuite/lib/libmudflap.exp (libmudflap-init): Append
|
||||
-fdiagnostics-color=never to cxxflags.
|
||||
libgomp/
|
||||
* testsuite/lib/libgomp.exp: Add -fdiagnostics-color=never to
|
||||
ALWAYS_CFLAGS.
|
||||
|
||||
--- gcc/common.opt.jj 2013-09-18 12:06:53.000000000 +0200
|
||||
+++ gcc/common.opt 2013-09-20 10:00:00.935823900 +0200
|
||||
@@ -1037,7 +1037,7 @@ Common Alias(fdiagnostics-color=,always,
|
||||
@ -55,37 +44,3 @@ libgomp/
|
||||
@samp{auto} means to use color only when the standard error is a terminal.
|
||||
The forms @option{-fdiagnostics-color} and @option{-fno-diagnostics-color} are
|
||||
aliases for @option{-fdiagnostics-color=always} and
|
||||
--- libstdc++-v3/testsuite/lib/libstdc++.exp.jj 2013-08-12 21:18:45.000000000 +0200
|
||||
+++ libstdc++-v3/testsuite/lib/libstdc++.exp 2013-09-20 12:13:41.342720820 +0200
|
||||
@@ -283,7 +283,7 @@ proc libstdc++_init { testfile } {
|
||||
v3track cxxflags 2
|
||||
|
||||
# Always use MO files built by this test harness.
|
||||
- set cxxflags "$cxxflags -DLOCALEDIR=\".\""
|
||||
+ set cxxflags "-fdiagnostics-color=never $cxxflags -DLOCALEDIR=\".\""
|
||||
set ccflags "$cxxflags -DLOCALEDIR=\".\""
|
||||
|
||||
# If a PCH file is available, use it. We must delay performing
|
||||
--- libmudflap/testsuite/lib/libmudflap.exp.jj 2013-02-04 14:49:32.000000000 +0100
|
||||
+++ libmudflap/testsuite/lib/libmudflap.exp 2013-09-20 12:16:31.760710659 +0200
|
||||
@@ -85,7 +85,7 @@ proc libmudflap-init { language } {
|
||||
append ld_library_path ":${blddir}/.libs"
|
||||
|
||||
set libs "-L${blddir}/.libs"
|
||||
- set cxxflags "-ggdb3 -DDEBUG_ASSERT"
|
||||
+ set cxxflags "-ggdb3 -DDEBUG_ASSERT -fdiagnostics-color=never"
|
||||
set includes "-I${srcdir} -I${srcdir}/.. -I.."
|
||||
|
||||
if {$language == "c++"} {
|
||||
--- libgomp/testsuite/lib/libgomp.exp.jj 2013-06-25 11:47:20.000000000 +0200
|
||||
+++ libgomp/testsuite/lib/libgomp.exp 2013-09-20 11:51:32.885800025 +0200
|
||||
@@ -167,6 +167,9 @@ proc libgomp_init { args } {
|
||||
# Disable caret
|
||||
lappend ALWAYS_CFLAGS "additional_flags=-fno-diagnostics-show-caret"
|
||||
|
||||
+ # Disable color diagnostics
|
||||
+ lappend ALWAYS_CFLAGS "additional_flags=-fdiagnostics-color=never"
|
||||
+
|
||||
# And, gee, turn on OpenMP.
|
||||
lappend ALWAYS_CFLAGS "additional_flags=-fopenmp"
|
||||
}
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
338fd150767b3c00192e54d1712aa79d gcc-4.8.1-20130920.tar.bz2
|
||||
c1817e33ad5123b5b635a428db89cd07 gcc-4.8.2-20131017.tar.bz2
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user