4.8.1-10
This commit is contained in:
parent
e175f3e4b7
commit
01c6d18afa
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@
|
||||
/gcc-4.8.1-20130829.tar.bz2
|
||||
/gcc-4.8.1-20130909.tar.bz2
|
||||
/gcc-4.8.1-20130915.tar.bz2
|
||||
/gcc-4.8.1-20130920.tar.bz2
|
||||
|
27
gcc.spec
27
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130915
|
||||
%global SVNREV 202602
|
||||
%global DATE 20130920
|
||||
%global SVNREV 202765
|
||||
%global gcc_version 4.8.1
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 9
|
||||
%global gcc_release 10
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -195,6 +195,7 @@ Patch11: gcc48-libstdc++-docs.patch
|
||||
Patch12: gcc48-no-add-needed.patch
|
||||
Patch13: gcc48-pr56564.patch
|
||||
Patch14: gcc48-pr56493.patch
|
||||
Patch15: gcc48-color-auto.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -750,6 +751,9 @@ package or when debugging this package.
|
||||
%patch12 -p0 -b .no-add-needed~
|
||||
%patch13 -p0 -b .pr56564~
|
||||
%patch14 -p0 -b .pr56493~
|
||||
%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
|
||||
%patch15 -p0 -b .color-auto~
|
||||
%endif
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -1049,7 +1053,7 @@ CC="$CC" CFLAGS="$OPT_FLAGS" \
|
||||
%endif
|
||||
%ifarch ppc ppc64
|
||||
%if 0%{?rhel} >= 7
|
||||
--with-cpu-32=power4 --with-tune-32=power7 --with-cpu-64=power4 --with-tune-64=power7 \
|
||||
--with-cpu-32=power7 --with-tune-32=power7 --with-cpu-64=power7 --with-tune-64=power7 \
|
||||
%endif
|
||||
%if 0%{?rhel} == 6
|
||||
--with-cpu-32=power4 --with-tune-32=power6 --with-cpu-64=power4 --with-tune-64=power6 \
|
||||
@ -1068,8 +1072,12 @@ CC="$CC" CFLAGS="$OPT_FLAGS" \
|
||||
--with-arch_32=i686 \
|
||||
%endif
|
||||
%ifarch s390 s390x
|
||||
%if 0%{?rhel} >= 7
|
||||
--with-arch=z10 --with-tune=zEC12 --enable-decimal-float \
|
||||
%else
|
||||
--with-arch=z9-109 --with-tune=z10 --enable-decimal-float \
|
||||
%endif
|
||||
%endif
|
||||
%ifarch armv7hl
|
||||
--with-cpu=cortex-a8 --with-tune=cortex-a8 --with-arch=armv7-a \
|
||||
--with-float=hard --with-fpu=vfpv3-d16 --with-abi=aapcs-linux \
|
||||
@ -3001,6 +3009,17 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Fri Sep 20 2013 Jakub Jelinek <jakub@redhat.com> 4.8.1-10
|
||||
- update from the 4.8 branch
|
||||
- PRs ada/58264, c++/58457, c++/58458, libstdc++/58358,
|
||||
tree-optimization/58088
|
||||
- on RHEL7, configure on ppc/ppc64 with default -mcpu=power7 and
|
||||
on s390/s390x with default -march=z10 -mtune=zEC12 (#805157)
|
||||
- on Fedora 20+ and RHEL7 default to -fdiagnostics-color=auto
|
||||
rather than -fdiagnostics-color=never, if GCC_COLORS isn't
|
||||
in the environment; to turn it off by default, set GCC_COLORS=
|
||||
in the environment
|
||||
|
||||
* Sun Sep 15 2013 Jakub Jelinek <jakub@redhat.com> 4.8.1-9
|
||||
- update from the 4.8 branch
|
||||
- PRs c++/58273, libstdc++/58415, middle-end/58377, rtl-optimization/58365,
|
||||
|
91
gcc48-color-auto.patch
Normal file
91
gcc48-color-auto.patch
Normal file
@ -0,0 +1,91 @@
|
||||
2013-09-20 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* common.opt (-fdiagnostics-color=): Default to auto.
|
||||
* toplev.c (process_options): Always default to
|
||||
-fdiagnostics-color=auto if no -f{,no-}diagnostics-color*.
|
||||
* doc/invoke.texi (-fdiagnostics-color*): Adjust documentation
|
||||
of the default.
|
||||
|
||||
PR testsuite/57605
|
||||
libstdc++-v3/
|
||||
* testsuite/lib/libstdc++.exp (libstdc++_init): Prepend
|
||||
-fdiagnostics-color=never to cxxflags.
|
||||
libmudflap/
|
||||
* testsuite/lib/libmudflap.exp (libmudflap-init): Append
|
||||
-fdiagnostics-color=never to cxxflags.
|
||||
libgomp/
|
||||
* testsuite/lib/libgomp.exp: Add -fdiagnostics-color=never to
|
||||
ALWAYS_CFLAGS.
|
||||
|
||||
--- gcc/common.opt.jj 2013-09-18 12:06:53.000000000 +0200
|
||||
+++ gcc/common.opt 2013-09-20 10:00:00.935823900 +0200
|
||||
@@ -1037,7 +1037,7 @@ Common Alias(fdiagnostics-color=,always,
|
||||
;
|
||||
|
||||
fdiagnostics-color=
|
||||
-Common Joined RejectNegative Var(flag_diagnostics_show_color) Enum(diagnostic_color_rule) Init(DIAGNOSTICS_COLOR_NO)
|
||||
+Common Joined RejectNegative Var(flag_diagnostics_show_color) Enum(diagnostic_color_rule) Init(DIAGNOSTICS_COLOR_AUTO)
|
||||
-fdiagnostics-color=[never|always|auto] Colorize diagnostics
|
||||
|
||||
; Required for these enum values.
|
||||
--- gcc/toplev.c.jj 2013-09-09 11:32:39.000000000 +0200
|
||||
+++ gcc/toplev.c 2013-09-20 10:10:08.198721005 +0200
|
||||
@@ -1229,10 +1229,8 @@ process_options (void)
|
||||
|
||||
maximum_field_alignment = initial_max_fld_align * BITS_PER_UNIT;
|
||||
|
||||
- /* Default to -fdiagnostics-color=auto if GCC_COLORS is in the environment,
|
||||
- otherwise default to -fdiagnostics-color=never. */
|
||||
- if (!global_options_set.x_flag_diagnostics_show_color
|
||||
- && getenv ("GCC_COLORS"))
|
||||
+ /* Default to -fdiagnostics-color=auto. */
|
||||
+ if (!global_options_set.x_flag_diagnostics_show_color)
|
||||
pp_show_color (global_dc->printer)
|
||||
= colorize_init (DIAGNOSTICS_COLOR_AUTO);
|
||||
|
||||
--- gcc/doc/invoke.texi.jj 2013-09-18 12:06:50.000000000 +0200
|
||||
+++ gcc/doc/invoke.texi 2013-09-20 10:09:29.079904455 +0200
|
||||
@@ -3046,8 +3046,7 @@ a message which is too long to fit on a
|
||||
@cindex highlight, color, colour
|
||||
@vindex GCC_COLORS @r{environment variable}
|
||||
Use color in diagnostics. @var{WHEN} is @samp{never}, @samp{always},
|
||||
-or @samp{auto}. The default is @samp{never} if @env{GCC_COLORS} environment
|
||||
-variable isn't present in the environment, and @samp{auto} otherwise.
|
||||
+or @samp{auto}. The default is @samp{auto}.
|
||||
@samp{auto} means to use color only when the standard error is a terminal.
|
||||
The forms @option{-fdiagnostics-color} and @option{-fno-diagnostics-color} are
|
||||
aliases for @option{-fdiagnostics-color=always} and
|
||||
--- libstdc++-v3/testsuite/lib/libstdc++.exp.jj 2013-08-12 21:18:45.000000000 +0200
|
||||
+++ libstdc++-v3/testsuite/lib/libstdc++.exp 2013-09-20 12:13:41.342720820 +0200
|
||||
@@ -283,7 +283,7 @@ proc libstdc++_init { testfile } {
|
||||
v3track cxxflags 2
|
||||
|
||||
# Always use MO files built by this test harness.
|
||||
- set cxxflags "$cxxflags -DLOCALEDIR=\".\""
|
||||
+ set cxxflags "-fdiagnostics-color=never $cxxflags -DLOCALEDIR=\".\""
|
||||
set ccflags "$cxxflags -DLOCALEDIR=\".\""
|
||||
|
||||
# If a PCH file is available, use it. We must delay performing
|
||||
--- libmudflap/testsuite/lib/libmudflap.exp.jj 2013-02-04 14:49:32.000000000 +0100
|
||||
+++ libmudflap/testsuite/lib/libmudflap.exp 2013-09-20 12:16:31.760710659 +0200
|
||||
@@ -85,7 +85,7 @@ proc libmudflap-init { language } {
|
||||
append ld_library_path ":${blddir}/.libs"
|
||||
|
||||
set libs "-L${blddir}/.libs"
|
||||
- set cxxflags "-ggdb3 -DDEBUG_ASSERT"
|
||||
+ set cxxflags "-ggdb3 -DDEBUG_ASSERT -fdiagnostics-color=never"
|
||||
set includes "-I${srcdir} -I${srcdir}/.. -I.."
|
||||
|
||||
if {$language == "c++"} {
|
||||
--- libgomp/testsuite/lib/libgomp.exp.jj 2013-06-25 11:47:20.000000000 +0200
|
||||
+++ libgomp/testsuite/lib/libgomp.exp 2013-09-20 11:51:32.885800025 +0200
|
||||
@@ -167,6 +167,9 @@ proc libgomp_init { args } {
|
||||
# Disable caret
|
||||
lappend ALWAYS_CFLAGS "additional_flags=-fno-diagnostics-show-caret"
|
||||
|
||||
+ # Disable color diagnostics
|
||||
+ lappend ALWAYS_CFLAGS "additional_flags=-fdiagnostics-color=never"
|
||||
+
|
||||
# And, gee, turn on OpenMP.
|
||||
lappend ALWAYS_CFLAGS "additional_flags=-fopenmp"
|
||||
}
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
42ba2efe4f6a90305bd407440580855a gcc-4.8.1-20130915.tar.bz2
|
||||
338fd150767b3c00192e54d1712aa79d gcc-4.8.1-20130920.tar.bz2
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user