4.8.0-0.17
This commit is contained in:
parent
89bd8eeaf5
commit
220b984b00
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@
|
||||
/gcc-4.8.0-20130220.tar.bz2
|
||||
/gcc-4.8.0-20130304.tar.bz2
|
||||
/gcc-4.8.0-20130307.tar.bz2
|
||||
/gcc-4.8.0-20130316.tar.bz2
|
||||
|
18
gcc.spec
18
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130307
|
||||
%global SVNREV 196524
|
||||
%global DATE 20130316
|
||||
%global SVNREV 196702
|
||||
%global gcc_version 4.8.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.16
|
||||
%global gcc_release 0.17
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -194,7 +194,6 @@ Patch10: gcc48-pr38757.patch
|
||||
Patch11: gcc48-libstdc++-docs.patch
|
||||
Patch12: gcc48-no-add-needed.patch
|
||||
Patch13: gcc48-pr55608.patch
|
||||
Patch14: gcc48-pr45078.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -749,7 +748,6 @@ package or when debugging this package.
|
||||
%endif
|
||||
%patch12 -p0 -b .no-add-needed~
|
||||
%patch13 -p0 -b .pr55608~
|
||||
%patch14 -p0 -b .pr45078~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -2975,6 +2973,16 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Sat Mar 16 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.17
|
||||
- update from trunk and the 4.8 branch
|
||||
- PRs ada/52123, c++/51412, c++/51494, c++/51884, c++/52183, c++/56222,
|
||||
c++/56346, c++/56565, c++/56567, c++/56611, c++/56614, debug/56307,
|
||||
fortran/56575, fortran/56615, libstdc++/56492, libstdc++/56609,
|
||||
libstdc++/56613, lto/56557, middle-end/56524, middle-end/56571,
|
||||
target/40797, target/49880, target/56470, target/56591, target/56619,
|
||||
testsuite/54119, tree-optimization/53265, tree-optimization/56478,
|
||||
tree-optimization/56570, tree-optimization/56608
|
||||
|
||||
* Thu Mar 7 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.16
|
||||
- updated from trunk
|
||||
- PRs bootstrap/56509, c++/54383, c++/55135, c++/56464, c++/56530,
|
||||
|
@ -1,54 +0,0 @@
|
||||
2013-03-06 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR plugins/45078
|
||||
* config.gcc: On arm, mips, sh and sparc add vxworks-dummy.h to
|
||||
tm_file.
|
||||
|
||||
--- gcc/config.gcc.jj 2013-02-22 17:04:41.000000000 +0100
|
||||
+++ gcc/config.gcc 2013-03-06 13:38:19.711201446 +0100
|
||||
@@ -536,6 +536,9 @@ x86_64-*-*)
|
||||
fi
|
||||
tm_file="vxworks-dummy.h ${tm_file}"
|
||||
;;
|
||||
+arm*-*-* | mips*-*-* | sh*-*-* | sparc*-*-*)
|
||||
+ tm_file="vxworks-dummy.h ${tm_file}"
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
# On a.out targets, we need to use collect2.
|
||||
@@ -861,7 +864,7 @@ arm-wrs-vxworks)
|
||||
tmake_file="${tmake_file} arm/t-arm arm/t-vxworks"
|
||||
;;
|
||||
arm*-*-netbsdelf*)
|
||||
- tm_file="dbxelf.h elfos.h netbsd.h netbsd-elf.h arm/elf.h arm/aout.h arm/arm.h arm/netbsd-elf.h"
|
||||
+ tm_file="dbxelf.h elfos.h netbsd.h netbsd-elf.h arm/elf.h arm/aout.h ${tm_file} arm/netbsd-elf.h"
|
||||
extra_options="${extra_options} netbsd.opt netbsd-elf.opt"
|
||||
tmake_file="${tmake_file} arm/t-arm"
|
||||
;;
|
||||
@@ -873,7 +876,7 @@ arm*-*-linux-*) # ARM GNU/Linux with E
|
||||
;;
|
||||
esac
|
||||
tmake_file="${tmake_file} arm/t-arm arm/t-arm-elf arm/t-bpabi arm/t-linux-eabi"
|
||||
- tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h arm/aout.h arm/arm.h"
|
||||
+ tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
# Define multilib configuration for arm-linux-androideabi.
|
||||
case ${target} in
|
||||
*-androideabi)
|
||||
@@ -891,7 +894,7 @@ arm*-*-linux-*) # ARM GNU/Linux with E
|
||||
arm*-*-uclinux*eabi*) # ARM ucLinux
|
||||
tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/linux-gas.h arm/uclinux-elf.h glibc-stdint.h"
|
||||
tmake_file="arm/t-arm arm/t-arm-elf arm/t-bpabi"
|
||||
- tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h arm/aout.h arm/arm.h"
|
||||
+ tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
# The BPABI long long divmod functions return a 128-bit value in
|
||||
# registers r0-r3. Correctly modeling that requires the use of
|
||||
# TImode.
|
||||
@@ -928,7 +931,7 @@ arm*-*-eabi* | arm*-*-symbianelf* | arm*
|
||||
tmake_file="${tmake_file} arm/t-symbian"
|
||||
;;
|
||||
esac
|
||||
- tm_file="${tm_file} arm/aout.h arm/arm.h"
|
||||
+ tm_file="${tm_file} arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
;;
|
||||
avr-*-rtems*)
|
||||
tm_file="elfos.h avr/elf.h avr/avr-arch.h avr/avr.h dbxelf.h avr/rtems.h rtems.h newlib-stdint.h"
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
5261d63f6322fdd1b871da3dece37371 gcc-4.8.0-20130307.tar.bz2
|
||||
2d5a7cef12a05d7ab3aa66c6e82d28d5 gcc-4.8.0-20130316.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user