4.8.0-0.16
This commit is contained in:
parent
2bea4b26c1
commit
89bd8eeaf5
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@
|
||||
/gcc-4.8.0-20130215.tar.bz2
|
||||
/gcc-4.8.0-20130220.tar.bz2
|
||||
/gcc-4.8.0-20130304.tar.bz2
|
||||
/gcc-4.8.0-20130307.tar.bz2
|
||||
|
28
gcc.spec
28
gcc.spec
@ -1,9 +1,9 @@
|
||||
%global DATE 20130304
|
||||
%global SVNREV 196430
|
||||
%global DATE 20130307
|
||||
%global SVNREV 196524
|
||||
%global gcc_version 4.8.0
|
||||
# Note, gcc_release must be integer, if you want to add suffixes to
|
||||
# %{release}, append them after %{gcc_release} on Release: line.
|
||||
%global gcc_release 0.15
|
||||
%global gcc_release 0.16
|
||||
%global _unpackaged_files_terminate_build 0
|
||||
%global multilib_64_archs sparc64 ppc64 s390x x86_64
|
||||
%ifarch %{ix86} x86_64 ia64 ppc ppc64 alpha
|
||||
@ -194,8 +194,7 @@ Patch10: gcc48-pr38757.patch
|
||||
Patch11: gcc48-libstdc++-docs.patch
|
||||
Patch12: gcc48-no-add-needed.patch
|
||||
Patch13: gcc48-pr55608.patch
|
||||
Patch14: gcc48-pr56424.patch
|
||||
Patch15: gcc48-pr56509.patch
|
||||
Patch14: gcc48-pr45078.patch
|
||||
|
||||
Patch1000: fastjar-0.97-segfault.patch
|
||||
Patch1001: fastjar-0.97-len1.patch
|
||||
@ -203,6 +202,8 @@ Patch1002: fastjar-0.97-filename0.patch
|
||||
Patch1003: fastjar-CVE-2010-0831.patch
|
||||
Patch1004: fastjar-man.patch
|
||||
|
||||
Patch1100: isl-%{isl_version}-aarch64-config.patch
|
||||
|
||||
# On ARM EABI systems, we do want -gnueabi to be part of the
|
||||
# target triple.
|
||||
%ifnarch %{arm}
|
||||
@ -748,8 +749,7 @@ package or when debugging this package.
|
||||
%endif
|
||||
%patch12 -p0 -b .no-add-needed~
|
||||
%patch13 -p0 -b .pr55608~
|
||||
%patch14 -p0 -b .pr56424~
|
||||
%patch15 -p0 -b .pr56509~
|
||||
%patch14 -p0 -b .pr45078~
|
||||
|
||||
%if 0%{?_enable_debug_packages}
|
||||
cat > split-debuginfo.sh <<\EOF
|
||||
@ -813,6 +813,8 @@ tar xzf %{SOURCE4}
|
||||
tar xjf %{SOURCE10}
|
||||
%endif
|
||||
|
||||
%patch1100 -p0 -b .isl-aarch64~
|
||||
|
||||
sed -i -e 's/4\.8\.0/4.8.0/' gcc/BASE-VER
|
||||
echo 'Red Hat %{version}-%{gcc_release}' > gcc/DEV-PHASE
|
||||
|
||||
@ -2973,6 +2975,18 @@ fi
|
||||
%{_prefix}/libexec/gcc/%{gcc_target_platform}/%{gcc_version}/plugin
|
||||
|
||||
%changelog
|
||||
* Thu Mar 7 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.16
|
||||
- updated from trunk
|
||||
- PRs bootstrap/56509, c++/54383, c++/55135, c++/56464, c++/56530,
|
||||
c++/56534, c++/56543, debug/55364, debug/56510, libquadmath/55473,
|
||||
lto/50293, lto/56515, middle-end/50494, middle-end/56294,
|
||||
middle-end/56525, middle-end/56526, middle-end/56548,
|
||||
rtl-optimization/56484, rtl-optimization/56494, target/56529,
|
||||
tree-optimization/56270, tree-optimization/56521,
|
||||
tree-optimization/56539, tree-optimization/56559
|
||||
- include arm-cores.def in gcc-python-plugin on arm (#910926)
|
||||
- include vxworks-dummy.h in gcc-python-plugin where needed (PR plugins/45078)
|
||||
|
||||
* Mon Mar 4 2013 Jakub Jelinek <jakub@redhat.com> 4.8.0-0.15
|
||||
- updated from trunk
|
||||
- PRs c++/10291, c++/40405, c++/52688, c++/55632, c++/55813, c++/56243,
|
||||
|
54
gcc48-pr45078.patch
Normal file
54
gcc48-pr45078.patch
Normal file
@ -0,0 +1,54 @@
|
||||
2013-03-06 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR plugins/45078
|
||||
* config.gcc: On arm, mips, sh and sparc add vxworks-dummy.h to
|
||||
tm_file.
|
||||
|
||||
--- gcc/config.gcc.jj 2013-02-22 17:04:41.000000000 +0100
|
||||
+++ gcc/config.gcc 2013-03-06 13:38:19.711201446 +0100
|
||||
@@ -536,6 +536,9 @@ x86_64-*-*)
|
||||
fi
|
||||
tm_file="vxworks-dummy.h ${tm_file}"
|
||||
;;
|
||||
+arm*-*-* | mips*-*-* | sh*-*-* | sparc*-*-*)
|
||||
+ tm_file="vxworks-dummy.h ${tm_file}"
|
||||
+ ;;
|
||||
esac
|
||||
|
||||
# On a.out targets, we need to use collect2.
|
||||
@@ -861,7 +864,7 @@ arm-wrs-vxworks)
|
||||
tmake_file="${tmake_file} arm/t-arm arm/t-vxworks"
|
||||
;;
|
||||
arm*-*-netbsdelf*)
|
||||
- tm_file="dbxelf.h elfos.h netbsd.h netbsd-elf.h arm/elf.h arm/aout.h arm/arm.h arm/netbsd-elf.h"
|
||||
+ tm_file="dbxelf.h elfos.h netbsd.h netbsd-elf.h arm/elf.h arm/aout.h ${tm_file} arm/netbsd-elf.h"
|
||||
extra_options="${extra_options} netbsd.opt netbsd-elf.opt"
|
||||
tmake_file="${tmake_file} arm/t-arm"
|
||||
;;
|
||||
@@ -873,7 +876,7 @@ arm*-*-linux-*) # ARM GNU/Linux with E
|
||||
;;
|
||||
esac
|
||||
tmake_file="${tmake_file} arm/t-arm arm/t-arm-elf arm/t-bpabi arm/t-linux-eabi"
|
||||
- tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h arm/aout.h arm/arm.h"
|
||||
+ tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
# Define multilib configuration for arm-linux-androideabi.
|
||||
case ${target} in
|
||||
*-androideabi)
|
||||
@@ -891,7 +894,7 @@ arm*-*-linux-*) # ARM GNU/Linux with E
|
||||
arm*-*-uclinux*eabi*) # ARM ucLinux
|
||||
tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/linux-gas.h arm/uclinux-elf.h glibc-stdint.h"
|
||||
tmake_file="arm/t-arm arm/t-arm-elf arm/t-bpabi"
|
||||
- tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h arm/aout.h arm/arm.h"
|
||||
+ tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
# The BPABI long long divmod functions return a 128-bit value in
|
||||
# registers r0-r3. Correctly modeling that requires the use of
|
||||
# TImode.
|
||||
@@ -928,7 +931,7 @@ arm*-*-eabi* | arm*-*-symbianelf* | arm*
|
||||
tmake_file="${tmake_file} arm/t-symbian"
|
||||
;;
|
||||
esac
|
||||
- tm_file="${tm_file} arm/aout.h arm/arm.h"
|
||||
+ tm_file="${tm_file} arm/aout.h vxworks-dummy.h arm/arm.h"
|
||||
;;
|
||||
avr-*-rtems*)
|
||||
tm_file="elfos.h avr/elf.h avr/avr-arch.h avr/avr.h dbxelf.h avr/rtems.h rtems.h newlib-stdint.h"
|
@ -1,57 +0,0 @@
|
||||
2013-03-04 Eric Botcazou <ebotcazou@adacore.com>
|
||||
|
||||
PR tree-optimization/56424
|
||||
* ipa-split.c (split_function): Do not set the RSO flag if result is
|
||||
not by reference and its type is not a register type.
|
||||
|
||||
* gcc.dg/pr56424.c: New test.
|
||||
|
||||
--- gcc/ipa-split.c (revision 196253)
|
||||
+++ gcc/ipa-split.c (working copy)
|
||||
@@ -1309,7 +1309,9 @@ split_function (struct split_point *spli
|
||||
so return slot optimization is always possible. Moreover this is
|
||||
required to make DECL_BY_REFERENCE work. */
|
||||
if (aggregate_value_p (DECL_RESULT (current_function_decl),
|
||||
- TREE_TYPE (current_function_decl)))
|
||||
+ TREE_TYPE (current_function_decl))
|
||||
+ && (!is_gimple_reg_type (TREE_TYPE (DECL_RESULT (current_function_decl)))
|
||||
+ || DECL_BY_REFERENCE (DECL_RESULT (current_function_decl))))
|
||||
gimple_call_set_return_slot_opt (call, true);
|
||||
|
||||
/* Update return value. This is bit tricky. When we do not return,
|
||||
--- gcc/testsuite/gcc.dg/pr56424.c 2013-02-13 21:50:57.150673158 +0100
|
||||
+++ gcc/testsuite/gcc.dg/pr56424.c 2013-03-04 12:59:24.133888683 +0100
|
||||
@@ -0,0 +1,33 @@
|
||||
+/* PR tree-optimization/56424 */
|
||||
+
|
||||
+/* { dg-do compile } */
|
||||
+/* { dg-options "-O2 -fexceptions -fnon-call-exceptions" } */
|
||||
+
|
||||
+extern long double cosl (long double);
|
||||
+extern long double sinl (long double);
|
||||
+extern long double reml (long double, long double);
|
||||
+
|
||||
+long double my_cos (long double arg)
|
||||
+{
|
||||
+ return cosl (arg);
|
||||
+}
|
||||
+
|
||||
+long double my_sin (long double arg)
|
||||
+{
|
||||
+ if (__builtin_fabs (arg) < 1.0)
|
||||
+ return arg;
|
||||
+
|
||||
+ return sinl (arg);
|
||||
+}
|
||||
+
|
||||
+long double my_cot (long double arg, long double cycle)
|
||||
+{
|
||||
+ long double t = reml (arg, cycle);
|
||||
+ return my_cos (t) / my_sin (t);
|
||||
+}
|
||||
+
|
||||
+long double my_tan (long double arg, long double cycle)
|
||||
+{
|
||||
+ long double t = reml (arg, cycle);
|
||||
+ return my_sin (t) / my_cos (t);
|
||||
+}
|
@ -1,92 +0,0 @@
|
||||
2013-03-04 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR bootstrap/56509
|
||||
* opts.c (opts_obstack, opts_concat): Moved to...
|
||||
* opts-common.c (opts_obstack, opts_concat): ... here.
|
||||
|
||||
--- gcc/opts-common.c.jj 2013-02-27 08:27:26.000000000 +0100
|
||||
+++ gcc/opts-common.c 2013-03-04 10:02:58.016096542 +0100
|
||||
@@ -692,6 +692,40 @@ decode_cmdline_option (const char **argv
|
||||
return result;
|
||||
}
|
||||
|
||||
+/* Obstack for option strings. */
|
||||
+
|
||||
+struct obstack opts_obstack;
|
||||
+
|
||||
+/* Like libiberty concat, but allocate using opts_obstack. */
|
||||
+
|
||||
+char *
|
||||
+opts_concat (const char *first, ...)
|
||||
+{
|
||||
+ char *newstr, *end;
|
||||
+ size_t length = 0;
|
||||
+ const char *arg;
|
||||
+ va_list ap;
|
||||
+
|
||||
+ /* First compute the size of the result and get sufficient memory. */
|
||||
+ va_start (ap, first);
|
||||
+ for (arg = first; arg; arg = va_arg (ap, const char *))
|
||||
+ length += strlen (arg);
|
||||
+ newstr = XOBNEWVEC (&opts_obstack, char, length + 1);
|
||||
+ va_end (ap);
|
||||
+
|
||||
+ /* Now copy the individual pieces to the result string. */
|
||||
+ va_start (ap, first);
|
||||
+ for (arg = first, end = newstr; arg; arg = va_arg (ap, const char *))
|
||||
+ {
|
||||
+ length = strlen (arg);
|
||||
+ memcpy (end, arg, length);
|
||||
+ end += length;
|
||||
+ }
|
||||
+ *end = '\0';
|
||||
+ va_end (ap);
|
||||
+ return newstr;
|
||||
+}
|
||||
+
|
||||
/* Decode command-line options (ARGC and ARGV being the arguments of
|
||||
main) into an array, setting *DECODED_OPTIONS to a pointer to that
|
||||
array and *DECODED_OPTIONS_COUNT to the number of entries in the
|
||||
--- gcc/opts.c.jj 2013-02-27 08:27:26.000000000 +0100
|
||||
+++ gcc/opts.c 2013-03-04 10:02:16.401346992 +0100
|
||||
@@ -268,40 +268,6 @@ add_comma_separated_to_vector (void **pv
|
||||
*pvec = v;
|
||||
}
|
||||
|
||||
-/* Like libiberty concat, but allocate using opts_obstack. */
|
||||
-
|
||||
-char *
|
||||
-opts_concat (const char *first, ...)
|
||||
-{
|
||||
- char *newstr, *end;
|
||||
- size_t length = 0;
|
||||
- const char *arg;
|
||||
- va_list ap;
|
||||
-
|
||||
- /* First compute the size of the result and get sufficient memory. */
|
||||
- va_start (ap, first);
|
||||
- for (arg = first; arg; arg = va_arg (ap, const char *))
|
||||
- length += strlen (arg);
|
||||
- newstr = XOBNEWVEC (&opts_obstack, char, length + 1);
|
||||
- va_end (ap);
|
||||
-
|
||||
- /* Now copy the individual pieces to the result string. */
|
||||
- va_start (ap, first);
|
||||
- for (arg = first, end = newstr; arg; arg = va_arg (ap, const char *))
|
||||
- {
|
||||
- length = strlen (arg);
|
||||
- memcpy (end, arg, length);
|
||||
- end += length;
|
||||
- }
|
||||
- *end = '\0';
|
||||
- va_end (ap);
|
||||
- return newstr;
|
||||
-}
|
||||
-
|
||||
-/* Obstack for option strings. */
|
||||
-
|
||||
-struct obstack opts_obstack;
|
||||
-
|
||||
/* Initialize OPTS and OPTS_SET before using them in parsing options. */
|
||||
|
||||
void
|
392
isl-0.11.1-aarch64-config.patch
Normal file
392
isl-0.11.1-aarch64-config.patch
Normal file
@ -0,0 +1,392 @@
|
||||
--- isl-0.11.1/config.guess
|
||||
+++ isl-0.11.1/config.guess
|
||||
@@ -2,9 +2,9 @@
|
||||
# Attempt to guess a canonical system name.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
-# 2011 Free Software Foundation, Inc.
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2011-05-11'
|
||||
+timestamp='2012-06-10'
|
||||
|
||||
# This file is free software; you can redistribute it and/or modify it
|
||||
# under the terms of the GNU General Public License as published by
|
||||
@@ -17,9 +17,7 @@ timestamp='2011-05-11'
|
||||
# General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -57,8 +55,8 @@ GNU config.guess ($timestamp)
|
||||
|
||||
Originally written by Per Bothner.
|
||||
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
|
||||
-Software Foundation, Inc.
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -145,7 +143,7 @@ UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
|
||||
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
||||
*:NetBSD:*:*)
|
||||
# NetBSD (nbsd) targets should (where applicable) match one or
|
||||
- # more of the tupples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
+ # more of the tuples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
# *-*-netbsdecoff* and *-*-netbsd*. For targets that recently
|
||||
# switched to ELF, *-*-netbsd* would select the old
|
||||
# object file format. This provides both forward
|
||||
@@ -792,13 +790,12 @@ EOF
|
||||
echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
|
||||
exit ;;
|
||||
*:FreeBSD:*:*)
|
||||
- case ${UNAME_MACHINE} in
|
||||
- pc98)
|
||||
- echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ UNAME_PROCESSOR=`/usr/bin/uname -p`
|
||||
+ case ${UNAME_PROCESSOR} in
|
||||
amd64)
|
||||
echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
*)
|
||||
- echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ echo ${UNAME_PROCESSOR}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
esac
|
||||
exit ;;
|
||||
i*:CYGWIN*:*)
|
||||
@@ -807,6 +804,9 @@ EOF
|
||||
*:MINGW*:*)
|
||||
echo ${UNAME_MACHINE}-pc-mingw32
|
||||
exit ;;
|
||||
+ i*:MSYS*:*)
|
||||
+ echo ${UNAME_MACHINE}-pc-msys
|
||||
+ exit ;;
|
||||
i*:windows32*:*)
|
||||
# uname -m includes "-pc" on this system.
|
||||
echo ${UNAME_MACHINE}-mingw32
|
||||
@@ -861,6 +861,13 @@ EOF
|
||||
i*86:Minix:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-minix
|
||||
exit ;;
|
||||
+ aarch64:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ aarch64_be:Linux:*:*)
|
||||
+ UNAME_MACHINE=aarch64_be
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
alpha:Linux:*:*)
|
||||
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
|
||||
EV5) UNAME_MACHINE=alphaev5 ;;
|
||||
@@ -895,13 +902,16 @@ EOF
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
cris:Linux:*:*)
|
||||
- echo cris-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
crisv32:Linux:*:*)
|
||||
- echo crisv32-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
frv:Linux:*:*)
|
||||
- echo frv-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ hexagon:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
i*86:Linux:*:*)
|
||||
LIBC=gnu
|
||||
@@ -943,7 +953,7 @@ EOF
|
||||
test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
|
||||
;;
|
||||
or32:Linux:*:*)
|
||||
- echo or32-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
padre:Linux:*:*)
|
||||
echo sparc-unknown-linux-gnu
|
||||
@@ -978,13 +988,13 @@ EOF
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
tile*:Linux:*:*)
|
||||
- echo ${UNAME_MACHINE}-tilera-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
vax:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-dec-linux-gnu
|
||||
exit ;;
|
||||
x86_64:Linux:*:*)
|
||||
- echo x86_64-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
xtensa*:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
@@ -1246,7 +1256,7 @@ EOF
|
||||
NEO-?:NONSTOP_KERNEL:*:*)
|
||||
echo neo-tandem-nsk${UNAME_RELEASE}
|
||||
exit ;;
|
||||
- NSE-?:NONSTOP_KERNEL:*:*)
|
||||
+ NSE-*:NONSTOP_KERNEL:*:*)
|
||||
echo nse-tandem-nsk${UNAME_RELEASE}
|
||||
exit ;;
|
||||
NSR-?:NONSTOP_KERNEL:*:*)
|
||||
@@ -1315,6 +1325,9 @@ EOF
|
||||
i*86:AROS:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-aros
|
||||
exit ;;
|
||||
+ x86_64:VMkernel:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-esx
|
||||
+ exit ;;
|
||||
esac
|
||||
|
||||
#echo '(No uname command or uname output not recognized.)' 1>&2
|
||||
--- isl-0.11.1/config.sub
|
||||
+++ isl-0.11.1/config.sub
|
||||
@@ -2,9 +2,9 @@
|
||||
# Configuration validation subroutine script.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
-# 2011 Free Software Foundation, Inc.
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2011-03-23'
|
||||
+timestamp='2012-04-18'
|
||||
|
||||
# This file is (in principle) common to ALL GNU software.
|
||||
# The presence of a machine in this file suggests that SOME GNU software
|
||||
@@ -21,9 +21,7 @@ timestamp='2011-03-23'
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -76,8 +74,8 @@ version="\
|
||||
GNU config.sub ($timestamp)
|
||||
|
||||
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
|
||||
-Software Foundation, Inc.
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -132,6 +130,10 @@ case $maybe_os in
|
||||
os=-$maybe_os
|
||||
basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
|
||||
;;
|
||||
+ android-linux)
|
||||
+ os=-linux-android
|
||||
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`-unknown
|
||||
+ ;;
|
||||
*)
|
||||
basic_machine=`echo $1 | sed 's/-[^-]*$//'`
|
||||
if [ $basic_machine != $1 ]
|
||||
@@ -223,6 +225,12 @@ case $os in
|
||||
-isc*)
|
||||
basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
|
||||
;;
|
||||
+ -lynx*178)
|
||||
+ os=-lynxos178
|
||||
+ ;;
|
||||
+ -lynx*5)
|
||||
+ os=-lynxos5
|
||||
+ ;;
|
||||
-lynx*)
|
||||
os=-lynxos
|
||||
;;
|
||||
@@ -247,17 +255,22 @@ case $basic_machine in
|
||||
# Some are omitted here because they have special meanings below.
|
||||
1750a | 580 \
|
||||
| a29k \
|
||||
+ | aarch64 | aarch64_be \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
| am33_2.0 \
|
||||
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
+ | be32 | be64 \
|
||||
| bfin \
|
||||
| c4x | clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
+ | epiphany \
|
||||
| fido | fr30 | frv \
|
||||
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
|
||||
+ | hexagon \
|
||||
| i370 | i860 | i960 | ia64 \
|
||||
| ip2k | iq2000 \
|
||||
+ | le32 | le64 \
|
||||
| lm32 \
|
||||
| m32c | m32r | m32rle | m68000 | m68k | m88k \
|
||||
| maxq | mb | microblaze | mcore | mep | metag \
|
||||
@@ -291,7 +304,7 @@ case $basic_machine in
|
||||
| pdp10 | pdp11 | pj | pjl \
|
||||
| powerpc | powerpc64 | powerpc64le | powerpcle \
|
||||
| pyramid \
|
||||
- | rx \
|
||||
+ | rl78 | rx \
|
||||
| score \
|
||||
| sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
|
||||
| sh64 | sh64le \
|
||||
@@ -300,7 +313,7 @@ case $basic_machine in
|
||||
| spu \
|
||||
| tahoe | tic4x | tic54x | tic55x | tic6x | tic80 | tron \
|
||||
| ubicom32 \
|
||||
- | v850 | v850e \
|
||||
+ | v850 | v850e | v850e1 | v850e2 | v850es | v850e2v3 \
|
||||
| we32k \
|
||||
| x86 | xc16x | xstormy16 | xtensa \
|
||||
| z8k | z80)
|
||||
@@ -315,8 +328,7 @@ case $basic_machine in
|
||||
c6x)
|
||||
basic_machine=tic6x-unknown
|
||||
;;
|
||||
- m6811 | m68hc11 | m6812 | m68hc12 | picochip)
|
||||
- # Motorola 68HC11/12.
|
||||
+ m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
|
||||
basic_machine=$basic_machine-unknown
|
||||
os=-none
|
||||
;;
|
||||
@@ -329,7 +341,10 @@ case $basic_machine in
|
||||
strongarm | thumb | xscale)
|
||||
basic_machine=arm-unknown
|
||||
;;
|
||||
-
|
||||
+ xgate)
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
+ os=-none
|
||||
+ ;;
|
||||
xscaleeb)
|
||||
basic_machine=armeb-unknown
|
||||
;;
|
||||
@@ -352,11 +367,13 @@ case $basic_machine in
|
||||
# Recognize the basic CPU types with company name.
|
||||
580-* \
|
||||
| a29k-* \
|
||||
+ | aarch64-* | aarch64_be-* \
|
||||
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
| avr-* | avr32-* \
|
||||
+ | be32-* | be64-* \
|
||||
| bfin-* | bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* \
|
||||
| clipper-* | craynv-* | cydra-* \
|
||||
@@ -365,8 +382,10 @@ case $basic_machine in
|
||||
| f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
|
||||
| h8300-* | h8500-* \
|
||||
| hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
|
||||
+ | hexagon-* \
|
||||
| i*86-* | i860-* | i960-* | ia64-* \
|
||||
| ip2k-* | iq2000-* \
|
||||
+ | le32-* | le64-* \
|
||||
| lm32-* \
|
||||
| m32c-* | m32r-* | m32rle-* \
|
||||
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
|
||||
@@ -400,7 +419,7 @@ case $basic_machine in
|
||||
| pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
|
||||
| powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
|
||||
| pyramid-* \
|
||||
- | romp-* | rs6000-* | rx-* \
|
||||
+ | rl78-* | romp-* | rs6000-* | rx-* \
|
||||
| sh-* | sh[1234]-* | sh[24]a-* | sh[24]aeb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
|
||||
| shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
|
||||
| sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
|
||||
@@ -408,10 +427,11 @@ case $basic_machine in
|
||||
| sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | sv1-* | sx?-* \
|
||||
| tahoe-* \
|
||||
| tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
|
||||
- | tile-* | tilegx-* \
|
||||
+ | tile*-* \
|
||||
| tron-* \
|
||||
| ubicom32-* \
|
||||
- | v850-* | v850e-* | vax-* \
|
||||
+ | v850-* | v850e-* | v850e1-* | v850es-* | v850e2-* | v850e2v3-* \
|
||||
+ | vax-* \
|
||||
| we32k-* \
|
||||
| x86-* | x86_64-* | xc16x-* | xps100-* \
|
||||
| xstormy16-* | xtensa*-* \
|
||||
@@ -711,7 +731,6 @@ case $basic_machine in
|
||||
i370-ibm* | ibm*)
|
||||
basic_machine=i370-ibm
|
||||
;;
|
||||
-# I'm not sure what "Sysv32" means. Should this be sysv3.2?
|
||||
i*86v32)
|
||||
basic_machine=`echo $1 | sed -e 's/86.*/86-pc/'`
|
||||
os=-sysv32
|
||||
@@ -808,10 +827,18 @@ case $basic_machine in
|
||||
ms1-*)
|
||||
basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
|
||||
;;
|
||||
+ msys)
|
||||
+ basic_machine=i386-pc
|
||||
+ os=-msys
|
||||
+ ;;
|
||||
mvs)
|
||||
basic_machine=i370-ibm
|
||||
os=-mvs
|
||||
;;
|
||||
+ nacl)
|
||||
+ basic_machine=le32-unknown
|
||||
+ os=-nacl
|
||||
+ ;;
|
||||
ncr3000)
|
||||
basic_machine=i486-ncr
|
||||
os=-sysv4
|
||||
@@ -1120,13 +1147,8 @@ case $basic_machine in
|
||||
basic_machine=t90-cray
|
||||
os=-unicos
|
||||
;;
|
||||
- # This must be matched before tile*.
|
||||
- tilegx*)
|
||||
- basic_machine=tilegx-unknown
|
||||
- os=-linux-gnu
|
||||
- ;;
|
||||
tile*)
|
||||
- basic_machine=tile-unknown
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
os=-linux-gnu
|
||||
;;
|
||||
tx39)
|
||||
@@ -1336,7 +1358,7 @@ case $os in
|
||||
| -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
|
||||
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
|
||||
| -chorusos* | -chorusrdb* | -cegcc* \
|
||||
- | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
| -mingw32* | -linux-gnu* | -linux-android* \
|
||||
| -linux-newlib* | -linux-uclibc* \
|
||||
| -uxpv* | -beos* | -mpeix* | -udk* \
|
||||
@@ -1521,6 +1543,9 @@ case $basic_machine in
|
||||
c4x-* | tic4x-*)
|
||||
os=-coff
|
||||
;;
|
||||
+ hexagon-*)
|
||||
+ os=-elf
|
||||
+ ;;
|
||||
tic54x-*)
|
||||
os=-coff
|
||||
;;
|
||||
@@ -1548,9 +1573,6 @@ case $basic_machine in
|
||||
;;
|
||||
m68000-sun)
|
||||
os=-sunos3
|
||||
- # This also exists in the configure program, but was not the
|
||||
- # default.
|
||||
- # os=-sunos4
|
||||
;;
|
||||
m68*-cisco)
|
||||
os=-aout
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
be78a47bd82523250eb3e91646db5b3d cloog-0.18.0.tar.gz
|
||||
2659f09c2e43ef8b7d4406321753f1b2 fastjar-0.97.tar.gz
|
||||
bce1586384d8635a76d2f017fb067cd2 isl-0.11.1.tar.bz2
|
||||
4f89409558bba0856fbd26778fd49841 gcc-4.8.0-20130304.tar.bz2
|
||||
5261d63f6322fdd1b871da3dece37371 gcc-4.8.0-20130307.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user