268ae0028c
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/firefox#c8daf71be4963daab37d810024e0a6e7f04cf2dd
17 lines
561 B
Diff
17 lines
561 B
Diff
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
|
|
--- a/config/makefiles/rust.mk
|
|
+++ b/config/makefiles/rust.mk
|
|
@@ -61,7 +61,11 @@
|
|
# Enable link-time optimization for release builds, but not when linking
|
|
# gkrust_gtest.
|
|
ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
|
|
+# Pass -Clto for older versions of rust, and CARGO_PROFILE_RELEASE_LTO=true
|
|
+# for newer ones that support it. Combining the latter with -Clto works, so
|
|
+# set both everywhere.
|
|
cargo_rustc_flags += -Clto
|
|
+export CARGO_PROFILE_RELEASE_LTO=true
|
|
endif
|
|
endif
|
|
endif
|
|
|