Build fixes, test update
This commit is contained in:
parent
53dac96cc2
commit
fcf7279272
15
firefox.spec
15
firefox.spec
@ -20,7 +20,7 @@
|
||||
%global system_nss 1
|
||||
%global build_with_clang 0
|
||||
%global build_with_asan 0
|
||||
%global test_on_wayland 0
|
||||
%global test_on_wayland 1
|
||||
|
||||
# There are still build problems on s390x, see
|
||||
# https://koji.fedoraproject.org/koji/taskinfo?taskID=55048351
|
||||
@ -332,6 +332,7 @@ BuildRequires: gnome-settings-daemon
|
||||
BuildRequires: mesa-dri-drivers
|
||||
%endif
|
||||
%if 0%{?run_firefox_tests}
|
||||
BuildRequires: procps-ng
|
||||
BuildRequires: nss-tools
|
||||
BuildRequires: python2.7
|
||||
BuildRequires: dejavu-sans-mono-fonts
|
||||
@ -739,7 +740,15 @@ xvfb-run ./mach build 2>&1 | cat -
|
||||
./mach build 2>&1 | cat -
|
||||
%endif
|
||||
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
%install
|
||||
# run Firefox test suite
|
||||
%if %{launch_wayland_compositor}
|
||||
cp %{SOURCE45} .
|
||||
. ./run-wayland-compositor
|
||||
%endif
|
||||
|
||||
%if 0%{?run_firefox_tests}
|
||||
mkdir -p objdir/_virtualenvs/init_py3
|
||||
%{__cat} > objdir/_virtualenvs/init_py3/pip.conf << EOF
|
||||
@ -759,9 +768,6 @@ mkdir -p test_results
|
||||
./print_failures || true
|
||||
%endif
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
%install
|
||||
|
||||
# set up our default bookmarks
|
||||
%if !0%{?flatpak}
|
||||
%{__cp} -p %{default_bookmarks_file} objdir/dist/bin/browser/chrome/en-US/locale/browser/bookmarks.html
|
||||
@ -1025,6 +1031,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%changelog
|
||||
* Fri Apr 23 2021 Martin Stransky <stransky@redhat.com> - 88.0-5
|
||||
- Added fix for mozbz#1580595 - mouse pointer lock.
|
||||
- Another test update.
|
||||
|
||||
* Thu Apr 22 2021 Martin Stransky <stransky@redhat.com> - 88.0-4
|
||||
- Run with mochitest test suite.
|
||||
|
@ -416,6 +416,29 @@ diff -up firefox-88.0/widget/gtk/nsWindow.h.1580595 firefox-88.0/widget/gtk/nsWi
|
||||
#endif
|
||||
|
||||
// Upper bound on pending ConfigureNotify events to be dispatched to the
|
||||
diff -up firefox-88.0/widget/gtk/wayland/moz.build.1580595 firefox-88.0/widget/gtk/wayland/moz.build
|
||||
--- firefox-88.0/widget/gtk/wayland/moz.build.1580595 2021-04-23 11:25:30.201028672 +0200
|
||||
+++ firefox-88.0/widget/gtk/wayland/moz.build 2021-04-23 11:26:20.015525447 +0200
|
||||
@@ -11,7 +11,9 @@ SOURCES += [
|
||||
"gtk-primary-selection-protocol.c",
|
||||
"idle-inhibit-unstable-v1-protocol.c",
|
||||
"linux-dmabuf-unstable-v1-protocol.c",
|
||||
+ "pointer-constraints-unstable-v1-protocol.c",
|
||||
"primary-selection-unstable-v1-protocol.c",
|
||||
+ "relative-pointer-unstable-v1-protocol.c",
|
||||
"xdg-output-unstable-v1-protocol.c",
|
||||
]
|
||||
|
||||
@@ -20,7 +22,9 @@ EXPORTS.mozilla.widget += [
|
||||
"gtk-primary-selection-client-protocol.h",
|
||||
"idle-inhibit-unstable-v1-client-protocol.h",
|
||||
"linux-dmabuf-unstable-v1-client-protocol.h",
|
||||
+ "pointer-constraints-unstable-v1-client-protocol.h",
|
||||
"primary-selection-unstable-v1-client-protocol.h",
|
||||
+ "relative-pointer-unstable-v1-client-protocol.h",
|
||||
"va_drmcommon.h",
|
||||
"xdg-output-unstable-v1-client-protocol.h",
|
||||
]
|
||||
diff -up firefox-88.0/widget/gtk/wayland/pointer-constraints-unstable-v1-client-protocol.h.1580595 firefox-88.0/widget/gtk/wayland/pointer-constraints-unstable-v1-client-protocol.h
|
||||
--- firefox-88.0/widget/gtk/wayland/pointer-constraints-unstable-v1-client-protocol.h.1580595 2021-04-23 10:16:59.823826750 +0200
|
||||
+++ firefox-88.0/widget/gtk/wayland/pointer-constraints-unstable-v1-client-protocol.h 2021-04-23 10:16:59.823826750 +0200
|
||||
@ -1598,3 +1621,13 @@ diff -up firefox-88.0/widget/PuppetWidget.h.1580595 firefox-88.0/widget/PuppetWi
|
||||
virtual void StartAsyncScrollbarDrag(
|
||||
const AsyncDragMetrics& aDragMetrics) override;
|
||||
|
||||
--- firefox-88.0/widget/gtk/mozgtk/mozgtk.c.old 2021-04-23 14:19:07.244820364 +0200
|
||||
+++ firefox-88.0/widget/gtk/mozgtk/mozgtk.c 2021-04-23 14:19:34.228631957 +0200
|
||||
@@ -644,6 +644,7 @@ STUB(gtk_color_chooser_get_type)
|
||||
STUB(gtk_color_chooser_set_rgba)
|
||||
STUB(gtk_color_chooser_get_rgba)
|
||||
STUB(gtk_color_chooser_set_use_alpha)
|
||||
+STUB(gdk_wayland_device_get_wl_pointer)
|
||||
#endif
|
||||
|
||||
#ifdef GTK2_SYMBOLS
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
set -x
|
||||
|
||||
RUN_XPCSHELL_TEST=0
|
||||
RUN_XPCSHELL_TEST=1
|
||||
RUN_REFTEST=1
|
||||
RUN_MOCHITEST=1
|
||||
RUN_CRASHTEST=1
|
||||
@ -28,6 +28,8 @@ MOCHITEST_PARAMS="--timeout 1 --chunk-by-dir 4"
|
||||
TEST_DIR="test_results"
|
||||
mkdir $TEST_DIR
|
||||
|
||||
env | grep "DISPLAY"
|
||||
|
||||
# Fix for system nss
|
||||
ln -s /usr/bin/certutil objdir/dist/bin/certutil
|
||||
ln -s /usr/bin/pk12util objdir/dist/bin/pk12util
|
||||
|
@ -24,14 +24,16 @@ export TEST_FLAVOUR=""
|
||||
# WebRender testing
|
||||
export TEST_PARAMS="--enable-webrender $TEST_PARAMS"
|
||||
export TEST_FLAVOUR="-wr"
|
||||
xvfb-run -s "$X_PARAMS" -n 95 ./mach xpcshell-test --sequential $TEST_PARAMS 2>&1 | cat - | tee $TEST_DIR/xpcshell-wr
|
||||
sleep 60
|
||||
xvfb-run -s "$X_PARAMS" -n 96 ./mach reftest $TEST_PARAMS 2>&1 | tee $TEST_DIR/reftest$TEST_FLAVOUR
|
||||
sleep 60
|
||||
xvfb-run -s "$X_PARAMS" -n 97 ./mach crashtest $TEST_PARAMS 2>&1 | tee $TEST_DIR/crashtest$TEST_FLAVOUR
|
||||
sleep 60
|
||||
xvfb-run -s "$X_PARAMS" -n 98 ./mach mochitest dom $MOCHITEST_PARAMS $TEST_PARAMS 2>&1 | tee $TEST_DIR/mochitest$TEST_FLAVOUR
|
||||
#xvfb-run -s "$X_PARAMS" -n 98 ./mach mochitest $MOCHITEST_PARAMS $TEST_PARAMS 2>&1 | tee $TEST_DIR/mochitest$TEST_FLAVOUR
|
||||
#xvfb-run -s "$X_PARAMS" -n 95 ./mach xpcshell-test --sequential $TEST_PARAMS 2>&1 | cat - | tee $TEST_DIR/xpcshell-wr
|
||||
#sleep 60
|
||||
#xvfb-run -s "$X_PARAMS" -n 96 ./mach reftest $TEST_PARAMS 2>&1 | tee $TEST_DIR/reftest$TEST_FLAVOUR
|
||||
#sleep 60
|
||||
#xvfb-run -s "$X_PARAMS" -n 97 ./mach crashtest $TEST_PARAMS 2>&1 | tee $TEST_DIR/crashtest$TEST_FLAVOUR
|
||||
#sleep 60
|
||||
#export DISPLAY=:0
|
||||
#./mach mochitest dom/base/test/ $MOCHITEST_PARAMS $TEST_PARAMS 2>&1 | tee $TEST_DIR/mochitest$TEST_FLAVOUR
|
||||
export DISPLAY=:98
|
||||
xvfb-run -s "$X_PARAMS" -n 98 ./mach mochitest dom/base/test/ $MOCHITEST_PARAMS $TEST_PARAMS 2>&1 | tee $TEST_DIR/mochitest$TEST_FLAVOUR
|
||||
|
||||
rm -f objdir/dist/bin/certutil
|
||||
rm -f objdir/dist/bin/pk12util
|
||||
|
@ -26,7 +26,8 @@ if [ -z "$XDG_RUNTIME_DIR" ]; then
|
||||
export XDG_RUNTIME_DIR=$HOME
|
||||
fi
|
||||
|
||||
xvfb-run -s "-screen 0 1600x1200x24" -n 80 mutter --wayland --nested &
|
||||
. xvfb-run -s "-screen 0 1600x1200x24" -n 80 mutter --display=:80 --wayland --nested &
|
||||
export DISPLAY=:80
|
||||
|
||||
if [ -z "$WAYLAND_DISPLAY" ] ; then
|
||||
export WAYLAND_DISPLAY=wayland-0
|
||||
@ -45,3 +46,5 @@ until [ $retry_count -gt $max_retries ]; do
|
||||
sleep 2
|
||||
fi
|
||||
done
|
||||
|
||||
env | grep "DISPLAY"
|
||||
|
Loading…
Reference in New Issue
Block a user