Merge branch 'master' of ssh://pkgs.fedoraproject.org/rpms/firefox
This commit is contained in:
commit
f84c39e4f9
@ -1,15 +0,0 @@
|
|||||||
diff -up firefox-68.0/mfbt/LinuxSignal.h.1238661 firefox-68.0/mfbt/LinuxSignal.h
|
|
||||||
--- firefox-68.0/mfbt/LinuxSignal.h.1238661 2019-07-08 22:27:29.620749569 +0200
|
|
||||||
+++ firefox-68.0/mfbt/LinuxSignal.h 2019-07-08 22:44:17.794112428 +0200
|
|
||||||
@@ -22,7 +22,10 @@ __attribute__((naked)) void SignalTrampo
|
|
||||||
void* aContext) {
|
|
||||||
asm volatile("nop; nop; nop; nop" : : : "memory");
|
|
||||||
|
|
||||||
- asm volatile("b %0" : : "X"(H) : "memory");
|
|
||||||
+ // Because the assembler may generate additional insturctions below, we
|
|
||||||
+ // need to ensure NOPs are inserted first by separating them out above.
|
|
||||||
+
|
|
||||||
+ asm volatile("bx %0" : : "r"(H), "l"(aSignal), "l"(aInfo), "l"(aContext) : "memory");
|
|
||||||
}
|
|
||||||
|
|
||||||
# define MOZ_SIGNAL_TRAMPOLINE(h) (mozilla::SignalTrampoline<h>)
|
|
@ -7,6 +7,7 @@ ac_add_options --enable-necko-wifi
|
|||||||
ac_add_options --disable-updater
|
ac_add_options --disable-updater
|
||||||
ac_add_options --enable-chrome-format=omni
|
ac_add_options --enable-chrome-format=omni
|
||||||
ac_add_options --enable-pulseaudio
|
ac_add_options --enable-pulseaudio
|
||||||
|
ac_add_options --enable-av1
|
||||||
ac_add_options --without-system-icu
|
ac_add_options --without-system-icu
|
||||||
ac_add_options --enable-release
|
ac_add_options --enable-release
|
||||||
ac_add_options --update-channel=release
|
ac_add_options --update-channel=release
|
||||||
|
15
firefox.spec
15
firefox.spec
@ -177,7 +177,6 @@ Patch227: firefox-locale-debug.patch
|
|||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
Patch412: mozilla-1337988.patch
|
Patch412: mozilla-1337988.patch
|
||||||
Patch415: Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
|
|
||||||
Patch417: bug1375074-save-restore-x28.patch
|
Patch417: bug1375074-save-restore-x28.patch
|
||||||
Patch422: mozilla-1580174-webrtc-popup.patch
|
Patch422: mozilla-1580174-webrtc-popup.patch
|
||||||
|
|
||||||
@ -382,9 +381,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch227 -p1 -b .locale-debug
|
%patch227 -p1 -b .locale-debug
|
||||||
|
|
||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
%ifarch %{arm}
|
|
||||||
%patch415 -p1 -b .1238661
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
# Wayland specific upstream patches
|
# Wayland specific upstream patches
|
||||||
@ -452,10 +448,6 @@ echo "ac_add_options --disable-debug" >> .mozconfig
|
|||||||
echo "ac_add_options --disable-jemalloc" >> .mozconfig
|
echo "ac_add_options --disable-jemalloc" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifnarch %{ix86} x86_64 ppc64le
|
|
||||||
echo "ac_add_options --disable-webrtc" >> .mozconfig
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%if !%{enable_mozilla_crashreporter}
|
%if !%{enable_mozilla_crashreporter}
|
||||||
echo "ac_add_options --disable-crashreporter" >> .mozconfig
|
echo "ac_add_options --disable-crashreporter" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
@ -487,13 +479,6 @@ echo "ac_add_options --enable-address-sanitizer" >> .mozconfig
|
|||||||
echo "ac_add_options --disable-jemalloc" >> .mozconfig
|
echo "ac_add_options --disable-jemalloc" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# We don't have recent nasm on Fedora 30...time to update to Fedora 31.
|
|
||||||
%if 0%{?fedora} < 31
|
|
||||||
echo "ac_add_options --disable-av1" >> .mozconfig
|
|
||||||
%else
|
|
||||||
echo "ac_add_options --enable-av1" >> .mozconfig
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# api keys full path
|
# api keys full path
|
||||||
echo "ac_add_options --with-mozilla-api-keyfile=`pwd`/mozilla-api-key" >> .mozconfig
|
echo "ac_add_options --with-mozilla-api-keyfile=`pwd`/mozilla-api-key" >> .mozconfig
|
||||||
# It seems that the api key we have is for the safe browsing only
|
# It seems that the api key we have is for the safe browsing only
|
||||||
|
Loading…
Reference in New Issue
Block a user