Updated to 27.0

This commit is contained in:
Martin Stransky 2014-02-03 11:27:18 +01:00
parent 863f53f57f
commit f6e2a4f3f2
5 changed files with 26 additions and 45 deletions

1
.gitignore vendored
View File

@ -90,3 +90,4 @@ firefox-3.6.4.source.tar.bz2
/firefox-langpacks-25.0-20131030.tar.xz /firefox-langpacks-25.0-20131030.tar.xz
/firefox-26.0.source.tar.bz2 /firefox-26.0.source.tar.bz2
/firefox-langpacks-26.0-20131209.tar.xz /firefox-langpacks-26.0-20131209.tar.xz
/firefox-27.0.source.tar.bz2

View File

@ -36,7 +36,7 @@
%if %{?system_nss} %if %{?system_nss}
%global nspr_version 4.10.2 %global nspr_version 4.10.2
%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536) %global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
%global nss_version 3.15.2 %global nss_version 3.15.4
%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536) %global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
%endif %endif
@ -85,8 +85,8 @@
Summary: Mozilla Firefox Web browser Summary: Mozilla Firefox Web browser
Name: firefox Name: firefox
Version: 26.0 Version: 27.0
Release: 7%{?pre_tag}%{?dist} Release: 1%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/ URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+ License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet Group: Applications/Internet
@ -220,8 +220,8 @@ cd %{tarballdir}
# ignored during this compare. # ignored during this compare.
%patch0 -p1 %patch0 -p1
%patch2 -p1 -b .bld %patch2 -p2 -b .bld
%patch3 -p1 -b .arm %patch3 -p2 -b .arm
%patch14 -p2 -b .chromium-types %patch14 -p2 -b .chromium-types
%patch17 -p1 -b .gcc47 %patch17 -p1 -b .gcc47
%patch18 -p2 -b .jemalloc-ppc %patch18 -p2 -b .jemalloc-ppc
@ -637,6 +637,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#--------------------------------------------------------------------- #---------------------------------------------------------------------
%changelog %changelog
* Mon Feb 3 2014 Martin Stransky <stransky@redhat.com> - 27.0-1
- Update to 27.0
* Thu Jan 30 2014 Jan Horak <jhorak@redhat.com> - 26.0-7 * Thu Jan 30 2014 Jan Horak <jhorak@redhat.com> - 26.0-7
- Set default homepage to about:newtab and make start.fedoraproject.org page pinned on it - Set default homepage to about:newtab and make start.fedoraproject.org page pinned on it
- Disable system cairo because of rhbz#1059076 - Disable system cairo because of rhbz#1059076

View File

@ -1,35 +1,12 @@
diff -up mozilla-release/gfx/layers/BufferUnrotate.cpp.arm mozilla-release/gfx/layers/BufferUnrotate.cpp diff -up firefox-27.0/mozilla-release/gfx/ycbcr/moz.build.arm firefox-27.0/mozilla-release/gfx/ycbcr/moz.build
--- mozilla-release/gfx/layers/BufferUnrotate.cpp.arm 2013-12-05 17:07:31.000000000 +0100 --- firefox-27.0/mozilla-release/gfx/ycbcr/moz.build.arm 2014-01-28 05:03:42.000000000 +0100
+++ mozilla-release/gfx/layers/BufferUnrotate.cpp 2013-12-10 14:47:43.234182482 +0100 +++ firefox-27.0/mozilla-release/gfx/ycbcr/moz.build 2014-02-03 11:14:34.062219509 +0100
@@ -8,6 +8,7 @@
#include <stdint.h>
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
void BufferUnrotate(uint8_t* aBuffer, int aByteWidth, int aHeight,
int aByteStride, int aXBoundary, int aYBoundary)
diff -up mozilla-release/gfx/ycbcr/moz.build.arm mozilla-release/gfx/ycbcr/moz.build
--- mozilla-release/gfx/ycbcr/moz.build.arm 2013-12-05 17:07:32.000000000 +0100
+++ mozilla-release/gfx/ycbcr/moz.build 2013-12-10 14:47:43.235182479 +0100
@@ -61,7 +61,7 @@ else: @@ -61,7 +61,7 @@ else:
'yuv_row_other.cpp', 'yuv_row_other.cpp',
] ]
-if CONFIG['CPU_ARCH'] == 'arm' and CONFIG['HAVE_ARM_NEON']: -if CONFIG['CPU_ARCH'] == 'arm' and CONFIG['HAVE_ARM_NEON']:
+if CONFIG['HAVE_ARM_NEON']: +if CONFIG['HAVE_ARM_NEON']:
ASFILES += [ SOURCES += [
'yuv_row_arm.s', 'yuv_row_arm.s',
] ]
diff -up mozilla-release/media/libtheora/lib/moz.build.arm mozilla-release/media/libtheora/lib/moz.build
--- mozilla-release/media/libtheora/lib/moz.build.arm 2013-12-05 17:07:48.000000000 +0100
+++ mozilla-release/media/libtheora/lib/moz.build 2013-12-12 11:45:41.882119059 +0100
@@ -8,7 +8,7 @@ MODULE = 'theora'
LIBRARY_NAME = 'theora'
-if CONFIG['OS_TEST'] == 'arm' and CONFIG['GNU_AS']:
+if CONFIG['HAVE_ARM_NEON'] and CONFIG['GNU_AS']:
asm_suffix = CONFIG['ASM_SUFFIX']
ASFILES += [
'armbits-gnu.%s' % asm_suffix,

View File

@ -1,22 +1,23 @@
diff -up mozilla-release/security/build/Makefile.in.build mozilla-release/security/build/Makefile.in diff -up firefox-27.0/mozilla-release/security/build/Makefile.in.bld firefox-27.0/mozilla-release/security/build/Makefile.in
--- mozilla-release/security/build/Makefile.in.build 2013-12-05 17:07:53.000000000 +0100 --- firefox-27.0/mozilla-release/security/build/Makefile.in.bld 2014-01-28 05:04:01.000000000 +0100
+++ mozilla-release/security/build/Makefile.in 2013-12-09 15:10:17.177970414 +0100 +++ firefox-27.0/mozilla-release/security/build/Makefile.in 2014-02-03 10:56:16.010749049 +0100
@@ -128,7 +128,6 @@ DEFAULT_GMAKE_FLAGS += NSPR_INCLUDE_DIR= @@ -128,7 +128,6 @@ DEFAULT_GMAKE_FLAGS += NSPR_INCLUDE_DIR=
DEFAULT_GMAKE_FLAGS += NSPR_LIB_DIR=$(NSPR_LIB_DIR) DEFAULT_GMAKE_FLAGS += NSPR_LIB_DIR=$(NSPR_LIB_DIR)
DEFAULT_GMAKE_FLAGS += MOZILLA_CLIENT=1 DEFAULT_GMAKE_FLAGS += MOZILLA_CLIENT=1
DEFAULT_GMAKE_FLAGS += NO_MDUPDATE=1 DEFAULT_GMAKE_FLAGS += NO_MDUPDATE=1
-DEFAULT_GMAKE_FLAGS += NSS_ENABLE_ECC=1 -DEFAULT_GMAKE_FLAGS += NSS_ENABLE_ECC=1
DEFAULT_GMAKE_FLAGS += NSINSTALL="$(NSINSTALL)" ifeq ($(OS_ARCH)_$(GNU_CC),WINNT_1)
ifeq ($(OS_ARCH),WINNT) DEFAULT_GMAKE_FLAGS += OS_DLLFLAGS="-static-libgcc"
DEFAULT_GMAKE_FLAGS += INSTALL="$(NSINSTALL) -t" endif
diff -up mozilla-release/security/manager/ssl/src/Makefile.in.build mozilla-release/security/manager/ssl/src/Makefile.in diff -up firefox-27.0/mozilla-release/security/manager/ssl/src/Makefile.in.bld firefox-27.0/mozilla-release/security/manager/ssl/src/Makefile.in
--- mozilla-release/security/manager/ssl/src/Makefile.in.build 2013-12-09 15:10:17.177970414 +0100 --- firefox-27.0/mozilla-release/security/manager/ssl/src/Makefile.in.bld 2014-02-03 11:01:58.000000000 +0100
+++ mozilla-release/security/manager/ssl/src/Makefile.in 2013-12-09 15:11:02.282047401 +0100 +++ firefox-27.0/mozilla-release/security/manager/ssl/src/Makefile.in 2014-02-03 11:02:05.941855059 +0100
@@ -6,7 +6,6 @@ @@ -5,7 +5,6 @@
# file, You can obtain one at http://mozilla.org/MPL/2.0/.
EXPORT_LIBRARY = 1
DEFINES += \ DEFINES += \
- -DNSS_ENABLE_ECC \ - -DNSS_ENABLE_ECC \
-DDLL_PREFIX=\"$(DLL_PREFIX)\" \ -DDLL_PREFIX=\"$(DLL_PREFIX)\" \
-DDLL_SUFFIX=\"$(DLL_SUFFIX)\" \ -DDLL_SUFFIX=\"$(DLL_SUFFIX)\" \
$(NULL) $(NULL)
diff -up firefox-27.0/mozilla-release/security/manager/ssl/src/moz.build.bld firefox-27.0/mozilla-release/security/manager/ssl/src/moz.build

View File

@ -1,2 +1 @@
91ce51cc6474f1269484e5327643a59c firefox-26.0.source.tar.bz2 212827908144b43e7c80ed9d56a08ca9 firefox-27.0.source.tar.bz2
d89f888817f60a87fb71fdd190632212 firefox-langpacks-26.0-20131209.tar.xz