build fixes
This commit is contained in:
parent
1cb85e968f
commit
f1073d2d12
@ -1,25 +1,23 @@
|
|||||||
diff -up firefox-7.0/mozilla-beta/config/autoconf.mk.in.old firefox-7.0/mozilla-beta/config/autoconf.mk.in
|
diff -up mozilla-aurora-7676a9a06403/config/baseconfig.mk.dir mozilla-aurora-7676a9a06403/config/baseconfig.mk
|
||||||
--- firefox-7.0/mozilla-beta/config/autoconf.mk.in.old 2011-08-31 21:16:06.000000000 +0200
|
--- mozilla-aurora-7676a9a06403/config/baseconfig.mk.dir 2012-09-13 14:18:35.000000000 +0200
|
||||||
+++ firefox-7.0/mozilla-beta/config/autoconf.mk.in 2011-09-06 12:08:00.859392269 +0200
|
+++ mozilla-aurora-7676a9a06403/config/baseconfig.mk 2012-09-26 10:13:45.258240426 +0200
|
||||||
@@ -68,7 +68,7 @@ datadir = @datadir@
|
@@ -2,7 +2,7 @@ INCLUDED_AUTOCONF_MK = 1
|
||||||
mandir = @mandir@
|
|
||||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
|
||||||
|
|
||||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||||
|
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||||
|
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||||
|
DIST = $(DEPTH)/dist
|
||||||
|
|
||||||
DIST = $(DEPTH)/dist
|
diff -up mozilla-aurora-7676a9a06403/js/src/config/baseconfig.mk.dir mozilla-aurora-7676a9a06403/js/src/config/baseconfig.mk
|
||||||
diff -up firefox-7.0/mozilla-beta/js/src/config/autoconf.mk.in.old firefox-7.0/mozilla-beta/js/src/config/autoconf.mk.in
|
--- mozilla-aurora-7676a9a06403/js/src/config/baseconfig.mk.dir 2012-09-13 14:18:35.000000000 +0200
|
||||||
--- firefox-7.0/mozilla-beta/js/src/config/autoconf.mk.in.old 2011-08-31 21:16:16.000000000 +0200
|
+++ mozilla-aurora-7676a9a06403/js/src/config/baseconfig.mk 2012-09-26 10:14:07.353351833 +0200
|
||||||
+++ firefox-7.0/mozilla-beta/js/src/config/autoconf.mk.in 2011-09-06 12:08:39.463500899 +0200
|
@@ -1,6 +1,6 @@
|
||||||
@@ -61,7 +61,7 @@ libdir = @libdir@
|
INCLUDED_AUTOCONF_MK = 1
|
||||||
datadir = @datadir@
|
|
||||||
mandir = @mandir@
|
|
||||||
|
|
||||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||||
|
|
||||||
TOP_DIST = @TOP_DIST@
|
ifneq (,$(filter /%,$(TOP_DIST)))
|
||||||
diff -up firefox-7.0/mozilla-beta/Makefile.in.old firefox-7.0/mozilla-beta/Makefile.in
|
|
||||||
|
@ -2,8 +2,6 @@
|
|||||||
|
|
||||||
ac_add_options --prefix="$PREFIX"
|
ac_add_options --prefix="$PREFIX"
|
||||||
ac_add_options --libdir="$LIBDIR"
|
ac_add_options --libdir="$LIBDIR"
|
||||||
ac_add_options --with-system-nspr
|
|
||||||
ac_add_options --with-system-nss
|
|
||||||
ac_add_options --with-system-jpeg
|
ac_add_options --with-system-jpeg
|
||||||
ac_add_options --with-system-zlib
|
ac_add_options --with-system-zlib
|
||||||
#ac_add_options --with-system-png
|
#ac_add_options --with-system-png
|
||||||
|
@ -116,7 +116,7 @@ cd %{tarballdir}
|
|||||||
# Build patches, can't change backup suffix from default because during build
|
# Build patches, can't change backup suffix from default because during build
|
||||||
# there is a compare of config and js/config directories and .orig suffix is
|
# there is a compare of config and js/config directories and .orig suffix is
|
||||||
# ignored during this compare.
|
# ignored during this compare.
|
||||||
%patch0 -p2 -b .orig
|
%patch0 -p1
|
||||||
|
|
||||||
# For branding specific patches.
|
# For branding specific patches.
|
||||||
|
|
||||||
@ -385,7 +385,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_datadir}/icons/hicolor/32x32/apps/firefox.png
|
%{_datadir}/icons/hicolor/32x32/apps/firefox.png
|
||||||
%{_datadir}/icons/hicolor/48x48/apps/firefox.png
|
%{_datadir}/icons/hicolor/48x48/apps/firefox.png
|
||||||
%{mozappdir}/xulrunner
|
%{mozappdir}/xulrunner
|
||||||
|
%{mozappdir}/webapprt-stub
|
||||||
|
%dir %{mozappdir}/webapprt
|
||||||
|
%{mozappdir}/webapprt/omni.ja
|
||||||
|
%{mozappdir}/webapprt/webapprt.ini
|
||||||
%if %{include_debuginfo}
|
%if %{include_debuginfo}
|
||||||
#%{mozappdir}/crashreporter
|
#%{mozappdir}/crashreporter
|
||||||
%{mozappdir}/crashreporter-override.ini
|
%{mozappdir}/crashreporter-override.ini
|
||||||
|
Loading…
Reference in New Issue
Block a user