Disabled arm, added ppc build fixes

This commit is contained in:
Martin Stransky 2017-08-03 12:08:12 +02:00
parent 9edd308c25
commit ef8411215c
2 changed files with 17 additions and 0 deletions

14
build-ppc-s390-dom.patch Normal file
View File

@ -0,0 +1,14 @@
diff -up firefox-55.0/dom/base/nsWrapperCache.h.old firefox-55.0/dom/base/nsWrapperCache.h
--- firefox-55.0/dom/base/nsWrapperCache.h.old 2017-08-03 12:02:06.720927791 +0200
+++ firefox-55.0/dom/base/nsWrapperCache.h 2017-08-03 12:03:16.576707873 +0200
@@ -41,7 +41,7 @@ class nsWindowRoot;
// This may waste space for some other nsWrapperCache-derived objects that have
// a 32-bit field as their first member, but those objects are unlikely to be as
// numerous or performance-critical as DOM nodes.
-#if defined(_M_X64) || defined(__x86_64__) || defined(__aarch64__)
+#if defined(_M_X64) || defined(__x86_64__) || defined(__aarch64__) || defined(__PPC64__) || defined(__pcc64le__) || defined(__S390X__) || defined(__s390x__)
static_assert(sizeof(void*) == 8, "These architectures should be 64-bit");
#define BOOL_FLAGS_ON_WRAPPER_CACHE
#else
diff -up firefox-55.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-55.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
diff -up firefox-55.0/media/webrtc/trunk/Makefile.old firefox-55.0/media/webrtc/trunk/Makefile

View File

@ -1,3 +1,4 @@
ExcludeArch: aarch64 armv7hl
# Use ALSA backend?
%define alsa_backend 0
@ -127,6 +128,7 @@ Patch29: build-big-endian.patch
Patch30: fedora-build.patch
Patch31: build-ppc64-s390x-curl.patch
Patch32: build-rust-ppc64le.patch
Patch33: build-ppc-s390-dom.patch
# Fedora specific patches
# Unable to install addons from https pages
@ -300,6 +302,7 @@ This package contains results of tests executed during build.
%patch30 -p1 -b .fedora-build
%patch31 -p1 -b .ppc64-s390x-curl
%patch32 -p1 -b .rust-ppc64le
%patch33 -p1 -b .ppc-s390-dom
%patch3 -p1 -b .arm