This commit is contained in:
Martin Stransky 2023-06-05 13:35:49 +02:00
commit e2f9245924
2 changed files with 4 additions and 51 deletions

View File

@ -21,13 +21,9 @@ ExcludeArch: i686
# as the build is *very* slow.
%global debug_build 0
# See rhbz#2134527 - Use portal Gtk file dialog on Fedora 37+
# See rhbz#2134527 - Use portal Gtk file dialog
# Disabled due to various issues now.
%if 0%{?fedora} >= 37
%global use_xdg_file_portal 0
%else
%global use_xdg_file_portal 0
%endif
%global system_nss 1
%global system_libevent 1
@ -40,14 +36,6 @@ ExcludeArch: i686
%global build_with_clang 0
%endif
%ifarch armv7hl
%global create_debuginfo 0
# always use clang for arm builds
%global toolchain clang
%global build_with_clang 1
%endif
# Temporary disabled due to
# https://bugzilla.redhat.com/show_bug.cgi?id=1951606
%global enable_mozilla_crashreporter 0
@ -67,11 +55,7 @@ ExcludeArch: i686
%endif
%global system_ffi 1
%ifarch armv7hl
%global system_libvpx 1
%else
%global system_libvpx 0
%endif
%global system_jpeg 1
%global system_pixman 1
%global use_bundled_cbindgen 1
@ -140,20 +124,15 @@ ExcludeArch: i686
%bcond_without langpacks
%if %{with langpacks}
%if 0%{?fedora} >= 37
%bcond_without langpacks_subpkg
%endif
%endif
%if !%{release_build}
%global pre_tag .npgo
%endif
# Don't use 'clang' suffix on arm
%ifnarch %{arm}
%if %{build_with_clang}
%global pre_tag .clang
%endif
%endif
%if %{build_with_asan}
%global pre_tag .asan
%global build_with_pgo 0
@ -561,7 +540,7 @@ echo "ac_add_options --with-system-libevent" >> .mozconfig
echo "ac_add_options --enable-system-ffi" >> .mozconfig
%endif
%ifarch %{arm} aarch64
%ifarch aarch64
echo "ac_add_options --disable-elf-hack" >> .mozconfig
%endif
@ -682,7 +661,7 @@ MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | sed -e 's/-O2//')
# If MOZ_DEBUG_FLAGS is empty, firefox's build will default it to "-g" which
# overrides the -g1 from line above and breaks building on s390/arm
# (OOM when linking, rhbz#1238225)
%ifarch %{arm} %{ix86}
%ifarch %{ix86}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | sed -e 's/-g/-g0/')
export MOZ_DEBUG_FLAGS=" "
%endif
@ -691,12 +670,8 @@ MOZ_LINK_FLAGS="%{build_ldflags}"
%ifarch aarch64 %{ix86}
MOZ_LINK_FLAGS="$MOZ_LINK_FLAGS -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
%endif
%ifarch %{arm}
MOZ_LINK_FLAGS="$MOZ_LINK_FLAGS -Wl,--no-keep-memory -Wl,--strip-debug"
echo "ac_add_options --enable-linker=gold" >> .mozconfig
%endif
%endif
%ifarch %{arm} %{ix86} s390x
%ifarch %{ix86} s390x
export RUSTFLAGS="-Cdebuginfo=0"
%endif
%if %{build_with_asan}
@ -704,16 +679,6 @@ MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fsanitize=address -Dxmalloc=myxmalloc"
MOZ_LINK_FLAGS="$MOZ_LINK_FLAGS -fsanitize=address -ldl"
%endif
%ifarch %{arm}
# disable hard-coded LTO due to RAM constraints
sed -i '/cargo_rustc_flags += -Clto/d' config/makefiles/rust.mk
sed -i '/RUSTFLAGS += -Cembed-bitcode=yes/d' config/makefiles/rust.mk
sed -i 's/codegen-units=1/codegen-units=16/' config/makefiles/rust.mk
# make sure "-g0" is the last flag so there's no debug info
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -g0"
%endif
# We don't wantfirefox to use CK_GCM_PARAMS_V3 in nss
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -DNSS_PKCS11_3_0_STRICT"

View File

@ -1,12 +0,0 @@
diff -ur a/gfx/skia/skia/third_party/skcms/src/Transform_inl.h b/gfx/skia/skia/third_party/skcms/src/Transform_inl.h
--- a/gfx/skia/skia/third_party/skcms/src/Transform_inl.h 2022-05-27 08:37:14.642698922 +0300
+++ b/gfx/skia/skia/third_party/skcms/src/Transform_inl.h 2022-05-27 12:23:43.592185545 +0300
@@ -683,7 +683,7 @@
// GCC 7.2.0 hits an internal compiler error with -finline-functions (or -O3)
// when targeting MIPS 64, i386, or s390x, I think attempting to inline clut() into exec_ops().
#if 1 && defined(__GNUC__) && !defined(__clang__) \
- && (defined(__mips64) || defined(__i386) || defined(__s390x__))
+ && (defined(__arm__) || defined(__mips64) || defined(__i386) || defined(__s390x__))
#define MAYBE_NOINLINE __attribute__((noinline))
#else
#define MAYBE_NOINLINE