Updated to build 2, added fix for mzbz#1826583/rhbz#2184842
This commit is contained in:
parent
afd2fc66a8
commit
d698bc4eec
1
.gitignore
vendored
1
.gitignore
vendored
@ -566,3 +566,4 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-111.0.1.source.tar.xz
|
||||
/firefox-112.0.source.tar.xz
|
||||
/firefox-langpacks-112.0-20230405.tar.xz
|
||||
/firefox-langpacks-112.0-20230406.tar.xz
|
||||
|
10
firefox.spec
10
firefox.spec
@ -175,12 +175,12 @@ ExcludeArch: i686
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 112.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230405.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20230406.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -255,6 +255,7 @@ Patch408: mozilla-1663844.patch
|
||||
Patch415: mozilla-1670333.patch
|
||||
# https://phabricator.services.mozilla.com/D173021
|
||||
Patch416: libwebrtc-pipewire-capturer-import-dmabuf-directly-into-desktop-frame.patch
|
||||
Patch417: mozilla-1826583.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -530,6 +531,7 @@ This package contains results of tests executed during build.
|
||||
%patch408 -p1 -b .1663844
|
||||
%patch415 -p1 -b .1670333
|
||||
%patch416 -p1 -b .libwebrtc-pipewire-capturer-import-dmabuf-directly-into-desktop-frame
|
||||
%patch417 -p1 -b .1826583
|
||||
|
||||
# PGO patches
|
||||
%if %{build_with_pgo}
|
||||
@ -1078,6 +1080,10 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Apr 6 2023 Martin Stransky <stransky@redhat.com>- 112.0-2
|
||||
- Updated to 112.0 build 2
|
||||
- don't crash on wayland logging (mzbz#1826583/rhbz#2184842).
|
||||
|
||||
* Wed Apr 5 2023 Martin Stransky <stransky@redhat.com>- 112.0-1
|
||||
- Updated to 112.0
|
||||
|
||||
|
14
mozilla-1826583.patch
Normal file
14
mozilla-1826583.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up firefox-112.0/widget/gtk/nsWaylandDisplay.cpp.old firefox-112.0/widget/gtk/nsWaylandDisplay.cpp
|
||||
--- firefox-112.0/widget/gtk/nsWaylandDisplay.cpp.old 2023-04-06 19:35:44.744731593 +0200
|
||||
+++ firefox-112.0/widget/gtk/nsWaylandDisplay.cpp 2023-04-06 19:35:23.650016723 +0200
|
||||
@@ -271,8 +271,8 @@ bool nsWaylandDisplay::Matches(wl_displa
|
||||
return mThreadId == PR_GetCurrentThread() && aDisplay == mDisplay;
|
||||
}
|
||||
|
||||
-static void WlCrashHandler(const char* format, va_list args) {
|
||||
- MOZ_CRASH_UNSAFE(g_strdup_vprintf(format, args));
|
||||
+static void WlCrashHandler(const char* format, va_list args) {
|
||||
+ vfprintf(stderr, format, args);
|
||||
}
|
||||
|
||||
nsWaylandDisplay::nsWaylandDisplay(wl_display* aDisplay)
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 0d45c1decfd7aaee853748745c9f5a907c0c6a0cf809c2387aac1cdcf680b0844b1ef4d05148e0527de4ff6e4d4666110bea317bd00b7d73a1210eb58a815563
|
||||
SHA512 (mochitest-python.tar.gz) = e0a2c569dafe013b6a4c073516388549a8f398d8aa4538a3bc69dcda44737a3a3cf070285e9fa040a15d7a62446665c6158d42a1b6dc3e8d7f4680bc2ef17a16
|
||||
SHA512 (firefox-112.0.source.tar.xz) = 4e394acce877e86282a57da6e9a90b3dc7025aa0bc243dde9f7d5dec20de7e3ed6a330ae8e8d459193b83e1fbf695214b333055815825d5f3fc120287249b387
|
||||
SHA512 (firefox-langpacks-112.0-20230405.tar.xz) = 67ac240a3cc079b0b8ffe89268e352cc789f36ba6f1fca5a3872bb1c8cf6f8b3ca3722349f6d2dc853577a4aebfbaa681980b8327369b9a99c2a8091d38340e7
|
||||
SHA512 (firefox-langpacks-112.0-20230406.tar.xz) = 11870eec9947b11be404016b6426f13c86b37be7d0021bf7ae640151d17df35212bfb4c1c14aef5948dcd49312b47daf582f2367f5ba4d2f81dfc8ce64d9609d
|
||||
SHA512 (firefox-112.0.source.tar.xz) = 6b2bc8c0c93f3109da27168fe7e8f734c6ab4efb4ca56ff2d5e3a52659da71173bba2104037a000623833be8338621fca482f39f836e3910fe2996e6d0a68b39
|
||||
|
Loading…
Reference in New Issue
Block a user