Fix build on AArch64 (based on upstream skia changes)
This commit is contained in:
parent
528941f0a3
commit
d4be59b850
18
aarch64-fix-skia.patch
Normal file
18
aarch64-fix-skia.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Based on https://github.com/google/skia/commit/b79ff56de23fef680ae7187040f2d6a9516b553d
|
||||
|
||||
Index: mozilla-release/gfx/skia/trunk/src/core/SkUtilsArm.h
|
||||
===================================================================
|
||||
--- mozilla-release.orig/gfx/skia/trunk/src/core/SkUtilsArm.h
|
||||
+++ mozilla-release/gfx/skia/trunk/src/core/SkUtilsArm.h
|
||||
@@ -21,9 +21,9 @@
|
||||
#define SK_ARM_NEON_MODE_ALWAYS 1
|
||||
#define SK_ARM_NEON_MODE_DYNAMIC 2
|
||||
|
||||
-#if defined(SK_CPU_ARM32) && defined(__ARM_HAVE_OPTIONAL_NEON_SUPPORT)
|
||||
+#if defined(__ARM_HAVE_OPTIONAL_NEON_SUPPORT)
|
||||
# define SK_ARM_NEON_MODE SK_ARM_NEON_MODE_DYNAMIC
|
||||
-#elif defined(SK_CPU_ARM32) && defined(__ARM_HAVE_NEON) || defined(SK_CPU_ARM64)
|
||||
+#elif defined(__ARM_HAVE_NEON)
|
||||
# define SK_ARM_NEON_MODE SK_ARM_NEON_MODE_ALWAYS
|
||||
#else
|
||||
# define SK_ARM_NEON_MODE SK_ARM_NEON_MODE_NONE
|
10
firefox.spec
10
firefox.spec
@ -107,7 +107,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 37.0
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Release: 3%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -154,6 +154,9 @@ Patch413: mozilla-975919-gtk3-hidpi.patch
|
||||
Patch414: mozilla-1143686.patch
|
||||
Patch415: mozilla-1144643.patch
|
||||
|
||||
# Fix Skia Neon stuff on AArch64
|
||||
Patch500: aarch64-fix-skia.patch
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
|
||||
@ -305,6 +308,8 @@ cd %{tarballdir}
|
||||
%patch415 -p1 -b .1144643
|
||||
%endif
|
||||
|
||||
%patch500 -p1
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
|
||||
@ -798,6 +803,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Mar 31 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 37.0-3
|
||||
- Fix build on AArch64 (based on upstream skia changes)
|
||||
|
||||
* Fri Mar 27 2015 Martin Stransky <stransky@redhat.com> - 37.0-2
|
||||
- Added tooltip patch (mozbz#1144643)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user