Removed autoconf213 dependency
This commit is contained in:
parent
7706260624
commit
d4a0f87d82
5771
D89554-autoconf1.diff
Normal file
5771
D89554-autoconf1.diff
Normal file
File diff suppressed because it is too large
Load Diff
118
D94538-autoconf2.diff
Normal file
118
D94538-autoconf2.diff
Normal file
@ -0,0 +1,118 @@
|
|||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/archlinux.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/archlinux.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/archlinux.py.D94538-autoconf2.diff 2021-02-25 13:53:04.963982705 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/archlinux.py 2021-02-25 13:53:25.713053151 +0100
|
||||||
|
@@ -26,7 +26,6 @@ class ArchlinuxBootstrapper(
|
||||||
|
'''Archlinux experimental bootstrapper.'''
|
||||||
|
|
||||||
|
SYSTEM_PACKAGES = [
|
||||||
|
- 'autoconf2.13',
|
||||||
|
'base-devel',
|
||||||
|
'nodejs',
|
||||||
|
'python2',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/centosfedora.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/centosfedora.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/centosfedora.py.D94538-autoconf2.diff 2021-02-17 08:49:42.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/centosfedora.py 2021-02-25 13:53:04.963982705 +0100
|
||||||
|
@@ -26,7 +26,6 @@ class CentOSFedoraBootstrapper(
|
||||||
|
# For CentOS 7, later versions of nodejs come from nodesource
|
||||||
|
# and include the npm package.
|
||||||
|
self.packages = [
|
||||||
|
- 'autoconf213',
|
||||||
|
'nodejs',
|
||||||
|
'which',
|
||||||
|
]
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/debian.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/debian.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/debian.py.D94538-autoconf2.diff 2021-02-25 13:53:04.963982705 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/debian.py 2021-02-25 13:53:42.874111415 +0100
|
||||||
|
@@ -32,7 +32,6 @@ class DebianBootstrapper(
|
||||||
|
# These are common packages for all Debian-derived distros (such as
|
||||||
|
# Ubuntu).
|
||||||
|
COMMON_PACKAGES = [
|
||||||
|
- 'autoconf2.13',
|
||||||
|
'build-essential',
|
||||||
|
'nodejs',
|
||||||
|
'python-setuptools',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/freebsd.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/freebsd.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/freebsd.py.D94538-autoconf2.diff 2021-02-17 08:49:42.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/freebsd.py 2021-02-25 13:53:04.963982705 +0100
|
||||||
|
@@ -15,7 +15,6 @@ class FreeBSDBootstrapper(BaseBootstrapp
|
||||||
|
self.flavor = flavor.lower()
|
||||||
|
|
||||||
|
self.packages = [
|
||||||
|
- 'autoconf213',
|
||||||
|
'gmake',
|
||||||
|
'gtar',
|
||||||
|
'pkgconf',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/gentoo.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/gentoo.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/gentoo.py.D94538-autoconf2.diff 2021-02-17 08:49:38.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/gentoo.py 2021-02-25 13:53:04.963982705 +0100
|
||||||
|
@@ -36,7 +36,6 @@ class GentooBootstrapper(
|
||||||
|
def ensure_system_packages(self):
|
||||||
|
self.run_as_root(['emerge', '--noreplace', '--quiet',
|
||||||
|
'app-arch/zip',
|
||||||
|
- 'sys-devel/autoconf:2.1'
|
||||||
|
])
|
||||||
|
|
||||||
|
def ensure_browser_packages(self, artifact_mode=False):
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/openbsd.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/openbsd.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/openbsd.py.D94538-autoconf2.diff 2021-02-17 08:49:15.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/openbsd.py 2021-02-25 13:53:04.964982709 +0100
|
||||||
|
@@ -12,7 +12,6 @@ class OpenBSDBootstrapper(BaseBootstrapp
|
||||||
|
BaseBootstrapper.__init__(self, **kwargs)
|
||||||
|
|
||||||
|
self.packages = [
|
||||||
|
- 'autoconf-2.13',
|
||||||
|
'gmake',
|
||||||
|
'gtar',
|
||||||
|
'rust',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/opensuse.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/opensuse.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/opensuse.py.D94538-autoconf2.diff 2021-02-17 08:49:42.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/opensuse.py 2021-02-25 13:53:04.964982709 +0100
|
||||||
|
@@ -13,7 +13,6 @@ class OpenSUSEBootstrapper(
|
||||||
|
'''openSUSE experimental bootstrapper.'''
|
||||||
|
|
||||||
|
SYSTEM_PACKAGES = [
|
||||||
|
- 'autoconf213',
|
||||||
|
'nodejs',
|
||||||
|
'npm',
|
||||||
|
'which',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/osx.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/osx.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/osx.py.D94538-autoconf2.diff 2021-02-25 13:53:04.964982709 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/osx.py 2021-02-25 13:54:07.162193882 +0100
|
||||||
|
@@ -353,7 +353,6 @@ class OSXBootstrapper(BaseBootstrapper):
|
||||||
|
# least on 10.8) and because the build system wants a version
|
||||||
|
# newer than what Apple ships.
|
||||||
|
packages = [
|
||||||
|
- 'autoconf@2.13',
|
||||||
|
'git',
|
||||||
|
'gnu-tar',
|
||||||
|
'node',
|
||||||
|
@@ -428,7 +427,6 @@ class OSXBootstrapper(BaseBootstrapper):
|
||||||
|
'python27',
|
||||||
|
'python36',
|
||||||
|
'py27-gnureadline',
|
||||||
|
- 'autoconf213',
|
||||||
|
'gnutar',
|
||||||
|
'watchman',
|
||||||
|
'nodejs8'
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/solus.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/solus.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/solus.py.D94538-autoconf2.diff 2021-02-25 13:53:04.964982709 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/solus.py 2021-02-25 13:53:32.090074802 +0100
|
||||||
|
@@ -23,7 +23,6 @@ class SolusBootstrapper(
|
||||||
|
'''Solus experimental bootstrapper.'''
|
||||||
|
|
||||||
|
SYSTEM_PACKAGES = [
|
||||||
|
- 'autoconf213',
|
||||||
|
'nodejs',
|
||||||
|
'python',
|
||||||
|
'python3',
|
||||||
|
diff -up firefox-78.8.0/python/mozboot/mozboot/windows.py.D94538-autoconf2.diff firefox-78.8.0/python/mozboot/mozboot/windows.py
|
||||||
|
--- firefox-78.8.0/python/mozboot/mozboot/windows.py.D94538-autoconf2.diff 2021-02-17 08:49:34.000000000 +0100
|
||||||
|
+++ firefox-78.8.0/python/mozboot/mozboot/windows.py 2021-02-25 13:53:04.978982756 +0100
|
||||||
|
@@ -48,7 +48,6 @@ class WindowsBootstrapper(BaseBootstrapp
|
||||||
|
'patch',
|
||||||
|
'patchutils',
|
||||||
|
'diffutils',
|
||||||
|
- 'autoconf2.13',
|
||||||
|
'tar',
|
||||||
|
'zip',
|
||||||
|
'unzip',
|
11
firefox.spec
11
firefox.spec
@ -198,7 +198,7 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 78.8.0
|
Version: 78.8.0
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
%if 0%{?rhel} == 7
|
%if 0%{?rhel} == 7
|
||||||
@ -254,6 +254,8 @@ Patch1002: python-2.7-gcc8-fix.patch
|
|||||||
Patch1003: python-missing-utimensat.patch
|
Patch1003: python-missing-utimensat.patch
|
||||||
Patch1004: build-icu-make.patch
|
Patch1004: build-icu-make.patch
|
||||||
Patch1005: mozilla-1692893-glib-object.patch
|
Patch1005: mozilla-1692893-glib-object.patch
|
||||||
|
Patch1006: D89554-autoconf1.diff
|
||||||
|
Patch1007: D94538-autoconf2.diff
|
||||||
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1699374
|
# workaround for https://bugzilla.redhat.com/show_bug.cgi?id=1699374
|
||||||
Patch4: build-mozconfig-fix.patch
|
Patch4: build-mozconfig-fix.patch
|
||||||
Patch6: build-nss-version.patch
|
Patch6: build-nss-version.patch
|
||||||
@ -337,8 +339,8 @@ BuildRequires: dbus-glib-devel
|
|||||||
%if %{?system_libvpx}
|
%if %{?system_libvpx}
|
||||||
BuildRequires: libvpx-devel >= %{libvpx_version}
|
BuildRequires: libvpx-devel >= %{libvpx_version}
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: autoconf213
|
|
||||||
BuildRequires: pkgconfig(libpulse)
|
BuildRequires: pkgconfig(libpulse)
|
||||||
|
BuildRequires: m4
|
||||||
|
|
||||||
%if 0%{?use_dts}
|
%if 0%{?use_dts}
|
||||||
BuildRequires: devtoolset-%{dts_version}-gcc-c++
|
BuildRequires: devtoolset-%{dts_version}-gcc-c++
|
||||||
@ -644,6 +646,8 @@ sed -ie 's|/usr/include|/app/include|' %_sourcedir/firefox-pipewire-0-3.patch
|
|||||||
%patch1001 -p1 -b .ppc64le-inline
|
%patch1001 -p1 -b .ppc64le-inline
|
||||||
%patch1004 -p1 -b .icu-make
|
%patch1004 -p1 -b .icu-make
|
||||||
%patch1005 -p1 -b .mozilla-1692893-glib-object
|
%patch1005 -p1 -b .mozilla-1692893-glib-object
|
||||||
|
%patch1006 -p1 -b .D89554-autoconf1.diff
|
||||||
|
%patch1007 -p1 -b .D94538-autoconf2.diff
|
||||||
|
|
||||||
# CentOS patches
|
# CentOS patches
|
||||||
%if 0%{?centos}
|
%if 0%{?centos}
|
||||||
@ -1609,6 +1613,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 01 2021 Jan Horak <jhorak@redhat.com> - 78.8.0-3
|
||||||
|
- Removed autoconf213 dependency
|
||||||
|
|
||||||
* Mon Feb 22 2021 Jan Horak <jhorak@redhat.com> - 78.8.0-2
|
* Mon Feb 22 2021 Jan Horak <jhorak@redhat.com> - 78.8.0-2
|
||||||
- Update to 78.8.0 build2
|
- Update to 78.8.0 build2
|
||||||
- Removed dependency on gconf-2
|
- Removed dependency on gconf-2
|
||||||
|
Loading…
Reference in New Issue
Block a user