Added extra va-api frames to vp8/9 decoder.
This commit is contained in:
parent
c9d361caf9
commit
d48800a4fb
14
firefox-vaapi-extra-frames.patch
Normal file
14
firefox-vaapi-extra-frames.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up firefox-76.0.1/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp.old firefox-76.0.1/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp
|
||||
--- firefox-76.0.1/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp.old 2020-05-13 14:28:26.556800474 +0200
|
||||
+++ firefox-76.0.1/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp 2020-05-13 14:28:31.562768959 +0200
|
||||
@@ -43,7 +43,7 @@ typedef int VAStatus;
|
||||
#endif
|
||||
|
||||
// Use some extra HW frames for potential rendering lags.
|
||||
-#define EXTRA_HW_FRAMES 6
|
||||
+#define EXTRA_HW_FRAMES 20
|
||||
|
||||
typedef mozilla::layers::Image Image;
|
||||
typedef mozilla::layers::PlanarYCbCrImage PlanarYCbCrImage;
|
||||
diff -up firefox-76.0.1/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-76.0.1/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
||||
diff -up firefox-76.0.1/media/webrtc/trunk/Makefile.old firefox-76.0.1/media/webrtc/trunk/Makefile
|
@ -118,7 +118,7 @@ ExcludeArch: aarch64
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 76.0.1
|
||||
Release: 1%{?nss_tag}%{?dist}
|
||||
Release: 2%{?nss_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
@ -194,6 +194,7 @@ Patch581: mozilla-1630754.patch
|
||||
Patch582: mozilla-1619543.patch
|
||||
Patch583: mozilla-1632059.patch
|
||||
Patch584: firefox-disable-ffvpx-with-vapi.patch
|
||||
Patch585: firefox-vaapi-extra-frames.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -406,6 +407,7 @@ This package contains results of tests executed during build.
|
||||
%patch581 -p1 -b .mozilla-1630754
|
||||
%patch583 -p1 -b .mozilla-1632059
|
||||
%patch584 -p1 -b .firefox-disable-ffvpx-with-vapi
|
||||
%patch585 -p1 -b .firefox-vaapi-extra-frames
|
||||
|
||||
# PGO patches
|
||||
%patch600 -p1 -b .pgo
|
||||
@ -980,6 +982,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed May 13 2020 Martin Stransky <stransky@redhat.com> - 76.0.1-2
|
||||
- Added extra va-api frames to vp8/9 decoder.
|
||||
|
||||
* Fri May 8 2020 Martin Stransky <stransky@redhat.com> - 76.0.1-1
|
||||
- Updated to 76.0.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user