Disabled openh264 download
This commit is contained in:
parent
85160fd5ad
commit
d27db77328
@ -12,3 +12,28 @@ diff -up firefox-81.0/toolkit/modules/GMPInstallManager.jsm.old firefox-81.0/too
|
|||||||
id: "gmp-widevinecdm",
|
id: "gmp-widevinecdm",
|
||||||
src: "chrome://global/content/gmp-sources/widevinecdm.json",
|
src: "chrome://global/content/gmp-sources/widevinecdm.json",
|
||||||
},
|
},
|
||||||
|
diff --git a/toolkit/content/jar.mn b/toolkit/content/jar.mn
|
||||||
|
--- a/toolkit/content/jar.mn
|
||||||
|
+++ b/toolkit/content/jar.mn
|
||||||
|
@@ -108,7 +108,6 @@ toolkit.jar:
|
||||||
|
#ifdef XP_MACOSX
|
||||||
|
content/global/macWindowMenu.js
|
||||||
|
#endif
|
||||||
|
- content/global/gmp-sources/openh264.json (gmp-sources/openh264.json)
|
||||||
|
content/global/gmp-sources/widevinecdm.json (gmp-sources/widevinecdm.json)
|
||||||
|
|
||||||
|
# Third party files
|
||||||
|
diff --git a/toolkit/modules/GMPInstallManager.jsm b/toolkit/modules/GMPInstallManager.jsm
|
||||||
|
--- a/toolkit/modules/GMPInstallManager.jsm
|
||||||
|
+++ b/toolkit/modules/GMPInstallManager.jsm
|
||||||
|
@@ -238,6 +234,9 @@ GMPInstallManager.prototype = {
|
||||||
|
* downloaderr, verifyerr or previouserrorencountered
|
||||||
|
*/
|
||||||
|
installAddon(gmpAddon) {
|
||||||
|
+ if (gmpAddon.isOpenH264) {
|
||||||
|
+ return Promise.reject({ type: "disabled" });
|
||||||
|
+ }
|
||||||
|
if (this._deferred) {
|
||||||
|
let log = getScopedLogger("GMPInstallManager.installAddon");
|
||||||
|
log.error("previous error encountered");
|
||||||
|
|
||||||
|
11
firefox.spec
11
firefox.spec
@ -5,9 +5,9 @@
|
|||||||
%global build_with_asan 0
|
%global build_with_asan 0
|
||||||
|
|
||||||
# Temporary disabled, filed as rhbz#1862012
|
# Temporary disabled, filed as rhbz#1862012
|
||||||
%if 0%{?fedora} == 33
|
#%if 0%{?fedora} == 33
|
||||||
ExcludeArch: ppc64le
|
#ExcludeArch: ppc64le
|
||||||
%endif
|
#%endif
|
||||||
# Disabled due to https://pagure.io/fedora-infrastructure/issue/7581
|
# Disabled due to https://pagure.io/fedora-infrastructure/issue/7581
|
||||||
ExcludeArch: s390x
|
ExcludeArch: s390x
|
||||||
|
|
||||||
@ -116,7 +116,7 @@ ExcludeArch: s390x
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 81.0
|
Version: 81.0
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
@ -979,6 +979,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 30 2020 Martin Stransky <stransky@redhat.com> - 81.0-8
|
||||||
|
- Disabled openh264 download
|
||||||
|
|
||||||
* Fri Sep 25 2020 Martin Stransky <stransky@redhat.com> - 81.0-7
|
* Fri Sep 25 2020 Martin Stransky <stransky@redhat.com> - 81.0-7
|
||||||
- Added openh264 fixes
|
- Added openh264 fixes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user