Added a fix for rhbz#1240259 - Firefox 39 does not open home page but restore session
This commit is contained in:
parent
62bcf95a3d
commit
cf16dc5152
10
firefox.spec
10
firefox.spec
@ -107,7 +107,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 39.0
|
||||
Release: 6%{?pre_tag}%{?dist}
|
||||
Release: 7%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -161,6 +161,8 @@ Patch423: mozilla-1129873-apppicker.patch
|
||||
# Fix Skia Neon stuff on AArch64
|
||||
Patch500: aarch64-fix-skia.patch
|
||||
|
||||
# Don't crash at end
|
||||
Patch510: mozilla-884831.patch
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
@ -319,6 +321,8 @@ cd %{tarballdir}
|
||||
|
||||
%patch500 -p1
|
||||
|
||||
%patch510 -p1 -b .884831
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
|
||||
@ -816,6 +820,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Mon Jul 06 2015 Martin Stransky <stransky@redhat.com> - 39.0-7
|
||||
- Added a fix for rhbz#1240259 - Firefox 39 does not open
|
||||
home page but "restore session"
|
||||
|
||||
* Thu Jul 02 2015 Martin Stransky <stransky@redhat.com> - 39.0-6
|
||||
- Added symbolic (high contrast) icon
|
||||
|
||||
|
21
mozilla-884831.patch
Normal file
21
mozilla-884831.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up mozilla-release/toolkit/xre/nsAppRunner.cpp.884831 mozilla-release/toolkit/xre/nsAppRunner.cpp
|
||||
--- mozilla-release/toolkit/xre/nsAppRunner.cpp.884831 2015-07-06 14:36:32.583521873 +0200
|
||||
+++ mozilla-release/toolkit/xre/nsAppRunner.cpp 2015-07-06 14:45:19.494258581 +0200
|
||||
@@ -2770,7 +2770,7 @@ static void MOZ_gdk_display_close(GdkDis
|
||||
// shut down cairo first otherwise it may crash because of dangling
|
||||
// references to Display objects (see bug 469831).
|
||||
if (!theme_is_qt)
|
||||
- gdk_display_close(display);
|
||||
+ //gdk_display_close(display);
|
||||
}
|
||||
|
||||
// Clean up PangoCairo's default fontmap.
|
||||
@@ -2807,7 +2807,7 @@ static void MOZ_gdk_display_close(GdkDis
|
||||
|
||||
if (buggyCairoShutdown) {
|
||||
if (!theme_is_qt)
|
||||
- gdk_display_close(display);
|
||||
+ //gdk_display_close(display);
|
||||
}
|
||||
#else // not CLEANUP_MEMORY
|
||||
// Don't do anything to avoid running into driver bugs under XCloseDisplay().
|
Loading…
Reference in New Issue
Block a user