Added patch for mozbz#1875469 / rhbz#1875469
This commit is contained in:
parent
eef6ef732b
commit
cedcf4cef3
10
firefox.spec
10
firefox.spec
@ -44,6 +44,9 @@ ExcludeArch: aarch64
|
|||||||
# Build PGO builds on Wayland backend
|
# Build PGO builds on Wayland backend
|
||||||
%global pgo_wayland 0
|
%global pgo_wayland 0
|
||||||
%endif
|
%endif
|
||||||
|
%if 0%{?fedora} >= 33
|
||||||
|
%global build_with_pgo 0
|
||||||
|
%endif
|
||||||
%if 0%{?fedora} > 30
|
%if 0%{?fedora} > 30
|
||||||
%global wayland_backend_default 1
|
%global wayland_backend_default 1
|
||||||
%endif
|
%endif
|
||||||
@ -114,7 +117,7 @@ ExcludeArch: aarch64
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 80.0.1
|
Version: 80.0.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
@ -161,6 +164,7 @@ Patch48: build-arm-wasm.patch
|
|||||||
Patch49: build-arm-libaom.patch
|
Patch49: build-arm-libaom.patch
|
||||||
#Patch50: Bug-1610814-Fix-NEON-compile-error-with-gcc-and-RGB-.patch
|
#Patch50: Bug-1610814-Fix-NEON-compile-error-with-gcc-and-RGB-.patch
|
||||||
Patch51: build-nspr.patch
|
Patch51: build-nspr.patch
|
||||||
|
Patch52: mozilla-1875469.patch
|
||||||
|
|
||||||
# Fedora specific patches
|
# Fedora specific patches
|
||||||
Patch215: firefox-enable-addons.patch
|
Patch215: firefox-enable-addons.patch
|
||||||
@ -363,6 +367,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch49 -p1 -b .build-arm-libaom
|
%patch49 -p1 -b .build-arm-libaom
|
||||||
#%patch50 -p1 -b .build-arm-SwizzleNEON
|
#%patch50 -p1 -b .build-arm-SwizzleNEON
|
||||||
%patch51 -p1 -b .build-nspr
|
%patch51 -p1 -b .build-nspr
|
||||||
|
%patch52 -p1 -b .mozilla-1875469
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch215 -p1 -b .addons
|
%patch215 -p1 -b .addons
|
||||||
@ -962,6 +967,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 4 2020 Martin Stransky <stransky@redhat.com> - 80.0.1-2
|
||||||
|
- Added patch for mozbz#1875469
|
||||||
|
|
||||||
* Tue Sep 1 2020 Martin Stransky <stransky@redhat.com> - 80.0.1-1
|
* Tue Sep 1 2020 Martin Stransky <stransky@redhat.com> - 80.0.1-1
|
||||||
- Updated to 80.0.1
|
- Updated to 80.0.1
|
||||||
|
|
||||||
|
72
mozilla-1875469.patch
Normal file
72
mozilla-1875469.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
|
||||||
|
# HG changeset patch
|
||||||
|
# User Olivier Tilloy <olivier@tilloy.net>
|
||||||
|
# Date 1598829330 0
|
||||||
|
# Node ID 02a9269355fc257811aca4d0966d2f8d99e17732
|
||||||
|
# Parent a8ca363a76ba63f62e364c3d6976ab5859d0a064
|
||||||
|
Bug 1661715 - Move GTK function stubs to the correct section. r=karlt, a=RyanVM
|
||||||
|
|
||||||
|
Differential Revision: https://phabricator.services.mozilla.com/D88588
|
||||||
|
|
||||||
|
diff --git a/widget/gtk/mozgtk/mozgtk.c b/widget/gtk/mozgtk/mozgtk.c
|
||||||
|
--- a/widget/gtk/mozgtk/mozgtk.c
|
||||||
|
+++ b/widget/gtk/mozgtk/mozgtk.c
|
||||||
|
@@ -524,21 +524,19 @@ STUB(gtk_window_resize)
|
||||||
|
STUB(gtk_window_set_accept_focus)
|
||||||
|
STUB(gtk_window_set_decorated)
|
||||||
|
STUB(gtk_window_set_deletable)
|
||||||
|
STUB(gtk_window_set_destroy_with_parent)
|
||||||
|
STUB(gtk_window_set_focus_on_map)
|
||||||
|
STUB(gtk_window_set_geometry_hints)
|
||||||
|
STUB(gtk_window_set_icon_name)
|
||||||
|
STUB(gtk_window_set_modal)
|
||||||
|
-STUB(gdk_window_set_opaque_region)
|
||||||
|
STUB(gtk_window_set_skip_taskbar_hint)
|
||||||
|
STUB(gtk_window_set_startup_id)
|
||||||
|
STUB(gtk_window_set_title)
|
||||||
|
-STUB(gtk_window_set_titlebar)
|
||||||
|
STUB(gtk_window_set_transient_for)
|
||||||
|
STUB(gtk_window_set_type_hint)
|
||||||
|
STUB(gtk_window_set_wmclass)
|
||||||
|
STUB(gtk_window_unfullscreen)
|
||||||
|
STUB(gtk_window_unmaximize)
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef GTK3_SYMBOLS
|
||||||
|
@@ -549,16 +547,17 @@ STUB(gdk_device_manager_get_client_point
|
||||||
|
STUB(gdk_disable_multidevice)
|
||||||
|
STUB(gdk_device_manager_list_devices)
|
||||||
|
STUB(gdk_display_get_device_manager)
|
||||||
|
STUB(gdk_display_manager_open_display)
|
||||||
|
STUB(gdk_error_trap_pop_ignored)
|
||||||
|
STUB(gdk_event_get_source_device)
|
||||||
|
STUB(gdk_screen_get_monitor_workarea)
|
||||||
|
STUB(gdk_window_get_type)
|
||||||
|
+STUB(gdk_window_set_opaque_region)
|
||||||
|
STUB(gdk_x11_window_get_xid)
|
||||||
|
STUB(gdk_x11_display_get_type)
|
||||||
|
STUB(gdk_wayland_display_get_type)
|
||||||
|
STUB(gdk_wayland_display_get_wl_compositor)
|
||||||
|
STUB(gdk_wayland_display_get_wl_display)
|
||||||
|
STUB(gdk_wayland_window_get_wl_surface)
|
||||||
|
STUB(gtk_box_new)
|
||||||
|
STUB(gtk_cairo_should_draw_window)
|
||||||
|
@@ -629,16 +628,17 @@ STUB(gtk_widget_path_copy)
|
||||||
|
STUB(gtk_widget_path_free)
|
||||||
|
STUB(gtk_widget_path_iter_add_class)
|
||||||
|
STUB(gtk_widget_path_get_object_type)
|
||||||
|
STUB(gtk_widget_path_length)
|
||||||
|
STUB(gtk_widget_path_new)
|
||||||
|
STUB(gtk_widget_path_unref)
|
||||||
|
STUB(gtk_widget_set_valign)
|
||||||
|
STUB(gtk_widget_set_visual)
|
||||||
|
+STUB(gtk_window_set_titlebar)
|
||||||
|
STUB(gtk_app_chooser_dialog_new_for_content_type)
|
||||||
|
STUB(gtk_app_chooser_get_type)
|
||||||
|
STUB(gtk_app_chooser_get_app_info)
|
||||||
|
STUB(gtk_app_chooser_dialog_get_type)
|
||||||
|
STUB(gtk_app_chooser_dialog_set_heading)
|
||||||
|
STUB(gtk_color_chooser_dialog_new)
|
||||||
|
STUB(gtk_color_chooser_dialog_get_type)
|
||||||
|
STUB(gtk_color_chooser_get_type)
|
||||||
|
|
Loading…
Reference in New Issue
Block a user