Update to 4.0 Beta 4
This commit is contained in:
parent
10ce7bb137
commit
cd9477d203
@ -1,7 +1,7 @@
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul.default firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul 2010-06-24 11:42:36.000000000 +0200
|
||||
@@ -185,10 +185,11 @@
|
||||
diff -up firefox-4.0/mozilla-central/browser/components/preferences/advanced.xul.default firefox-4.0/mozilla-central/browser/components/preferences/advanced.xul
|
||||
--- firefox-4.0/mozilla-central/browser/components/preferences/advanced.xul.default 2010-08-06 03:08:58.000000000 +0200
|
||||
+++ firefox-4.0/mozilla-central/browser/components/preferences/advanced.xul 2010-08-30 16:35:21.000000000 +0200
|
||||
@@ -183,10 +183,11 @@
|
||||
</groupbox>
|
||||
|
||||
#ifdef HAVE_SHELL_SERVICE
|
||||
@ -14,7 +14,7 @@ diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul
|
||||
<hbox id="checkDefaultBox" align="center" flex="1">
|
||||
<checkbox id="alwaysCheckDefault" preference="browser.shell.checkDefaultBrowser"
|
||||
label="&alwaysCheckDefault.label;" accesskey="&alwaysCheckDefault.accesskey;"
|
||||
@@ -198,6 +199,7 @@
|
||||
@@ -196,6 +197,7 @@
|
||||
oncommand="gAdvancedPane.checkNow()"
|
||||
preference="pref.general.disable_button.default_browser"/>
|
||||
</hbox>
|
||||
@ -22,7 +22,7 @@ diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul
|
||||
#ifdef MOZ_CRASHREPORTER
|
||||
<checkbox id="submitCrashesBox" flex="1"
|
||||
oncommand="gAdvancedPane.updateSubmitCrashes();"
|
||||
@@ -205,6 +207,7 @@
|
||||
@@ -203,6 +205,7 @@
|
||||
#endif
|
||||
</groupbox>
|
||||
#endif
|
||||
@ -30,9 +30,9 @@ diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul
|
||||
</tabpanel>
|
||||
|
||||
<!-- Network -->
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp.default firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp 2010-06-24 11:42:36.000000000 +0200
|
||||
diff -up firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.cpp.default firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.cpp
|
||||
--- firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.cpp.default 2010-08-06 03:08:59.000000000 +0200
|
||||
+++ firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.cpp 2010-08-30 16:37:41.000000000 +0200
|
||||
@@ -140,27 +140,21 @@ NS_IMPL_ISUPPORTS1(nsGNOMEShellService,
|
||||
PRBool
|
||||
nsGNOMEShellService::KeyMatchesAppName(const char *aKeyValue) const
|
||||
@ -66,10 +66,10 @@ diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellSe
|
||||
}
|
||||
|
||||
NS_IMETHODIMP
|
||||
@@ -216,8 +210,8 @@ nsGNOMEShellService::SetDefaultBrowser(P
|
||||
@@ -215,8 +209,8 @@ nsGNOMEShellService::SetDefaultBrowser(P
|
||||
|
||||
nsCOMPtr<nsIGConfService> gconf = do_GetService(NS_GCONFSERVICE_CONTRACTID);
|
||||
|
||||
nsCAutoString schemeList;
|
||||
- nsCAutoString appKeyValue(mAppPath);
|
||||
- appKeyValue.Append(" \"%s\"");
|
||||
+ nsCAutoString appKeyValue(MOZ_APP_NAME);
|
||||
@ -77,9 +77,9 @@ diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellSe
|
||||
unsigned int i;
|
||||
|
||||
for (i = 0; i < NS_ARRAY_LENGTH(appProtocols); ++i) {
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h.default firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h 2010-06-24 11:42:36.000000000 +0200
|
||||
diff -up firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.h.default firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.h
|
||||
--- firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.h.default 2010-08-06 03:08:59.000000000 +0200
|
||||
+++ firefox-4.0/mozilla-central/browser/components/shell/src/nsGNOMEShellService.h 2010-08-30 16:35:22.000000000 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
class nsGNOMEShellService : public nsIShellService
|
||||
{
|
||||
|
@ -10,7 +10,7 @@ ac_add_options --with-system-zlib
|
||||
ac_add_options --with-pthreads
|
||||
ac_add_options --disable-tests
|
||||
ac_add_options --disable-debug
|
||||
ac_add_options --enable-optimize="$RPM_OPT_FLAGS"
|
||||
ac_add_options --enable-optimize
|
||||
#ac_add_options --enable-debug
|
||||
#ac_add_options --disable-optimize
|
||||
ac_add_options --disable-installer
|
||||
@ -28,6 +28,7 @@ ac_add_options --disable-crashreporter
|
||||
ac_add_options --enable-safe-browsing
|
||||
ac_add_options --enable-libnotify
|
||||
ac_add_options --disable-necko-wifi
|
||||
ac_add_options --disable-cpp-exceptions
|
||||
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -up mozilla-1.9.2/browser/installer/Makefile.in.version mozilla-1.9.2/browser/installer/Makefile.in
|
||||
--- mozilla-1.9.2/browser/installer/Makefile.in.version 2009-11-09 01:33:57.000000000 +0100
|
||||
+++ mozilla-1.9.2/browser/installer/Makefile.in 2009-11-13 13:48:15.000000000 +0100
|
||||
@@ -43,6 +43,8 @@ VPATH = @srcdir@
|
||||
diff -up mozilla-central/browser/installer/Makefile.in.version mozilla-central/browser/installer/Makefile.in
|
||||
--- mozilla-central/browser/installer/Makefile.in.version 2010-08-06 03:08:59.000000000 +0200
|
||||
+++ mozilla-central/browser/installer/Makefile.in 2010-08-30 15:27:40.000000000 +0200
|
||||
@@ -45,6 +45,8 @@ include $(DEPTH)/config/autoconf.mk
|
||||
|
||||
include $(DEPTH)/config/autoconf.mk
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
||||
+MOZ_APP_VERSION="__RPM_VERSION_INTERNAL__"
|
||||
+
|
||||
NO_PKG_FILES = \
|
||||
$(MOZ_APP_NAME)-config \
|
||||
$(MOZ_APP_NAME)-bin.elf \
|
||||
MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
|
||||
|
||||
ifdef MOZ_ENABLE_LIBXUL
|
||||
|
33
firefox.spec
33
firefox.spec
@ -3,36 +3,36 @@
|
||||
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
|
||||
|
||||
%define mozappdir %{_libdir}/%{name}-%{internal_version}
|
||||
%define tarballdir mozilla-1.9.2
|
||||
%define tarballdir mozilla-central
|
||||
|
||||
# xulrunner_version matches the firefox package.
|
||||
# xulrunner_version_max is first next incompatible xulrunner version
|
||||
%define xulrunner_version 1.9.2.4-1
|
||||
%define xulrunner_version_max 1.9.2.5
|
||||
%define xulrunner_version 1.9.3.0
|
||||
%define xulrunner_version_max 1.9.3.1
|
||||
|
||||
%define internal_version 3.6
|
||||
%define internal_version 4.0
|
||||
|
||||
%define official_branding 1
|
||||
%define official_branding 0
|
||||
%define build_langpacks 1
|
||||
%define include_debuginfo 0
|
||||
|
||||
%if ! %{official_branding}
|
||||
%define cvsdate 20080327
|
||||
%define nightly .cvs%{cvsdate}
|
||||
%define prever rc2
|
||||
%define prever b4
|
||||
%endif
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 3.6.4
|
||||
Release: 2%{?prever}%{?dist}
|
||||
Version: 4.0
|
||||
Release: 0.1%{?prever}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
# From ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pretag}/source
|
||||
Source0: firefox-%{version}%{?prever}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source2: firefox-langpacks-%{version}-20100622.tar.bz2
|
||||
Source2: firefox-langpacks-%{version}%{?prever}-20100830.tar.bz2
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -46,7 +46,7 @@ Source100: find-external-requires
|
||||
|
||||
#Build patches
|
||||
Patch0: firefox-version.patch
|
||||
Patch1: mozilla-jemalloc-526152.patch
|
||||
#Patch1: mozilla-jemalloc-526152.patch
|
||||
|
||||
# Fedora patches
|
||||
Patch10: firefox-disable-checkupdates.patch
|
||||
@ -97,7 +97,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
|
||||
|
||||
|
||||
# For branding specific patches.
|
||||
%patch1 -p1 -b .526152
|
||||
#%patch1 -p1 -b .526152
|
||||
|
||||
# Fedora patches
|
||||
%patch10 -p1 -b .checkupdates
|
||||
@ -131,7 +131,7 @@ cd %{tarballdir}
|
||||
|
||||
# Mozilla builds with -Wall with exception of a few warnings which show up
|
||||
# everywhere in the code; so, don't override that.
|
||||
MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
|
||||
MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//' | %{__sed} -e 's/-fexceptions//')
|
||||
export CFLAGS=$MOZ_OPT_FLAGS
|
||||
export CXXFLAGS=$MOZ_OPT_FLAGS
|
||||
|
||||
@ -346,6 +346,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%ghost %{mozappdir}/components/xpti.dat
|
||||
%{mozappdir}/components/*.so
|
||||
%{mozappdir}/components/*.xpt
|
||||
%{mozappdir}/components/browser.manifest
|
||||
%attr(644, root, root) %{mozappdir}/blocklist.xml
|
||||
%attr(644, root, root) %{mozappdir}/components/*.js
|
||||
%{mozappdir}/defaults
|
||||
@ -361,11 +362,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{mozappdir}/modules/distribution.js
|
||||
%{mozappdir}/modules/openLocationLastURL.jsm
|
||||
%{mozappdir}/modules/NetworkPrioritizer.jsm
|
||||
%{mozappdir}/.autoreg
|
||||
# XXX See if these are needed still
|
||||
%{mozappdir}/modules/PlacesUIUtils.jsm
|
||||
%{mozappdir}/modules/stylePanel.jsm
|
||||
%{mozappdir}/updater*
|
||||
%exclude %{mozappdir}/removed-files
|
||||
%exclude %{mozappdir}/components/components.list
|
||||
%{_datadir}/icons/hicolor/16x16/apps/firefox.png
|
||||
%{_datadir}/icons/hicolor/22x22/apps/firefox.png
|
||||
%{_datadir}/icons/hicolor/24x24/apps/firefox.png
|
||||
@ -383,6 +383,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Mon Aug 30 2010 Martin Stransky <stransky@redhat.com> - 4.0-0.1.b4
|
||||
- Update to 4.0 Beta 4
|
||||
|
||||
* Tue Jun 24 2010 Martin Stransky <stransky@redhat.com> - 3.6.4-2
|
||||
- Fixed rhbz#531159 - disable firefox default browser check
|
||||
- Disabled automatic updates
|
||||
|
Loading…
Reference in New Issue
Block a user