Update to 107.0
This commit is contained in:
parent
97a5bb3a97
commit
caacd1dc09
65
D158747.diff
65
D158747.diff
@ -1,65 +0,0 @@
|
|||||||
diff --git a/widget/gtk/ScreenHelperGTK.cpp b/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
--- a/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
+++ b/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
@@ -221,11 +221,11 @@
|
|
||||||
refreshRate, contentsScale, defaultCssScale, dpi,
|
|
||||||
Screen::IsPseudoDisplay::No);
|
|
||||||
}
|
|
||||||
|
|
||||||
void ScreenGetterGtk::RefreshScreens() {
|
|
||||||
- LOG_SCREEN("Refreshing screens");
|
|
||||||
+ LOG_SCREEN("ScreenGetterGtk::RefreshScreens()");
|
|
||||||
AutoTArray<RefPtr<Screen>, 4> screenList;
|
|
||||||
|
|
||||||
GdkScreen* defaultScreen = gdk_screen_get_default();
|
|
||||||
gint numScreens = gdk_screen_get_n_monitors(defaultScreen);
|
|
||||||
LOG_SCREEN("GDK reports %d screens", numScreens);
|
|
||||||
@@ -387,16 +387,16 @@
|
|
||||||
monitor->refresh, contentsScale, defaultCssScale,
|
|
||||||
dpi, Screen::IsPseudoDisplay::No);
|
|
||||||
}
|
|
||||||
|
|
||||||
void ScreenGetterWayland::RefreshScreens() {
|
|
||||||
- LOG_SCREEN("Refreshing screens");
|
|
||||||
+ LOG_SCREEN("ScreenGetterWayland::RefreshScreens()");
|
|
||||||
AutoTArray<RefPtr<Screen>, 4> managerScreenList;
|
|
||||||
|
|
||||||
mScreenList.Clear();
|
|
||||||
const gint numScreens = mMonitors.Length();
|
|
||||||
- LOG_SCREEN("Wayland reports %d screens", numScreens);
|
|
||||||
+ LOG_SCREEN("Wayland reports %d monitors", numScreens);
|
|
||||||
for (gint i = 0; i < numScreens; i++) {
|
|
||||||
RefPtr<Screen> screen = MakeScreenWayland(i);
|
|
||||||
mScreenList.AppendElement(screen);
|
|
||||||
managerScreenList.AppendElement(screen);
|
|
||||||
}
|
|
||||||
@@ -446,18 +446,27 @@
|
|
||||||
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
RefPtr<nsIScreen> ScreenGetterWayland::GetScreenForWindow(nsWindow* aWindow) {
|
|
||||||
- if (mScreenList.IsEmpty()) {
|
|
||||||
+ if (mMonitors.IsEmpty()) {
|
|
||||||
return nullptr;
|
|
||||||
}
|
|
||||||
|
|
||||||
int monitor = GetMonitorForWindow(aWindow);
|
|
||||||
if (monitor < 0) {
|
|
||||||
return nullptr;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ if (mMonitors.Length() != mScreenList.Length()) {
|
|
||||||
+ // Gtk list of GtkScreens are out of sync with our monitor list.
|
|
||||||
+ // Try to refresh it now.
|
|
||||||
+ RefreshScreens();
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ MOZ_DIAGNOSTIC_ASSERT((unsigned)monitor < mScreenList.Length(),
|
|
||||||
+ "We're missing screen?");
|
|
||||||
return mScreenList[monitor];
|
|
||||||
}
|
|
||||||
|
|
||||||
static bool IsGNOMECompositor() {
|
|
||||||
const char* currentDesktop = getenv("XDG_CURRENT_DESKTOP");
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up firefox-81.0/toolkit/modules/GMPInstallManager.jsm.old firefox-81.0/toolkit/modules/GMPInstallManager.jsm
|
diff -up firefox-81.0/toolkit/modules/GMPInstallManager.sys.mjs.old firefox-81.0/toolkit/modules/GMPInstallManager.sys.mjs
|
||||||
--- firefox-81.0/toolkit/modules/GMPInstallManager.jsm.old 2020-09-25 10:39:04.769458703 +0200
|
--- firefox-81.0/toolkit/modules/GMPInstallManager.sys.mjs.old 2020-09-25 10:39:04.769458703 +0200
|
||||||
+++ firefox-81.0/toolkit/modules/GMPInstallManager.jsm 2020-09-25 10:39:22.038504747 +0200
|
+++ firefox-81.0/toolkit/modules/GMPInstallManager.sys.mjs 2020-09-25 10:39:22.038504747 +0200
|
||||||
@@ -54,10 +54,6 @@ function getScopedLogger(prefix) {
|
@@ -54,10 +54,6 @@ function getScopedLogger(prefix) {
|
||||||
|
|
||||||
const LOCAL_GMP_SOURCES = [
|
const LOCAL_GMP_SOURCES = [
|
||||||
@ -23,9 +23,9 @@ diff --git a/toolkit/content/jar.mn b/toolkit/content/jar.mn
|
|||||||
content/global/gmp-sources/widevinecdm.json (gmp-sources/widevinecdm.json)
|
content/global/gmp-sources/widevinecdm.json (gmp-sources/widevinecdm.json)
|
||||||
|
|
||||||
# Third party files
|
# Third party files
|
||||||
diff --git a/toolkit/modules/GMPInstallManager.jsm b/toolkit/modules/GMPInstallManager.jsm
|
diff --git a/toolkit/modules/GMPInstallManager.sys.mjs b/toolkit/modules/GMPInstallManager.sys.mjs
|
||||||
--- a/toolkit/modules/GMPInstallManager.jsm
|
--- a/toolkit/modules/GMPInstallManager.sys.mjs
|
||||||
+++ b/toolkit/modules/GMPInstallManager.jsm
|
+++ b/toolkit/modules/GMPInstallManager.sys.mjs
|
||||||
@@ -238,6 +234,9 @@ GMPInstallManager.prototype = {
|
@@ -238,6 +234,9 @@ GMPInstallManager.prototype = {
|
||||||
* downloaderr, verifyerr or previouserrorencountered
|
* downloaderr, verifyerr or previouserrorencountered
|
||||||
*/
|
*/
|
||||||
@ -36,4 +36,3 @@ diff --git a/toolkit/modules/GMPInstallManager.jsm b/toolkit/modules/GMPInstallM
|
|||||||
if (this._deferred) {
|
if (this._deferred) {
|
||||||
let log = getScopedLogger("GMPInstallManager.installAddon");
|
let log = getScopedLogger("GMPInstallManager.installAddon");
|
||||||
log.error("previous error encountered");
|
log.error("previous error encountered");
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up firefox-106.0/media/ffvpx/config_unix_aarch64.h.old firefox-106.0/media/ffvpx/config_unix_aarch64.h
|
|
||||||
--- firefox-106.0/media/ffvpx/config_unix_aarch64.h.old 2022-10-20 20:50:57.938936868 +0200
|
|
||||||
+++ firefox-106.0/media/ffvpx/config_unix_aarch64.h 2022-10-20 20:51:05.431187713 +0200
|
|
||||||
@@ -329,7 +329,7 @@
|
|
||||||
#define HAVE_SLEEP 0
|
|
||||||
#define HAVE_STRERROR_R 1
|
|
||||||
#define HAVE_SYSCONF 1
|
|
||||||
-#define HAVE_SYSCTL 1
|
|
||||||
+#define HAVE_SYSCTL 0
|
|
||||||
#define HAVE_USLEEP 1
|
|
||||||
#define HAVE_UTGETOSTYPEFROMSTRING 0
|
|
||||||
#define HAVE_VIRTUALALLOC 0
|
|
11
firefox.spec
11
firefox.spec
@ -171,13 +171,13 @@ ExcludeArch: i686
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 106.0.4
|
Version: 107.0
|
||||||
Release: 1%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20221104.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20221114.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
@ -227,7 +227,6 @@ Patch62: build-python.patch
|
|||||||
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
||||||
Patch77: build-python-3.11.patch
|
Patch77: build-python-3.11.patch
|
||||||
Patch78: firefox-i686-build.patch
|
Patch78: firefox-i686-build.patch
|
||||||
Patch79: firefox-aarch64-sysctl.patch
|
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
# Generate without context by
|
# Generate without context by
|
||||||
@ -252,7 +251,6 @@ Patch402: mozilla-1196777.patch
|
|||||||
Patch407: mozilla-1667096.patch
|
Patch407: mozilla-1667096.patch
|
||||||
Patch408: mozilla-1663844.patch
|
Patch408: mozilla-1663844.patch
|
||||||
Patch415: mozilla-1670333.patch
|
Patch415: mozilla-1670333.patch
|
||||||
Patch417: D158747.diff
|
|
||||||
|
|
||||||
# PGO/LTO patches
|
# PGO/LTO patches
|
||||||
Patch600: pgo.patch
|
Patch600: pgo.patch
|
||||||
@ -492,7 +490,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
||||||
%patch77 -p1 -b .build-python-3.11
|
%patch77 -p1 -b .build-python-3.11
|
||||||
%patch78 -p1 -b .firefox-i686
|
%patch78 -p1 -b .firefox-i686
|
||||||
%patch79 -p1 -b .aarch64-sysctl
|
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
#%patch100 -p1 -b .firefox-tests-xpcshell
|
#%patch100 -p1 -b .firefox-tests-xpcshell
|
||||||
@ -515,7 +512,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch407 -p1 -b .1667096
|
%patch407 -p1 -b .1667096
|
||||||
%patch408 -p1 -b .1663844
|
%patch408 -p1 -b .1663844
|
||||||
%patch415 -p1 -b .1670333
|
%patch415 -p1 -b .1670333
|
||||||
%patch417 -p1 -b .D158747
|
|
||||||
|
|
||||||
# PGO patches
|
# PGO patches
|
||||||
%if %{build_with_pgo}
|
%if %{build_with_pgo}
|
||||||
@ -1109,6 +1105,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 14 2022 Martin Stransky <stransky@redhat.com>- 107.0-1
|
||||||
|
- Update to 107.0
|
||||||
|
|
||||||
* Fri Nov 04 2022 Martin Stransky <stransky@redhat.com>- 106.0.4-1
|
* Fri Nov 04 2022 Martin Stransky <stransky@redhat.com>- 106.0.4-1
|
||||||
- Update to 106.0.4
|
- Update to 106.0.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user