Added a fix for mozbz#1245783 - gcc6.1 crashes in JIT
This commit is contained in:
parent
63d497b625
commit
c27e5b3c07
23
firefox.spec
23
firefox.spec
@ -34,13 +34,6 @@
|
|||||||
|
|
||||||
%define system_jpeg 1
|
%define system_jpeg 1
|
||||||
|
|
||||||
# Separated plugins are supported on x86(64) only
|
|
||||||
%ifarch %{ix86} x86_64
|
|
||||||
%define separated_plugins 1
|
|
||||||
%else
|
|
||||||
%define separated_plugins 0
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
%define run_tests 0
|
%define run_tests 0
|
||||||
%else
|
%else
|
||||||
@ -92,7 +85,7 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 46.0.1
|
Version: 46.0.1
|
||||||
Release: 4%{?pre_tag}%{?dist}
|
Release: 5%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -138,6 +131,7 @@ Patch400: mozilla-1255590.patch
|
|||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
Patch403: mozilla-1216658.patch
|
Patch403: mozilla-1216658.patch
|
||||||
Patch404: mozilla-1270046.patch
|
Patch404: mozilla-1270046.patch
|
||||||
|
Patch405: mozilla-1245783.patch
|
||||||
|
|
||||||
# Debian patches
|
# Debian patches
|
||||||
Patch500: mozilla-440908.patch
|
Patch500: mozilla-440908.patch
|
||||||
@ -286,6 +280,7 @@ cd %{tarballdir}
|
|||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
%patch403 -p1 -b .1216658
|
%patch403 -p1 -b .1216658
|
||||||
%patch404 -p1 -b .1270046
|
%patch404 -p1 -b .1270046
|
||||||
|
%patch405 -p1 -b .1245783
|
||||||
|
|
||||||
# Debian extension patch
|
# Debian extension patch
|
||||||
%patch500 -p1 -b .440908
|
%patch500 -p1 -b .440908
|
||||||
@ -327,10 +322,6 @@ echo "ac_add_options --disable-system-cairo" >> .mozconfig
|
|||||||
echo "ac_add_options --enable-system-ffi" >> .mozconfig
|
echo "ac_add_options --enable-system-ffi" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if !%{?separated_plugins}
|
|
||||||
echo "ac_add_options --disable-ipc" >> .mozconfig
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%ifarch %{arm}
|
%ifarch %{arm}
|
||||||
echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
@ -375,11 +366,6 @@ echo "ac_add_options --disable-ion" >> .mozconfig
|
|||||||
echo "ac_add_options --disable-yarr-jit" >> .mozconfig
|
echo "ac_add_options --disable-yarr-jit" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#Workarounf for mozbz#1245783
|
|
||||||
%if 0%{?fedora} > 23
|
|
||||||
echo "ac_add_options --disable-ion" >> .mozconfig
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%ifnarch %{ix86} x86_64
|
%ifnarch %{ix86} x86_64
|
||||||
echo "ac_add_options --disable-webrtc" >> .mozconfig
|
echo "ac_add_options --disable-webrtc" >> .mozconfig
|
||||||
%endif
|
%endif
|
||||||
@ -805,6 +791,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 19 2016 Martin Stransky <stransky@redhat.com> - 46.0.1-5
|
||||||
|
- Added a fix for mozbz#1245783 - gcc6.1 crashes in JIT
|
||||||
|
|
||||||
* Thu May 12 2016 Martin Stransky <stransky@redhat.com> - 46.0.1-4
|
* Thu May 12 2016 Martin Stransky <stransky@redhat.com> - 46.0.1-4
|
||||||
- Added fix for rhbz#1332821 - Crash on "Select" in "Open with" dialog
|
- Added fix for rhbz#1332821 - Crash on "Select" in "Open with" dialog
|
||||||
|
|
||||||
|
15
mozilla-1245783.patch
Normal file
15
mozilla-1245783.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- firefox-45.0.1-orig/js/src/Makefile.in 2016-05-17 14:53:58.753178403 +0200
|
||||||
|
+++ firefox-45.0.1/js/src/Makefile.in 2016-05-17 14:53:28.432817862 +0200
|
||||||
|
@@ -144,6 +144,11 @@ distclean::
|
||||||
|
|
||||||
|
CFLAGS += $(MOZ_ZLIB_CFLAGS)
|
||||||
|
|
||||||
|
+# Avoid GNU gcc bug #70526
|
||||||
|
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70526#c14
|
||||||
|
+CFLAGS += -fno-schedule-insns2
|
||||||
|
+CXXFLAGS += -fno-schedule-insns2
|
||||||
|
+
|
||||||
|
# Silence warnings on AIX/HP-UX from non-GNU compilers
|
||||||
|
ifndef GNU_CC
|
||||||
|
ifeq ($(OS_ARCH),AIX)
|
||||||
|
|
Loading…
Reference in New Issue
Block a user