Merge branch 'master' into f23
This commit is contained in:
commit
be216b1d68
2
.gitignore
vendored
2
.gitignore
vendored
@ -199,3 +199,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-47.0-20160606.tar.xz
|
||||
/firefox-47.0.1.source.tar.xz
|
||||
/firefox-langpacks-47.0.1-20160711.tar.xz
|
||||
/firefox-langpacks-48.0-20160726.tar.xz
|
||||
/firefox-48.0.source.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up firefox-46.0/browser/app/profile/firefox.js.addons firefox-46.0/browser/app/profile/firefox.js
|
||||
--- firefox-46.0/browser/app/profile/firefox.js.addons 2016-04-22 02:37:18.000000000 +0200
|
||||
+++ firefox-46.0/browser/app/profile/firefox.js 2016-04-25 12:09:36.133479899 +0200
|
||||
@@ -74,7 +74,8 @@ pref("extensions.systemAddon.update.url"
|
||||
diff -up firefox-48.0/browser/app/profile/firefox.js.addons firefox-48.0/browser/app/profile/firefox.js
|
||||
--- firefox-48.0/browser/app/profile/firefox.js.addons 2016-07-26 10:56:48.598900568 +0200
|
||||
+++ firefox-48.0/browser/app/profile/firefox.js 2016-07-26 11:05:45.199789758 +0200
|
||||
@@ -94,7 +94,8 @@ pref("extensions.systemAddon.update.url"
|
||||
|
||||
// Disable add-ons that are not installed by the user in all scopes by default.
|
||||
// See the SCOPE constants in AddonManager.jsm for values to use here.
|
||||
@ -9,5 +9,5 @@ diff -up firefox-46.0/browser/app/profile/firefox.js.addons firefox-46.0/browser
|
||||
+pref("extensions.autoDisableScopes", 0);
|
||||
+pref("extensions.showMismatchUI", false);
|
||||
|
||||
// Require signed add-ons by default
|
||||
pref("xpinstall.signatures.required", true);
|
||||
// Add-on content security policies.
|
||||
pref("extensions.webextensions.base-content-security-policy", "script-src 'self' https://* moz-extension: blob: filesystem: 'unsafe-eval' 'unsafe-inline'; object-src 'self' https://* moz-extension: blob: filesystem:;");
|
||||
|
24
firefox.spec
24
firefox.spec
@ -81,14 +81,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 47.0.1
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
Version: 48.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20160711.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20160726.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -122,9 +122,6 @@ Patch224: mozilla-1170092.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch304: mozilla-1253216.patch
|
||||
Patch305: mozilla-1245076.patch
|
||||
Patch306: mozilla-1245076-1.patch
|
||||
Patch400: mozilla-1255590.patch
|
||||
Patch402: mozilla-1196777.patch
|
||||
Patch404: mozilla-1270046.patch
|
||||
# Remove when mozbz#1269319 lands - Firefox 49
|
||||
@ -242,7 +239,7 @@ cd %{tarballdir}
|
||||
# ignored during this compare.
|
||||
%patch0 -p1
|
||||
|
||||
%patch18 -p2 -b .jemalloc-ppc
|
||||
%patch18 -p1 -b .jemalloc-ppc
|
||||
%patch19 -p2 -b .s390-inlines
|
||||
%patch20 -p1 -b .prbool
|
||||
%patch21 -p2 -b .ppc64le
|
||||
@ -265,12 +262,9 @@ cd %{tarballdir}
|
||||
%endif
|
||||
%patch224 -p1 -b .1170092
|
||||
%if 0%{?fedora} > 23
|
||||
%patch304 -p2 -b .1253216
|
||||
%patch222 -p1 -b .gtk3-20
|
||||
#%patch304 -p2 -b .1253216
|
||||
#%patch222 -p1 -b .gtk3-20
|
||||
%endif
|
||||
%patch305 -p1 -b .1245076
|
||||
%patch306 -p1 -b .1245076-1
|
||||
%patch400 -p1 -b .1255590
|
||||
%patch402 -p1 -b .1196777
|
||||
%patch404 -p1 -b .1270046
|
||||
%patch405 -p1 -b .1245783
|
||||
@ -778,6 +772,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jul 26 2016 Martin Stransky <stransky@redhat.com> - 48.0-1
|
||||
- Updated to 48.0
|
||||
|
||||
* Fri Jul 22 2016 Tom Callaway <spot@fedoraproject.org> - 47.0.1-3
|
||||
- rebuild for libvpx 1.6.0
|
||||
|
||||
* Mon Jul 11 2016 Martin Stransky <stransky@redhat.com> - 47.0.1-2
|
||||
- Added fix for mozbz#256180 - gmail paste issues
|
||||
|
||||
|
@ -1,49 +0,0 @@
|
||||
diff --git a/config/gcc-stl-wrapper.template.h b/config/gcc-stl-wrapper.template.h
|
||||
--- a/config/gcc-stl-wrapper.template.h
|
||||
+++ b/config/gcc-stl-wrapper.template.h
|
||||
@@ -12,33 +12,39 @@
|
||||
// compiling ObjC.
|
||||
#if defined(__EXCEPTIONS) && __EXCEPTIONS && !(__OBJC__ && __GNUC__ && XP_IOS)
|
||||
# error "STL code can only be used with -fno-exceptions"
|
||||
#endif
|
||||
|
||||
// Silence "warning: #include_next is a GCC extension"
|
||||
#pragma GCC system_header
|
||||
|
||||
+#ifndef moz_dont_include_mozalloc_for_cstdlib
|
||||
+# define moz_dont_include_mozalloc_for_cstdlib
|
||||
+#endif
|
||||
+#ifndef moz_dont_include_mozalloc_for_${HEADER}
|
||||
// mozalloc.h wants <new>; break the cycle by always explicitly
|
||||
// including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
|
||||
//
|
||||
// `#include_next' does not distinguish between <file> and "file"
|
||||
// inclusion, nor does it check that the file you specify has the
|
||||
// same name as the current file. It simply looks for the file
|
||||
// named, starting with the directory in the search path after the
|
||||
// one where the current file was found.
|
||||
-#include_next <new>
|
||||
+# include_next <new>
|
||||
|
||||
// See if we're in code that can use mozalloc. NB: this duplicates
|
||||
// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
|
||||
// can't build with that being included before base/basictypes.h.
|
||||
-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
-# include "mozilla/mozalloc.h"
|
||||
-#else
|
||||
-# error "STL code can only be used with infallible ::operator new()"
|
||||
+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
|
||||
+# include "mozilla/mozalloc.h"
|
||||
+# else
|
||||
+# error "STL code can only be used with infallible ::operator new()"
|
||||
+# endif
|
||||
+
|
||||
#endif
|
||||
|
||||
#if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)
|
||||
// Enable checked iterators and other goodies
|
||||
//
|
||||
// FIXME/bug 551254: gcc's debug STL implementation requires -frtti.
|
||||
// Figure out how to resolve this with -fno-rtti. Maybe build with
|
||||
// -frtti in DEBUG builds?
|
||||
|
@ -1,23 +0,0 @@
|
||||
diff --git a/gfx/graphite2/src/Collider.cpp b/gfx/graphite2/src/Collider.cpp
|
||||
--- a/gfx/graphite2/src/Collider.cpp
|
||||
+++ b/gfx/graphite2/src/Collider.cpp
|
||||
@@ -21,17 +21,17 @@
|
||||
|
||||
Alternatively, the contents of this file may be used under the terms of the
|
||||
Mozilla Public License (http://mozilla.org/MPL) or the GNU General Public
|
||||
License, as published by the Free Software Foundation, either version 2
|
||||
of the License or (at your option) any later version.
|
||||
*/
|
||||
#include <algorithm>
|
||||
#include <limits>
|
||||
-#include <math.h>
|
||||
+#include <cmath>
|
||||
#include <string>
|
||||
#include <functional>
|
||||
#include "inc/Collider.h"
|
||||
#include "inc/Segment.h"
|
||||
#include "inc/Slot.h"
|
||||
#include "inc/GlyphCache.h"
|
||||
#include "inc/Sparse.h"
|
||||
|
||||
|
@ -1,60 +0,0 @@
|
||||
diff --git a/toolkit/mozapps/extensions/content/extensions.js b/toolkit/mozapps/extensions/content/extensions.js
|
||||
--- a/toolkit/mozapps/extensions/content/extensions.js
|
||||
+++ b/toolkit/mozapps/extensions/content/extensions.js
|
||||
@@ -195,19 +195,25 @@ function loadView(aViewId) {
|
||||
|
||||
gViewController.loadInitialView(aViewId);
|
||||
} else {
|
||||
gViewController.loadView(aViewId);
|
||||
}
|
||||
}
|
||||
|
||||
function isCorrectlySigned(aAddon) {
|
||||
- // temporary add-ons do not require signing
|
||||
+ // Temporary add-ons do not require signing.
|
||||
if (aAddon.scope == AddonManager.SCOPE_TEMPORARY)
|
||||
return true;
|
||||
+ // On UNIX platforms except OSX, an additional location for system add-ons
|
||||
+ // exists in /usr/{lib,share}/mozilla/extensions. Add-ons installed there
|
||||
+ // do not require signing either.
|
||||
+ if (aAddon.scope == AddonManager.SCOPE_SYSTEM &&
|
||||
+ Services.appinfo.OS != "Darwin")
|
||||
+ return true;
|
||||
if (aAddon.signedState <= AddonManager.SIGNEDSTATE_MISSING)
|
||||
return false;
|
||||
return true;
|
||||
}
|
||||
|
||||
function isDiscoverEnabled() {
|
||||
if (Services.prefs.getPrefType(PREF_DISCOVERURL) == Services.prefs.PREF_INVALID)
|
||||
return false;
|
||||
diff --git a/toolkit/mozapps/extensions/internal/XPIProvider.jsm b/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
--- a/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
+++ b/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
@@ -682,18 +682,23 @@ function isUsableAddon(aAddon) {
|
||||
// Hack to ensure the default theme is always usable
|
||||
if (aAddon.type == "theme" && aAddon.internalName == XPIProvider.defaultSkin)
|
||||
return true;
|
||||
|
||||
if (aAddon._installLocation.name == KEY_APP_SYSTEM_ADDONS &&
|
||||
aAddon.signedState != AddonManager.SIGNEDSTATE_SYSTEM) {
|
||||
return false;
|
||||
}
|
||||
- // temporary and system add-ons do not require signing
|
||||
- if ((aAddon._installLocation.name != KEY_APP_SYSTEM_DEFAULTS &&
|
||||
+ // Temporary and system add-ons do not require signing.
|
||||
+ // On UNIX platforms except OSX, an additional location for system add-ons
|
||||
+ // exists in /usr/{lib,share}/mozilla/extensions. Add-ons installed there
|
||||
+ // do not require signing either.
|
||||
+ if (((aAddon._installLocation.scope != AddonManager.SCOPE_SYSTEM ||
|
||||
+ Services.appinfo.OS == "Darwin") &&
|
||||
+ aAddon._installLocation.name != KEY_APP_SYSTEM_DEFAULTS &&
|
||||
aAddon._installLocation.name != KEY_APP_TEMPORARY) &&
|
||||
mustSign(aAddon.type)) {
|
||||
if (aAddon.signedState <= AddonManager.SIGNEDSTATE_MISSING)
|
||||
return false;
|
||||
}
|
||||
|
||||
if (aAddon.blocklistState == Blocklist.STATE_BLOCKED)
|
||||
return false;
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
aba4b673b10e3fdcee80f88300829613 firefox-47.0.1.source.tar.xz
|
||||
906516a1111d2fd6ebf902d8ff1a6cd7 firefox-langpacks-47.0.1-20160711.tar.xz
|
||||
c8efa23c33b6402b17d6477bc9f297d4 firefox-langpacks-48.0-20160726.tar.xz
|
||||
c7f46b9cd8f5750ec16f9d557deb65fb firefox-48.0.source.tar.xz
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -up xulrunner-24.0/mozilla-release/memory/mozjemalloc/jemalloc.c.jemalloc-ppc xulrunner-24.0/mozilla-release/memory/mozjemalloc/jemalloc.c
|
||||
--- xulrunner-24.0/mozilla-release/memory/mozjemalloc/jemalloc.c.jemalloc-ppc 2013-09-11 01:15:18.000000000 +0200
|
||||
+++ xulrunner-24.0/mozilla-release/memory/mozjemalloc/jemalloc.c 2013-09-13 13:36:34.171680919 +0200
|
||||
@@ -1104,7 +1104,7 @@ static unsigned ncpus;
|
||||
diff -up firefox-48.0/memory/mozjemalloc/jemalloc.c.jemalloc-ppc firefox-48.0/memory/mozjemalloc/jemalloc.c
|
||||
--- firefox-48.0/memory/mozjemalloc/jemalloc.c.jemalloc-ppc 2016-07-26 10:51:46.385434384 +0200
|
||||
+++ firefox-48.0/memory/mozjemalloc/jemalloc.c 2016-07-26 10:53:49.061023106 +0200
|
||||
@@ -1090,7 +1090,7 @@ static const bool config_recycle = false
|
||||
* controlling the malloc behavior are defined as compile-time constants
|
||||
* for best performance and cannot be altered at runtime.
|
||||
*/
|
||||
-#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__)
|
||||
+#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !(defined(__powerpc__))
|
||||
-#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__)
|
||||
+#if !defined(__ia64__) && !defined(__sparc__) && !defined(__mips__) && !defined(__aarch64__) && !(defined(__powerpc__))
|
||||
#define MALLOC_STATIC_SIZES 1
|
||||
#endif
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user