Added aarch64 patch (mozbz#1353817)
This commit is contained in:
parent
8b4c244194
commit
bc096e5ee2
10
firefox.spec
10
firefox.spec
@ -56,7 +56,7 @@ ExcludeArch: ppc64le aarch64 ppc64 s390 s390x
|
||||
|
||||
%define build_with_rust 0
|
||||
|
||||
%ifarch %{ix86} x86_64 armv7hl
|
||||
%ifarch %{ix86} x86_64 armv7hl aarch64
|
||||
%define build_with_rust 1
|
||||
%endif
|
||||
|
||||
@ -105,7 +105,7 @@ ExcludeArch: ppc64le aarch64 ppc64 s390 s390x
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 53.0.2
|
||||
Release: 5%{?pre_tag}%{?dist}
|
||||
Release: 6%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -158,6 +158,7 @@ Patch409: mozilla-1158076-2.patch
|
||||
Patch410: mozilla-1321521.patch
|
||||
Patch411: mozilla-1321521-2.patch
|
||||
Patch412: mozilla-1337988.patch
|
||||
Patch413: mozilla-1353817.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -336,13 +337,13 @@ cd %{tarballdir}
|
||||
%patch409 -p1 -b .1158076-2
|
||||
%patch410 -p1 -b .1321521
|
||||
%patch411 -p1 -b .1321521-2
|
||||
|
||||
%ifarch %{arm}
|
||||
%if 0%{?fedora} < 26
|
||||
# Workaround for mozbz#1337988
|
||||
%patch412 -p1 -b .1337988
|
||||
%endif
|
||||
%endif
|
||||
%patch413 -p1 -b .1353817
|
||||
|
||||
# Debian extension patch
|
||||
%patch500 -p1 -b .440908
|
||||
@ -867,6 +868,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed May 24 2017 Martin Stransky <stransky@redhat.com> - 53.0.2-6
|
||||
- Added aarch64 patch (mozbz#1353817)
|
||||
|
||||
* Tue May 16 2017 Martin Stransky <stransky@redhat.com> - 53.0.2-5
|
||||
- Arm gcc6 build fix (mozbz#1337988)
|
||||
|
||||
|
27
mozilla-1353817.patch
Normal file
27
mozilla-1353817.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 1cc652f5525f458b0b4ceb12af24bf5a4367db32 Mon Sep 17 00:00:00 2001
|
||||
From: Nicolas Dufresne <nicolas.dufresne@collabora.com>
|
||||
Date: Tue, 23 May 2017 13:09:48 -0400
|
||||
Subject: [PATCH] Bug 1353817: Include SkNx_neon.h for ARM64 too
|
||||
|
||||
This fixes build errors as arm_neon.h was missing along with some
|
||||
missing converters.
|
||||
---
|
||||
gfx/skia/skia/src/core/SkNx.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gfx/skia/skia/src/core/SkNx.h b/gfx/skia/skia/src/core/SkNx.h
|
||||
index 6bca856..b0427aa 100644
|
||||
--- a/gfx/skia/skia/src/core/SkNx.h
|
||||
+++ b/gfx/skia/skia/src/core/SkNx.h
|
||||
@@ -299,7 +299,7 @@ typedef SkNx<4, uint32_t> Sk4u;
|
||||
// Include platform specific specializations if available.
|
||||
#if !defined(SKNX_NO_SIMD) && SK_CPU_SSE_LEVEL >= SK_CPU_SSE_LEVEL_SSE2
|
||||
#include "../opts/SkNx_sse.h"
|
||||
-#elif !defined(SKNX_NO_SIMD) && defined(SK_ARM_HAS_NEON)
|
||||
+#elif !defined(SKNX_NO_SIMD) && (defined(SK_ARM_HAS_NEON) || defined(SK_CPU_ARM64))
|
||||
#include "../opts/SkNx_neon.h"
|
||||
#else
|
||||
|
||||
--
|
||||
2.9.4
|
||||
|
Loading…
Reference in New Issue
Block a user