- Update to 2.0.0.4 RC3
This commit is contained in:
parent
5266156bb4
commit
b3cc4544dc
@ -1,2 +1,2 @@
|
|||||||
firefox-langpacks-2.0.0.3-20070320.tar.bz2
|
firefox-2.0.0.4-source.tar.bz2
|
||||||
firefox-2.0.0.3-source.tar.bz2
|
firefox-langpacks-2.0.0.4-20070523.tar.bz2
|
||||||
|
@ -1,25 +0,0 @@
|
|||||||
See https://bugzilla.mozilla.org/show_bug.cgi?id=367203
|
|
||||||
|
|
||||||
Index: mozilla/widget/src/gtk2/nsDragService.cpp
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/widget/src/gtk2/nsDragService.cpp,v
|
|
||||||
retrieving revision 1.9.10.1
|
|
||||||
diff -d -u -p -r1.9.10.1 nsDragService.cpp
|
|
||||||
--- mozilla/widget/src/gtk2/nsDragService.cpp 22 Jun 2006 21:37:45 -0000 1.9.10.1
|
|
||||||
+++ mozilla/widget/src/gtk2/nsDragService.cpp 31 Jan 2007 04:27:43 -0000
|
|
||||||
@@ -799,7 +799,6 @@ nsDragService::IsTargetContextList(void)
|
|
||||||
void
|
|
||||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
|
||||||
{
|
|
||||||
- gtk_grab_add(mHiddenWidget);
|
|
||||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
|
||||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
|
||||||
mTargetWidget, mTargetDragContext));
|
|
||||||
@@ -817,7 +816,6 @@ nsDragService::GetTargetDragData(GdkAtom
|
|
||||||
gtk_main_iteration();
|
|
||||||
}
|
|
||||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
|
||||||
- gtk_grab_remove(mHiddenWidget);
|
|
||||||
}
|
|
||||||
|
|
||||||
void
|
|
@ -1,23 +0,0 @@
|
|||||||
Index: embedding/browser/gtk/src/EmbedWindow.cpp
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/embedding/browser/gtk/src/EmbedWindow.cpp,v
|
|
||||||
retrieving revision 1.31
|
|
||||||
diff -d -u -p -r1.31 EmbedWindow.cpp
|
|
||||||
--- embedding/browser/gtk/src/EmbedWindow.cpp 17 Jan 2005 17:19:39 -0000 1.31
|
|
||||||
+++ embedding/browser/gtk/src/EmbedWindow.cpp 27 Sep 2006 00:41:38 -0000
|
|
||||||
@@ -359,7 +359,14 @@ EmbedWindow::GetSiteWindow(void **aSiteW
|
|
||||||
NS_IMETHODIMP
|
|
||||||
EmbedWindow::GetVisibility(PRBool *aVisibility)
|
|
||||||
{
|
|
||||||
- *aVisibility = mVisibility;
|
|
||||||
+ // XXX See bug 312998
|
|
||||||
+ // Work around the problem that sometimes the window
|
|
||||||
+ // is already visible even though mVisibility isn't true
|
|
||||||
+ // yet.
|
|
||||||
+ *aVisibility = mVisibility ||
|
|
||||||
+ (!mOwner->mIsChrome &&
|
|
||||||
+ mOwner->mOwningWidget &&
|
|
||||||
+ GTK_WIDGET_MAPPED(mOwner->mOwningWidget));
|
|
||||||
return NS_OK;
|
|
||||||
}
|
|
||||||
|
|
@ -1,27 +0,0 @@
|
|||||||
Index: widget/src/gtk2/nsWindow.cpp
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/widget/src/gtk2/nsWindow.cpp,v
|
|
||||||
retrieving revision 1.185
|
|
||||||
diff -u -8 -p -r1.185 nsWindow.cpp
|
|
||||||
--- widget/src/gtk2/nsWindow.cpp 20 Sep 2006 19:16:19 -0000 1.185
|
|
||||||
+++ widget/src/gtk2/nsWindow.cpp 22 Sep 2006 05:07:04 -0000
|
|
||||||
@@ -2859,19 +2859,16 @@ nsWindow::NativeCreate(nsIWidget
|
|
||||||
g_signal_connect(G_OBJECT(mShell), "window_state_event",
|
|
||||||
G_CALLBACK(window_state_event_cb), NULL);
|
|
||||||
|
|
||||||
GtkSettings* default_settings = gtk_settings_get_default();
|
|
||||||
g_signal_connect_after(default_settings,
|
|
||||||
"notify::gtk-theme-name",
|
|
||||||
G_CALLBACK(theme_changed_cb), this);
|
|
||||||
g_signal_connect_after(default_settings,
|
|
||||||
- "notify::gtk-key-theme-name",
|
|
||||||
- G_CALLBACK(theme_changed_cb), this);
|
|
||||||
- g_signal_connect_after(default_settings,
|
|
||||||
"notify::gtk-font-name",
|
|
||||||
G_CALLBACK(theme_changed_cb), this);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (mContainer) {
|
|
||||||
g_signal_connect_after(G_OBJECT(mContainer), "size_allocate",
|
|
||||||
G_CALLBACK(size_allocate_cb), NULL);
|
|
||||||
g_signal_connect(G_OBJECT(mContainer), "expose_event",
|
|
97
firefox-2.0.0.4-undo-uriloader.patch
Normal file
97
firefox-2.0.0.4-undo-uriloader.patch
Normal file
@ -0,0 +1,97 @@
|
|||||||
|
Index: mozilla/uriloader/exthandler/unix/nsOSHelperAppService.cpp
|
||||||
|
===================================================================
|
||||||
|
RCS file: /cvsroot/mozilla/uriloader/exthandler/unix/nsOSHelperAppService.cpp,v
|
||||||
|
retrieving revision 1.58.20.1
|
||||||
|
retrieving revision 1.58
|
||||||
|
diff -d -u -p -r1.58.20.1 -r1.58
|
||||||
|
--- mozilla/uriloader/exthandler/unix/nsOSHelperAppService.cpp 16 Apr 2007 18:54:53 -0000 1.58.20.1
|
||||||
|
+++ mozilla/uriloader/exthandler/unix/nsOSHelperAppService.cpp 25 Oct 2004 07:46:01 -0000 1.58
|
||||||
|
@@ -1506,8 +1506,13 @@ nsOSHelperAppService::GetFromType(const
|
||||||
|
|
||||||
|
nsDependentSubstring majorType(majorTypeStart, majorTypeEnd);
|
||||||
|
nsDependentSubstring minorType(minorTypeStart, minorTypeEnd);
|
||||||
|
+ nsAutoString extensions, mime_types_description;
|
||||||
|
+ LookUpExtensionsAndDescription(majorType,
|
||||||
|
+ minorType,
|
||||||
|
+ extensions,
|
||||||
|
+ mime_types_description);
|
||||||
|
+
|
||||||
|
|
||||||
|
- // First check the user's private mailcap file
|
||||||
|
nsAutoString mailcap_description, handler, mozillaFlags;
|
||||||
|
DoLookUpHandlerAndDescription(majorType,
|
||||||
|
minorType,
|
||||||
|
@@ -1516,46 +1521,23 @@ nsOSHelperAppService::GetFromType(const
|
||||||
|
mailcap_description,
|
||||||
|
mozillaFlags,
|
||||||
|
PR_TRUE);
|
||||||
|
-
|
||||||
|
- LOG(("Private Handler/Description results: handler='%s', description='%s'\n",
|
||||||
|
- NS_LossyConvertUTF16toASCII(handler).get(),
|
||||||
|
- NS_LossyConvertUTF16toASCII(mailcap_description).get()));
|
||||||
|
|
||||||
|
+
|
||||||
|
+ if (handler.IsEmpty() && extensions.IsEmpty() &&
|
||||||
|
+ mailcap_description.IsEmpty() && mime_types_description.IsEmpty()) {
|
||||||
|
+ // No useful data yet
|
||||||
|
+
|
||||||
|
#ifdef MOZ_WIDGET_GTK2
|
||||||
|
- nsMIMEInfoBase *gnomeInfo = nsnull;
|
||||||
|
- if (handler.IsEmpty()) {
|
||||||
|
- // No useful data yet. Check the GNOME registry. Unfortunately, newer
|
||||||
|
- // GNOME versions no longer have type-to-extension mappings, so we might
|
||||||
|
- // get back a MIMEInfo without any extensions set. In that case we'll have
|
||||||
|
- // to look in our mime.types files for the extensions.
|
||||||
|
LOG(("Looking in GNOME registry\n"));
|
||||||
|
- gnomeInfo = nsGNOMERegistry::GetFromType(aMIMEType.get()).get();
|
||||||
|
- if (gnomeInfo && gnomeInfo->HasExtensions()) {
|
||||||
|
- LOG(("Got MIMEInfo from GNOME registry, and it has extensions set\n"));
|
||||||
|
+ nsMIMEInfoBase *gnomeInfo = nsGNOMERegistry::GetFromType(aMIMEType.get()).get();
|
||||||
|
+ if (gnomeInfo) {
|
||||||
|
+ LOG(("Got MIMEInfo from GNOME registry\n"));
|
||||||
|
return gnomeInfo;
|
||||||
|
}
|
||||||
|
- }
|
||||||
|
#endif
|
||||||
|
-
|
||||||
|
- // Now look up our extensions
|
||||||
|
- nsAutoString extensions, mime_types_description;
|
||||||
|
- LookUpExtensionsAndDescription(majorType,
|
||||||
|
- minorType,
|
||||||
|
- extensions,
|
||||||
|
- mime_types_description);
|
||||||
|
-
|
||||||
|
-#ifdef MOZ_WIDGET_GTK2
|
||||||
|
- if (gnomeInfo) {
|
||||||
|
- LOG(("Got MIMEInfo from GNOME registry without extensions; setting them "
|
||||||
|
- "to %s\n", NS_LossyConvertUTF16toASCII(extensions).get()));
|
||||||
|
-
|
||||||
|
- NS_ASSERTION(!gnomeInfo->HasExtensions(), "How'd that happen?");
|
||||||
|
- gnomeInfo->SetFileExtensions(NS_ConvertUTF16toUTF8(extensions));
|
||||||
|
- return gnomeInfo;
|
||||||
|
}
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
- if (handler.IsEmpty()) {
|
||||||
|
+ if (handler.IsEmpty() && mailcap_description.IsEmpty()) {
|
||||||
|
DoLookUpHandlerAndDescription(majorType,
|
||||||
|
minorType,
|
||||||
|
typeOptions,
|
||||||
|
@@ -1565,7 +1547,7 @@ nsOSHelperAppService::GetFromType(const
|
||||||
|
PR_FALSE);
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (handler.IsEmpty()) {
|
||||||
|
+ if (handler.IsEmpty() && mailcap_description.IsEmpty()) {
|
||||||
|
DoLookUpHandlerAndDescription(majorType,
|
||||||
|
NS_LITERAL_STRING("*"),
|
||||||
|
typeOptions,
|
||||||
|
@@ -1575,7 +1557,7 @@ nsOSHelperAppService::GetFromType(const
|
||||||
|
PR_TRUE);
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (handler.IsEmpty()) {
|
||||||
|
+ if (handler.IsEmpty() && mailcap_description.IsEmpty()) {
|
||||||
|
DoLookUpHandlerAndDescription(majorType,
|
||||||
|
NS_LITERAL_STRING("*"),
|
||||||
|
typeOptions,
|
17
firefox.spec
17
firefox.spec
@ -11,8 +11,8 @@
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser.
|
Summary: Mozilla Firefox Web browser.
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 2.0.0.3
|
Version: 2.0.0.4
|
||||||
Release: 4%{?dist}
|
Release: 0.rc3%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPL/LGPL
|
License: MPL/LGPL
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -22,7 +22,7 @@ Group: Applications/Internet
|
|||||||
%define tarball firefox-2.0rc3-source.tar.bz2
|
%define tarball firefox-2.0rc3-source.tar.bz2
|
||||||
%endif
|
%endif
|
||||||
Source0: %{tarball}
|
Source0: %{tarball}
|
||||||
Source2: firefox-langpacks-%{version}-20070320.tar.bz2
|
Source2: firefox-langpacks-%{version}-20070523.tar.bz2
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source11: firefox-mozconfig-branded
|
Source11: firefox-mozconfig-branded
|
||||||
Source12: firefox-redhat-default-prefs.js
|
Source12: firefox-redhat-default-prefs.js
|
||||||
@ -52,6 +52,7 @@ Patch27: firefox-gnomestripe-0.1-livemarks.patch
|
|||||||
|
|
||||||
# local bugfixes
|
# local bugfixes
|
||||||
Patch40: firefox-1.5-bullet-bill.patch
|
Patch40: firefox-1.5-bullet-bill.patch
|
||||||
|
Patch41: firefox-2.0.0.4-undo-uriloader.patch
|
||||||
Patch42: firefox-1.1-uriloader.patch
|
Patch42: firefox-1.1-uriloader.patch
|
||||||
|
|
||||||
# font system fixes
|
# font system fixes
|
||||||
@ -61,10 +62,7 @@ Patch83: firefox-1.5-pango-cursor-position.patch
|
|||||||
Patch84: firefox-2.0-pango-printing.patch
|
Patch84: firefox-2.0-pango-printing.patch
|
||||||
|
|
||||||
# Other
|
# Other
|
||||||
Patch100: firefox-1.5-gtk-key-theme-crash.patch
|
|
||||||
Patch101: firefox-1.5-embedwindow-visibility.patch
|
|
||||||
Patch102: firefox-1.5-theme-change.patch
|
Patch102: firefox-1.5-theme-change.patch
|
||||||
Patch103: firefox-1.5-dnd-nograb.patch
|
|
||||||
Patch104: firefox-1.5-ppc64.patch
|
Patch104: firefox-1.5-ppc64.patch
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
@ -152,16 +150,14 @@ removed in favor of xulrunner-devel.
|
|||||||
#%patch26 -p0
|
#%patch26 -p0
|
||||||
#%patch27 -p1
|
#%patch27 -p1
|
||||||
%patch40 -p1 -b .bullet-bill
|
%patch40 -p1 -b .bullet-bill
|
||||||
|
%patch41 -p1 -b .undo-uriloader
|
||||||
%patch42 -p0 -b .uriloader
|
%patch42 -p0 -b .uriloader
|
||||||
%patch81 -p1 -b .nopangoxft
|
%patch81 -p1 -b .nopangoxft
|
||||||
#%patch82 -p1 -b .pango-mathml
|
#%patch82 -p1 -b .pango-mathml
|
||||||
%patch83 -p1 -b .pango-cursor-position
|
%patch83 -p1 -b .pango-cursor-position
|
||||||
%patch84 -p0 -b .pango-printing
|
%patch84 -p0 -b .pango-printing
|
||||||
|
|
||||||
#%patch100 -p0 -b .gtk-key-theme-crash
|
|
||||||
%patch101 -p0 -b .embedwindow-visibility
|
|
||||||
%patch102 -p0 -b .theme-change
|
%patch102 -p0 -b .theme-change
|
||||||
#%patch103 -p1 -b .dnd-nograb
|
|
||||||
%patch104 -p1 -b .ppc64
|
%patch104 -p1 -b .ppc64
|
||||||
|
|
||||||
# For branding specific patches.
|
# For branding specific patches.
|
||||||
@ -420,6 +416,9 @@ fi
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 23 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.4-0.rc3
|
||||||
|
- Update to 2.0.0.4 RC3
|
||||||
|
|
||||||
* Tue Apr 17 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.3-4
|
* Tue Apr 17 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.3-4
|
||||||
- Fix permissions of the man page
|
- Fix permissions of the man page
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
775913a54f9aae0020947284a6f63cf6 firefox-langpacks-2.0.0.3-20070320.tar.bz2
|
99c14794976b2532addfcd2d836c6bb2 firefox-2.0.0.4-source.tar.bz2
|
||||||
24398e3d98673a2a92a01a8f771ca12a firefox-2.0.0.3-source.tar.bz2
|
6356fb7701c91e5dfa38f2aecf4eb156 firefox-langpacks-2.0.0.4-20070523.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user