Sync snapshot of Firefox ESR 128 rebase into RHEL 10
To drop the requirements on dbus-glib which we want to remove from RHEL 10. Related: RHEL-24328 Related: DESKTOP-742 Related: RHELMISC-5474
This commit is contained in:
parent
9f825d7cfa
commit
afb435ac43
2
.gitignore
vendored
2
.gitignore
vendored
@ -622,3 +622,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/nspr-4.35.0-1.el8_1.src.rpm
|
||||
/nss-3.90.0-3.el8_1.src.rpm
|
||||
/nss-3.90.0-3.el9_0.src.rpm
|
||||
/firefox-128.0b5.processed-source.tar.xz
|
||||
/firefox-langpacks-128.0b5-20240620.tar.xz
|
||||
|
@ -1,127 +0,0 @@
|
||||
From 263682c9a29395055f3b3afe2d97be1828a6223f Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Jiang <jianj@google.com>
|
||||
Date: Thu, 30 Jun 2022 13:48:56 -0400
|
||||
Subject: [PATCH] Fix bug with smaller width bigger size
|
||||
|
||||
Fixed previous patch that clusterfuzz failed on.
|
||||
|
||||
Bug: webm:1642
|
||||
Change-Id: If0e08e72abd2e042efe4dcfac21e4cc51afdfdb9
|
||||
---
|
||||
test/resize_test.cc | 11 +++--------
|
||||
vp9/common/vp9_alloccommon.c | 13 ++++++-------
|
||||
vp9/encoder/vp9_encoder.c | 27 +++++++++++++++++++++++++--
|
||||
3 files changed, 34 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/test/resize_test.cc b/test/resize_test.cc
|
||||
index fd1c2a92de6..20ad2229b46 100644
|
||||
--- a/test/resize_test.cc
|
||||
+++ b/test/resize_test.cc
|
||||
@@ -102,11 +102,8 @@ void ScaleForFrameNumber(unsigned int frame, unsigned int initial_w,
|
||||
if (frame < 30) {
|
||||
return;
|
||||
}
|
||||
- if (frame < 100) {
|
||||
- *w = initial_w * 7 / 10;
|
||||
- *h = initial_h * 16 / 10;
|
||||
- return;
|
||||
- }
|
||||
+ *w = initial_w * 7 / 10;
|
||||
+ *h = initial_h * 16 / 10;
|
||||
return;
|
||||
}
|
||||
if (frame < 10) {
|
||||
@@ -559,9 +556,7 @@ TEST_P(ResizeRealtimeTest, TestExternalResizeWorks) {
|
||||
}
|
||||
}
|
||||
|
||||
-// TODO(https://crbug.com/webm/1642): This causes a segfault in
|
||||
-// init_encode_frame_mb_context().
|
||||
-TEST_P(ResizeRealtimeTest, DISABLED_TestExternalResizeSmallerWidthBiggerSize) {
|
||||
+TEST_P(ResizeRealtimeTest, TestExternalResizeSmallerWidthBiggerSize) {
|
||||
ResizingVideoSource video;
|
||||
video.flag_codec_ = true;
|
||||
video.smaller_width_larger_size_ = true;
|
||||
diff --git a/vp9/common/vp9_alloccommon.c b/vp9/common/vp9_alloccommon.c
|
||||
index e53883f621d..9e73e40ea09 100644
|
||||
--- a/vp9/common/vp9_alloccommon.c
|
||||
+++ b/vp9/common/vp9_alloccommon.c
|
||||
@@ -135,13 +135,6 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
|
||||
cm->free_mi(cm);
|
||||
if (cm->alloc_mi(cm, new_mi_size)) goto fail;
|
||||
}
|
||||
-
|
||||
- if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
|
||||
- // Create the segmentation map structure and set to 0.
|
||||
- free_seg_map(cm);
|
||||
- if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
|
||||
- }
|
||||
-
|
||||
if (cm->above_context_alloc_cols < cm->mi_cols) {
|
||||
vpx_free(cm->above_context);
|
||||
cm->above_context = (ENTROPY_CONTEXT *)vpx_calloc(
|
||||
@@ -156,6 +149,12 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
|
||||
cm->above_context_alloc_cols = cm->mi_cols;
|
||||
}
|
||||
|
||||
+ if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
|
||||
+ // Create the segmentation map structure and set to 0.
|
||||
+ free_seg_map(cm);
|
||||
+ if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
|
||||
+ }
|
||||
+
|
||||
if (vp9_alloc_loop_filter(cm)) goto fail;
|
||||
|
||||
return 0;
|
||||
diff --git a/vp9/encoder/vp9_encoder.c b/vp9/encoder/vp9_encoder.c
|
||||
index 69a4e3c314f..e3ba294c32f 100644
|
||||
--- a/vp9/encoder/vp9_encoder.c
|
||||
+++ b/vp9/encoder/vp9_encoder.c
|
||||
@@ -2047,6 +2047,17 @@ static void alloc_copy_partition_data(VP9_COMP *cpi) {
|
||||
}
|
||||
}
|
||||
|
||||
+static void free_copy_partition_data(VP9_COMP *cpi) {
|
||||
+ vpx_free(cpi->prev_partition);
|
||||
+ cpi->prev_partition = NULL;
|
||||
+ vpx_free(cpi->prev_segment_id);
|
||||
+ cpi->prev_segment_id = NULL;
|
||||
+ vpx_free(cpi->prev_variance_low);
|
||||
+ cpi->prev_variance_low = NULL;
|
||||
+ vpx_free(cpi->copied_frame_cnt);
|
||||
+ cpi->copied_frame_cnt = NULL;
|
||||
+}
|
||||
+
|
||||
void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
||||
VP9_COMMON *const cm = &cpi->common;
|
||||
RATE_CONTROL *const rc = &cpi->rc;
|
||||
@@ -2126,6 +2137,8 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
||||
new_mi_size = cm->mi_stride * calc_mi_size(cm->mi_rows);
|
||||
if (cm->mi_alloc_size < new_mi_size) {
|
||||
vp9_free_context_buffers(cm);
|
||||
+ vp9_free_pc_tree(&cpi->td);
|
||||
+ vpx_free(cpi->mbmi_ext_base);
|
||||
alloc_compressor_data(cpi);
|
||||
realloc_segmentation_maps(cpi);
|
||||
cpi->initial_width = cpi->initial_height = 0;
|
||||
@@ -2144,8 +2157,18 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
|
||||
update_frame_size(cpi);
|
||||
|
||||
if (last_w != cpi->oxcf.width || last_h != cpi->oxcf.height) {
|
||||
- memset(cpi->consec_zero_mv, 0,
|
||||
- cm->mi_rows * cm->mi_cols * sizeof(*cpi->consec_zero_mv));
|
||||
+ vpx_free(cpi->consec_zero_mv);
|
||||
+ CHECK_MEM_ERROR(
|
||||
+ &cm->error, cpi->consec_zero_mv,
|
||||
+ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(*cpi->consec_zero_mv)));
|
||||
+
|
||||
+ vpx_free(cpi->skin_map);
|
||||
+ CHECK_MEM_ERROR(
|
||||
+ &cm->error, cpi->skin_map,
|
||||
+ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(cpi->skin_map[0])));
|
||||
+
|
||||
+ free_copy_partition_data(cpi);
|
||||
+ alloc_copy_partition_data(cpi);
|
||||
if (cpi->oxcf.aq_mode == CYCLIC_REFRESH_AQ)
|
||||
vp9_cyclic_refresh_reset_resize(cpi);
|
||||
rc->rc_1_frame = 0;
|
@ -1,12 +1,12 @@
|
||||
diff -up firefox-115.2.0/toolkit/moz.configure.disable-elfhack firefox-115.2.0/toolkit/moz.configure
|
||||
--- firefox-115.2.0/toolkit/moz.configure.disable-elfhack 2023-09-20 21:55:41.002788320 +0200
|
||||
+++ firefox-115.2.0/toolkit/moz.configure 2023-09-20 21:56:37.343757245 +0200
|
||||
@@ -1511,7 +1511,7 @@ with only_when("--enable-compile-environ
|
||||
"Cannot enable elfhack with lld."
|
||||
" Use --enable-linker=bfd, --enable-linker=gold, or --disable-elf-hack"
|
||||
)
|
||||
- return True
|
||||
+ return False
|
||||
|
||||
set_config("USE_ELF_HACK", use_elf_hack)
|
||||
|
||||
diff -up firefox-128.0/toolkit/moz.configure.disable-elfhack firefox-128.0/toolkit/moz.configure
|
||||
--- firefox-128.0/toolkit/moz.configure.disable-elfhack 2024-06-19 17:24:29.964976617 +0200
|
||||
+++ firefox-128.0/toolkit/moz.configure 2024-06-19 17:24:53.015843805 +0200
|
||||
@@ -1553,7 +1553,7 @@ with only_when("--enable-compile-environ
|
||||
@depends(host, target)
|
||||
def has_elfhack(host, target):
|
||||
return (
|
||||
- target.kernel == "Linux"
|
||||
+ False and target.kernel == "Linux"
|
||||
and host.kernel == "Linux"
|
||||
and target.cpu in ("arm", "aarch64", "x86", "x86_64")
|
||||
)
|
||||
|
@ -1,9 +0,0 @@
|
||||
diff -up firefox-73.0/build/unix/run-mozilla.sh.old firefox-73.0/build/unix/run-mozilla.sh
|
||||
--- firefox-73.0/build/unix/run-mozilla.sh.old 2020-02-12 09:58:00.150895904 +0100
|
||||
+++ firefox-73.0/build/unix/run-mozilla.sh 2020-02-12 09:58:06.505860696 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/sh
|
||||
+#!/usr/bin/sh
|
||||
#
|
||||
# This Source Code Form is subject to the terms of the Mozilla Public
|
||||
# License, v. 2.0. If a copy of the MPL was not distributed with this
|
@ -1,10 +1,10 @@
|
||||
diff -up firefox-55.0/browser/app/profile/firefox.js.addons firefox-55.0/browser/app/profile/firefox.js
|
||||
--- firefox-55.0/browser/app/profile/firefox.js.addons 2017-08-02 10:58:30.566363833 +0200
|
||||
+++ firefox-55.0/browser/app/profile/firefox.js 2017-08-02 10:59:15.377216959 +0200
|
||||
@@ -65,7 +65,8 @@ pref("extensions.systemAddon.update.url"
|
||||
diff -up firefox-128.0/browser/app/profile/firefox.js.addons firefox-128.0/browser/app/profile/firefox.js
|
||||
--- firefox-128.0/browser/app/profile/firefox.js.addons 2024-06-13 11:47:04.255428350 +0200
|
||||
+++ firefox-128.0/browser/app/profile/firefox.js 2024-06-13 11:53:00.442837371 +0200
|
||||
@@ -56,7 +56,8 @@ pref("extensions.systemAddon.update.enab
|
||||
|
||||
// Disable add-ons that are not installed by the user in all scopes by default.
|
||||
// See the SCOPE constants in AddonManager.jsm for values to use here.
|
||||
// See the SCOPE constants in AddonManager.sys.mjs for values to use here.
|
||||
-pref("extensions.autoDisableScopes", 15);
|
||||
+pref("extensions.autoDisableScopes", 0);
|
||||
+pref("extensions.showMismatchUI", false);
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up firefox-88.0/testing/xpcshell/runxpcshelltests.py.old firefox-88.0/testing/xpcshell/runxpcshelltests.py
|
||||
--- firefox-88.0/testing/xpcshell/runxpcshelltests.py.old 2021-04-30 10:45:14.466616224 +0200
|
||||
+++ firefox-88.0/testing/xpcshell/runxpcshelltests.py 2021-04-30 10:45:21.339525085 +0200
|
||||
@@ -1382,8 +1382,8 @@ class XPCShellTests(object):
|
||||
self.log.info("Process %s" % label)
|
||||
self.log.info(msg)
|
||||
|
||||
- dumpOutput(proc.stdout, "stdout")
|
||||
- dumpOutput(proc.stderr, "stderr")
|
||||
+ #dumpOutput(proc.stdout, "stdout")
|
||||
+ #dumpOutput(proc.stderr, "stderr")
|
||||
self.nodeProc = {}
|
||||
|
||||
def startHttp3Server(self):
|
66
firefox.spec
66
firefox.spec
@ -36,7 +36,7 @@ function dist_to_rhel_minor(str, start)
|
||||
end
|
||||
match = string.match(str, ".el9")
|
||||
if match then
|
||||
return 5
|
||||
return 4
|
||||
end
|
||||
return -1
|
||||
end}
|
||||
@ -44,19 +44,22 @@ end}
|
||||
%global rhel_minor_version %{lua:print(dist_to_rhel_minor(rpm.expand("%dist")))}
|
||||
|
||||
# System libraries options
|
||||
%global system_nss 1
|
||||
#FIXME need to switch to system
|
||||
%global system_nss 0
|
||||
%global bundle_nss 0
|
||||
|
||||
%if 0%{?rhel} == 8
|
||||
%if %{rhel_minor_version} <= 6
|
||||
%global bundle_nss 1
|
||||
%global system_nss 1
|
||||
#FIXME 1
|
||||
%global bundle_nss 0
|
||||
%global system_nss 0
|
||||
%endif
|
||||
%endif
|
||||
%if 0%{?rhel} == 9
|
||||
%if %{rhel_minor_version} <= 0
|
||||
%global bundle_nss 1
|
||||
%global system_nss 1
|
||||
# FIXME 1
|
||||
%global bundle_nss 0
|
||||
%global system_nss 0
|
||||
%endif
|
||||
%endif
|
||||
|
||||
@ -74,7 +77,8 @@ end}
|
||||
%global use_gcc_ts 0
|
||||
%global use_llvm_ts 0
|
||||
%global use_nodejs_scl 0
|
||||
%global use_rust_ts 1
|
||||
#FIXME switch to 1
|
||||
%global use_rust_ts 0
|
||||
%global use_python3_scl 0
|
||||
|
||||
%global nodejs_build_req nodejs
|
||||
@ -117,7 +121,7 @@ end}
|
||||
%global mozappdir %{_libdir}/firefox
|
||||
%global langpackdir %{mozappdir}/browser/extensions
|
||||
%define bundled_install_path %{mozappdir}/bundled
|
||||
%global pre_version esr
|
||||
%global pre_version b5
|
||||
# Workaround the dreaded "upstream source file changed content" rpminspect failure.
|
||||
# If set to .b2 or .b3 ... the processed source file needs to be renamed before upload, e.g.
|
||||
# firefox-102.8.0esr.b2.processed-source.tar.xz
|
||||
@ -132,7 +136,7 @@ end}
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 115.12.0
|
||||
Version: 128.0
|
||||
Release: 1%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
@ -163,7 +167,7 @@ ExcludeArch: aarch64 s390 ppc
|
||||
# Link to original tarball: https://archive.mozilla.org/pub/firefox/releases/%%{version}%%{?pre_version}/source/firefox-%%{version}%%{?pre_version}.source.tar.xz
|
||||
Source0: firefox-%{version}%{?pre_version}%{?buildnum}.processed-source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20240604.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20240620.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source3: process-official-tarball
|
||||
@ -224,7 +228,6 @@ Patch109: mozilla-bmo1789216-disable-av1.patch
|
||||
# ---- Fedora specific patches ----
|
||||
Patch151: firefox-enable-addons.patch
|
||||
Patch152: rhbz-1173156.patch
|
||||
Patch153: fedora-shebang-build.patch
|
||||
Patch154: firefox-nss-addon-hack.patch
|
||||
# ARM run-time patch
|
||||
Patch155: rhbz-1354671.patch
|
||||
@ -233,10 +236,8 @@ Patch155: rhbz-1354671.patch
|
||||
# Generate without context by
|
||||
# GENDIFF_DIFF_ARGS=-U0 gendiff firefox-xxxx .firefox-tests-xpcshell
|
||||
# GENDIFF_DIFF_ARGS=-U0 gendiff firefox-xxxx .firefox-tests-reftest
|
||||
Patch201: firefox-tests-xpcshell-freeze.patch
|
||||
|
||||
# ---- Security patches ----
|
||||
Patch301: CVE-2023-44488-libvpx.patch
|
||||
|
||||
# BUILD REQURES/REQUIRES
|
||||
%if %{?system_nss} && !0%{?bundle_nss}
|
||||
@ -253,7 +254,6 @@ BuildRequires: libvpx-devel >= 1.8.2
|
||||
%endif
|
||||
|
||||
BuildRequires: bzip2-devel
|
||||
BuildRequires: dbus-glib-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: libappstream-glib
|
||||
BuildRequires: libjpeg-devel
|
||||
@ -296,6 +296,7 @@ BuildRequires: pipewire-devel
|
||||
|
||||
%if 0%{?rhel} == 8
|
||||
BuildRequires: cargo
|
||||
BuildRequires: clang-libs >= %{llvm_version}
|
||||
BuildRequires: clang-devel >= %{llvm_version}
|
||||
BuildRequires: clang >= %{llvm_version}
|
||||
BuildRequires: llvm-devel >= %{llvm_version}
|
||||
@ -403,9 +404,10 @@ BuildRequires: xorg-x11-server-Xvfb
|
||||
|
||||
%if 0%{?rhel} == 8 && %{rhel_minor_version} < 6
|
||||
%ifarch aarch64
|
||||
BuildRequires: gcc-toolset-12-gcc-plugin-annobin
|
||||
BuildRequires: gcc-toolset-13-gcc-plugin-annobin
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: gcc-toolset-13
|
||||
|
||||
Requires: mozilla-filesystem
|
||||
Requires: p11-kit-trust
|
||||
@ -992,6 +994,7 @@ echo "use_nodejs_scl %{?use_nodejs_scl}"
|
||||
echo "use_llvm_ts %{?use_llvm_ts}"
|
||||
echo "use_python3_scl %{?use_python3_scl}"
|
||||
echo "--------------------------------------------"
|
||||
clang -print-search-dirs
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
# ---- RHEL specific patches ---
|
||||
@ -1020,8 +1023,8 @@ echo "--------------------------------------------"
|
||||
%patch -P51 -p1 -b .mozilla-bmo1170092
|
||||
|
||||
# -- Submitted upstream, not merged --
|
||||
%patch -P101 -p1 -b .mozilla-bmo1636168-fscreen
|
||||
%patch -P102 -p1 -b .mozilla-bmo1670333
|
||||
#%patch -P101 -p1 -b .mozilla-bmo1636168-fscreen TODO
|
||||
#%patch -P102 -p1 -b .mozilla-bmo1670333 TODO
|
||||
%patch -P103 -p1 -b .mozilla-bmo1504834-part1
|
||||
%patch -P104 -p1 -b .mozilla-bmo1504834-part3
|
||||
%patch -P105 -p1 -b .mozilla-bmo849632
|
||||
@ -1033,20 +1036,13 @@ echo "--------------------------------------------"
|
||||
# ---- Fedora specific patches ----
|
||||
%patch -P151 -p1 -b .addons
|
||||
%patch -P152 -p1 -b .rhbz-1173156
|
||||
%patch -P153 -p1 -b .fedora-shebang
|
||||
%patch -P154 -p1 -b .addons-nss-hack
|
||||
# ARM run-time patch
|
||||
%ifarch aarch64
|
||||
%patch -P155 -p1 -b .rhbz-1354671
|
||||
%endif
|
||||
|
||||
# ---- Test patches ----
|
||||
%patch -P201 -p1 -b .firefox-tests-xpcshell-freeze
|
||||
|
||||
# ---- Security patches ----
|
||||
cd media/libvpx/libvpx
|
||||
%patch -P301 -p1 -b .CVE-2023-44488-libvpx
|
||||
cd -
|
||||
|
||||
%{__rm} -f .mozconfig
|
||||
%{__cp} %{SOURCE10} .mozconfig
|
||||
@ -1123,7 +1119,8 @@ echo "ac_add_options --with-google-safebrowsing-api-keyfile=`pwd`/google-api-key
|
||||
|
||||
# May result in empty --with-libclang-path= in earlier versions.
|
||||
# So far this is needed only for c8s/c9s.
|
||||
%if (0%{?rhel} == 8 && %{rhel_minor_version} >= 10) || (0%{?rhel} == 9 && %{rhel_minor_version} >= 4)
|
||||
#if (0%{?rhel} == 8 && %{rhel_minor_version} >= 10) || (0%{?rhel} == 9 && %{rhel_minor_version} >= 4)
|
||||
%if (0%{?rhel} == 8) || (0%{?rhel} == 9)
|
||||
# Clang 17 upstream's detection fails, tell it where to look.
|
||||
echo "ac_add_options --with-libclang-path=`llvm-config --libdir`" >> .mozconfig
|
||||
%endif
|
||||
@ -1225,6 +1222,7 @@ set +e
|
||||
source scl_source enable gcc-toolset-12
|
||||
%endif
|
||||
%endif
|
||||
source scl_source enable gcc-toolset-13
|
||||
%if 0%{?use_dts}
|
||||
source scl_source enable devtoolset-%{dts_version}
|
||||
%endif
|
||||
@ -1280,7 +1278,7 @@ cp %{SOURCE32} %{_buildrootdir}/bin || :
|
||||
# Do not update config.guess in the ./third_party/rust because that would break checksums
|
||||
find ./ -path ./third_party/rust -prune -o -name config.guess -exec cp /usr/lib/rpm/config.guess {} ';'
|
||||
|
||||
MOZ_OPT_FLAGS=$(echo "%{optflags}" | %{__sed} -e 's/-Wall//')
|
||||
MOZ_OPT_FLAGS=$(echo "%{optflags}" | %{__sed} -e 's/-Wall//' | %{__sed} -e 's/-fexceptions//' )
|
||||
#rhbz#1037063
|
||||
# -Werror=format-security causes build failures when -Wno-format is explicitly given
|
||||
# for some sources
|
||||
@ -1601,9 +1599,6 @@ ln -s %{_datadir}/myspell %{buildroot}%{mozappdir}/dictionaries
|
||||
%{__cp} failures-* %{buildroot}/%{version}-%{release}/ || true
|
||||
%endif
|
||||
|
||||
# Copy over run-mozilla.sh
|
||||
%{__cp} build/unix/run-mozilla.sh %{buildroot}%{mozappdir}
|
||||
|
||||
# Add distribution.ini
|
||||
%{__mkdir_p} %{buildroot}%{mozappdir}/distribution
|
||||
%{__cp} %{SOURCE26} %{buildroot}%{mozappdir}/distribution
|
||||
@ -1695,7 +1690,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%dir %{langpackdir}
|
||||
%endif
|
||||
%{mozappdir}/browser/omni.ja
|
||||
%{mozappdir}/run-mozilla.sh
|
||||
%{mozappdir}/application.ini
|
||||
%{mozappdir}/pingsender
|
||||
%exclude %{mozappdir}/removed-files
|
||||
@ -1716,11 +1710,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{mozappdir}/dictionaries
|
||||
%{mozappdir}/omni.ja
|
||||
%{mozappdir}/platform.ini
|
||||
%{mozappdir}/plugin-container
|
||||
%{mozappdir}/gmp-clearkey
|
||||
%{mozappdir}/fonts/TwemojiMozilla.ttf
|
||||
%{mozappdir}/glxtest
|
||||
%{mozappdir}/vaapitest
|
||||
%ifarch aarch64
|
||||
%{mozappdir}/v4l2test
|
||||
%endif
|
||||
|
||||
%if !%{?system_nss}
|
||||
%exclude %{mozappdir}/libnssckbi.so
|
||||
@ -1740,11 +1736,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jun 04 2024 Eike Rathke <erack@redhat.com> - 115.12.0-1
|
||||
- Update to 115.12.0 build1
|
||||
* Thu Jun 20 2024 Jan Horak <jhorak@redhat.com> - 128.0b5-1
|
||||
- Update to 128.0b5
|
||||
|
||||
* Tue May 07 2024 Eike Rathke <erack@redhat.com> - 115.11.0-1
|
||||
- Update to 115.11.0 build1
|
||||
* Thu Jun 13 2024 Jan Horak <jhorak@redhat.com> - 128.0b2-1
|
||||
- Update to 128.0b2
|
||||
|
||||
* Tue Apr 09 2024 Eike Rathke <erack@redhat.com> - 115.10.0-1
|
||||
- Update to 115.10.0 build1
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up firefox-115.2.0/gfx/2d/DrawTargetSkia.cpp.mozilla-bmo1504834-part1 firefox-115.2.0/gfx/2d/DrawTargetSkia.cpp
|
||||
--- firefox-115.2.0/gfx/2d/DrawTargetSkia.cpp.mozilla-bmo1504834-part1 2023-09-20 22:15:11.850172571 +0200
|
||||
+++ firefox-115.2.0/gfx/2d/DrawTargetSkia.cpp 2023-09-20 22:16:10.446147737 +0200
|
||||
diff -up firefox-128.0/gfx/2d/DrawTargetSkia.cpp.mozilla-bmo1504834-part1 firefox-128.0/gfx/2d/DrawTargetSkia.cpp
|
||||
--- firefox-128.0/gfx/2d/DrawTargetSkia.cpp.mozilla-bmo1504834-part1 2024-06-12 15:02:55.000000000 +0200
|
||||
+++ firefox-128.0/gfx/2d/DrawTargetSkia.cpp 2024-06-13 11:36:54.550728034 +0200
|
||||
@@ -156,8 +156,8 @@ static IntRect CalculateSurfaceBounds(co
|
||||
}
|
||||
|
||||
@ -12,9 +12,9 @@ diff -up firefox-115.2.0/gfx/2d/DrawTargetSkia.cpp.mozilla-bmo1504834-part1 fire
|
||||
static bool VerifyRGBXFormat(uint8_t* aData, const IntSize& aSize,
|
||||
const int32_t aStride, SurfaceFormat aFormat) {
|
||||
if (aFormat != SurfaceFormat::B8G8R8X8 || aSize.IsEmpty()) {
|
||||
diff -up firefox-115.2.0/gfx/2d/Types.h.mozilla-bmo1504834-part1 firefox-115.2.0/gfx/2d/Types.h
|
||||
--- firefox-115.2.0/gfx/2d/Types.h.mozilla-bmo1504834-part1 2023-08-21 15:43:23.000000000 +0200
|
||||
+++ firefox-115.2.0/gfx/2d/Types.h 2023-09-20 22:15:11.850172571 +0200
|
||||
diff -up firefox-128.0/gfx/2d/Types.h.mozilla-bmo1504834-part1 firefox-128.0/gfx/2d/Types.h
|
||||
--- firefox-128.0/gfx/2d/Types.h.mozilla-bmo1504834-part1 2024-06-12 15:02:56.000000000 +0200
|
||||
+++ firefox-128.0/gfx/2d/Types.h 2024-06-13 11:36:54.551728036 +0200
|
||||
@@ -89,18 +89,11 @@ enum class SurfaceFormat : int8_t {
|
||||
// This represents the unknown format.
|
||||
UNKNOWN, // TODO: Replace uses with Maybe<SurfaceFormat>.
|
||||
@ -37,10 +37,10 @@ diff -up firefox-115.2.0/gfx/2d/Types.h.mozilla-bmo1504834-part1 firefox-115.2.0
|
||||
|
||||
// The following values are OS and endian-independent synonyms.
|
||||
//
|
||||
diff -up firefox-115.2.0/gfx/skia/skia/modules/skcms/skcms.cc.mozilla-bmo1504834-part1 firefox-115.2.0/gfx/skia/skia/modules/skcms/skcms.cc
|
||||
--- firefox-115.2.0/gfx/skia/skia/modules/skcms/skcms.cc.mozilla-bmo1504834-part1 2023-08-21 15:43:23.000000000 +0200
|
||||
+++ firefox-115.2.0/gfx/skia/skia/modules/skcms/skcms.cc 2023-09-20 22:15:11.851172570 +0200
|
||||
@@ -30,6 +30,8 @@
|
||||
diff -up firefox-128.0/gfx/skia/skia/modules/skcms/skcms.cc.mozilla-bmo1504834-part1 firefox-128.0/gfx/skia/skia/modules/skcms/skcms.cc
|
||||
--- firefox-128.0/gfx/skia/skia/modules/skcms/skcms.cc.mozilla-bmo1504834-part1 2024-06-12 15:02:57.000000000 +0200
|
||||
+++ firefox-128.0/gfx/skia/skia/modules/skcms/skcms.cc 2024-06-13 11:38:45.377835856 +0200
|
||||
@@ -31,6 +31,8 @@
|
||||
#include <avx512fintrin.h>
|
||||
#include <avx512dqintrin.h>
|
||||
#endif
|
||||
@ -48,7 +48,7 @@ diff -up firefox-115.2.0/gfx/skia/skia/modules/skcms/skcms.cc.mozilla-bmo1504834
|
||||
+ #define SKCMS_PORTABLE
|
||||
#endif
|
||||
|
||||
static bool runtime_cpu_detection = true;
|
||||
using namespace skcms_private;
|
||||
@@ -324,20 +326,28 @@ enum {
|
||||
static uint16_t read_big_u16(const uint8_t* ptr) {
|
||||
uint16_t be;
|
||||
|
@ -1,9 +1,7 @@
|
||||
diff --git a/media/ffvpx/libavcodec/allcodecs.c b/media/ffvpx/libavcodec/allcodecs.c
|
||||
--- a/media/ffvpx/libavcodec/allcodecs.c
|
||||
+++ b/media/ffvpx/libavcodec/allcodecs.c
|
||||
@@ -755,12 +755,15 @@
|
||||
extern FFCodec ff_libaom_av1_encoder;
|
||||
extern const FFCodec ff_libaribb24_decoder;
|
||||
diff -up firefox-128.0/media/ffvpx/libavcodec/allcodecs.c.mozilla-bmo1789216-disable-av1 firefox-128.0/media/ffvpx/libavcodec/allcodecs.c
|
||||
--- firefox-128.0/media/ffvpx/libavcodec/allcodecs.c.mozilla-bmo1789216-disable-av1 2024-06-12 15:03:01.000000000 +0200
|
||||
+++ firefox-128.0/media/ffvpx/libavcodec/allcodecs.c 2024-06-13 11:44:10.637215674 +0200
|
||||
@@ -764,8 +764,11 @@ extern const FFCodec ff_libaribb24_decod
|
||||
extern const FFCodec ff_libcelt_decoder;
|
||||
extern const FFCodec ff_libcodec2_encoder;
|
||||
extern const FFCodec ff_libcodec2_decoder;
|
||||
@ -15,11 +13,7 @@ diff --git a/media/ffvpx/libavcodec/allcodecs.c b/media/ffvpx/libavcodec/allcode
|
||||
extern const FFCodec ff_libfdk_aac_encoder;
|
||||
extern const FFCodec ff_libfdk_aac_decoder;
|
||||
extern const FFCodec ff_libgsm_encoder;
|
||||
extern const FFCodec ff_libgsm_decoder;
|
||||
extern const FFCodec ff_libgsm_ms_encoder;
|
||||
@@ -783,11 +786,10 @@
|
||||
extern const FFCodec ff_libspeex_encoder;
|
||||
extern const FFCodec ff_libspeex_decoder;
|
||||
@@ -793,7 +796,6 @@ extern const FFCodec ff_libspeex_decoder
|
||||
extern const FFCodec ff_libsvtav1_encoder;
|
||||
extern const FFCodec ff_libtheora_encoder;
|
||||
extern const FFCodec ff_libtwolame_encoder;
|
||||
@ -27,14 +21,10 @@ diff --git a/media/ffvpx/libavcodec/allcodecs.c b/media/ffvpx/libavcodec/allcode
|
||||
extern const FFCodec ff_libvo_amrwbenc_encoder;
|
||||
extern const FFCodec ff_libvorbis_encoder;
|
||||
extern const FFCodec ff_libvorbis_decoder;
|
||||
extern const FFCodec ff_libvpx_vp8_encoder;
|
||||
extern const FFCodec ff_libvpx_vp8_decoder;
|
||||
diff --git a/media/ffvpx/libavcodec/codec_list.c b/media/ffvpx/libavcodec/codec_list.c
|
||||
--- a/media/ffvpx/libavcodec/codec_list.c
|
||||
+++ b/media/ffvpx/libavcodec/codec_list.c
|
||||
@@ -9,12 +9,14 @@
|
||||
&ff_flac_decoder,
|
||||
#endif
|
||||
diff -up firefox-128.0/media/ffvpx/libavcodec/codec_list.c.mozilla-bmo1789216-disable-av1 firefox-128.0/media/ffvpx/libavcodec/codec_list.c
|
||||
--- firefox-128.0/media/ffvpx/libavcodec/codec_list.c.mozilla-bmo1789216-disable-av1 2024-06-13 11:40:12.668924117 +0200
|
||||
+++ firefox-128.0/media/ffvpx/libavcodec/codec_list.c 2024-06-13 11:44:41.411253372 +0200
|
||||
@@ -11,12 +11,14 @@ static const FFCodec * const codec_list[
|
||||
#if CONFIG_MP3_DECODER
|
||||
&ff_mp3_decoder,
|
||||
#endif
|
||||
@ -45,26 +35,22 @@ diff --git a/media/ffvpx/libavcodec/codec_list.c b/media/ffvpx/libavcodec/codec_
|
||||
#if CONFIG_AV1_DECODER
|
||||
&ff_av1_decoder,
|
||||
#endif
|
||||
+#endif
|
||||
NULL };
|
||||
diff --git a/media/ffvpx/libavcodec/moz.build b/media/ffvpx/libavcodec/moz.build
|
||||
--- a/media/ffvpx/libavcodec/moz.build
|
||||
+++ b/media/ffvpx/libavcodec/moz.build
|
||||
@@ -84,11 +84,10 @@
|
||||
'cbs.c',
|
||||
'cbs_av1.c',
|
||||
'golomb.c',
|
||||
'h264pred.c',
|
||||
+#endif
|
||||
#if CONFIG_LIBVORBIS_DECODER
|
||||
&ff_libvorbis_decoder,
|
||||
#endif
|
||||
diff -up firefox-128.0/media/ffvpx/libavcodec/moz.build.mozilla-bmo1789216-disable-av1 firefox-128.0/media/ffvpx/libavcodec/moz.build
|
||||
--- firefox-128.0/media/ffvpx/libavcodec/moz.build.mozilla-bmo1789216-disable-av1 2024-06-13 11:40:12.669924118 +0200
|
||||
+++ firefox-128.0/media/ffvpx/libavcodec/moz.build 2024-06-13 11:45:22.867304151 +0200
|
||||
@@ -94,7 +94,6 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
|
||||
'imgconvert.c',
|
||||
'libaom.c',
|
||||
'libaomenc.c',
|
||||
- 'libdav1d.c',
|
||||
'libvpxdec.c',
|
||||
'libvpxenc.c',
|
||||
'mathtables.c',
|
||||
'qsv_api.c',
|
||||
'raw.c',
|
||||
'videodsp.c',
|
||||
'vp8.c',
|
||||
@@ -107,14 +106,19 @@
|
||||
'vp9mvs.c',
|
||||
'vp9prob.c',
|
||||
@@ -119,10 +118,16 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
|
||||
'vp9recon.c',
|
||||
'vpx_rac.c',
|
||||
]
|
||||
@ -81,9 +67,7 @@ diff --git a/media/ffvpx/libavcodec/moz.build b/media/ffvpx/libavcodec/moz.build
|
||||
+ 'libdav1d.c',
|
||||
+ ]
|
||||
+
|
||||
if CONFIG['MOZ_WAYLAND']:
|
||||
+
|
||||
if CONFIG["MOZ_WIDGET_TOOLKIT"] == "gtk":
|
||||
LOCAL_INCLUDES += ['/media/mozva']
|
||||
SOURCES += [
|
||||
'vaapi_av1.c',
|
||||
'vaapi_decode.c',
|
||||
|
||||
|
6
sources
6
sources
@ -1,6 +1,6 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 161811f4adfc74e5d92871c78139704d32e1e1ad6b615c85353de300d9647a68f1ca8b1c953f7cc5539d861e9e8d8e42892cae757a3eafea78804e19bc323c16
|
||||
SHA512 (firefox-115.12.0esr.processed-source.tar.xz) = 243a839539dc8a2ca3f2c3ec5603895687c3ea27b65f5ba17ca915905e38720964ad0767b958b2c9747c21aa7791a7941a76b38d7276b6bc78a39c54261ec0fe
|
||||
SHA512 (firefox-langpacks-115.12.0esr-20240604.tar.xz) = 896897cd8769cb4f9c87d53244132033226badf92128b64537ac4861de45bfda2697ac802613bf321f7a464cba0183aaf52cd06293934467eda8add598886b52
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 0c7a40033ccd38dadd30ad064feef390444af4562be07d3dfd0c4cccc55821b01b5228ddee367d0af3bd1b4ef9b1552cdd104506579b020ac1940a7c536b8b68
|
||||
SHA512 (firefox-128.0b5.processed-source.tar.xz) = f648bb104fc2dfa54203a5a12f34709388cf43dea320e2c076059fd7fe9886e36ad9d22bdbf90b158535e59547a80fa0cdeebe2e9e3da9d47eb00b8a13766f39
|
||||
SHA512 (firefox-langpacks-128.0b5-20240620.tar.xz) = 776f94c91767dd1f30f5fc5a5f123899fed9ac76793f1482d86559f8bf88ba792c11e51f1d76641d47cf003692cdb50d5e086995b9490d0b7dca0231dc7c4e8e
|
||||
SHA512 (mochitest-python.tar.gz) = 089b1593068b76f4572af0086eaccf52a6a1299bfffb58593206d19bf021ae381f2380bbfeb4371586cd53706ff6dde3d240238b2caf19b96c57dfc2f4524e36
|
||||
SHA512 (nspr-4.35.0-1.el8_1.src.rpm) = 5123a443fcc42602e31104999be339ae899eb7b1f1e2f1ea87ba4f283eb894d08ab568e421dba1df4770f23be91ff88aa6a0748bce7feef31ed88bee5bdecb2c
|
||||
SHA512 (nss-3.90.0-3.el8_1.src.rpm) = 81df24bd4eda4935888170e994834f4510c20fa51079631527b195b723d8f536ec4144d4a2e5d45768aeec7c426d50d70d0a294577d18233acc07c49c8af5130
|
||||
|
Loading…
Reference in New Issue
Block a user