Updated to 97.0.1 / GCC 12 build fixes
This commit is contained in:
parent
6d9b08e92b
commit
af44b86020
2
.gitignore
vendored
2
.gitignore
vendored
@ -493,3 +493,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-96.0.3-20220131.tar.xz
|
/firefox-langpacks-96.0.3-20220131.tar.xz
|
||||||
/firefox-97.0.source.tar.xz
|
/firefox-97.0.source.tar.xz
|
||||||
/firefox-langpacks-97.0-20220208.tar.xz
|
/firefox-langpacks-97.0-20220208.tar.xz
|
||||||
|
/firefox-97.0.1.source.tar.xz
|
||||||
|
/firefox-langpacks-97.0.1-20220218.tar.xz
|
||||||
|
34
D139022.diff
Normal file
34
D139022.diff
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
diff --git a/dom/animation/TimingParams.h b/dom/animation/TimingParams.h
|
||||||
|
--- a/dom/animation/TimingParams.h
|
||||||
|
+++ b/dom/animation/TimingParams.h
|
||||||
|
@@ -31,22 +31,19 @@
|
||||||
|
struct TimingParams {
|
||||||
|
constexpr TimingParams() = default;
|
||||||
|
|
||||||
|
- constexpr TimingParams(float aDuration, float aDelay, float aIterationCount,
|
||||||
|
- dom::PlaybackDirection aDirection,
|
||||||
|
- dom::FillMode aFillMode)
|
||||||
|
+ TimingParams(float aDuration, float aDelay, float aIterationCount,
|
||||||
|
+ dom::PlaybackDirection aDirection, dom::FillMode aFillMode)
|
||||||
|
: mIterations(aIterationCount), mDirection(aDirection), mFill(aFillMode) {
|
||||||
|
mDuration.emplace(StickyTimeDuration::FromMilliseconds(aDuration));
|
||||||
|
mDelay = TimeDuration::FromMilliseconds(aDelay);
|
||||||
|
Update();
|
||||||
|
}
|
||||||
|
|
||||||
|
- constexpr TimingParams(const TimeDuration& aDuration,
|
||||||
|
- const TimeDuration& aDelay,
|
||||||
|
- const TimeDuration& aEndDelay, float aIterations,
|
||||||
|
- float aIterationStart,
|
||||||
|
- dom::PlaybackDirection aDirection,
|
||||||
|
- dom::FillMode aFillMode,
|
||||||
|
- Maybe<ComputedTimingFunction>&& aFunction)
|
||||||
|
+ TimingParams(const TimeDuration& aDuration, const TimeDuration& aDelay,
|
||||||
|
+ const TimeDuration& aEndDelay, float aIterations,
|
||||||
|
+ float aIterationStart, dom::PlaybackDirection aDirection,
|
||||||
|
+ dom::FillMode aFillMode,
|
||||||
|
+ Maybe<ComputedTimingFunction>&& aFunction)
|
||||||
|
: mDelay(aDelay),
|
||||||
|
mEndDelay(aEndDelay),
|
||||||
|
mIterations(aIterations),
|
||||||
|
|
94
D139078.diff
Normal file
94
D139078.diff
Normal file
@ -0,0 +1,94 @@
|
|||||||
|
diff --git a/gfx/wr/swgl/src/glsl.h b/gfx/wr/swgl/src/glsl.h
|
||||||
|
--- a/gfx/wr/swgl/src/glsl.h
|
||||||
|
+++ b/gfx/wr/swgl/src/glsl.h
|
||||||
|
@@ -2301,20 +2301,12 @@
|
||||||
|
const vec2& operator[](int index) const { return data[index]; }
|
||||||
|
mat2() = default;
|
||||||
|
|
||||||
|
- IMPLICIT mat2(Float a) {
|
||||||
|
- data[0] = vec2(a);
|
||||||
|
- data[1] = vec2(a);
|
||||||
|
- }
|
||||||
|
+ IMPLICIT constexpr mat2(Float a) : data{vec2(a), vec2(a)} {}
|
||||||
|
|
||||||
|
- mat2(vec2 a, vec2 b) {
|
||||||
|
- data[0] = a;
|
||||||
|
- data[1] = b;
|
||||||
|
- }
|
||||||
|
+ constexpr mat2(vec2 a, vec2 b) : data{a, b} {}
|
||||||
|
IMPLICIT mat2(const mat4& mat);
|
||||||
|
- IMPLICIT constexpr mat2(mat2_scalar s) {
|
||||||
|
- data[0] = vec2(s.data[0]);
|
||||||
|
- data[1] = vec2(s.data[1]);
|
||||||
|
- }
|
||||||
|
+ IMPLICIT constexpr mat2(mat2_scalar s)
|
||||||
|
+ : data{vec2(s.data[0]), vec2(s.data[1])} {}
|
||||||
|
|
||||||
|
friend vec2 operator*(mat2 m, vec2 v) {
|
||||||
|
vec2 u;
|
||||||
|
@@ -2404,30 +2396,19 @@
|
||||||
|
vec3& operator[](int index) { return data[index]; }
|
||||||
|
const vec3& operator[](int index) const { return data[index]; }
|
||||||
|
mat3() = default;
|
||||||
|
- mat3(vec3 a, vec3 b, vec3 c) {
|
||||||
|
- data[0] = a;
|
||||||
|
- data[1] = b;
|
||||||
|
- data[2] = c;
|
||||||
|
- }
|
||||||
|
+ constexpr mat3(vec3 a, vec3 b, vec3 c) : data{a, b, c} {}
|
||||||
|
|
||||||
|
- IMPLICIT constexpr mat3(mat3_scalar s) {
|
||||||
|
- data[0] = vec3(s.data[0]);
|
||||||
|
- data[1] = vec3(s.data[1]);
|
||||||
|
- data[2] = vec3(s.data[2]);
|
||||||
|
- }
|
||||||
|
- constexpr mat3(mat3_scalar s0, mat3_scalar s1, mat3_scalar s2,
|
||||||
|
- mat3_scalar s3) {
|
||||||
|
- data[0] = vec3(s0.data[0], s1.data[0], s2.data[0], s3.data[0]);
|
||||||
|
- data[1] = vec3(s0.data[1], s1.data[1], s2.data[1], s3.data[1]);
|
||||||
|
- data[2] = vec3(s0.data[2], s1.data[2], s2.data[2], s3.data[2]);
|
||||||
|
- }
|
||||||
|
+ IMPLICIT constexpr mat3(mat3_scalar s)
|
||||||
|
+ : data{vec3(s.data[0]), vec3(s.data[1]), vec3(s.data[2])} {}
|
||||||
|
+
|
||||||
|
+ constexpr mat3(mat3_scalar s0, mat3_scalar s1, mat3_scalar s2, mat3_scalar s3)
|
||||||
|
+ : data{vec3(s0.data[0], s1.data[0], s2.data[0], s3.data[0]),
|
||||||
|
+ vec3(s0.data[1], s1.data[1], s2.data[1], s3.data[1]),
|
||||||
|
+ vec3(s0.data[2], s1.data[2], s2.data[2], s3.data[2])} {}
|
||||||
|
|
||||||
|
constexpr mat3(Float d1, Float d2, Float d3, Float d4, Float d5, Float d6,
|
||||||
|
- Float d7, Float d8, Float d9) {
|
||||||
|
- data[0] = vec3(d1, d2, d3);
|
||||||
|
- data[1] = vec3(d4, d5, d6);
|
||||||
|
- data[2] = vec3(d7, d8, d9);
|
||||||
|
- }
|
||||||
|
+ Float d7, Float d8, Float d9)
|
||||||
|
+ : data{vec3(d1, d2, d3), vec3(d4, d5, d6), vec3(d7, d8, d9)} {}
|
||||||
|
|
||||||
|
IMPLICIT mat3(const mat4& mat);
|
||||||
|
|
||||||
|
@@ -2597,19 +2578,11 @@
|
||||||
|
vec4 data[4];
|
||||||
|
|
||||||
|
mat4() = default;
|
||||||
|
- IMPLICIT constexpr mat4(mat4_scalar s) {
|
||||||
|
- data[0] = vec4(s.data[0]);
|
||||||
|
- data[1] = vec4(s.data[1]);
|
||||||
|
- data[2] = vec4(s.data[2]);
|
||||||
|
- data[3] = vec4(s.data[3]);
|
||||||
|
- }
|
||||||
|
+ IMPLICIT constexpr mat4(mat4_scalar s)
|
||||||
|
+ : data{vec4(s.data[0]), vec4(s.data[1]), vec4(s.data[2]),
|
||||||
|
+ vec4(s.data[3])} {}
|
||||||
|
|
||||||
|
- mat4(vec4 a, vec4 b, vec4 c, vec4 d) {
|
||||||
|
- data[0] = a;
|
||||||
|
- data[1] = b;
|
||||||
|
- data[2] = c;
|
||||||
|
- data[3] = d;
|
||||||
|
- }
|
||||||
|
+ constexpr mat4(vec4 a, vec4 b, vec4 c, vec4 d) : data{a, b, c, d} {}
|
||||||
|
|
||||||
|
vec4& operator[](int index) { return data[index]; }
|
||||||
|
const vec4& operator[](int index) const { return data[index]; }
|
||||||
|
|
13
D139088.diff
Normal file
13
D139088.diff
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/gfx/wr/swgl/src/gl.cc b/gfx/wr/swgl/src/gl.cc
|
||||||
|
--- a/gfx/wr/swgl/src/gl.cc
|
||||||
|
+++ b/gfx/wr/swgl/src/gl.cc
|
||||||
|
@@ -82,7 +82,7 @@
|
||||||
|
|
||||||
|
#define FALLTHROUGH [[fallthrough]]
|
||||||
|
|
||||||
|
-#ifdef MOZILLA_CLIENT
|
||||||
|
+#if defined(MOZILLA_CLIENT) && defined(MOZ_CLANG_PLUGIN)
|
||||||
|
# define IMPLICIT __attribute__((annotate("moz_implicit")))
|
||||||
|
#else
|
||||||
|
# define IMPLICIT
|
||||||
|
|
19
firefox.spec
19
firefox.spec
@ -162,13 +162,13 @@ ExcludeArch: aarch64
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 97.0
|
Version: 97.0.1
|
||||||
Release: 1%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20220208.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20220218.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
@ -217,7 +217,11 @@ Patch55: firefox-testing.patch
|
|||||||
Patch57: firefox-disable-ffvpx-with-vapi.patch
|
Patch57: firefox-disable-ffvpx-with-vapi.patch
|
||||||
Patch61: firefox-glibc-dynstack.patch
|
Patch61: firefox-glibc-dynstack.patch
|
||||||
Patch62: build-python.patch
|
Patch62: build-python.patch
|
||||||
Patch64: mozilla-1753402.patch
|
#Patch64: mozilla-1753402.patch
|
||||||
|
# GCC12 build fixes
|
||||||
|
Patch65: D139022.diff
|
||||||
|
Patch66: D139078.diff
|
||||||
|
Patch67: D139088.diff
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
# Generate without context by
|
# Generate without context by
|
||||||
@ -457,7 +461,10 @@ This package contains results of tests executed during build.
|
|||||||
%patch54 -p1 -b .1669639
|
%patch54 -p1 -b .1669639
|
||||||
%patch55 -p1 -b .testing
|
%patch55 -p1 -b .testing
|
||||||
%patch57 -p1 -b .ffvpx-with-vapi
|
%patch57 -p1 -b .ffvpx-with-vapi
|
||||||
%patch64 -p1 -b .1753402
|
#%patch64 -p1 -b .1753402
|
||||||
|
%patch65 -p1 -b .D139022
|
||||||
|
%patch66 -p1 -b .D139078
|
||||||
|
%patch67 -p1 -b .D139088
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
%patch100 -p1 -b .firefox-tests-xpcshell
|
%patch100 -p1 -b .firefox-tests-xpcshell
|
||||||
@ -1044,6 +1051,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 18 2022 Martin Stransky <stransky@redhat.com> - 97.0.1-1
|
||||||
|
- Updated to 97.0.1
|
||||||
|
- GCC 12 build fixes
|
||||||
|
|
||||||
* Tue Feb 8 2022 Martin Stransky <stransky@redhat.com> - 97.0-1
|
* Tue Feb 8 2022 Martin Stransky <stransky@redhat.com> - 97.0-1
|
||||||
- Updated to 97.0
|
- Updated to 97.0
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (cbindgen-vendor.tar.xz) = b9ab1498be90ecf60822df7021f8812f124550d97f8cd687c69d3ab56fc5fb714bfe88c78c978a1794d211724909a9a5cad6a4b483fa05f762909c45d5075520
|
SHA512 (cbindgen-vendor.tar.xz) = b9ab1498be90ecf60822df7021f8812f124550d97f8cd687c69d3ab56fc5fb714bfe88c78c978a1794d211724909a9a5cad6a4b483fa05f762909c45d5075520
|
||||||
SHA512 (mochitest-python.tar.gz) = 18e1aeb475df5fbf1fe3838897d5ac2f3114aa349030713fc2be27af087b1b12f57642621b87bd052f324a7cb7fbae5f36b21502191d85692f62c8cdd69c8bf2
|
SHA512 (mochitest-python.tar.gz) = 18e1aeb475df5fbf1fe3838897d5ac2f3114aa349030713fc2be27af087b1b12f57642621b87bd052f324a7cb7fbae5f36b21502191d85692f62c8cdd69c8bf2
|
||||||
SHA512 (firefox-97.0.source.tar.xz) = a913695a42cb06ee9bda2a20e65cc573e40ca93e9f75b7ee0a43ebd1935b371e7e80d5fc8d5f126ad0712ab848635a8624bbeed43807e5c179537aa32c884186
|
SHA512 (firefox-97.0.1.source.tar.xz) = 8620aace77167593aab5acd230860eb3e67eeddc49c0aad0491b5dc20bd0ddb6089dbb8975aed241426f57b2ad772238b04d03b95390175f580cbd80bb6d5f6c
|
||||||
SHA512 (firefox-langpacks-97.0-20220208.tar.xz) = 40c15f6c30566268fbc9c148d70f48bbf9f029b5d13c263e8e97917c96823d6bda552b1fd18e3f778117187c7fe44da0343dfd228bf66648a259e13cb1f94f28
|
SHA512 (firefox-langpacks-97.0.1-20220218.tar.xz) = bb191d08d5bf8b1d375667a019f33a35cc62ce416415ae1213ce392c112b54efde13d0ad2e1d4d7e84943ff1d20249c5970ec0e648067231b28ef13b9fa85306
|
||||||
|
Loading…
Reference in New Issue
Block a user