* Tue Mar 13 2012 Martin Stransky <stransky@redhat.com> - 11.0-1

- Update to 11.0
- Fixed rhbz#800622 - make default home page of fedoraproject.org conditional
- Fixed rhbz#801796 - enable debug build by some simple way
This commit is contained in:
Martin Stransky 2012-03-13 11:15:37 +01:00
parent 5c40b1e753
commit ab8ce9bf19
6 changed files with 108 additions and 42 deletions

2
.gitignore vendored
View File

@ -38,3 +38,5 @@ firefox-3.6.4.source.tar.bz2
/firefox-langpacks-10.0-20120131.tar.xz
/firefox-10.0.1.source.tar.bz2
/firefox-langpacks-10.0.1-20120209.tar.xz
/firefox-11.0.source.tar.bz2
/firefox-langpacks-11.0-20120313.tar.xz

View File

@ -7,10 +7,9 @@ ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
#ac_add_options --with-system-png
ac_add_options --with-system-libvpx
ac_add_options --with-pthreads
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --disable-installer
ac_add_options --enable-xinerama
ac_add_options --enable-default-toolkit=cairo-gtk2

View File

@ -5,11 +5,18 @@
%define separated_plugins 0
%endif
# Build as a debug package?
%define debug_build 0
%if 0%{?fedora}
%define homepage http://start.fedoraproject.org/
%else
%define homepage file:///usr/share/doc/HTML/index.html
%endif
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
%global gecko_version 10.0.1
%global gecko_version 11.0
%global gecko_release 1
%global alpha_version 0
%global beta_version 0
@ -44,14 +51,14 @@
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 10.0.1
Release: 2%{?pre_tag}%{?dist}
Version: 11.0
Release: 1%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
%if %{build_langpacks}
Source1: firefox-langpacks-%{version}%{?pre_version}-20120209.tar.xz
Source1: firefox-langpacks-%{version}%{?pre_version}-20120313.tar.xz
%endif
Source10: firefox-mozconfig
Source11: firefox-mozconfig-branded
@ -69,8 +76,7 @@ Patch14: firefox-5.0-asciidel.patch
Patch15: firefox-8.0-enable-addons.patch
# Upstream patches
# fixes non functional web development tools, obsolete by version 11
Patch100: mozilla-703633.patch
Patch100: mozilla-722127.patch
%if %{official_branding}
# Required by Mozilla Corporation
@ -87,8 +93,6 @@ Patch100: mozilla-703633.patch
BuildRequires: desktop-file-utils
BuildRequires: system-bookmarks
BuildRequires: gecko-devel%{?_isa} = %{gecko_verrel}
# For WebM support
BuildRequires: yasm
Requires: gecko-libs%{?_isa} = %{gecko_verrel}
Requires: system-bookmarks
@ -117,7 +121,7 @@ cd %{tarballdir}
%patch15 -p2 -b .addons
# Upstream patches
%patch100 -p1 -b .703633
%patch100 -p2 -b .722127
%if %{official_branding}
# Required by Mozilla Corporation
@ -148,6 +152,14 @@ echo "ac_add_options --disable-ipc" >> .mozconfig
echo "ac_add_options --disable-elf-hack" >> .mozconfig
%endif
%if %{?debug_build}
echo "ac_add_options --enable-debug" >> .mozconfig
echo "ac_add_options --disable-optimize" >> .mozconfig
%else
echo "ac_add_options --disable-debug" >> .mozconfig
echo "ac_add_options --enable-optimize" >> .mozconfig
%endif
#---------------------------------------------------------------------
%build
@ -160,6 +172,9 @@ cd %{tarballdir}
#
MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | \
%{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
%if %{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')
%endif
export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS=$MOZ_OPT_FLAGS
@ -351,6 +366,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
* Tue Mar 13 2012 Martin Stransky <stransky@redhat.com> - 11.0-1
- Update to 11.0
- Fixed rhbz#800622 - make default home page of fedoraproject.org conditional
- Fixed rhbz#801796 - enable debug build by some simple way
* Mon Feb 27 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 10.0.1-2
- Add ARM config options to fix compile

View File

@ -1,29 +0,0 @@
# HG changeset patch
# User Mike Hommey <mh+mozilla@glandium.org>
# Date 1321637776 -3600
# Node ID a5c78674f5edf4c1cea091ae900e187f4f8ce6a9
# Parent 4a16dc96aab3c56b1dda84e197e1e6c0db8fab6d
Bug 703633 - TreePanel.jsm uses a resource:/// url that ought to be resource://gre/
diff --git a/browser/devtools/highlighter/TreePanel.jsm b/browser/devtools/highlighter/TreePanel.jsm
--- a/browser/devtools/highlighter/TreePanel.jsm
+++ b/browser/devtools/highlighter/TreePanel.jsm
@@ -40,17 +40,17 @@
* the terms of any one of the MPL, the GPL or the LGPL.
*
* ***** END LICENSE BLOCK ***** */
const Cu = Components.utils;
Cu.import("resource:///modules/domplate.jsm");
Cu.import("resource:///modules/InsideOutBox.jsm");
-Cu.import("resource:///modules/Services.jsm");
+Cu.import("resource://gre/modules/Services.jsm");
var EXPORTED_SYMBOLS = ["TreePanel", "DOMHelpers"];
const INSPECTOR_URI = "chrome://browser/content/inspector.html";
/**
* TreePanel
* A container for the Inspector's HTML Tree Panel widget constructor function.

74
mozilla-722127.patch Normal file
View File

@ -0,0 +1,74 @@
diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
--- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
+++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
[MOZ_NATIVE_LIBVPX_DEC_TEST=1],
([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
- dnl We need at least v0.9.7 to fix several crash bugs (for which we
- dnl had local patches prior to v0.9.7).
+ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
+ dnl We need at least v1.0.0 to fix several crash bugs (for which we
+ dnl had local patches prior to v1.0.0).
dnl
dnl This is a terrible test for the library version, but we don't
dnl have a good one. There is no version number in a public header,
dnl and testing the headers still doesn't guarantee we link against
dnl the right version. While we could call vpx_codec_version() at
dnl run-time, that would break cross-compiling. There are no
- dnl additional exported symbols between the v0.9.7 release and the
- dnl v0.9.6 one to check for.
+ dnl additional exported decoder symbols between the v1.0.0 release
+ dnl and the v0.9.7 one to check for.
AC_TRY_COMPILE([
#include <vpx/vpx_decoder.h>
- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
#error "test failed."
#endif
],
@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
[AC_MSG_RESULT([no])
- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
+ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
fi
CFLAGS=$_SAVE_CFLAGS
LDFLAGS=$_SAVE_LDFLAGS
diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
--- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
+++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
@@ -17761,14 +17761,14 @@ else
fi
if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
-echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
+ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
+echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
cat > conftest.$ac_ext <<EOF
#line 17768 "configure"
#include "confdefs.h"
#include <vpx/vpx_decoder.h>
- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
#error "test failed."
#endif
@@ -17791,7 +17791,7 @@ else
cat conftest.$ac_ext >&5
rm -rf conftest*
echo "$ac_t""no" 1>&6
- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
+ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
fi
rm -f conftest*
fi
@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
else
rm -f config/autoconf.mk.orig 2> /dev/null
fi
-

View File

@ -1,2 +1,2 @@
265c53120fd923c742164b0002ebbf6c firefox-10.0.1.source.tar.bz2
5e056b895de281a19d1c8d72e931430a firefox-langpacks-10.0.1-20120209.tar.xz
4b07acf47857aff72776d805409cdd1b firefox-11.0.source.tar.bz2
c47ddb9e66b37a00ad05e0945710a718 firefox-langpacks-11.0-20120313.tar.xz