Update to Firefox 29 build 1
This commit is contained in:
parent
8afde90f0e
commit
ab3d8585f1
2
.gitignore
vendored
2
.gitignore
vendored
@ -96,3 +96,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-27.0.1-20140224.tar.xz
|
||||
/firefox-28.0.source.tar.bz2
|
||||
/firefox-langpacks-28.0-20140318.tar.xz
|
||||
/firefox-29.0.source.tar.bz2
|
||||
/firefox-langpacks-29.0-20140422.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up firefox-21.0/mozilla-release/browser/app/profile/firefox.js.addons firefox-21.0/mozilla-release/browser/app/profile/firefox.js
|
||||
--- firefox-21.0/mozilla-release/browser/app/profile/firefox.js.addons 2013-05-11 21:19:20.000000000 +0200
|
||||
+++ firefox-21.0/mozilla-release/browser/app/profile/firefox.js 2013-05-16 12:02:13.840660585 +0200
|
||||
@@ -61,7 +61,8 @@ pref("extensions.hotfix.certs.1.sha1Fing
|
||||
diff -up firefox-29.0/mozilla-release/browser/app/profile/firefox.js.addons firefox-29.0/mozilla-release/browser/app/profile/firefox.js
|
||||
--- firefox-29.0/mozilla-release/browser/app/profile/firefox.js.addons 2014-04-22 07:27:34.000000000 +0200
|
||||
+++ firefox-29.0/mozilla-release/browser/app/profile/firefox.js 2014-04-22 15:49:04.953173027 +0200
|
||||
@@ -65,7 +65,8 @@ pref("extensions.hotfix.certs.1.sha1Fing
|
||||
|
||||
// Disable add-ons that are not installed by the user in all scopes by default.
|
||||
// See the SCOPE constants in AddonManager.jsm for values to use here.
|
||||
@ -11,18 +11,17 @@ diff -up firefox-21.0/mozilla-release/browser/app/profile/firefox.js.addons fire
|
||||
|
||||
// Dictionary download preference
|
||||
pref("browser.dictionaries.download.url", "https://addons.mozilla.org/%LOCALE%/firefox/dictionaries/");
|
||||
diff -up firefox-21.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm.addons firefox-21.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm
|
||||
diff -up firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm.addons firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm
|
||||
--- firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm.addons 2012-08-15 07:48:32.000000000 +0200
|
||||
+++ firefox-15.0/mozilla-beta/toolkit/mozapps/extensions/XPIProvider.jsm 2012-08-21 11:56:41.441980035 +0200
|
||||
@@ -1630,8 +1630,8 @@ var XPIProvider = {
|
||||
this.showUpgradeUI();
|
||||
flushCaches = true;
|
||||
}
|
||||
- else if (aAppChanged === undefined) {
|
||||
- // For new profiles we will never need to show the add-on selection UI
|
||||
+ else {
|
||||
+ // For all profiles we will never need to show the add-on selection UI
|
||||
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
|
||||
}
|
||||
diff -up firefox-29.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm.addons firefox-29.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm
|
||||
--- firefox-29.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm.addons 2014-04-22 15:49:04.955173021 +0200
|
||||
+++ firefox-29.0/mozilla-release/toolkit/mozapps/extensions/XPIProvider.jsm 2014-04-22 15:50:34.711891888 +0200
|
||||
@@ -2051,8 +2051,8 @@ var XPIProvider = {
|
||||
this.showUpgradeUI();
|
||||
flushCaches = true;
|
||||
}
|
||||
- else if (aAppChanged === undefined) {
|
||||
- // For new profiles we will never need to show the add-on selection UI
|
||||
+ else {
|
||||
+ // For all profiles we will never need to show the add-on selection UI
|
||||
Services.prefs.setBoolPref(PREF_SHOWN_SELECTION_UI, true);
|
||||
}
|
||||
|
||||
|
@ -1,20 +1,12 @@
|
||||
diff -up mozilla-release/config/baseconfig.mk.orig mozilla-release/config/baseconfig.mk
|
||||
--- mozilla-release/config/baseconfig.mk.orig 2013-12-09 15:07:53.357724904 +0100
|
||||
+++ mozilla-release/config/baseconfig.mk 2013-12-09 15:08:35.819797392 +0100
|
||||
@@ -1,6 +1,6 @@
|
||||
diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/mozilla-release/config/baseconfig.mk
|
||||
--- mozilla-release/config/baseconfig.mk.orig 2014-04-22 15:38:52.948165295 +0200
|
||||
+++ mozilla-release/config/baseconfig.mk 2014-04-22 15:42:20.387481673 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
# whether a normal build is happening or whether the check is running.
|
||||
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
DIST = $(DEPTH)/dist
|
||||
|
||||
diff -up mozilla-release/js/src/config/baseconfig.mk.orig mozilla-release/js/src/config/baseconfig.mk
|
||||
--- mozilla-release/js/src/config/baseconfig.mk.orig 2013-12-09 15:07:53.357724904 +0100
|
||||
+++ mozilla-release/js/src/config/baseconfig.mk 2013-12-09 15:09:06.906850462 +0100
|
||||
@@ -1,4 +1,4 @@
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
|
||||
ifneq (,$(filter /%,$(TOP_DIST)))
|
||||
ifndef TOP_DIST
|
||||
TOP_DIST = dist
|
||||
|
@ -89,14 +89,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 28.0
|
||||
Release: 4%{?pre_tag}%{?dist}
|
||||
Version: 29.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20140318.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20140422.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -639,6 +639,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Apr 22 2014 Martin Stransky <stransky@redhat.com> - 29.0-1
|
||||
- Update to 29.0 Build 1
|
||||
|
||||
* Tue Apr 8 2014 Jan Horak <jhorak@redhat.com> - 28.0-4
|
||||
- Support for ppc64le architecture
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
db06b6da6b826cfc6a49c15bca115a6b firefox-28.0.source.tar.bz2
|
||||
6b8a78488747b8949c6d4ff575452319 firefox-langpacks-28.0-20140318.tar.xz
|
||||
07c515fc487824f107a947d23f420e9d firefox-29.0.source.tar.bz2
|
||||
242f4a44dcea9799eaa7234278a6a125 firefox-langpacks-29.0-20140422.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up xulrunner-17.0/mozilla-release/gfx/ycbcr/chromium_types.h.chromium-types xulrunner-17.0/mozilla-release/gfx/ycbcr/chromium_types.h
|
||||
--- xulrunner-17.0/mozilla-release/gfx/ycbcr/chromium_types.h.chromium-types 2012-11-16 20:56:29.000000000 +0100
|
||||
+++ xulrunner-17.0/mozilla-release/gfx/ycbcr/chromium_types.h 2012-11-20 09:19:14.843448418 +0100
|
||||
@@ -30,7 +30,11 @@ typedef int16_t int16;
|
||||
diff -up firefox-29.0/mozilla-release/gfx/ycbcr/chromium_types.h.chromium-types firefox-29.0/mozilla-release/gfx/ycbcr/chromium_types.h
|
||||
--- firefox-29.0/mozilla-release/gfx/ycbcr/chromium_types.h.chromium-types 2014-04-22 07:27:47.000000000 +0200
|
||||
+++ firefox-29.0/mozilla-release/gfx/ycbcr/chromium_types.h 2014-04-22 15:46:24.288677788 +0200
|
||||
@@ -34,7 +34,11 @@ typedef uint32_t uint32;
|
||||
#define ARCH_CPU_ARM_FAMILY 1
|
||||
#define ARCH_CPU_ARMEL 1
|
||||
#define ARCH_CPU_32_BITS 1
|
||||
@ -14,9 +14,9 @@ diff -up xulrunner-17.0/mozilla-release/gfx/ycbcr/chromium_types.h.chromium-type
|
||||
#define ARCH_CPU_PPC_FAMILY 1
|
||||
#define ARCH_CPU_PPC 1
|
||||
#define ARCH_CPU_32_BITS 1
|
||||
@@ -42,6 +46,14 @@ typedef int16_t int16;
|
||||
#define ARCH_CPU_SPARC_FAMILY 1
|
||||
#define ARCH_CPU_SPARC 1
|
||||
@@ -50,6 +54,14 @@ typedef uint32_t uint32;
|
||||
#define ARCH_CPU_AARCH64_FAMILY 1
|
||||
#define ARCH_CPU_AARCH64 1
|
||||
#define ARCH_CPU_64_BITS 1
|
||||
+#elif defined(__s390x__)
|
||||
+#define ARCH_CPU_S390_FAMILY 1
|
||||
|
Loading…
Reference in New Issue
Block a user