- Update to 2.0
- Add patch from Behdad to fix pango printing.
This commit is contained in:
parent
777a1c822a
commit
ab0f13fc20
@ -1,3 +1,2 @@
|
||||
firefox-1.5.0.6-source.tar.bz2
|
||||
firefox-langpacks-1.5.0.6-20060803.tar.bz2
|
||||
add-gecko-provides
|
||||
firefox-2.0-source.tar.bz2
|
||||
firefox-langpacks-2.0-20061024.tar.bz2
|
||||
|
@ -14,19 +14,19 @@ diff -d -u -p -r1.2.4.1 nsGNOMEShellService.h
|
||||
|
||||
NS_DECL_ISUPPORTS
|
||||
NS_DECL_NSISHELLSERVICE
|
||||
Index: browser/components/preferences/general.xul
|
||||
Index: browser/components/preferences/main.xul
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/browser/components/preferences/general.xul,v
|
||||
retrieving revision 1.5
|
||||
diff -d -u -p -r1.5 general.xul
|
||||
--- browser/components/preferences/general.xul 10 Mar 2005 18:43:57 -0000 1.5
|
||||
+++ browser/components/preferences/general.xul 17 Jun 2005 14:25:12 -0000
|
||||
@@ -62,7 +62,7 @@
|
||||
</hbox>
|
||||
RCS file: /cvsroot/mozilla/browser/components/preferences/main.xul,v
|
||||
retrieving revision 1.3.2.6
|
||||
diff -d -u -p -r1.3.2.6 main.xul
|
||||
--- browser/components/preferences/main.xul 13 Sep 2006 03:01:38 -0000 1.3.2.6
|
||||
+++ browser/components/preferences/main.xul 7 Oct 2006 19:58:16 -0000
|
||||
@@ -193,7 +193,7 @@
|
||||
</radiogroup>
|
||||
</groupbox>
|
||||
|
||||
-#ifdef HAVE_SHELL_SERVICE
|
||||
+#if 0
|
||||
<groupbox orient="horizontal">
|
||||
<caption label="&defaultBrowserGroup.label;"/>
|
||||
<hbox align="center" flex="1">
|
||||
<!-- System Defaults -->
|
||||
<groupbox id="systemDefaultsGroup" orient="horizontal">
|
||||
<caption label="&systemDefaults.label;"/>
|
||||
|
@ -1,124 +0,0 @@
|
||||
Index: mozilla/security/coreconf/location.mk
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/coreconf/location.mk,v
|
||||
retrieving revision 1.9
|
||||
diff -u -r1.9 location.mk
|
||||
--- mozilla/security/coreconf/location.mk 25 Apr 2004 15:02:17 -0000 1.9
|
||||
+++ mozilla/security/coreconf/location.mk 11 Apr 2005 20:21:57 -0000
|
||||
@@ -61,6 +61,8 @@
|
||||
|
||||
DIST = $(SOURCE_PREFIX)/$(PLATFORM)
|
||||
|
||||
+NSPR_LIBDIR = $(DIST)/lib
|
||||
+
|
||||
ifdef BUILD_DEBUG_GC
|
||||
DEFINES += -DDEBUG_GC
|
||||
endif
|
||||
Index: mozilla/security/manager/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/manager/Makefile.in,v
|
||||
retrieving revision 1.56
|
||||
diff -u -r1.56 Makefile.in
|
||||
--- mozilla/security/manager/Makefile.in 14 Mar 2005 10:00:58 -0000 1.56
|
||||
+++ mozilla/security/manager/Makefile.in 11 Apr 2005 20:21:57 -0000
|
||||
@@ -76,12 +76,23 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+ABS_DIST := $(shell cd $(DIST) && pwd)
|
||||
+ifeq ($(OS_ARCH),WINNT)
|
||||
+ABS_DIST := $(shell cygpath -w $(ABS_DIST) | sed -e 's|\\\\|/|g')
|
||||
+endif
|
||||
+NSPR_LIBDIR = $(firstword $(filter -L%,$(NSPR_LIBS)))
|
||||
+ifneq (,$(strip $(NSPR_LIBDIR)))
|
||||
+NSPR_LIBDIR := $(subst -L,,$(subst -L$(DIST),-L$(ABS_DIST),$(NSPR_LIBDIR)))
|
||||
+else
|
||||
+NSPR_LIBDIR = $(ABS_DIST)/lib
|
||||
+endif
|
||||
# NSS makefiles are not safe for parallel execution.
|
||||
DEFAULT_GMAKE_FLAGS = MAKE="$(MAKE) -j1" -j1
|
||||
DEFAULT_GMAKE_FLAGS += CC="$(CC)"
|
||||
-DEFAULT_GMAKE_FLAGS += MOZILLA_INCLUDES="-I$(MOZ_BUILD_ROOT)/dist/include/nspr -I$(MOZ_BUILD_ROOT)/dist/include/dbm"
|
||||
-DEFAULT_GMAKE_FLAGS += SOURCE_MD_DIR=$(MOZ_BUILD_ROOT)/dist
|
||||
-DEFAULT_GMAKE_FLAGS += DIST=$(MOZ_BUILD_ROOT)/dist
|
||||
+DEFAULT_GMAKE_FLAGS += MOZILLA_INCLUDES="$(subst -I$(DIST),-I$(ABS_DIST),$(NSPR_CFLAGS) -I$(DIST)/include/dbm)"
|
||||
+DEFAULT_GMAKE_FLAGS += SOURCE_MD_DIR=$(ABS_DIST)
|
||||
+DEFAULT_GMAKE_FLAGS += DIST=$(ABS_DIST)
|
||||
+DEFAULT_GMAKE_FLAGS += NSPR_LIBDIR=$(NSPR_LIBDIR)
|
||||
DEFAULT_GMAKE_FLAGS += MOZILLA_CLIENT=1
|
||||
DEFAULT_GMAKE_FLAGS += NO_MDUPDATE=1
|
||||
ABS_topsrcdir := $(shell cd $(topsrcdir); pwd)
|
||||
Index: mozilla/security/nss/lib/ckfw/builtins/Makefile
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/nss/lib/ckfw/builtins/Makefile,v
|
||||
retrieving revision 1.14
|
||||
diff -u -r1.14 Makefile
|
||||
--- mozilla/security/nss/lib/ckfw/builtins/Makefile 20 Jan 2005 02:25:46 -0000 1.14
|
||||
+++ mozilla/security/nss/lib/ckfw/builtins/Makefile 11 Apr 2005 20:21:57 -0000
|
||||
@@ -53,23 +53,23 @@
|
||||
# This is merely an expedient hack and not the right solution.
|
||||
ifdef NS_USE_GCC
|
||||
EXTRA_LIBS += \
|
||||
- -L$(DIST)/lib \
|
||||
+ -L$(NSPR_LIBDIR) \
|
||||
-lplc4 \
|
||||
-lplds4 \
|
||||
-lnspr4 \
|
||||
$(NULL)
|
||||
else
|
||||
EXTRA_LIBS += \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
$(NULL)
|
||||
endif
|
||||
|
||||
else
|
||||
|
||||
EXTRA_LIBS += \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
$(NULL)
|
||||
|
||||
endif
|
||||
Index: mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile,v
|
||||
retrieving revision 1.18
|
||||
diff -u -r1.18 Makefile
|
||||
--- mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile 25 Apr 2004 15:03:08 -0000 1.18
|
||||
+++ mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile 11 Apr 2005 20:21:57 -0000
|
||||
@@ -63,7 +63,7 @@
|
||||
$(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
|
||||
- -L$(DIST)/lib \
|
||||
+ -L$(NSPR_LIBDIR) \
|
||||
-lplc4 \
|
||||
-lplds4 \
|
||||
-lnspr4 \
|
||||
@@ -76,8 +76,8 @@
|
||||
$(DIST)/lib/softokn.lib \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/secutil.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
wsock32.lib \
|
||||
winmm.lib \
|
||||
$(NULL)
|
||||
@@ -98,8 +98,8 @@
|
||||
$(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
$(NULL)
|
||||
|
||||
endif
|
19
firefox-2.0-link-layout.patch
Normal file
19
firefox-2.0-link-layout.patch
Normal file
@ -0,0 +1,19 @@
|
||||
Index: mozilla/layout/build/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/layout/build/Makefile.in,v
|
||||
retrieving revision 1.127.8.7
|
||||
diff -d -u -p -r1.127.8.7 Makefile.in
|
||||
--- mozilla/layout/build/Makefile.in 17 Jul 2006 19:05:13 -0000 1.127.8.7
|
||||
+++ mozilla/layout/build/Makefile.in 10 Oct 2006 04:29:16 -0000
|
||||
@@ -240,6 +240,11 @@ EXTRA_DSO_LDOPTS += \
|
||||
$(NULL)
|
||||
endif
|
||||
|
||||
+# Add explicit X11 dependency when building against X11 toolkits
|
||||
+ifneq (,$(filter gtk gtk2 qt xlib,$(MOZ_WIDGET_TOOLKIT)))
|
||||
+EXTRA_DSO_LDOPTS += $(XLDFLAGS) $(XLIBS) -lXrender
|
||||
+endif
|
||||
+
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
||||
LOCAL_INCLUDES += -I$(srcdir)/../base \
|
4576
firefox-2.0-pango-printing.patch
Normal file
4576
firefox-2.0-pango-printing.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -2,7 +2,9 @@ pref("app.update.enabled", false);
|
||||
pref("app.update.autoInstallEnabled", false);
|
||||
pref("browser.display.use_system_colors", true);
|
||||
pref("browser.link.open_external", 3);
|
||||
pref("browser.startup.homepage", "chrome://browser-region/locale/region.properties");
|
||||
pref("browser.startup.homepage", "file:///usr/share/doc/HTML/index.html");
|
||||
pref("startup.homepage_override_url", "file:///usr/share/doc/HTML/index.html");
|
||||
pref("startup.homepage_welcome_url, "file:///usr/share/doc/HTML/index.html");
|
||||
pref("general.smoothScroll", true);
|
||||
pref("general.useragent.vendor", "Fedora");
|
||||
pref("general.useragent.vendorSub", "FIREFOX_RPM_VR");
|
||||
|
@ -42,7 +42,7 @@ then
|
||||
MOZ_LIB_DIR="/usr/lib64"
|
||||
fi
|
||||
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox-FIREFOX_VERSION"
|
||||
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox"
|
||||
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox-bin"
|
||||
MOZ_CLIENT_PROGRAM="$MOZ_DIST_BIN/mozilla-xremote-client"
|
||||
MOZ_CLIENT_PROGRAM_PARAM="-a firefox"
|
||||
|
||||
|
49
firefox.spec
49
firefox.spec
@ -10,18 +10,18 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser.
|
||||
Name: firefox
|
||||
Version: 1.5.0.7
|
||||
Release: 7%{?dist}
|
||||
Version: 2.0
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPL/LGPL
|
||||
Group: Applications/Internet
|
||||
%if %{official_branding}
|
||||
%define tarball firefox-%{version}-source.tar.bz2
|
||||
%else
|
||||
%define tarball firefox-1.5rc3-source.tar.bz2
|
||||
%define tarball firefox-2.0rc3-source.tar.bz2
|
||||
%endif
|
||||
Source0: %{tarball}
|
||||
Source2: firefox-langpacks-%{version}-20060911.tar.bz2
|
||||
Source2: firefox-langpacks-%{version}-20061024.tar.bz2
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
Source12: firefox-redhat-default-bookmarks.html
|
||||
@ -35,6 +35,7 @@ Source100: find-external-requires
|
||||
Source101: add-gecko-provides.in
|
||||
|
||||
# build patches
|
||||
Patch1: firefox-2.0-link-layout.patch
|
||||
Patch3: firefox-1.1-nss-system-nspr.patch
|
||||
Patch4: firefox-1.5-with-system-nss.patch
|
||||
Patch5: firefox-1.5-visibility.patch
|
||||
@ -57,6 +58,7 @@ Patch42: firefox-1.1-uriloader.patch
|
||||
Patch81: firefox-1.5-nopangoxft.patch
|
||||
Patch82: firefox-1.5-pango-mathml.patch
|
||||
Patch83: firefox-1.5-pango-cursor-position.patch
|
||||
Patch84: firefox-2.0-pango-printing.patch
|
||||
|
||||
# Other
|
||||
Patch100: firefox-1.5-gtk-key-theme-crash.patch
|
||||
@ -132,11 +134,12 @@ removed in favor of xulrunner-devel.
|
||||
|
||||
%prep
|
||||
%setup -q -n mozilla
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch1 -p1 -b .link-layout
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1
|
||||
%patch5 -p1 -b .visibility
|
||||
|
||||
%patch20 -p0
|
||||
#%patch20 -p0
|
||||
%patch21 -p1
|
||||
%patch22 -p0
|
||||
#%patch23 -p0
|
||||
@ -147,10 +150,11 @@ removed in favor of xulrunner-devel.
|
||||
%patch40 -p1
|
||||
%patch42 -p0
|
||||
%patch81 -p1
|
||||
%patch82 -p1
|
||||
#%patch82 -p1
|
||||
%patch83 -p1
|
||||
%patch84 -p0
|
||||
|
||||
%patch100 -p0 -b .gtk-key-theme-crash
|
||||
#%patch100 -p0 -b .gtk-key-theme-crash
|
||||
%patch101 -p0 -b .embedwindow-visibility
|
||||
%patch102 -p0 -b .theme-change
|
||||
|
||||
@ -199,17 +203,10 @@ make -f client.mk build
|
||||
%install
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
|
||||
cd browser/installer
|
||||
%{__make} STRIP=/bin/true
|
||||
cd -
|
||||
DESTDIR=$RPM_BUILD_ROOT make install
|
||||
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
|
||||
|
||||
%{__tar} -C $RPM_BUILD_ROOT%{_libdir}/ -xzf dist/%{name}-*linux*.tar.gz
|
||||
%{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name} $RPM_BUILD_ROOT%{mozappdir}
|
||||
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}-*linux*.tar
|
||||
|
||||
%{__install} -p -D %{SOURCE22} $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
|
||||
|
||||
desktop-file-install --vendor mozilla \
|
||||
@ -317,7 +314,10 @@ EOF
|
||||
GECKO_VERSION=$(./config/milestone.pl --topsrcdir='.')
|
||||
%{__cat} %{SOURCE101} | %{__sed} -e "s/@GECKO_VERSION@/$GECKO_VERSION/g" > \
|
||||
%{_builddir}/add-gecko-provides
|
||||
chmod +x %{_builddir}/add-gecko-provides
|
||||
chmod 700 %{_builddir}/add-gecko-provides
|
||||
|
||||
# Copy over the LICENSE
|
||||
install -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
|
||||
|
||||
# ghost files
|
||||
touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
|
||||
@ -346,6 +346,7 @@ fi
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/firefox
|
||||
%exclude %{_bindir}/firefox-config
|
||||
%{_mandir}/man1/*
|
||||
%{_datadir}/applications/mozilla-%{name}.desktop
|
||||
%{_datadir}/pixmaps/firefox.png
|
||||
@ -355,9 +356,10 @@ fi
|
||||
|
||||
%dir %{mozappdir}
|
||||
%{mozappdir}/LICENSE
|
||||
%{mozappdir}/README.txt
|
||||
%{mozappdir}/*.properties
|
||||
%{mozappdir}/chrome
|
||||
%{mozappdir}/chrome.manifest
|
||||
%{mozappdir}/dictionaries
|
||||
%dir %{mozappdir}/components
|
||||
%ghost %{mozappdir}/components/compreg.dat
|
||||
%ghost %{mozappdir}/components/xpti.dat
|
||||
@ -373,21 +375,20 @@ fi
|
||||
%{mozappdir}/res
|
||||
%{mozappdir}/searchplugins
|
||||
%{mozappdir}/*.so
|
||||
%{mozappdir}/firefox
|
||||
%{mozappdir}/firefox-bin
|
||||
%{mozappdir}/firefox-xremote-client
|
||||
%{mozappdir}/mozilla-xremote-client
|
||||
%{mozappdir}/run-mozilla.sh
|
||||
%{mozappdir}/regxpcom
|
||||
# XXX See if these are needed still
|
||||
%{mozappdir}/dependentlibs.list
|
||||
%{mozappdir}/updater*
|
||||
%{mozappdir}/removed-files
|
||||
|
||||
%if %{build_devel_package}
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/idl/firefox-%{version}
|
||||
%{_includedir}/firefox-%{version}
|
||||
%{mozappdir}/TestGtkEmbed
|
||||
%{mozappdir}/xpcshell
|
||||
%{mozappdir}/xpicleanup
|
||||
%{mozappdir}/xpidl
|
||||
@ -404,6 +405,10 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Oct 24 2006 Christopher Aillon <caillon@redhat.com> 2.0-1
|
||||
- Update to 2.0
|
||||
- Add patch from Behdad to fix pango printing.
|
||||
|
||||
* Wed Oct 11 2006 Christopher Aillon <caillon@redhat.com> 1.5.0.7-7
|
||||
- Add virtual provides for gecko applications.
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
e013df5f64d05cc968555a731cf2b63e firefox-1.5.0.7-source.tar.bz2
|
||||
207acc3c039519c774177b07422909f1 firefox-langpacks-1.5.0.7-20060911.tar.bz2
|
||||
03709c15cba0e0375ff5336d538f77e7 firefox-2.0-source.tar.bz2
|
||||
b64f5d03177f15613bdd113a3fa8be91 firefox-langpacks-2.0-20061024.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user