Update to 51.0 (B1)
This commit is contained in:
parent
b2b845f7ba
commit
a25c5d4d7c
2
.gitignore
vendored
2
.gitignore
vendored
@ -218,3 +218,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-50.0.2-20161130.tar.xz
|
||||
/firefox-50.1.0.source.tar.xz
|
||||
/firefox-langpacks-50.1.0-20161213.tar.xz
|
||||
/firefox-51.0.source.tar.xz
|
||||
/firefox-langpacks-51.0-20170118.tar.xz
|
||||
|
17
firefox.spec
17
firefox.spec
@ -93,14 +93,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 50.1.0
|
||||
Release: 4%{?pre_tag}%{?dist}
|
||||
Version: 51.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20161213.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20170118.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -137,9 +137,7 @@ Patch402: mozilla-1196777.patch
|
||||
Patch406: mozilla-256180.patch
|
||||
# Rebase Gtk3 widget code to latest trunk to
|
||||
# fix various rendering problems
|
||||
Patch407: widget-rebase.patch
|
||||
Patch408: mozilla-1290037.patch
|
||||
Patch409: mozilla-1329272.patch
|
||||
#Patch407: widget-rebase.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -281,9 +279,7 @@ cd %{tarballdir}
|
||||
%patch406 -p1 -b .256180
|
||||
# Rebase Gtk3 widget code to latest trunk to
|
||||
# fix various rendering problems
|
||||
%patch407 -p1 -b .widget-rebase
|
||||
%patch408 -p1 -b .1290037
|
||||
%patch409 -p1 -b .1329272
|
||||
#%patch407 -p1 -b .widget-rebase
|
||||
|
||||
# Debian extension patch
|
||||
%patch500 -p1 -b .440908
|
||||
@ -792,6 +788,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Wed Jan 18 2017 Martin Stransky <stransky@redhat.com> - 51.0-1
|
||||
- Update to 51.0 (B1)
|
||||
|
||||
* Tue Jan 17 2017 Jan Horak <jhorak@redhat.com> - 50.1.0-4
|
||||
- Enable telemetry (rhbz#1412971)
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up firefox-48.0.1/toolkit/mozapps/extensions/internal/XPIProvider.jsm.mydebug firefox-48.0.1/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
--- firefox-48.0.1/toolkit/mozapps/extensions/internal/XPIProvider.jsm.mydebug 2016-08-15 23:35:40.000000000 +0200
|
||||
+++ firefox-48.0.1/toolkit/mozapps/extensions/internal/XPIProvider.jsm 2016-09-21 16:08:04.441220821 +0200
|
||||
@@ -2724,6 +2724,11 @@ this.XPIProvider = {
|
||||
diff -up firefox-51.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm.1005640-accept-lang firefox-51.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
--- firefox-51.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm.1005640-accept-lang 2017-01-16 17:16:52.000000000 +0100
|
||||
+++ firefox-51.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm 2017-01-18 12:35:29.380394216 +0100
|
||||
@@ -2852,6 +2852,11 @@ this.XPIProvider = {
|
||||
this.addAddonsToCrashReporter();
|
||||
}
|
||||
|
||||
@ -12,8 +12,8 @@ diff -up firefox-48.0.1/toolkit/mozapps/extensions/internal/XPIProvider.jsm.myde
|
||||
+
|
||||
try {
|
||||
AddonManagerPrivate.recordTimestamp("XPI_bootstrap_addons_begin");
|
||||
for (let id in this.bootstrappedAddons) {
|
||||
@@ -2751,6 +2756,14 @@ this.XPIProvider = {
|
||||
|
||||
@@ -2880,6 +2885,14 @@ this.XPIProvider = {
|
||||
AddonManagerPrivate.recordException("XPI-BOOTSTRAP", "startup failed", e);
|
||||
}
|
||||
|
||||
|
@ -1,34 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Franziskus Kiefer <franziskuskiefer@gmail.com>
|
||||
# Date 1469717280 -7200
|
||||
# Thu Jul 28 16:48:00 2016 +0200
|
||||
# Node ID 95aa61f1e3562e526bf88179d9d078fd90ad1bda
|
||||
# Parent d42aacfe34af25e2f5110e2ca3d24a210eabeb33
|
||||
Update keybits in H2, r=mt
|
||||
|
||||
MozReview-Commit-ID: 35oWoDMqe1Y
|
||||
|
||||
diff --git a/netwerk/protocol/http/Http2Session.cpp b/netwerk/protocol/http/Http2Session.cpp
|
||||
--- a/netwerk/protocol/http/Http2Session.cpp
|
||||
+++ b/netwerk/protocol/http/Http2Session.cpp
|
||||
@@ -3544,18 +3544,18 @@ Http2Session::ConfirmTLSProfile()
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
uint32_t keybits = ssl->GetKEAKeyBits();
|
||||
if (kea == ssl_kea_dh && keybits < 2048) {
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
|
||||
- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
|
||||
+ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
|
||||
+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
int16_t macAlgorithm = ssl->GetMACAlgorithmUsed();
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p MAC Algortihm (aead==6) %d\n",
|
||||
this, macAlgorithm));
|
||||
if (macAlgorithm != nsISSLSocketControl::SSL_MAC_AEAD) {
|
@ -1,29 +0,0 @@
|
||||
From 66fc64a75617ffc68f16780f60e39c1f368dfd41 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Stenberg <daniel@haxx.se>
|
||||
Date: Mon, 9 Jan 2017 14:37:33 +0100
|
||||
Subject: [PATCH] bug 1329272: add bracket for sed 4.3 compliance, r=glandium
|
||||
|
||||
---
|
||||
build/autoconf/icu.m4 | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
|
||||
index 4f46345f435a..794ddcdf4e52 100644
|
||||
--- a/build/autoconf/icu.m4
|
||||
+++ b/build/autoconf/icu.m4
|
||||
@@ -67,11 +67,11 @@ if test -n "$USE_ICU"; then
|
||||
if test ! -d "$icudir"; then
|
||||
AC_MSG_ERROR([Cannot find the ICU directory])
|
||||
fi
|
||||
fi
|
||||
|
||||
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
if test x"$version" = x; then
|
||||
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
|
||||
fi
|
||||
MOZ_ICU_VERSION="$version"
|
||||
|
||||
--
|
||||
2.11.0
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (firefox-50.1.0.source.tar.xz) = 370d2e9b8c4b1b59c3394659c3a7f0f79e6a911ccd9f32095b50b3a22d087132b1f7cb87b734f7497c4381b1df6df80d120b4b87c13eecc425cc66f56acccba5
|
||||
SHA512 (firefox-langpacks-50.1.0-20161213.tar.xz) = 0d3b70079255bacaef11c38604ea6cd049b74e4db321c0b0bf9f75f8579c97dc2d8dc0d3655143a71a21b6875e2e3f2c70a74cb14abc7fb4d58e7e7587cc36dc
|
||||
SHA512 (firefox-51.0.source.tar.xz) = fbb80ee0fd425a9b3715c39d207aaaee5712b1d4274fa95479fefe8497ee871bef3566c9d604165cee4497d7f7032364477771808b7deb37b9020673bb6f60d2
|
||||
SHA512 (firefox-langpacks-51.0-20170118.tar.xz) = 5daac462218a7df2d6098f71484b4cccf8eafa98a9f05f6df522112db160bb0e51106057a6b6ab1e115c6881651b8af6c14ae7d888fa91a66e2ca313bf06991d
|
||||
|
Loading…
Reference in New Issue
Block a user