Update to 33.0
This commit is contained in:
parent
1c41bbe557
commit
a212ee70d4
2
.gitignore
vendored
2
.gitignore
vendored
@ -110,3 +110,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-32.0.1-20140915.tar.xz
|
/firefox-langpacks-32.0.1-20140915.tar.xz
|
||||||
/firefox-32.0.2.source.tar.bz2
|
/firefox-32.0.2.source.tar.bz2
|
||||||
/firefox-langpacks-32.0.2-20140918.tar.xz
|
/firefox-langpacks-32.0.2-20140918.tar.xz
|
||||||
|
/firefox-langpacks-33.0-20141014.tar.xz
|
||||||
|
/firefox-33.0.source.tar.bz2
|
||||||
|
14
firefox.spec
14
firefox.spec
@ -92,14 +92,14 @@
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 32.0.2
|
Version: 33.0
|
||||||
Release: 2%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20140918.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20141014.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source11: firefox-mozconfig-branded
|
Source11: firefox-mozconfig-branded
|
||||||
@ -117,8 +117,6 @@ Patch3: mozilla-build-arm.patch
|
|||||||
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
||||||
# workaround linking issue on s390 (JSContext::updateMallocCounter(size_t) not found)
|
# workaround linking issue on s390 (JSContext::updateMallocCounter(size_t) not found)
|
||||||
Patch19: xulrunner-24.0-s390-inlines.patch
|
Patch19: xulrunner-24.0-s390-inlines.patch
|
||||||
# backport js/src/configure.in changes for secondary arches
|
|
||||||
Patch20: xulrunner-32.0-backport-js-src-configure-in.patch
|
|
||||||
|
|
||||||
# Fedora specific patches
|
# Fedora specific patches
|
||||||
# Unable to install addons from https pages
|
# Unable to install addons from https pages
|
||||||
@ -251,12 +249,11 @@ cd %{tarballdir}
|
|||||||
%endif
|
%endif
|
||||||
%patch18 -p2 -b .jemalloc-ppc
|
%patch18 -p2 -b .jemalloc-ppc
|
||||||
%patch19 -p2 -b .s390-inlines
|
%patch19 -p2 -b .s390-inlines
|
||||||
%patch20 -p2 -b .js-configure
|
|
||||||
|
|
||||||
# For branding specific patches.
|
# For branding specific patches.
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch204 -p1 -b .966424
|
%patch204 -p2 -b .966424
|
||||||
%patch215 -p1 -b .addons
|
%patch215 -p1 -b .addons
|
||||||
%patch216 -p1 -b .duckduckgo
|
%patch216 -p1 -b .duckduckgo
|
||||||
# disable baseline JIT on i686 (rhbz#1047079)
|
# disable baseline JIT on i686 (rhbz#1047079)
|
||||||
@ -711,6 +708,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 14 2014 Martin Stransky <stransky@redhat.com> - 33.0-1
|
||||||
|
- Update to 33.0 build 2
|
||||||
|
|
||||||
* Fri Sep 19 2014 Jan Horak <jhorak@redhat.com> - 32.0.2-2
|
* Fri Sep 19 2014 Jan Horak <jhorak@redhat.com> - 32.0.2-2
|
||||||
- Added support for Mozilla tests
|
- Added support for Mozilla tests
|
||||||
|
|
||||||
|
@ -1,11 +1,7 @@
|
|||||||
--- a/toolkit/modules/CertUtils.jsm
|
diff -up firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm.966424 firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm
|
||||||
+++ b/toolkit/modules/CertUtils.jsm
|
--- firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm.966424 2014-10-14 08:12:14.358697255 +0200
|
||||||
@@ -170,17 +170,19 @@ this.checkCert =
|
+++ firefox-33.0/mozilla-release/toolkit/modules/CertUtils.jsm 2014-10-14 08:17:59.962181908 +0200
|
||||||
issuerCert = issuerCert.QueryInterface(Ci.nsIX509Cert3);
|
@@ -174,7 +174,9 @@ this.checkCert =
|
||||||
var tokenNames = issuerCert.getAllTokenNames({});
|
|
||||||
|
|
||||||
if (!tokenNames || !tokenNames.some(isBuiltinToken))
|
|
||||||
throw new Ce(certNotBuiltInErr, Cr.NS_ERROR_ABORT);
|
|
||||||
}
|
}
|
||||||
|
|
||||||
function isBuiltinToken(tokenName) {
|
function isBuiltinToken(tokenName) {
|
||||||
@ -16,8 +12,3 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/**
|
/**
|
||||||
* This class implements nsIBadCertListener. Its job is to prevent "bad cert"
|
|
||||||
* security dialogs from being shown to the user. It is better to simply fail
|
|
||||||
* if the certificate is bad. See bug 304286.
|
|
||||||
*
|
|
||||||
* @param aAllowNonBuiltInCerts (optional)
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
4e2d215627cbeba9d526de872dd7b3ee firefox-32.0.2.source.tar.bz2
|
a3d44b545ad9c28183b24ae1675eb99b firefox-langpacks-33.0-20141014.tar.xz
|
||||||
1965782459e16d34a9d5c6e574de98c0 firefox-langpacks-32.0.2-20140918.tar.xz
|
b0e793898bddf4f2bc46e42a331f3383 firefox-33.0.source.tar.bz2
|
||||||
|
@ -1,92 +0,0 @@
|
|||||||
#Based on:
|
|
||||||
#https://hg.mozilla.org/mozilla-central/rev/57852745f33b
|
|
||||||
#https://hg.mozilla.org/mozilla-central/rev/926f47807112
|
|
||||||
#https://hg.mozilla.org/mozilla-central/rev/a7b832e15a34
|
|
||||||
--- firefox-32.0/mozilla-release/js/src/configure.in 2014-08-26 05:37:57.000000000 +0200
|
|
||||||
+++ configure.in 2014-09-12 09:30:32.252623444 +0200
|
|
||||||
@@ -1313,10 +1316,10 @@
|
|
||||||
result="yes", result="no")
|
|
||||||
AC_MSG_RESULT("$result")
|
|
||||||
if test "$result" = "yes"; then
|
|
||||||
- AC_DEFINE(HAVE_64BIT_OS)
|
|
||||||
- HAVE_64BIT_OS=1
|
|
||||||
+ AC_DEFINE(HAVE_64BIT_BUILD)
|
|
||||||
+ HAVE_64BIT_BUILD=1
|
|
||||||
fi
|
|
||||||
-AC_SUBST(HAVE_64BIT_OS)
|
|
||||||
+AC_SUBST(HAVE_64BIT_BUILD)
|
|
||||||
AC_LANG_RESTORE
|
|
||||||
fi # COMPILE_ENVIRONMENT
|
|
||||||
|
|
||||||
@@ -1404,7 +1407,7 @@
|
|
||||||
*-aix*)
|
|
||||||
AC_DEFINE(AIX)
|
|
||||||
if test ! "$GNU_CC"; then
|
|
||||||
- if test ! "$HAVE_64BIT_OS"; then
|
|
||||||
+ if test ! "$HAVE_64BIT_BUILD"; then
|
|
||||||
# Compiling with Visual Age C++ object model compat is the
|
|
||||||
# default. To compile with object model ibm, add
|
|
||||||
# AIX_OBJMODEL=ibm to .mozconfig.
|
|
||||||
@@ -1748,7 +1763,7 @@
|
|
||||||
|
|
||||||
case "$target" in
|
|
||||||
i*86-*)
|
|
||||||
- if test "$HAVE_64BIT_OS"; then
|
|
||||||
+ if test "$HAVE_64BIT_BUILD"; then
|
|
||||||
AC_MSG_ERROR([You are targeting i386 but using the 64-bit compiler.])
|
|
||||||
fi
|
|
||||||
|
|
||||||
@@ -1983,39 +1998,34 @@
|
|
||||||
i?86-*)
|
|
||||||
ENABLE_ION=1
|
|
||||||
AC_DEFINE(JS_CPU_X86)
|
|
||||||
- AC_DEFINE(JS_NUNBOX32)
|
|
||||||
;;
|
|
||||||
x86_64*-*)
|
|
||||||
ENABLE_ION=1
|
|
||||||
AC_DEFINE(JS_CPU_X64)
|
|
||||||
- AC_DEFINE(JS_PUNBOX64)
|
|
||||||
;;
|
|
||||||
arm*-*)
|
|
||||||
ENABLE_ION=1
|
|
||||||
AC_DEFINE(JS_CPU_ARM)
|
|
||||||
- AC_DEFINE(JS_NUNBOX32)
|
|
||||||
;;
|
|
||||||
-sparc*-*)
|
|
||||||
- if test ! "$HAVE_64BIT_OS" ; then
|
|
||||||
+sparc-*)
|
|
||||||
dnl ENABLE_ION=0
|
|
||||||
AC_DEFINE(JS_CPU_SPARC)
|
|
||||||
- AC_DEFINE(JS_NUNBOX32)
|
|
||||||
- else
|
|
||||||
- AC_DEFINE(JS_CPU_SPARC64)
|
|
||||||
- AC_DEFINE(JS_PUNBOX64)
|
|
||||||
- fi
|
|
||||||
- ;;
|
|
||||||
-powerpc64-*)
|
|
||||||
- AC_DEFINE(JS_CPU_PPC64)
|
|
||||||
- AC_DEFINE(JS_PUNBOX64)
|
|
||||||
- ;;
|
|
||||||
-powerpc-*)
|
|
||||||
- AC_DEFINE(JS_CPU_PPC)
|
|
||||||
- AC_DEFINE(JS_NUNBOX32)
|
|
||||||
;;
|
|
||||||
mips*-*)
|
|
||||||
AC_DEFINE(JS_CPU_MIPS)
|
|
||||||
- AC_DEFINE(JS_NUNBOX32)
|
|
||||||
+ ;;
|
|
||||||
+esac
|
|
||||||
+
|
|
||||||
+case "$target" in
|
|
||||||
+mips*-*)
|
|
||||||
+ AC_DEFINE(JS_NUNBOX32)
|
|
||||||
+ ;;
|
|
||||||
+*)
|
|
||||||
+ if test "$HAVE_64BIT_BUILD" ; then
|
|
||||||
+ AC_DEFINE(JS_PUNBOX64)
|
|
||||||
+ else
|
|
||||||
+ AC_DEFINE(JS_NUNBOX32)
|
|
||||||
+ fi
|
|
||||||
;;
|
|
||||||
esac
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user