Gtk3 - Workaround for Firefox freeze when accessibility is enabled
This commit is contained in:
parent
02e8ef68f3
commit
983d5dbd18
14
firefox-gtk3-atk.patch
Normal file
14
firefox-gtk3-atk.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up firefox-34.0/mozilla-release/accessible/atk/Platform.cpp.old firefox-34.0/mozilla-release/accessible/atk/Platform.cpp
|
||||||
|
--- firefox-34.0/mozilla-release/accessible/atk/Platform.cpp.old 2014-11-26 03:17:05.000000000 +0100
|
||||||
|
+++ firefox-34.0/mozilla-release/accessible/atk/Platform.cpp 2014-12-13 17:40:29.414539391 +0100
|
||||||
|
@@ -276,6 +276,9 @@ dbus_done:
|
||||||
|
bool
|
||||||
|
a11y::ShouldA11yBeEnabled()
|
||||||
|
{
|
||||||
|
+ // Temporary disable for Gtk3
|
||||||
|
+ return false;
|
||||||
|
+
|
||||||
|
static bool sChecked = false, sShouldEnable = false;
|
||||||
|
if (sChecked)
|
||||||
|
return sShouldEnable;
|
||||||
|
diff -up firefox-34.0/mozilla-release/media/webrtc/trunk/Makefile.old firefox-34.0/mozilla-release/media/webrtc/trunk/Makefile
|
@ -113,7 +113,7 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 34.0
|
Version: 34.0
|
||||||
Release: 7%{?pre_tag}%{?dist}
|
Release: 8%{?pre_tag}%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -158,6 +158,7 @@ Patch404: mozilla-1101582.patch
|
|||||||
Patch405: mozilla-1073117-check.patch
|
Patch405: mozilla-1073117-check.patch
|
||||||
Patch406: mozilla-1073117-color.patch
|
Patch406: mozilla-1073117-color.patch
|
||||||
Patch407: mozilla-1097592.patch
|
Patch407: mozilla-1097592.patch
|
||||||
|
Patch408: firefox-gtk3-atk.patch
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
# Required by Mozilla Corporation
|
# Required by Mozilla Corporation
|
||||||
@ -312,6 +313,7 @@ cd %{tarballdir}
|
|||||||
%patch405 -p1 -b .1073117-check
|
%patch405 -p1 -b .1073117-check
|
||||||
%patch406 -p1 -b .1073117-color
|
%patch406 -p1 -b .1073117-color
|
||||||
%patch407 -p1 -b .1097592
|
%patch407 -p1 -b .1097592
|
||||||
|
%patch408 -p2 -b .gtk3
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{official_branding}
|
%if %{official_branding}
|
||||||
@ -775,6 +777,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 13 2014 Martin Stransky <stransky@redhat.com> - 34.0-8
|
||||||
|
- Gtk3 - Workaround for Firefox freeze when accessibility is enabled
|
||||||
|
|
||||||
* Fri Dec 12 2014 Martin Stransky <stransky@redhat.com> - 34.0-7
|
* Fri Dec 12 2014 Martin Stransky <stransky@redhat.com> - 34.0-7
|
||||||
- Added fix for mozbz#1097592 - Firefox freeze in Gtk3
|
- Added fix for mozbz#1097592 - Firefox freeze in Gtk3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user