Updated to 109.0
This commit is contained in:
parent
8bed0f2480
commit
916853162b
58
D163310.diff
58
D163310.diff
@ -1,58 +0,0 @@
|
|||||||
diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
|
|
||||||
--- a/widget/gtk/nsWindow.cpp
|
|
||||||
+++ b/widget/gtk/nsWindow.cpp
|
|
||||||
@@ -3029,11 +3029,11 @@
|
|
||||||
#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
void nsWindow::SetUserTimeAndStartupTokenForActivatedWindow() {
|
|
||||||
nsGTKToolkit* toolkit = nsGTKToolkit::GetToolkit();
|
|
||||||
- if (!toolkit) {
|
|
||||||
+ if (!toolkit || MOZ_UNLIKELY(mWindowType == eWindowType_invisible)) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
mWindowActivationTokenFromEnv = toolkit->GetStartupToken();
|
|
||||||
if (!mWindowActivationTokenFromEnv.IsEmpty()) {
|
|
||||||
@@ -6614,30 +6614,34 @@
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
// Set up usertime/startupID metadata for the created window.
|
|
||||||
- if (mWindowType != eWindowType_invisible) {
|
|
||||||
+ // On X11 we use gtk_window_set_startup_id() so we need to call it
|
|
||||||
+ // before show.
|
|
||||||
+ if (GdkIsX11Display()) {
|
|
||||||
SetUserTimeAndStartupTokenForActivatedWindow();
|
|
||||||
}
|
|
||||||
if (GdkIsWaylandDisplay()) {
|
|
||||||
if (IsWaylandPopup()) {
|
|
||||||
ShowWaylandPopupWindow();
|
|
||||||
} else {
|
|
||||||
ShowWaylandToplevelWindow();
|
|
||||||
}
|
|
||||||
+ } else {
|
|
||||||
+ LOG(" calling gtk_widget_show(mShell)\n");
|
|
||||||
+ gtk_widget_show(mShell);
|
|
||||||
+ }
|
|
||||||
+ if (GdkIsWaylandDisplay()) {
|
|
||||||
+ SetUserTimeAndStartupTokenForActivatedWindow();
|
|
||||||
#ifdef MOZ_WAYLAND
|
|
||||||
auto token = std::move(mWindowActivationTokenFromEnv);
|
|
||||||
if (!token.IsEmpty()) {
|
|
||||||
FocusWaylandWindow(token.get());
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
- } else {
|
|
||||||
- LOG(" calling gtk_widget_show(mShell)\n");
|
|
||||||
- gtk_widget_show(mShell);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
+ }
|
|
||||||
if (mHiddenPopupPositioned && IsPopup()) {
|
|
||||||
LOG(" re-position hidden popup window");
|
|
||||||
gtk_window_move(GTK_WINDOW(mShell), mPopupPosition.x, mPopupPosition.y);
|
|
||||||
mHiddenPopupPositioned = false;
|
|
||||||
}
|
|
||||||
|
|
55
D163696.diff
55
D163696.diff
@ -1,55 +0,0 @@
|
|||||||
diff --git a/widget/gtk/GtkCompositorWidget.cpp b/widget/gtk/GtkCompositorWidget.cpp
|
|
||||||
--- a/widget/gtk/GtkCompositorWidget.cpp
|
|
||||||
+++ b/widget/gtk/GtkCompositorWidget.cpp
|
|
||||||
@@ -19,13 +19,14 @@
|
|
||||||
# include "mozilla/layers/NativeLayerWayland.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#ifdef MOZ_LOGGING
|
|
||||||
# undef LOG
|
|
||||||
-# define LOG(...) \
|
|
||||||
+# define LOG(str, ...) \
|
|
||||||
MOZ_LOG(IsPopup() ? gWidgetPopupLog : gWidgetLog, \
|
|
||||||
- mozilla::LogLevel::Debug, (__VA_ARGS__))
|
|
||||||
+ mozilla::LogLevel::Debug, \
|
|
||||||
+ ("[%p]: " str, mWidget.get(), ##__VA_ARGS__))
|
|
||||||
#endif /* MOZ_LOGGING */
|
|
||||||
|
|
||||||
namespace mozilla {
|
|
||||||
namespace widget {
|
|
||||||
|
|
||||||
@@ -92,10 +93,13 @@
|
|
||||||
|
|
||||||
nsIWidget* GtkCompositorWidget::RealWidget() { return mWidget; }
|
|
||||||
|
|
||||||
void GtkCompositorWidget::NotifyClientSizeChanged(
|
|
||||||
const LayoutDeviceIntSize& aClientSize) {
|
|
||||||
+ LOG("GtkCompositorWidget::NotifyClientSizeChanged() to %d x %d",
|
|
||||||
+ aClientSize.width, aClientSize.height);
|
|
||||||
+
|
|
||||||
auto size = mClientSize.Lock();
|
|
||||||
*size = aClientSize;
|
|
||||||
}
|
|
||||||
|
|
||||||
LayoutDeviceIntSize GtkCompositorWidget::GetClientSize() {
|
|
||||||
@@ -107,14 +111,19 @@
|
|
||||||
const LayoutDeviceRect& aSize) {
|
|
||||||
if (!mWidget || !mWidget->IsWaitingForCompositorResume()) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ LOG("GtkCompositorWidget::RemoteLayoutSizeUpdated() %d x %d",
|
|
||||||
+ (int)aSize.width, (int)aSize.height);
|
|
||||||
+
|
|
||||||
// We're waiting for layout to match widget size.
|
|
||||||
auto clientSize = mClientSize.Lock();
|
|
||||||
if (clientSize->width != (int)aSize.width ||
|
|
||||||
clientSize->height != (int)aSize.height) {
|
|
||||||
+ LOG("quit, client size doesn't match (%d x %d)", clientSize->width,
|
|
||||||
+ clientSize->height);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
mWidget->ResumeCompositorFromCompositorThread();
|
|
||||||
}
|
|
||||||
|
|
28
D163697.diff
28
D163697.diff
@ -1,28 +0,0 @@
|
|||||||
diff --git a/widget/gtk/ScreenHelperGTK.cpp b/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
--- a/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
+++ b/widget/gtk/ScreenHelperGTK.cpp
|
|
||||||
@@ -433,19 +433,21 @@
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
GdkRectangle workArea;
|
|
||||||
if (!GdkMonitorGetWorkarea(monitor, &workArea)) {
|
|
||||||
+ LOG_SCREEN(" failed, can't get work area");
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
for (unsigned int i = 0; i < mMonitors.Length(); i++) {
|
|
||||||
// Although Gtk/Mutter is very creative in reporting various screens sizes
|
|
||||||
// we can rely on Gtk work area start position to match wl_output.
|
|
||||||
if (mMonitors[i]->x == workArea.x && mMonitors[i]->y == workArea.y) {
|
|
||||||
- LOG_SCREEN(" monitor %d values %d %d -> %d x %d", i, mMonitors[i]->x,
|
|
||||||
- mMonitors[i]->y, mMonitors[i]->width, mMonitors[i]->height);
|
|
||||||
+ LOG_SCREEN(" monitor %d work area [%d, %d] -> (%d x %d) scale %d", i,
|
|
||||||
+ mMonitors[i]->x, mMonitors[i]->y, mMonitors[i]->width,
|
|
||||||
+ mMonitors[i]->height, mMonitors[i]->scale);
|
|
||||||
return i;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
return -1;
|
|
||||||
|
|
315
D163698.diff
315
D163698.diff
@ -1,315 +0,0 @@
|
|||||||
diff --git a/widget/gtk/MozContainerWayland.h b/widget/gtk/MozContainerWayland.h
|
|
||||||
--- a/widget/gtk/MozContainerWayland.h
|
|
||||||
+++ b/widget/gtk/MozContainerWayland.h
|
|
||||||
@@ -76,13 +76,17 @@
|
|
||||||
struct wl_egl_window* moz_container_wayland_get_egl_window(
|
|
||||||
MozContainer* container, double scale);
|
|
||||||
|
|
||||||
gboolean moz_container_wayland_has_egl_window(MozContainer* container);
|
|
||||||
void moz_container_wayland_egl_window_set_size(MozContainer* container,
|
|
||||||
- int width, int height);
|
|
||||||
+ nsIntSize aSize);
|
|
||||||
+bool moz_container_wayland_egl_window_needs_size_update(MozContainer* container,
|
|
||||||
+ nsIntSize aSize,
|
|
||||||
+ int scale);
|
|
||||||
void moz_container_wayland_set_scale_factor(MozContainer* container);
|
|
||||||
-void moz_container_wayland_set_scale_factor_locked(MozContainer* container);
|
|
||||||
+void moz_container_wayland_set_scale_factor_locked(
|
|
||||||
+ const mozilla::MutexAutoLock& aProofOfLock, MozContainer* container);
|
|
||||||
|
|
||||||
void moz_container_wayland_add_initial_draw_callback_locked(
|
|
||||||
MozContainer* container, const std::function<void(void)>& initial_draw_cb);
|
|
||||||
void moz_container_wayland_add_or_fire_initial_draw_callback(
|
|
||||||
MozContainer* container, const std::function<void(void)>& initial_draw_cb);
|
|
||||||
diff --git a/widget/gtk/MozContainerWayland.cpp b/widget/gtk/MozContainerWayland.cpp
|
|
||||||
--- a/widget/gtk/MozContainerWayland.cpp
|
|
||||||
+++ b/widget/gtk/MozContainerWayland.cpp
|
|
||||||
@@ -108,13 +108,11 @@
|
|
||||||
mSurface = moz_container_wayland_surface_lock(aContainer);
|
|
||||||
}
|
|
||||||
MozContainerSurfaceLock::~MozContainerSurfaceLock() {
|
|
||||||
moz_container_wayland_surface_unlock(mContainer, &mSurface);
|
|
||||||
}
|
|
||||||
-struct wl_surface* MozContainerSurfaceLock::GetSurface() {
|
|
||||||
- return mSurface;
|
|
||||||
-}
|
|
||||||
+struct wl_surface* MozContainerSurfaceLock::GetSurface() { return mSurface; }
|
|
||||||
|
|
||||||
// Imlemented in MozContainer.cpp
|
|
||||||
void moz_container_realize(GtkWidget* widget);
|
|
||||||
|
|
||||||
// Invalidate gtk wl_surface to commit changes to wl_subsurface.
|
|
||||||
@@ -163,15 +161,16 @@
|
|
||||||
// This is called from layout/compositor code only with
|
|
||||||
// size equal to GL rendering context. Otherwise there are
|
|
||||||
// rendering artifacts as wl_egl_window size does not match
|
|
||||||
// GL rendering pipeline setup.
|
|
||||||
void moz_container_wayland_egl_window_set_size(MozContainer* container,
|
|
||||||
- int width, int height) {
|
|
||||||
+ nsIntSize aSize) {
|
|
||||||
MozContainerWayland* wl_container = &container->wl_container;
|
|
||||||
MutexAutoLock lock(*wl_container->container_lock);
|
|
||||||
if (wl_container->eglwindow) {
|
|
||||||
- wl_egl_window_resize(wl_container->eglwindow, width, height, 0, 0);
|
|
||||||
+ wl_egl_window_resize(wl_container->eglwindow, aSize.width, aSize.height, 0,
|
|
||||||
+ 0);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
void moz_container_wayland_class_init(MozContainerClass* klass) {
|
|
||||||
/*GObjectClass *gobject_class = G_OBJECT_CLASS (klass);
|
|
||||||
@@ -432,11 +431,11 @@
|
|
||||||
MOZ_CONTAINER(widget))) {
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- moz_container_wayland_set_scale_factor_locked(MOZ_CONTAINER(widget));
|
|
||||||
+ moz_container_wayland_set_scale_factor_locked(lock, MOZ_CONTAINER(widget));
|
|
||||||
moz_container_wayland_set_opaque_region_locked(lock, MOZ_CONTAINER(widget));
|
|
||||||
moz_container_clear_input_region(MOZ_CONTAINER(widget));
|
|
||||||
moz_container_wayland_invalidate(MOZ_CONTAINER(widget));
|
|
||||||
return FALSE;
|
|
||||||
}
|
|
||||||
@@ -487,11 +486,11 @@
|
|
||||||
if (!container->wl_container.surface) {
|
|
||||||
if (!moz_container_wayland_surface_create_locked(lock, container)) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- moz_container_wayland_set_scale_factor_locked(container);
|
|
||||||
+ moz_container_wayland_set_scale_factor_locked(lock, container);
|
|
||||||
moz_container_wayland_set_opaque_region_locked(lock, container);
|
|
||||||
moz_container_wayland_move_locked(lock, container, allocation->x,
|
|
||||||
allocation->y);
|
|
||||||
moz_container_clear_input_region(container);
|
|
||||||
moz_container_wayland_invalidate(MOZ_CONTAINER(widget));
|
|
||||||
@@ -542,55 +541,61 @@
|
|
||||||
if (wl_container->surface) {
|
|
||||||
moz_container_wayland_set_opaque_region_locked(lock, container);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-void moz_container_wayland_set_scale_factor_locked(MozContainer* container) {
|
|
||||||
+static void moz_container_wayland_surface_set_scale_locked(
|
|
||||||
+ const MutexAutoLock& aProofOfLock, MozContainerWayland* wl_container,
|
|
||||||
+ int scale) {
|
|
||||||
+ if (wl_container->buffer_scale == scale) {
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ LOGCONTAINER("%s scale %d\n", __FUNCTION__, scale);
|
|
||||||
+
|
|
||||||
+ // There is a chance that the attached wl_buffer has not yet been doubled
|
|
||||||
+ // on the main thread when scale factor changed to 2. This leads to
|
|
||||||
+ // crash with the following message:
|
|
||||||
+ // Buffer size (AxB) must be an integer multiple of the buffer_scale (2)
|
|
||||||
+ // Removing the possibly wrong wl_buffer to prevent that crash:
|
|
||||||
+ wl_surface_attach(wl_container->surface, nullptr, 0, 0);
|
|
||||||
+ wl_surface_set_buffer_scale(wl_container->surface, scale);
|
|
||||||
+ wl_container->buffer_scale = scale;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+void moz_container_wayland_set_scale_factor_locked(
|
|
||||||
+ const MutexAutoLock& aProofOfLock, MozContainer* container) {
|
|
||||||
if (gfx::gfxVars::UseWebRenderCompositor()) {
|
|
||||||
// the compositor backend handles scaling itself
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
MozContainerWayland* wl_container = &container->wl_container;
|
|
||||||
wl_container->container_lock->AssertCurrentThreadOwns();
|
|
||||||
|
|
||||||
nsWindow* window = moz_container_get_nsWindow(container);
|
|
||||||
-
|
|
||||||
- if (window && window->UseFractionalScale()) {
|
|
||||||
+ MOZ_DIAGNOSTIC_ASSERT(window);
|
|
||||||
+ if (window->UseFractionalScale()) {
|
|
||||||
if (!wl_container->viewport) {
|
|
||||||
wl_container->viewport = wp_viewporter_get_viewport(
|
|
||||||
WaylandDisplayGet()->GetViewporter(), wl_container->surface);
|
|
||||||
}
|
|
||||||
|
|
||||||
GdkWindow* gdkWindow = gtk_widget_get_window(GTK_WIDGET(container));
|
|
||||||
wp_viewport_set_destination(wl_container->viewport,
|
|
||||||
gdk_window_get_width(gdkWindow),
|
|
||||||
gdk_window_get_height(gdkWindow));
|
|
||||||
} else {
|
|
||||||
- int scale = window ? window->GdkCeiledScaleFactor() : 1;
|
|
||||||
-
|
|
||||||
- if (scale == wl_container->buffer_scale) {
|
|
||||||
- return;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- LOGCONTAINER("%s [%p] scale %d\n", __FUNCTION__,
|
|
||||||
- (void*)moz_container_get_nsWindow(container), scale);
|
|
||||||
- // There is a chance that the attached wl_buffer has not yet been doubled
|
|
||||||
- // on the main thread when scale factor changed to 2. This leads to
|
|
||||||
- // crash with the following message:
|
|
||||||
- // Buffer size (AxB) must be an integer multiple of the buffer_scale (2)
|
|
||||||
- // Removing the possibly wrong wl_buffer to prevent that crash:
|
|
||||||
- wl_surface_attach(wl_container->surface, nullptr, 0, 0);
|
|
||||||
- wl_surface_set_buffer_scale(wl_container->surface, scale);
|
|
||||||
- wl_container->buffer_scale = scale;
|
|
||||||
+ moz_container_wayland_surface_set_scale_locked(
|
|
||||||
+ aProofOfLock, wl_container, window->GdkCeiledScaleFactor());
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
void moz_container_wayland_set_scale_factor(MozContainer* container) {
|
|
||||||
MutexAutoLock lock(*container->wl_container.container_lock);
|
|
||||||
if (container->wl_container.surface) {
|
|
||||||
- moz_container_wayland_set_scale_factor_locked(container);
|
|
||||||
+ moz_container_wayland_set_scale_factor_locked(lock, container);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
static bool moz_container_wayland_surface_create_locked(
|
|
||||||
const MutexAutoLock& aProofOfLock, MozContainer* container) {
|
|
||||||
@@ -598,10 +603,12 @@
|
|
||||||
|
|
||||||
LOGWAYLAND("%s [%p]\n", __FUNCTION__,
|
|
||||||
(void*)moz_container_get_nsWindow(container));
|
|
||||||
|
|
||||||
GdkWindow* window = gtk_widget_get_window(GTK_WIDGET(container));
|
|
||||||
+ MOZ_DIAGNOSTIC_ASSERT(window);
|
|
||||||
+
|
|
||||||
wl_surface* parent_surface = gdk_wayland_window_get_wl_surface(window);
|
|
||||||
if (!parent_surface) {
|
|
||||||
LOGWAYLAND(" Failed - missing parent surface!");
|
|
||||||
return false;
|
|
||||||
}
|
|
||||||
@@ -691,36 +698,65 @@
|
|
||||||
*surface = nullptr;
|
|
||||||
}
|
|
||||||
container->wl_container.container_lock->Unlock();
|
|
||||||
}
|
|
||||||
|
|
||||||
+bool moz_container_wayland_egl_window_needs_size_update(MozContainer* container,
|
|
||||||
+ nsIntSize aSize,
|
|
||||||
+ int aScale) {
|
|
||||||
+ MozContainerWayland* wl_container = &container->wl_container;
|
|
||||||
+ if (wl_container->buffer_scale != aScale) {
|
|
||||||
+ return true;
|
|
||||||
+ }
|
|
||||||
+ nsIntSize recentSize;
|
|
||||||
+ wl_egl_window_get_attached_size(wl_container->eglwindow, &recentSize.width,
|
|
||||||
+ &recentSize.height);
|
|
||||||
+ return aSize != recentSize;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
struct wl_egl_window* moz_container_wayland_get_egl_window(
|
|
||||||
MozContainer* container, double scale) {
|
|
||||||
MozContainerWayland* wl_container = &container->wl_container;
|
|
||||||
|
|
||||||
- LOGCONTAINER("%s [%p] eglwindow %p\n", __FUNCTION__,
|
|
||||||
+ LOGCONTAINER("%s [%p] eglwindow %p scale %d\n", __FUNCTION__,
|
|
||||||
(void*)moz_container_get_nsWindow(container),
|
|
||||||
- (void*)wl_container->eglwindow);
|
|
||||||
+ (void*)wl_container->eglwindow, (int)scale);
|
|
||||||
|
|
||||||
MutexAutoLock lock(*wl_container->container_lock);
|
|
||||||
if (!wl_container->surface || !wl_container->ready_to_draw) {
|
|
||||||
- LOGWAYLAND(
|
|
||||||
+ LOGCONTAINER(
|
|
||||||
" quit, wl_container->surface %p wl_container->ready_to_draw %d\n",
|
|
||||||
wl_container->surface, wl_container->ready_to_draw);
|
|
||||||
return nullptr;
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ GdkWindow* window = gtk_widget_get_window(GTK_WIDGET(container));
|
|
||||||
+ nsIntSize requestedSize((int)round(gdk_window_get_width(window) * scale),
|
|
||||||
+ (int)round(gdk_window_get_height(window) * scale));
|
|
||||||
+
|
|
||||||
if (!wl_container->eglwindow) {
|
|
||||||
- GdkWindow* window = gtk_widget_get_window(GTK_WIDGET(container));
|
|
||||||
wl_container->eglwindow = wl_egl_window_create(
|
|
||||||
- wl_container->surface, (int)round(gdk_window_get_width(window) * scale),
|
|
||||||
- (int)round(gdk_window_get_height(window) * scale));
|
|
||||||
+ wl_container->surface, requestedSize.width, requestedSize.height);
|
|
||||||
|
|
||||||
- LOGCONTAINER("%s [%p] created eglwindow %p size %d x %d scale %f\n",
|
|
||||||
+ LOGCONTAINER("%s [%p] created eglwindow %p size %d x %d (with scale %f)\n",
|
|
||||||
__FUNCTION__, (void*)moz_container_get_nsWindow(container),
|
|
||||||
- (void*)wl_container->eglwindow, gdk_window_get_width(window),
|
|
||||||
- gdk_window_get_height(window), scale);
|
|
||||||
+ (void*)wl_container->eglwindow, requestedSize.width,
|
|
||||||
+ requestedSize.height, scale);
|
|
||||||
+ } else {
|
|
||||||
+ nsIntSize recentSize;
|
|
||||||
+ wl_egl_window_get_attached_size(wl_container->eglwindow, &recentSize.width,
|
|
||||||
+ &recentSize.height);
|
|
||||||
+ if (requestedSize != recentSize) {
|
|
||||||
+ LOGCONTAINER("%s [%p] resized to %d x %d (with scale %f)\n", __FUNCTION__,
|
|
||||||
+ (void*)moz_container_get_nsWindow(container),
|
|
||||||
+ requestedSize.width, requestedSize.height, scale);
|
|
||||||
+ wl_egl_window_resize(wl_container->eglwindow, requestedSize.width,
|
|
||||||
+ requestedSize.height, 0, 0);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
+ moz_container_wayland_surface_set_scale_locked(lock, wl_container,
|
|
||||||
+ static_cast<int>(scale));
|
|
||||||
return wl_container->eglwindow;
|
|
||||||
}
|
|
||||||
|
|
||||||
gboolean moz_container_wayland_has_egl_window(MozContainer* container) {
|
|
||||||
return container->wl_container.eglwindow != nullptr;
|
|
||||||
diff --git a/widget/gtk/WindowSurfaceWaylandMultiBuffer.cpp b/widget/gtk/WindowSurfaceWaylandMultiBuffer.cpp
|
|
||||||
--- a/widget/gtk/WindowSurfaceWaylandMultiBuffer.cpp
|
|
||||||
+++ b/widget/gtk/WindowSurfaceWaylandMultiBuffer.cpp
|
|
||||||
@@ -301,11 +301,11 @@
|
|
||||||
LayoutDeviceIntRect r = iter.Get();
|
|
||||||
wl_surface_damage_buffer(waylandSurface, r.x, r.y, r.width, r.height);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- moz_container_wayland_set_scale_factor_locked(container);
|
|
||||||
+ moz_container_wayland_set_scale_factor_locked(aProofOfLock, container);
|
|
||||||
mInProgressBuffer->AttachAndCommit(waylandSurface);
|
|
||||||
|
|
||||||
mInProgressBuffer->ResetBufferAge();
|
|
||||||
mFrontBuffer = mInProgressBuffer;
|
|
||||||
mFrontBufferInvalidRegion = aInvalidRegion;
|
|
||||||
diff --git a/widget/gtk/mozwayland/mozwayland.c b/widget/gtk/mozwayland/mozwayland.c
|
|
||||||
--- a/widget/gtk/mozwayland/mozwayland.c
|
|
||||||
+++ b/widget/gtk/mozwayland/mozwayland.c
|
|
||||||
@@ -186,10 +186,13 @@
|
|
||||||
MOZ_EXPORT void wl_egl_window_destroy(struct wl_egl_window* egl_window) {}
|
|
||||||
|
|
||||||
MOZ_EXPORT void wl_egl_window_resize(struct wl_egl_window* egl_window,
|
|
||||||
int width, int height, int dx, int dy) {}
|
|
||||||
|
|
||||||
+MOZ_EXPORT void wl_egl_window_get_attached_size(
|
|
||||||
+ struct wl_egl_window* egl_window, int* width, int* height) {}
|
|
||||||
+
|
|
||||||
MOZ_EXPORT void wl_list_init(struct wl_list* list) {}
|
|
||||||
|
|
||||||
MOZ_EXPORT void wl_list_insert(struct wl_list* list, struct wl_list* elm) {}
|
|
||||||
|
|
||||||
MOZ_EXPORT void wl_list_remove(struct wl_list* elm) {}
|
|
||||||
diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
|
|
||||||
--- a/widget/gtk/nsWindow.cpp
|
|
||||||
+++ b/widget/gtk/nsWindow.cpp
|
|
||||||
@@ -9816,13 +9816,18 @@
|
|
||||||
void nsWindow::SetEGLNativeWindowSize(
|
|
||||||
const LayoutDeviceIntSize& aEGLWindowSize) {
|
|
||||||
if (!mContainer || !GdkIsWaylandDisplay()) {
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
- moz_container_wayland_egl_window_set_size(mContainer, aEGLWindowSize.width,
|
|
||||||
- aEGLWindowSize.height);
|
|
||||||
- moz_container_wayland_set_scale_factor(mContainer);
|
|
||||||
+ if (moz_container_wayland_egl_window_needs_size_update(
|
|
||||||
+ mContainer, aEGLWindowSize.ToUnknownSize(), GdkCeiledScaleFactor())) {
|
|
||||||
+ LOG("nsWindow::SetEGLNativeWindowSize() %d x %d", aEGLWindowSize.width,
|
|
||||||
+ aEGLWindowSize.height);
|
|
||||||
+ moz_container_wayland_egl_window_set_size(mContainer,
|
|
||||||
+ aEGLWindowSize.ToUnknownSize());
|
|
||||||
+ moz_container_wayland_set_scale_factor(mContainer);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
||||||
LayoutDeviceIntSize nsWindow::GetMozContainerSize() {
|
|
||||||
LayoutDeviceIntSize size(0, 0);
|
|
||||||
|
|
1842
D164896.diff
1842
D164896.diff
File diff suppressed because one or more lines are too long
19
firefox.spec
19
firefox.spec
@ -172,13 +172,13 @@ ExcludeArch: i686
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 108.0.1
|
Version: 109.0
|
||||||
Release: 4%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20221218.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20230111.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
@ -225,7 +225,6 @@ Patch55: firefox-testing.patch
|
|||||||
Patch61: firefox-glibc-dynstack.patch
|
Patch61: firefox-glibc-dynstack.patch
|
||||||
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
Patch71: 0001-GLIBCXX-fix-for-GCC-12.patch
|
||||||
Patch78: firefox-i686-build.patch
|
Patch78: firefox-i686-build.patch
|
||||||
Patch79: D163310.diff
|
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
# Generate without context by
|
# Generate without context by
|
||||||
@ -250,10 +249,6 @@ Patch402: mozilla-1196777.patch
|
|||||||
Patch407: mozilla-1667096.patch
|
Patch407: mozilla-1667096.patch
|
||||||
Patch408: mozilla-1663844.patch
|
Patch408: mozilla-1663844.patch
|
||||||
Patch415: mozilla-1670333.patch
|
Patch415: mozilla-1670333.patch
|
||||||
Patch416: D163696.diff
|
|
||||||
Patch417: D163697.diff
|
|
||||||
Patch418: D163698.diff
|
|
||||||
Patch419: D164896.diff
|
|
||||||
|
|
||||||
# PGO/LTO patches
|
# PGO/LTO patches
|
||||||
Patch600: pgo.patch
|
Patch600: pgo.patch
|
||||||
@ -506,7 +501,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch54 -p1 -b .1669639
|
%patch54 -p1 -b .1669639
|
||||||
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
%patch71 -p1 -b .0001-GLIBCXX-fix-for-GCC-12
|
||||||
%patch78 -p1 -b .firefox-i686
|
%patch78 -p1 -b .firefox-i686
|
||||||
%patch79 -p1 -b .D163310
|
|
||||||
|
|
||||||
# Test patches
|
# Test patches
|
||||||
#%patch100 -p1 -b .firefox-tests-xpcshell
|
#%patch100 -p1 -b .firefox-tests-xpcshell
|
||||||
@ -529,10 +523,6 @@ This package contains results of tests executed during build.
|
|||||||
%patch407 -p1 -b .1667096
|
%patch407 -p1 -b .1667096
|
||||||
%patch408 -p1 -b .1663844
|
%patch408 -p1 -b .1663844
|
||||||
%patch415 -p1 -b .1670333
|
%patch415 -p1 -b .1670333
|
||||||
%patch416 -p1 -b .D163696
|
|
||||||
%patch417 -p1 -b .D163697
|
|
||||||
%patch418 -p1 -b .D163698
|
|
||||||
%patch419 -p1 -b .D164896
|
|
||||||
|
|
||||||
# PGO patches
|
# PGO patches
|
||||||
%if %{build_with_pgo}
|
%if %{build_with_pgo}
|
||||||
@ -1086,6 +1076,9 @@ fi
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 11 2023 Martin Stransky <stransky@redhat.com>- 109.0-1
|
||||||
|
- Update to 109.0
|
||||||
|
|
||||||
* Mon Jan 09 2023 Kalev Lember <klember@redhat.com> - 108.0.1-4
|
* Mon Jan 09 2023 Kalev Lember <klember@redhat.com> - 108.0.1-4
|
||||||
- Drop conditionals for F35
|
- Drop conditionals for F35
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,7 +1,7 @@
|
|||||||
diff -up firefox-101.0.1/dom/media/gmp/GMPSharedMemManager.h.1663844 firefox-101.0.1/dom/media/gmp/GMPSharedMemManager.h
|
diff -up firefox-109.0/dom/media/gmp/GMPSharedMemManager.h.1663844 firefox-109.0/dom/media/gmp/GMPSharedMemManager.h
|
||||||
--- firefox-101.0.1/dom/media/gmp/GMPSharedMemManager.h.1663844 2022-06-08 23:06:36.000000000 +0200
|
--- firefox-109.0/dom/media/gmp/GMPSharedMemManager.h.1663844 2023-01-09 20:34:10.000000000 +0100
|
||||||
+++ firefox-101.0.1/dom/media/gmp/GMPSharedMemManager.h 2022-06-09 17:17:04.775008085 +0200
|
+++ firefox-109.0/dom/media/gmp/GMPSharedMemManager.h 2023-01-12 09:28:56.035741438 +0100
|
||||||
@@ -27,7 +27,7 @@ class GMPSharedMem {
|
@@ -26,7 +26,7 @@ class GMPSharedMem {
|
||||||
// returned to the parent pool (which is not included). If more than
|
// returned to the parent pool (which is not included). If more than
|
||||||
// this are needed, we presume the client has either crashed or hung
|
// this are needed, we presume the client has either crashed or hung
|
||||||
// (perhaps temporarily).
|
// (perhaps temporarily).
|
||||||
@ -10,9 +10,9 @@ diff -up firefox-101.0.1/dom/media/gmp/GMPSharedMemManager.h.1663844 firefox-101
|
|||||||
|
|
||||||
GMPSharedMem() {
|
GMPSharedMem() {
|
||||||
for (size_t i = 0; i < sizeof(mGmpAllocated) / sizeof(mGmpAllocated[0]);
|
for (size_t i = 0; i < sizeof(mGmpAllocated) / sizeof(mGmpAllocated[0]);
|
||||||
diff -up firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp.1663844 firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp
|
diff -up firefox-109.0/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp.1663844 firefox-109.0/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp
|
||||||
--- firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp.1663844 2022-06-08 16:10:21.000000000 +0200
|
--- firefox-109.0/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp.1663844 2023-01-09 20:34:10.000000000 +0100
|
||||||
+++ firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp 2022-06-09 20:31:25.120035588 +0200
|
+++ firefox-109.0/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp 2023-01-12 09:28:56.036741473 +0100
|
||||||
@@ -84,6 +84,9 @@ media::DecodeSupportSet GMPDecoderModule
|
@@ -84,6 +84,9 @@ media::DecodeSupportSet GMPDecoderModule
|
||||||
|
|
||||||
media::DecodeSupportSet GMPDecoderModule::SupportsMimeType(
|
media::DecodeSupportSet GMPDecoderModule::SupportsMimeType(
|
||||||
@ -23,12 +23,12 @@ diff -up firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPDecoderModule.cpp.1
|
|||||||
return media::DecodeSupport::Unsupported;
|
return media::DecodeSupport::Unsupported;
|
||||||
}
|
}
|
||||||
|
|
||||||
diff -up firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp.1663844 firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp
|
diff -up firefox-109.0/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp.1663844 firefox-109.0/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp
|
||||||
--- firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp.1663844 2022-06-08 16:10:21.000000000 +0200
|
--- firefox-109.0/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp.1663844 2023-01-12 09:28:56.036741473 +0100
|
||||||
+++ firefox-101.0.1/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp 2022-06-09 17:17:04.776008117 +0200
|
+++ firefox-109.0/dom/media/platforms/agnostic/gmp/GMPVideoDecoder.cpp 2023-01-12 14:18:12.354866405 +0100
|
||||||
@@ -70,6 +70,8 @@ void GMPVideoDecoder::Decoded(GMPVideoi4
|
@@ -81,6 +81,8 @@ void GMPVideoDecoder::Decoded(GMPVideoi4
|
||||||
RefPtr<GMPVideoDecoder> self = this;
|
});
|
||||||
if (v) {
|
|
||||||
mDecodedData.AppendElement(std::move(v));
|
mDecodedData.AppendElement(std::move(v));
|
||||||
+ mDecodePromise.ResolveIfExists(std::move(mDecodedData), __func__);
|
+ mDecodePromise.ResolveIfExists(std::move(mDecodedData), __func__);
|
||||||
+ mDecodedData = DecodedData();
|
+ mDecodedData = DecodedData();
|
||||||
|
Loading…
Reference in New Issue
Block a user