Fixed typo at startup script, removed unused patches
This commit is contained in:
parent
c45606f457
commit
91102985e0
@ -1,12 +0,0 @@
|
||||
diff -up firefox-58.0/js/src/jit/none/MacroAssembler-none.h.old firefox-58.0/js/src/jit/none/MacroAssembler-none.h
|
||||
--- firefox-58.0/js/src/jit/none/MacroAssembler-none.h.old 2018-01-24 20:33:52.569147937 +0100
|
||||
+++ firefox-58.0/js/src/jit/none/MacroAssembler-none.h 2018-01-24 20:34:06.985088057 +0100
|
||||
@@ -88,7 +88,7 @@ static constexpr Register WasmTableCallI
|
||||
static constexpr Register WasmTlsReg { Registers::invalid_reg };
|
||||
|
||||
static constexpr uint32_t ABIStackAlignment = 4;
|
||||
-static constexpr uint32_t CodeAlignment = 4;
|
||||
+static constexpr uint32_t CodeAlignment = 8;
|
||||
static constexpr uint32_t JitStackAlignment = 8;
|
||||
static constexpr uint32_t JitStackValueAlignment = JitStackAlignment / sizeof(Value);
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -up firefox-54.0/toolkit/crashreporter/google-breakpad/src/third_party/curl/curlbuild.h.ppc-curl firefox-54.0/toolkit/crashreporter/google-breakpad/src/third_party/curl/curlbuild.h
|
||||
--- firefox-54.0/toolkit/crashreporter/google-breakpad/src/third_party/curl/curlbuild.h.ppc-curl 2017-06-09 23:31:15.186207877 +0200
|
||||
+++ firefox-54.0/toolkit/crashreporter/google-breakpad/src/third_party/curl/curlbuild.h 2017-06-10 00:21:26.731117206 +0200
|
||||
@@ -155,7 +155,8 @@
|
||||
|
||||
/* The size of `long', as computed by sizeof. */
|
||||
#if defined(_M_X64) || (defined(__x86_64__) && !defined(__ILP32__)) || \
|
||||
- defined(__aarch64__) || (defined(__mips__) && _MIPS_SIM == _ABI64)
|
||||
+ defined(__aarch64__) || (defined(__mips__) && _MIPS_SIM == _ABI64) || \
|
||||
+ defined(__PPC64__) || defined(__pcc64le__) || defined(__S390X__) || defined(__s390x__)
|
||||
#define CURL_SIZEOF_LONG 8
|
||||
#else
|
||||
#define CURL_SIZEOF_LONG 4
|
@ -1,14 +0,0 @@
|
||||
diff -up firefox-58.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-58.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
||||
diff -up firefox-58.0/media/webrtc/trunk/Makefile.old firefox-58.0/media/webrtc/trunk/Makefile
|
||||
diff -up firefox-58.0/old-configure.in.old firefox-58.0/old-configure.in
|
||||
--- firefox-58.0/old-configure.in.old 2018-01-23 14:49:51.771309172 +0100
|
||||
+++ firefox-58.0/old-configure.in 2018-01-23 14:50:04.091265876 +0100
|
||||
@@ -1915,7 +1915,7 @@ MOZ_ARG_WITH_BOOL(system-nss,
|
||||
_USE_SYSTEM_NSS=1 )
|
||||
|
||||
if test -n "$_USE_SYSTEM_NSS"; then
|
||||
- AM_PATH_NSS(3.34.1, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
|
||||
+ AM_PATH_NSS(3.34.0, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
|
||||
fi
|
||||
|
||||
if test -n "$MOZ_SYSTEM_NSS"; then
|
@ -1,52 +0,0 @@
|
||||
diff --git a/security/certverifier/NSSCertDBTrustDomain.cpp b/security/certverifier/NSSCertDBTrustDomain.cpp
|
||||
--- a/security/certverifier/NSSCertDBTrustDomain.cpp
|
||||
+++ b/security/certverifier/NSSCertDBTrustDomain.cpp
|
||||
@@ -1059,26 +1059,17 @@ InitializeNSS(const nsACString& dir, boo
|
||||
// "/usr/lib/nss/libnssckbi.so".
|
||||
uint32_t flags = NSS_INIT_NOROOTINIT | NSS_INIT_OPTIMIZESPACE;
|
||||
if (readOnly) {
|
||||
flags |= NSS_INIT_READONLY;
|
||||
}
|
||||
if (!loadPKCS11Modules) {
|
||||
flags |= NSS_INIT_NOMODDB;
|
||||
}
|
||||
- // At the moment, sqldb does not work with non-ASCII file paths on Windows.
|
||||
- bool useSQLDB = Preferences::GetBool("security.use_sqldb", false) &&
|
||||
- (NS_IsNativeUTF8() || NS_IsAscii(PromiseFlatCString(dir).get()));
|
||||
nsAutoCString dbTypeAndDirectory;
|
||||
- // Don't change any behavior if the user has specified an alternative database
|
||||
- // location with MOZPSM_NSSDBDIR_OVERRIDE.
|
||||
- const char* dbDirOverride = getenv("MOZPSM_NSSDBDIR_OVERRIDE");
|
||||
- if (useSQLDB && (!dbDirOverride || strlen(dbDirOverride) == 0)) {
|
||||
- dbTypeAndDirectory.Append("sql:");
|
||||
- }
|
||||
dbTypeAndDirectory.Append(dir);
|
||||
MOZ_LOG(gCertVerifierLog, LogLevel::Debug,
|
||||
("InitializeNSS(%s, %d, %d)", dbTypeAndDirectory.get(), readOnly,
|
||||
loadPKCS11Modules));
|
||||
SECStatus srv = NSS_Initialize(dbTypeAndDirectory.get(), "", "",
|
||||
SECMOD_DB, flags);
|
||||
if (srv != SECSuccess) {
|
||||
return srv;
|
||||
diff --git a/security/manager/ssl/security-prefs.js b/security/manager/ssl/security-prefs.js
|
||||
--- a/security/manager/ssl/security-prefs.js
|
||||
+++ b/security/manager/ssl/security-prefs.js
|
||||
@@ -39,17 +39,17 @@ pref("security.ask_for_password",
|
||||
pref("security.password_lifetime", 30);
|
||||
|
||||
// If true, use the modern sqlite-backed certificate and key databases in NSS.
|
||||
// If false, use the default format. Currently the default in NSS is the old
|
||||
// BerkeleyDB format, but this will change in bug 1377940.
|
||||
// Changing this requires a restart to take effect.
|
||||
// Note that the environment variable MOZPSM_NSSDBDIR_OVERRIDE can override both
|
||||
// the behavior of this preference and the NSS default.
|
||||
-pref("security.use_sqldb", true);
|
||||
+pref("security.use_sqldb", false);
|
||||
|
||||
// The supported values of this pref are:
|
||||
// 0: disable detecting Family Safety mode and importing the root
|
||||
// 1: only attempt to detect Family Safety mode (don't import the root)
|
||||
// 2: detect Family Safety mode and import the root
|
||||
// (This is only relevant to Windows 8.1)
|
||||
pref("security.family_safety.mode", 2);
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up firefox-45.0/firefox-45.0/config/baseconfig.mk.orig firefox-45.0/firefox-45.0/config/baseconfig.mk
|
||||
--- firefox-45.0/config/baseconfig.mk.orig 2016-03-02 13:26:31.981927073 +0100
|
||||
+++ firefox-45.0/config/baseconfig.mk 2016-03-02 13:30:09.044756473 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
# whether a normal build is happening or whether the check is running.
|
||||
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
ifeq (.,$(DEPTH))
|
||||
DIST = dist
|
@ -70,7 +70,7 @@ MOZ_LAUNCHER="$MOZ_DIST_BIN/run-mozilla.sh"
|
||||
##
|
||||
## Set X11 backed as a default one
|
||||
##
|
||||
if ! [ "$GDK_BACKEND" ] then
|
||||
if ! [ "$GDK_BACKEND" ]; then
|
||||
export GDK_BACKEND=x11
|
||||
fi
|
||||
|
||||
|
26
firefox.spec
26
firefox.spec
@ -96,7 +96,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 59.0
|
||||
Release: 0.1%{?pre_tag}%{?dist}
|
||||
Release: 0.2%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
#Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
@ -116,7 +116,6 @@ Source27: google-api-key
|
||||
Source28: firefox-wayland.sh.in
|
||||
|
||||
# Build patches
|
||||
#Patch0: firefox-install-dir.patch
|
||||
Patch3: mozilla-build-arm.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
|
||||
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
||||
@ -125,7 +124,6 @@ Patch26: build-icu-big-endian.patch
|
||||
Patch27: mozilla-1335250.patch
|
||||
# Also fixes s390x: https://bugzilla.mozilla.org/show_bug.cgi?id=1376268
|
||||
Patch29: build-big-endian.patch
|
||||
Patch31: build-ppc64-s390x-curl.patch
|
||||
Patch32: build-rust-ppc64le.patch
|
||||
Patch35: build-ppc-jit.patch
|
||||
Patch36: build-missing-xlocale-h.patch
|
||||
@ -144,9 +142,6 @@ Patch225: mozilla-1005640-accept-lang.patch
|
||||
#ARM run-time patch
|
||||
Patch226: rhbz-1354671.patch
|
||||
Patch229: firefox-nss-version.patch
|
||||
Patch230: firefox-fedora-rhbz-1537287-v2.patch
|
||||
Patch231: build-with-nss-3.34.0.patch
|
||||
Patch232: build-jit-CodeAlignment.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch402: mozilla-1196777.patch
|
||||
@ -156,9 +151,6 @@ Patch410: mozilla-1321521.patch
|
||||
Patch411: mozilla-1321521-2.patch
|
||||
Patch412: mozilla-1337988.patch
|
||||
Patch413: mozilla-1353817.patch
|
||||
Patch416: mozilla-1399611.patch
|
||||
# ppc64/le build patch
|
||||
Patch417: mozilla-1416170.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -296,7 +288,6 @@ This package contains results of tests executed during build.
|
||||
# Build patches, can't change backup suffix from default because during build
|
||||
# there is a compare of config and js/config directories and .orig suffix is
|
||||
# ignored during this compare.
|
||||
#%patch0 -p1
|
||||
|
||||
|
||||
%patch18 -p1 -b .jemalloc-ppc
|
||||
@ -304,7 +295,6 @@ This package contains results of tests executed during build.
|
||||
%patch25 -p1 -b .rhbz-1219542-s390
|
||||
%endif
|
||||
%patch29 -p1 -b .big-endian
|
||||
#%patch31 -p1 -b .ppc64-s390x-curl
|
||||
%patch37 -p1 -b .jit-atomic-lucky
|
||||
|
||||
%patch3 -p1 -b .arm
|
||||
@ -319,20 +309,10 @@ This package contains results of tests executed during build.
|
||||
%ifarch aarch64
|
||||
%patch226 -p1 -b .1354671
|
||||
%endif
|
||||
# NSS stuff
|
||||
#%if 0%{?fedora} < 28
|
||||
#%patch230 -p1 -b .rhbz-1537287
|
||||
#%endif
|
||||
#%patch231 -p1
|
||||
#%patch232 -p1 -b .CodeAlignment
|
||||
|
||||
%patch402 -p1 -b .1196777
|
||||
%patch406 -p1 -b .256180
|
||||
%patch413 -p1 -b .1353817
|
||||
# CSD - Disabled now
|
||||
#%patch416 -p1 -b .1399611
|
||||
|
||||
#%patch417 -p1 -b .1416170
|
||||
|
||||
# Patch for big endian platforms only
|
||||
%if 0%{?big_endian}
|
||||
@ -820,7 +800,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%dir %{langpackdir}
|
||||
%endif
|
||||
%{mozappdir}/browser/omni.ja
|
||||
#%{mozappdir}/browser/icons
|
||||
%{mozappdir}/chrome.manifest
|
||||
%{mozappdir}/run-mozilla.sh
|
||||
%{mozappdir}/application.ini
|
||||
@ -863,6 +842,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jan 30 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.2
|
||||
- Fixed typo at startup script.
|
||||
|
||||
* Mon Jan 29 2018 Martin Stransky <stransky@redhat.com> - 59.0-0.1
|
||||
- Update to Firefox 59.0 Beta 4
|
||||
- Enabled Wayland backend
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,50 +0,0 @@
|
||||
diff --git a/memory/build/Utils.h b/memory/build/Utils.h
|
||||
--- a/memory/build/Utils.h
|
||||
+++ b/memory/build/Utils.h
|
||||
@@ -67,19 +67,19 @@ constexpr size_t operator"" _MiB(unsigne
|
||||
return size_t(aNum) * 1024_KiB;
|
||||
}
|
||||
|
||||
constexpr size_t operator"" _MiB(long double aNum)
|
||||
{
|
||||
return size_t(aNum * 1024_KiB);
|
||||
}
|
||||
|
||||
-constexpr long double operator""_percent(long double aPercent)
|
||||
+constexpr double operator""_percent(long double aPercent)
|
||||
{
|
||||
- return aPercent / 100;
|
||||
+ return double(aPercent) / 100;
|
||||
}
|
||||
|
||||
// Helper for (fast) comparison of fractions without involving divisions or
|
||||
// floats.
|
||||
class Fraction
|
||||
{
|
||||
public:
|
||||
explicit constexpr Fraction(size_t aNumerator, size_t aDenominator)
|
||||
diff --git a/memory/build/mozjemalloc.cpp b/memory/build/mozjemalloc.cpp
|
||||
--- a/memory/build/mozjemalloc.cpp
|
||||
+++ b/memory/build/mozjemalloc.cpp
|
||||
@@ -908,18 +908,18 @@ struct arena_bin_t
|
||||
|
||||
// Offset of first region in a run for this bin's size class.
|
||||
uint32_t mRunFirstRegionOffset;
|
||||
|
||||
// Current number of runs in this bin, full or otherwise.
|
||||
unsigned long mNumRuns;
|
||||
|
||||
// Amount of overhead runs are allowed to have.
|
||||
- static constexpr long double kRunOverhead = 1.6_percent;
|
||||
- static constexpr long double kRunRelaxedOverhead = 2.4_percent;
|
||||
+ static constexpr double kRunOverhead = 1.6_percent;
|
||||
+ static constexpr double kRunRelaxedOverhead = 2.4_percent;
|
||||
|
||||
// Initialize a bin for the given size class.
|
||||
// The generated run sizes, for a page size of 4 KiB, are:
|
||||
// size|run size|run size|run size|run
|
||||
// class|size class|size class|size class|size
|
||||
// 4 4 KiB 8 4 KiB 16 4 KiB 32 4 KiB
|
||||
// 48 4 KiB 64 4 KiB 80 4 KiB 96 4 KiB
|
||||
// 112 4 KiB 128 8 KiB 144 4 KiB 160 8 KiB
|
||||
|
Loading…
Reference in New Issue
Block a user