Update to 35.0 Build 1
This commit is contained in:
parent
3cfb2b8c1f
commit
8ef0a520c1
2
.gitignore
vendored
2
.gitignore
vendored
@ -116,3 +116,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-33.1-20141111.tar.xz
|
||||
/firefox-34.0.source.tar.bz2
|
||||
/firefox-langpacks-34.0-20141201.tar.xz
|
||||
/firefox-35.0.source.tar.bz2
|
||||
/firefox-langpacks-35.0-20150106.tar.xz
|
||||
|
25
firefox.spec
25
firefox.spec
@ -106,14 +106,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 34.0
|
||||
Release: 12%{?pre_tag}%{?dist}
|
||||
Version: 35.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20141201.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20150106.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
@ -138,19 +138,15 @@ Patch20: firefox-build-prbool.patch
|
||||
# Unable to install addons from https pages
|
||||
Patch204: rhbz-966424.patch
|
||||
Patch215: firefox-enable-addons.patch
|
||||
Patch217: firefox-baseline-disable.patch
|
||||
Patch218: java-plugin-url.patch
|
||||
#Patch217: firefox-baseline-disable.patch
|
||||
Patch219: rhbz-1173156.patch
|
||||
Patch220: rhbz-1014858.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch300: mozilla-858919.patch
|
||||
Patch301: mozilla-1097550-dict-fix.patch
|
||||
Patch302: mozilla-1050258.patch
|
||||
|
||||
# Gtk3 upstream patches
|
||||
Patch402: mozilla-gtk3-tab-size.patch
|
||||
Patch403: mozilla-1051209.patch
|
||||
Patch404: mozilla-1101582.patch
|
||||
Patch405: mozilla-1073117-check.patch
|
||||
Patch406: mozilla-1073117-color.patch
|
||||
@ -291,24 +287,20 @@ cd %{tarballdir}
|
||||
# For branding specific patches.
|
||||
|
||||
# Fedora patches
|
||||
%patch218 -p1 -b .icedtea
|
||||
%patch204 -p2 -b .966424
|
||||
%patch215 -p1 -b .addons
|
||||
# disable baseline JIT on i686 (rhbz#1047079)
|
||||
%ifarch %{ix86}
|
||||
%patch217 -p2 -b .baseline
|
||||
%endif
|
||||
#%ifarch %{ix86}
|
||||
#%patch217 -p2 -b .baseline
|
||||
#%endif
|
||||
%patch219 -p2 -b .rhbz-1173156
|
||||
%patch220 -p1 -b .rhbz-1014858
|
||||
|
||||
# Upstream patches
|
||||
%patch300 -p1 -b .858919
|
||||
%patch301 -p1 -b .1097550-dict-fix
|
||||
%patch302 -p1 -b .1050258
|
||||
|
||||
%if %{toolkit_gtk3}
|
||||
%patch402 -p1 -b .gtk3-tab-size
|
||||
%patch403 -p1 -b .1051209
|
||||
%patch404 -p1 -b .1101582
|
||||
%patch405 -p1 -b .1073117-check
|
||||
%patch406 -p1 -b .1073117-color
|
||||
@ -777,6 +769,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jan 6 2015 Martin Stransky <stransky@redhat.com> - 35.0-1
|
||||
- Update to 35.0 Build 1
|
||||
|
||||
* Mon Jan 5 2015 Martin Stransky <stransky@redhat.com> - 34.0-12
|
||||
- Fixed rhbz#1014858 - GLib-CRITICAL **: g_slice_set_config:
|
||||
assertion `sys_page_size == 0' failed
|
||||
|
@ -1,25 +0,0 @@
|
||||
--- mozilla-release/toolkit/mozapps/plugins/content/pluginInstallerWizard.js
|
||||
+++ mozilla-release/toolkit/mozapps/plugins/content/pluginInstallerWizard.js
|
||||
@@ -315,6 +315,11 @@
|
||||
xpiPlugins);
|
||||
else
|
||||
this.advancePage(null);
|
||||
+}
|
||||
+
|
||||
+
|
||||
+function endsWith(str, suffix) {
|
||||
+ return str.indexOf(suffix, str.length - suffix.length) !== -1;
|
||||
}
|
||||
|
||||
/*
|
||||
@@ -405,6 +410,9 @@
|
||||
|
||||
// manual install
|
||||
if (aManualUrl) {
|
||||
+ if (endsWith(aManualUrl, "use-java-plugin-to-view-interactive-content")) {
|
||||
+ aManualUrl="http://icedtea.classpath.org/wiki/IcedTea-Web_On_Fedora_And_Rhel"
|
||||
+ }
|
||||
var myButton = document.createElement("button");
|
||||
|
||||
var manualInstallLabel = this.getString("pluginInstallationSummary.manualInstall.label");
|
||||
|
@ -1,29 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Douglas Crosher <dtc-moz@scieneer.com>
|
||||
# Date 1415349848 -39600
|
||||
# Fri Nov 07 19:44:08 2014 +1100
|
||||
# Node ID b98d6205da98b5bec30b0677c30a6d09f351f4b8
|
||||
# Parent 17e19083908620e8a83876e49bac6f6ba2fcc272
|
||||
Bug 1050258 - ARM hard-float XPCOM: correct argument passing.
|
||||
|
||||
diff --git a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
|
||||
--- a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
|
||||
+++ b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
|
||||
@@ -219,16 +219,17 @@ static inline void copy_dword(uint32_t*
|
||||
{
|
||||
if (ireg_args + 1 < end) {
|
||||
if ((uint32_t)ireg_args & 4) {
|
||||
ireg_args++;
|
||||
}
|
||||
*(uint64_t *)ireg_args = data;
|
||||
ireg_args += 2;
|
||||
} else {
|
||||
+ ireg_args = end;
|
||||
if ((uint32_t)stack_args & 4) {
|
||||
stack_args++;
|
||||
}
|
||||
*(uint64_t *)stack_args = data;
|
||||
stack_args += 2;
|
||||
}
|
||||
}
|
||||
|
@ -1,47 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Mike Hommey <mh+mozilla@glandium.org>
|
||||
# Date 1409907676 -32400
|
||||
# Fri Sep 05 18:01:16 2014 +0900
|
||||
# Node ID 4eac619b94070c8e854f6b3925879700430ab7f1
|
||||
# Parent 477f8748127a6f702616803e6c43632cb560f8a2
|
||||
Bug 1051209 - Properly link libxul.so on GTK+3 builds after bug 1045783
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -4153,17 +4153,16 @@ cairo-gtk3)
|
||||
MOZ_ENABLE_XREMOTE=1
|
||||
MOZ_GL_DEFAULT_PROVIDER=GLX
|
||||
|
||||
AC_DEFINE(MOZ_X11)
|
||||
MOZ_X11=1
|
||||
USE_FC_FREETYPE=1
|
||||
|
||||
TK_CFLAGS='$(MOZ_GTK3_CFLAGS)'
|
||||
- TK_LIBS='$(MOZ_GTK3_LIBS)'
|
||||
MOZ_WIDGET_GTK=3
|
||||
AC_DEFINE_UNQUOTED(MOZ_WIDGET_GTK,$MOZ_WIDGET_GTK)
|
||||
MOZ_PDF_PRINTING=1
|
||||
MOZ_INSTRUMENT_EVENT_LOOP=1
|
||||
;;
|
||||
|
||||
cairo-gtk2|cairo-gtk2-x11)
|
||||
MOZ_WIDGET_TOOLKIT=gtk2
|
||||
@@ -4266,16 +4265,17 @@ fi
|
||||
if test "$MOZ_INSTRUMENT_EVENT_LOOP"; then
|
||||
AC_DEFINE(MOZ_INSTRUMENT_EVENT_LOOP)
|
||||
fi
|
||||
|
||||
if test "$COMPILE_ENVIRONMENT"; then
|
||||
if test "$MOZ_ENABLE_GTK3"; then
|
||||
PKG_CHECK_MODULES(MOZ_GTK3, gtk+-3.0 >= $GTK3_VERSION gtk+-unix-print-3.0 glib-2.0 gobject-2.0 $GDK_PACKAGES)
|
||||
MOZ_GTK3_CFLAGS="-I${_topsrcdir}/widget/gtk/compat-gtk3 $MOZ_GTK3_CFLAGS"
|
||||
+ TK_LIBS=$MOZ_GTK3_LIBS
|
||||
fi
|
||||
if test "$MOZ_ENABLE_GTK"; then
|
||||
if test "$MOZ_X11"; then
|
||||
GDK_PACKAGES=gdk-x11-2.0
|
||||
fi
|
||||
|
||||
PKG_CHECK_MODULES(MOZ_GTK2, gtk+-2.0 >= $GTK2_VERSION gtk+-unix-print-2.0 glib-2.0 gobject-2.0 $GDK_PACKAGES)
|
||||
MOZ_GTK2_CFLAGS="-I${_topsrcdir}/widget/gtk/compat $MOZ_GTK2_CFLAGS"
|
@ -1,6 +1,6 @@
|
||||
diff -up firefox-34.0/mozilla-release/accessible/atk/Platform.cpp.gtk3 firefox-34.0/mozilla-release/accessible/atk/Platform.cpp
|
||||
--- firefox-34.0/mozilla-release/accessible/atk/Platform.cpp.gtk3 2014-11-26 03:17:05.000000000 +0100
|
||||
+++ firefox-34.0/mozilla-release/accessible/atk/Platform.cpp 2015-01-02 15:28:48.948346742 +0100
|
||||
diff -up firefox-35.0/mozilla-release/accessible/atk/Platform.cpp.1110211 firefox-35.0/mozilla-release/accessible/atk/Platform.cpp
|
||||
--- firefox-35.0/mozilla-release/accessible/atk/Platform.cpp.1110211 2015-01-06 06:11:41.000000000 +0100
|
||||
+++ firefox-35.0/mozilla-release/accessible/atk/Platform.cpp 2015-01-06 12:24:02.508105586 +0100
|
||||
@@ -18,6 +18,9 @@
|
||||
#include <dbus/dbus.h>
|
||||
#endif
|
||||
@ -70,9 +70,9 @@ diff -up firefox-34.0/mozilla-release/accessible/atk/Platform.cpp.gtk3 firefox-3
|
||||
// if (sATKLib) {
|
||||
// PR_UnloadLibrary(sATKLib);
|
||||
// sATKLib = nullptr;
|
||||
diff -up firefox-34.0/mozilla-release/config/system-headers.gtk3 firefox-34.0/mozilla-release/config/system-headers
|
||||
--- firefox-34.0/mozilla-release/config/system-headers.gtk3 2014-11-26 03:17:09.000000000 +0100
|
||||
+++ firefox-34.0/mozilla-release/config/system-headers 2015-01-02 15:28:48.948346742 +0100
|
||||
diff -up firefox-35.0/mozilla-release/config/system-headers.1110211 firefox-35.0/mozilla-release/config/system-headers
|
||||
--- firefox-35.0/mozilla-release/config/system-headers.1110211 2015-01-06 06:11:48.000000000 +0100
|
||||
+++ firefox-35.0/mozilla-release/config/system-headers 2015-01-06 12:24:02.508105586 +0100
|
||||
@@ -189,6 +189,7 @@ asm/signal.h
|
||||
ASRegistry.h
|
||||
assert.h
|
||||
@ -81,15 +81,15 @@ diff -up firefox-34.0/mozilla-release/config/system-headers.gtk3 firefox-34.0/mo
|
||||
atlcom.h
|
||||
atlconv.h
|
||||
atlctl.cpp
|
||||
diff -up firefox-34.0/mozilla-release/configure.in.gtk3 firefox-34.0/mozilla-release/configure.in
|
||||
--- firefox-34.0/mozilla-release/configure.in.gtk3 2015-01-02 15:28:48.950346747 +0100
|
||||
+++ firefox-34.0/mozilla-release/configure.in 2015-01-02 15:30:42.253625279 +0100
|
||||
@@ -4282,7 +4282,7 @@ fi
|
||||
diff -up firefox-35.0/mozilla-release/configure.in.1110211 firefox-35.0/mozilla-release/configure.in
|
||||
--- firefox-35.0/mozilla-release/configure.in.1110211 2015-01-06 12:24:02.509105590 +0100
|
||||
+++ firefox-35.0/mozilla-release/configure.in 2015-01-06 12:24:49.419274706 +0100
|
||||
@@ -4364,7 +4364,7 @@ fi
|
||||
|
||||
if test "$COMPILE_ENVIRONMENT"; then
|
||||
if test "$MOZ_ENABLE_GTK3"; then
|
||||
- PKG_CHECK_MODULES(MOZ_GTK3, gtk+-3.0 >= $GTK3_VERSION gtk+-unix-print-3.0 glib-2.0 gobject-2.0 $GDK_PACKAGES)
|
||||
+ PKG_CHECK_MODULES(MOZ_GTK3, gtk+-3.0 >= $GTK3_VERSION gtk+-unix-print-3.0 glib-2.0 gobject-2.0 atk-bridge-2.0 $GDK_PACKAGES)
|
||||
MOZ_GTK3_CFLAGS="-I${_topsrcdir}/widget/gtk/compat-gtk3 $MOZ_GTK3_CFLAGS"
|
||||
TK_LIBS=$MOZ_GTK3_LIBS
|
||||
fi
|
||||
dnl Contrary to MOZ_GTK2_LIBS, MOZ_GTK3_LIBS needs to be literally added to TK_LIBS instead
|
||||
dnl of a make reference because of how TK_LIBS is mangled in toolkit/library/moz.build
|
||||
|
@ -1,258 +0,0 @@
|
||||
diff -up src/widget/gtk/gtk3drawing.c.gtk3-tab-size src/widget/gtk/gtk3drawing.c
|
||||
--- src/widget/gtk/gtk3drawing.c.gtk3-tab-size 2014-05-22 11:59:23.000000000 +0200
|
||||
+++ src/widget/gtk/gtk3drawing.c 2014-06-03 14:41:06.740369999 +0200
|
||||
@@ -2063,22 +2063,35 @@ moz_gtk_tab_paint(cairo_t *cr, GdkRectan
|
||||
* tab appear physically attached to the tabpanel; see details below. */
|
||||
|
||||
GtkStyleContext* style;
|
||||
+ GdkRectangle tabRect;
|
||||
GdkRectangle focusRect;
|
||||
GdkRectangle backRect;
|
||||
+ int initial_gap = 0;
|
||||
|
||||
ensure_tab_widget();
|
||||
gtk_widget_set_direction(gTabWidget, direction);
|
||||
|
||||
style = gtk_widget_get_style_context(gTabWidget);
|
||||
- backRect = focusRect = *rect;
|
||||
-
|
||||
gtk_style_context_save(style);
|
||||
|
||||
+ tabRect = *rect;
|
||||
+
|
||||
+ if (flags & MOZ_GTK_TAB_FIRST) {
|
||||
+ gtk_widget_style_get (gTabWidget, "initial-gap", &initial_gap, NULL);
|
||||
+ tabRect.width -= initial_gap;
|
||||
+
|
||||
+ if (direction != GTK_TEXT_DIR_RTL) {
|
||||
+ tabRect.x += initial_gap;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ focusRect = backRect = tabRect;
|
||||
+
|
||||
if ((flags & MOZ_GTK_TAB_SELECTED) == 0) {
|
||||
/* Only draw the tab */
|
||||
gtk_style_context_set_state(style, GTK_STATE_FLAG_NORMAL);
|
||||
gtk_render_extension(style, cr,
|
||||
- rect->x, rect->y, rect->width, rect->height,
|
||||
+ tabRect.x, tabRect.y, tabRect.width, tabRect.height,
|
||||
(flags & MOZ_GTK_TAB_BOTTOM) ?
|
||||
GTK_POS_TOP : GTK_POS_BOTTOM );
|
||||
} else {
|
||||
@@ -2132,15 +2145,17 @@ moz_gtk_tab_paint(cairo_t *cr, GdkRectan
|
||||
gap_loffset = gap_roffset = 20; /* should be enough */
|
||||
if (flags & MOZ_GTK_TAB_FIRST) {
|
||||
if (direction == GTK_TEXT_DIR_RTL)
|
||||
- gap_roffset = 0;
|
||||
+ gap_roffset = initial_gap;
|
||||
else
|
||||
- gap_loffset = 0;
|
||||
+ gap_loffset = initial_gap;
|
||||
}
|
||||
|
||||
- gtk_style_context_set_state(style, GTK_STATE_FLAG_ACTIVE);
|
||||
-
|
||||
/* Adwaita theme engine crashes without it (rhbz#713764) */
|
||||
- gtk_style_context_add_region(style, GTK_STYLE_REGION_TAB, 0);
|
||||
+ gtk_style_context_add_region(style, GTK_STYLE_REGION_TAB,
|
||||
+ (flags & MOZ_GTK_TAB_FIRST) ?
|
||||
+ GTK_REGION_FIRST : 0);
|
||||
+
|
||||
+ gtk_style_context_set_state(style, GTK_STATE_FLAG_ACTIVE);
|
||||
|
||||
if (flags & MOZ_GTK_TAB_BOTTOM) {
|
||||
/* Draw the tab on bottom */
|
||||
@@ -2148,8 +2163,8 @@ moz_gtk_tab_paint(cairo_t *cr, GdkRectan
|
||||
focusRect.height -= gap_voffset;
|
||||
|
||||
gtk_render_extension(style, cr,
|
||||
- rect->x, rect->y + gap_voffset, rect->width,
|
||||
- rect->height - gap_voffset, GTK_POS_TOP);
|
||||
+ tabRect.x, tabRect.y + gap_voffset, tabRect.width,
|
||||
+ tabRect.height - gap_voffset, GTK_POS_TOP);
|
||||
|
||||
gtk_style_context_remove_region(style, GTK_STYLE_REGION_TAB);
|
||||
|
||||
@@ -2165,38 +2180,39 @@ moz_gtk_tab_paint(cairo_t *cr, GdkRectan
|
||||
cairo_clip(cr);
|
||||
|
||||
gtk_render_frame_gap(style, cr,
|
||||
- rect->x - gap_loffset,
|
||||
- rect->y + gap_voffset - 3 * gap_height,
|
||||
- rect->width + gap_loffset + gap_roffset,
|
||||
+ tabRect.x - gap_loffset,
|
||||
+ tabRect.y + gap_voffset - 3 * gap_height,
|
||||
+ tabRect.width + gap_loffset + gap_roffset,
|
||||
3 * gap_height, GTK_POS_BOTTOM,
|
||||
- gap_loffset, gap_loffset + rect->width);
|
||||
+ gap_loffset, gap_loffset + tabRect.width);
|
||||
cairo_restore(cr);
|
||||
} else {
|
||||
/* Draw the tab on top */
|
||||
focusRect.height -= gap_voffset;
|
||||
gtk_render_extension(style, cr,
|
||||
- rect->x, rect->y, rect->width,
|
||||
- rect->height - gap_voffset, GTK_POS_BOTTOM);
|
||||
+ tabRect.x, tabRect.y, tabRect.width,
|
||||
+ tabRect.height - gap_voffset, GTK_POS_BOTTOM);
|
||||
|
||||
gtk_style_context_remove_region(style, GTK_STYLE_REGION_TAB);
|
||||
|
||||
- backRect.y += (rect->height - gap_voffset);
|
||||
+ backRect.y += (tabRect.height - gap_voffset);
|
||||
backRect.height = gap_height;
|
||||
|
||||
/* Draw the gap; erase with background color before painting in
|
||||
* case theme does not */
|
||||
gtk_render_background(style, cr, backRect.x, backRect.y,
|
||||
backRect.width, backRect.height);
|
||||
+
|
||||
cairo_save(cr);
|
||||
cairo_rectangle(cr, backRect.x, backRect.y, backRect.width, backRect.height);
|
||||
cairo_clip(cr);
|
||||
|
||||
gtk_render_frame_gap(style, cr,
|
||||
- rect->x - gap_loffset,
|
||||
- rect->y + rect->height - gap_voffset,
|
||||
- rect->width + gap_loffset + gap_roffset,
|
||||
+ tabRect.x - gap_loffset,
|
||||
+ tabRect.y + tabRect.height - gap_voffset,
|
||||
+ tabRect.width + gap_loffset + gap_roffset,
|
||||
3 * gap_height, GTK_POS_TOP,
|
||||
- gap_loffset, gap_loffset + rect->width);
|
||||
+ gap_loffset, gap_loffset + tabRect.width);
|
||||
cairo_restore(cr);
|
||||
}
|
||||
}
|
||||
@@ -2825,10 +2841,6 @@ moz_gtk_get_widget_border(GtkThemeWidget
|
||||
left, top, right, bottom);
|
||||
return MOZ_GTK_SUCCESS;
|
||||
}
|
||||
- case MOZ_GTK_TAB:
|
||||
- ensure_tab_widget();
|
||||
- w = gTabWidget;
|
||||
- break;
|
||||
/* These widgets have no borders, since they are not containers. */
|
||||
case MOZ_GTK_SPLITTER_HORIZONTAL:
|
||||
case MOZ_GTK_SPLITTER_VERTICAL:
|
||||
@@ -2871,6 +2883,58 @@ moz_gtk_get_widget_border(GtkThemeWidget
|
||||
return MOZ_GTK_SUCCESS;
|
||||
}
|
||||
|
||||
+gint
|
||||
+moz_gtk_get_tab_border(GtkThemeWidgetType widget, gint* left, gint* top,
|
||||
+ gint* right, gint* bottom, GtkTextDirection direction,
|
||||
+ GtkTabFlags flags)
|
||||
+{
|
||||
+ GtkStyleContext* style;
|
||||
+ int tab_curvature;
|
||||
+
|
||||
+ ensure_tab_widget();
|
||||
+
|
||||
+ style = gtk_widget_get_style_context(gTabWidget);
|
||||
+ gtk_style_context_save(style);
|
||||
+
|
||||
+ gtk_style_context_set_state(style, ((flags & MOZ_GTK_TAB_SELECTED) == 0) ?
|
||||
+ GTK_STATE_FLAG_NORMAL :
|
||||
+ GTK_STATE_FLAG_ACTIVE);
|
||||
+ gtk_style_context_add_region(style, GTK_STYLE_REGION_TAB,
|
||||
+ (flags & MOZ_GTK_TAB_FIRST) ?
|
||||
+ GTK_REGION_FIRST : 0);
|
||||
+ gtk_style_context_add_class(style, (flags & MOZ_GTK_TAB_BOTTOM) ?
|
||||
+ GTK_STYLE_CLASS_BOTTOM :
|
||||
+ GTK_STYLE_CLASS_TOP);
|
||||
+
|
||||
+ *left = *top = *right = *bottom = 0;
|
||||
+ moz_gtk_add_style_border(style, left, top, right, bottom);
|
||||
+ moz_gtk_add_style_padding(style, left, top, right, bottom);
|
||||
+
|
||||
+ gtk_widget_style_get (gTabWidget, "tab-curvature", &tab_curvature, NULL);
|
||||
+ *left += tab_curvature;
|
||||
+ *right += tab_curvature;
|
||||
+
|
||||
+ if (flags & MOZ_GTK_TAB_FIRST) {
|
||||
+ int initial_gap;
|
||||
+ gtk_widget_style_get (gTabWidget, "initial-gap", &initial_gap, NULL);
|
||||
+ if (direction == GTK_TEXT_DIR_RTL)
|
||||
+ *right += initial_gap;
|
||||
+ else
|
||||
+ *left += initial_gap;
|
||||
+ }
|
||||
+
|
||||
+ // Top tabs have no bottom border, bottom tabs have no top border
|
||||
+ if (flags & MOZ_GTK_TAB_BOTTOM) {
|
||||
+ *top = 0;
|
||||
+ } else {
|
||||
+ *bottom = 0;
|
||||
+ }
|
||||
+
|
||||
+ gtk_style_context_restore(style);
|
||||
+
|
||||
+ return MOZ_GTK_SUCCESS;
|
||||
+}
|
||||
+
|
||||
gint
|
||||
moz_gtk_get_combo_box_entry_button_size(gint* width, gint* height)
|
||||
{
|
||||
diff -up src/widget/gtk/gtkdrawing.h.gtk3-tab-size src/widget/gtk/gtkdrawing.h
|
||||
--- src/widget/gtk/gtkdrawing.h.gtk3-tab-size 2014-04-22 17:06:04.000000000 +0200
|
||||
+++ src/widget/gtk/gtkdrawing.h 2014-06-03 14:39:09.240424957 +0200
|
||||
@@ -258,6 +258,13 @@ gint moz_gtk_get_widget_border(GtkThemeW
|
||||
gint* right, gint* bottom, GtkTextDirection direction,
|
||||
gboolean inhtml);
|
||||
|
||||
+#if (MOZ_WIDGET_GTK == 3)
|
||||
+gint
|
||||
+moz_gtk_get_tab_border(GtkThemeWidgetType widget, gint* left, gint* top,
|
||||
+ gint* right, gint* bottom, GtkTextDirection direction,
|
||||
+ GtkTabFlags flags);
|
||||
+#endif
|
||||
+
|
||||
/**
|
||||
* Get the desired size of a GtkCheckButton
|
||||
* indicator_size: [OUT] the indicator size
|
||||
diff -up src/widget/gtk/nsNativeThemeGTK.cpp.gtk3-tab-size src/widget/gtk/nsNativeThemeGTK.cpp
|
||||
--- src/widget/gtk/nsNativeThemeGTK.cpp.gtk3-tab-size 2014-05-21 13:29:44.000000000 +0200
|
||||
+++ src/widget/gtk/nsNativeThemeGTK.cpp 2014-06-03 14:39:09.240424957 +0200
|
||||
@@ -915,15 +915,31 @@ nsNativeThemeGTK::GetWidgetBorder(nsDevi
|
||||
// but don't reserve any space for it.
|
||||
break;
|
||||
case NS_THEME_TAB:
|
||||
- // Top tabs have no bottom border, bottom tabs have no top border
|
||||
- moz_gtk_get_widget_border(MOZ_GTK_TAB, &aResult->left, &aResult->top,
|
||||
- &aResult->right, &aResult->bottom, direction,
|
||||
- FALSE);
|
||||
- if (IsBottomTab(aFrame))
|
||||
- aResult->top = 0;
|
||||
- else
|
||||
- aResult->bottom = 0;
|
||||
- break;
|
||||
+ {
|
||||
+#if (MOZ_WIDGET_GTK == 2)
|
||||
+ // Top tabs have no bottom border, bottom tabs have no top border
|
||||
+ moz_gtk_get_widget_border(MOZ_GTK_TAB, &aResult->left, &aResult->top,
|
||||
+ &aResult->right, &aResult->bottom, direction,
|
||||
+ FALSE);
|
||||
+ if (IsBottomTab(aFrame))
|
||||
+ aResult->top = 0;
|
||||
+ else
|
||||
+ aResult->bottom = 0;
|
||||
+#else
|
||||
+ GtkWidgetState state;
|
||||
+ GtkThemeWidgetType gtkWidgetType;
|
||||
+ gint flags;
|
||||
+
|
||||
+ if (!GetGtkWidgetAndState(aWidgetType, aFrame, gtkWidgetType, &state,
|
||||
+ &flags))
|
||||
+ return NS_OK;
|
||||
+
|
||||
+ moz_gtk_get_tab_border(MOZ_GTK_TAB, &aResult->left, &aResult->top,
|
||||
+ &aResult->right, &aResult->bottom, direction,
|
||||
+ (GtkTabFlags)flags);
|
||||
+#endif
|
||||
+ }
|
||||
+ break;
|
||||
case NS_THEME_MENUITEM:
|
||||
case NS_THEME_CHECKMENUITEM:
|
||||
case NS_THEME_RADIOMENUITEM:
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
8ce294a40ecaaf8a1ae6a6c6a6e2c3c9 firefox-34.0.source.tar.bz2
|
||||
988cd25476b027f1188271940800cc22 firefox-langpacks-34.0-20141201.tar.xz
|
||||
c325ebaae05357b722cd865538021f86 firefox-35.0.source.tar.bz2
|
||||
8cfa0c0b279d188a53215559a0187e41 firefox-langpacks-35.0-20150106.tar.xz
|
||||
|
Loading…
Reference in New Issue
Block a user