Updated to 74.0.1, Added fix for mozbz#1624745
This commit is contained in:
parent
6c801f52ad
commit
830bb9636f
2
.gitignore
vendored
2
.gitignore
vendored
@ -389,3 +389,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-74.0-20200303.tar.xz
|
/firefox-langpacks-74.0-20200303.tar.xz
|
||||||
/firefox-langpacks-74.0-20200309.tar.xz
|
/firefox-langpacks-74.0-20200309.tar.xz
|
||||||
/firefox-langpacks-74.0-20200310.tar.xz
|
/firefox-langpacks-74.0-20200310.tar.xz
|
||||||
|
/firefox-74.0.1.source.tar.xz
|
||||||
|
/firefox-langpacks-74.0.1-20200404.tar.xz
|
||||||
|
12
firefox.spec
12
firefox.spec
@ -117,13 +117,13 @@ ExcludeArch: s390x
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 74.0
|
Version: 74.0.1
|
||||||
Release: 14%{?nss_tag}%{?dist}
|
Release: 1%{?nss_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20200310.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20200404.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
@ -191,6 +191,7 @@ Patch425: mozilla-1623106.patch
|
|||||||
Patch574: firefox-pipewire.patch
|
Patch574: firefox-pipewire.patch
|
||||||
Patch575: mozilla-1609538.patch
|
Patch575: mozilla-1609538.patch
|
||||||
Patch576: mozilla-1623060.patch
|
Patch576: mozilla-1623060.patch
|
||||||
|
Patch577: mozilla-1624745.patch
|
||||||
|
|
||||||
# PGO/LTO patches
|
# PGO/LTO patches
|
||||||
Patch600: pgo.patch
|
Patch600: pgo.patch
|
||||||
@ -401,6 +402,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch574 -p1 -b .firefox-pipewire
|
%patch574 -p1 -b .firefox-pipewire
|
||||||
%patch575 -p1 -b .mozilla-1609538
|
%patch575 -p1 -b .mozilla-1609538
|
||||||
%patch576 -p1 -b .mozilla-1623060
|
%patch576 -p1 -b .mozilla-1623060
|
||||||
|
%patch577 -p1 -b .mozilla-1624745
|
||||||
|
|
||||||
# PGO patches
|
# PGO patches
|
||||||
%patch600 -p1 -b .pgo
|
%patch600 -p1 -b .pgo
|
||||||
@ -967,6 +969,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Apr 4 2020 Martin Stransky <stransky@redhat.com> - 74.0.1-1
|
||||||
|
- Updated to latest upstream
|
||||||
|
- Added fix for mozbz#1624745
|
||||||
|
|
||||||
* Wed Apr 1 2020 Martin Stransky <stransky@redhat.com> - 74.0-14
|
* Wed Apr 1 2020 Martin Stransky <stransky@redhat.com> - 74.0-14
|
||||||
- Added fixes to gnome shell search provider
|
- Added fixes to gnome shell search provider
|
||||||
|
|
||||||
|
33
mozilla-1624745.patch
Normal file
33
mozilla-1624745.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff --git a/widget/gtk/mozcontainer.cpp b/widget/gtk/mozcontainer.cpp
|
||||||
|
--- a/widget/gtk/mozcontainer.cpp
|
||||||
|
+++ b/widget/gtk/mozcontainer.cpp
|
||||||
|
@@ -624,17 +624,25 @@
|
||||||
|
GdkDisplay* display = gtk_widget_get_display(GTK_WIDGET(container));
|
||||||
|
nsWaylandDisplay* waylandDisplay = WaylandDisplayGet(display);
|
||||||
|
|
||||||
|
+ wl_surface* parent_surface =
|
||||||
|
+ moz_gtk_widget_get_wl_surface(GTK_WIDGET(container));
|
||||||
|
+ if (!parent_surface) {
|
||||||
|
+ return nullptr;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
// Available as of GTK 3.8+
|
||||||
|
struct wl_compositor* compositor = waylandDisplay->GetCompositor();
|
||||||
|
container->surface = wl_compositor_create_surface(compositor);
|
||||||
|
- wl_surface* parent_surface =
|
||||||
|
- moz_gtk_widget_get_wl_surface(GTK_WIDGET(container));
|
||||||
|
- if (!container->surface || !parent_surface) {
|
||||||
|
+ if (!container->surface) {
|
||||||
|
return nullptr;
|
||||||
|
}
|
||||||
|
|
||||||
|
container->subsurface = wl_subcompositor_get_subsurface(
|
||||||
|
waylandDisplay->GetSubcompositor(), container->surface, parent_surface);
|
||||||
|
+ if (!container->subsurface) {
|
||||||
|
+ g_clear_pointer(&container->surface, wl_surface_destroy);
|
||||||
|
+ return nullptr;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
GdkWindow* window = gtk_widget_get_window(GTK_WIDGET(container));
|
||||||
|
gint x, y;
|
||||||
|
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (cbindgen-vendor.tar.xz) = a12d9dd45301614f3a7fcd77f61e3f731718fc418fcf84b0ac7363ef4ddd8ff60e057febef917620ac89d2d47d76b8dccfa71405935e346b849b93425732016a
|
SHA512 (cbindgen-vendor.tar.xz) = a12d9dd45301614f3a7fcd77f61e3f731718fc418fcf84b0ac7363ef4ddd8ff60e057febef917620ac89d2d47d76b8dccfa71405935e346b849b93425732016a
|
||||||
SHA512 (firefox-74.0.source.tar.xz) = 710ae0803e7261ecda359b64edfd4142433619570817cc02d1e0381897a69cfa5863f01759d0658ffc16a72c568f01cf5ae3ec91777fa71db43cfa73340a5b88
|
SHA512 (firefox-74.0.1.source.tar.xz) = c437c40740bd035ff374b3fa15abaff49dde3f613906f5e018f42dd3e219d32112e8b2e85efd9c0f7a872475640908adb1cf7cdd677b03a39ff435a57c48e6d5
|
||||||
SHA512 (firefox-langpacks-74.0-20200310.tar.xz) = 4b67837cd6c23244339f064627a18a26c82e972cac4d2431d6cf588302b57977955ab2ebf0b529bec05ff90f5118b8ee9aefd436b0f3c060ae74acc0c2330578
|
SHA512 (firefox-langpacks-74.0.1-20200404.tar.xz) = f67ea5188910200150878b5978e2004ca30bc69ab99ef84702d636a320a6f45cd5555767f99e3e9b31b5227dd940a0888ffc7e8643e797fc1191f6f80a47fc6e
|
||||||
|
Loading…
Reference in New Issue
Block a user