Merge branch 'master' into f24
This commit is contained in:
commit
82aa2b82a4
2
.gitignore
vendored
2
.gitignore
vendored
@ -228,3 +228,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-52.0-20170303.tar.xz
|
/firefox-langpacks-52.0-20170303.tar.xz
|
||||||
/firefox-52.0.2.source.tar.xz
|
/firefox-52.0.2.source.tar.xz
|
||||||
/firefox-langpacks-52.0.2-20170329.tar.xz
|
/firefox-langpacks-52.0.2-20170329.tar.xz
|
||||||
|
/firefox-53.0.2.source.tar.xz
|
||||||
|
/firefox-langpacks-53.0.2-20170505.tar.xz
|
||||||
|
11
firefox.spec
11
firefox.spec
@ -66,6 +66,7 @@
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
# Build as a debug package?
|
# Build as a debug package?
|
||||||
%define debug_build 0
|
%define debug_build 0
|
||||||
|
|
||||||
@ -109,14 +110,15 @@
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 53.0
|
Version: 53.0.2
|
||||||
Release: 4%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
|
ExcludeArch: armv7hl ppc64le aarch64 ppc64
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20170418.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20170505.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source12: firefox-redhat-default-prefs.js
|
Source12: firefox-redhat-default-prefs.js
|
||||||
@ -861,6 +863,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 5 2017 Jan Horak <jhorak@redhat.com> - 53.0.2-1
|
||||||
|
- Update to 53.0.2
|
||||||
|
|
||||||
* Thu Apr 27 2017 Jan Horak <jhorak@redhat.com> - 53.0-4
|
* Thu Apr 27 2017 Jan Horak <jhorak@redhat.com> - 53.0-4
|
||||||
- Added patch from rhbz#1400293
|
- Added patch from rhbz#1400293
|
||||||
|
|
||||||
|
@ -1,16 +1,12 @@
|
|||||||
@@ -, +, @@
|
diff -up firefox-53.0/layout/base/nsIPresShell.h.1354671 firefox-53.0/layout/base/nsIPresShell.h
|
||||||
---
|
--- firefox-53.0/layout/base/nsIPresShell.h.1354671 2017-04-27 13:07:43.808653320 +0200
|
||||||
layout/base/nsIPresShell.h | 2 +-
|
+++ firefox-53.0/layout/base/nsIPresShell.h 2017-04-27 13:09:40.404427641 +0200
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
@@ -212,7 +212,7 @@ public:
|
||||||
--- a/layout/base/nsIPresShell.h
|
* to the same aSize value. AllocateFrame is infallible and will abort
|
||||||
+++ a/layout/base/nsIPresShell.h
|
* on out-of-memory.
|
||||||
@@ -224,7 +224,7 @@ public:
|
|
||||||
* to the same aSize value. AllocateFrame returns zero-filled memory.
|
|
||||||
* AllocateFrame is infallible and will abort on out-of-memory.
|
|
||||||
*/
|
*/
|
||||||
- void* AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
- void* AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||||
+ void* __attribute__((optimize("no-lifetime-dse"))) AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
+ void* __attribute__((optimize("no-lifetime-dse"))) AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||||
{
|
{
|
||||||
void* result = mFrameArena.AllocateByFrameID(aID, aSize);
|
void* result = mFrameArena.AllocateByFrameID(aID, aSize);
|
||||||
RecordAlloc(result);
|
RecordAlloc(result);
|
||||||
--
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (firefox-53.0.source.tar.xz) = 36ec810bab58e3d99478455a38427a5efbc74d6dd7d4bb93b700fd7429b9b89250efd0abe4609091483991802090c6373c8434dfc9ba64c79a778e51fd2a2886
|
SHA512 (firefox-53.0.2.source.tar.xz) = d56d563db7e1a0faa2de9315b71b479adb9109624d0958224ad2cee331dcbdb4f414380bd91f70ee0b3e543eca812c172eb2d6f6b5620f6dd6f61675f5ac69d8
|
||||||
SHA512 (firefox-langpacks-53.0-20170418.tar.xz) = 5bb972e22953149b03e135be64664412ee2b2c0791eb6b26c506a170b2aa6ea2e31c77ae6971e393ac3952146855ad423e66c3be53258dcedd17b8932d16982b
|
SHA512 (firefox-langpacks-53.0.2-20170505.tar.xz) = 2f1b903c7fb3f0165fe9b1160492595856c8e51d9a89fe4ab260baab050344bf7f372dfd51240f3d8fe36455724067f54253fc8aeae77f7c5363f7cb1e429f9a
|
||||||
|
Loading…
Reference in New Issue
Block a user