Update to 7

This commit is contained in:
Jan Horak 2011-09-27 19:36:41 +02:00
parent 3f0fa16962
commit 75e2bcf391
3 changed files with 54 additions and 54 deletions

View File

@ -1,53 +0,0 @@
diff -up firefox-6.0/mozilla-release/browser/installer/Makefile.in.cache firefox-6.0/mozilla-release/browser/installer/Makefile.in
--- firefox-6.0/mozilla-release/browser/installer/Makefile.in.cache 2011-08-16 15:55:27.000000000 +0200
+++ firefox-6.0/mozilla-release/browser/installer/Makefile.in 2011-08-16 15:56:29.854358878 +0200
@@ -110,19 +110,6 @@ ifndef LIBXUL_SDK
INSTALL_SDK = 1
endif
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
-ifdef RUN_TEST_PROGRAM
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
-endif
-
-GENERATE_CACHE = \
- $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -a "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
- rm -rf jsloader && \
- $(UNZIP) startupCache.zip && \
- rm startupCache.zip && \
- $(ZIP) -r9m omni.jar jsloader
-endif
-
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
ifeq (bundle, $(MOZ_FS_LAYOUT))
diff -up firefox-6.0/mozilla-release/browser/installer/package-manifest.in.cache firefox-6.0/mozilla-release/browser/installer/package-manifest.in
--- firefox-6.0/mozilla-release/browser/installer/package-manifest.in.cache 2011-08-11 23:40:51.000000000 +0200
+++ firefox-6.0/mozilla-release/browser/installer/package-manifest.in 2011-08-16 15:55:27.791593231 +0200
@@ -86,6 +86,7 @@
[browser]
; [Base Browser Files]
+@BINPATH@/jsloader/
#ifndef XP_UNIX
@BINPATH@/@MOZ_APP_NAME@.exe
#else
diff -up firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk
--- firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache 2011-08-11 23:41:31.000000000 +0200
+++ firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk 2011-08-16 15:56:57.869808700 +0200
@@ -363,7 +363,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
endif
ifdef MOZ_OMNIJAR
-GENERATE_CACHE ?= true
OMNIJAR_FILES = \
chrome \
@@ -393,7 +392,6 @@ PACK_OMNIJAR = \
mv tmp.manifest $$m; \
done; \
$(ZIP) -r9m omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
- $(GENERATE_CACHE) && \
$(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR) ./ ./ && \
mv binary.manifest components && \
printf "manifest components/binary.manifest\n" > chrome.manifest

View File

@ -0,0 +1,53 @@
diff -up firefox-7.0/mozilla-beta/browser/installer/Makefile.in.cache firefox-7.0/mozilla-beta/browser/installer/Makefile.in
--- firefox-7.0/mozilla-beta/browser/installer/Makefile.in.cache 2011-09-06 10:43:04.421293791 +0200
+++ firefox-7.0/mozilla-beta/browser/installer/Makefile.in 2011-09-06 10:43:04.422293805 +0200
@@ -114,19 +114,6 @@ ifndef LIBXUL_SDK
INSTALL_SDK = 1
endif
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
-ifdef RUN_TEST_PROGRAM
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
-endif
-
-GENERATE_CACHE = \
- $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -a "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
- rm -rf jsloader && \
- $(UNZIP) startupCache.zip && \
- rm startupCache.zip && \
- $(ZIP) -r9m omni.jar jsloader
-endif
-
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
ifeq (bundle, $(MOZ_FS_LAYOUT))
diff -up firefox-7.0/mozilla-beta/browser/installer/package-manifest.in.cache firefox-7.0/mozilla-beta/browser/installer/package-manifest.in
--- firefox-7.0/mozilla-beta/browser/installer/package-manifest.in.cache 2011-08-31 21:16:05.000000000 +0200
+++ firefox-7.0/mozilla-beta/browser/installer/package-manifest.in 2011-09-06 10:43:04.423293819 +0200
@@ -91,6 +91,7 @@
[browser]
; [Base Browser Files]
+@BINPATH@/jsloader/
#ifndef XP_UNIX
@BINPATH@/@MOZ_APP_NAME@.exe
#else
diff -up firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk.cache firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk
--- firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk.cache 2011-08-31 21:16:34.000000000 +0200
+++ firefox-7.0/mozilla-beta/toolkit/mozapps/installer/packager.mk 2011-09-06 10:43:52.861924899 +0200
@@ -383,7 +383,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
endif
ifdef MOZ_OMNIJAR
-GENERATE_CACHE ?= true
OMNIJAR_FILES = \
chrome \
@@ -413,7 +412,6 @@ PACK_OMNIJAR = \
mv tmp.manifest $$m; \
done; \
$(ZIP) -r9m omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
- $(GENERATE_CACHE) && \
$(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR_AB_CD) ./ ./ && \
mv binary.manifest components && \
printf "manifest components/binary.manifest\n" > chrome.manifest

View File

@ -62,7 +62,7 @@ Source23: firefox.1
#Build patches
Patch0: firefox-install-dir.patch
Patch1: firefox-6.0-cache-build.patch
Patch1: firefox-7.0-cache-build.patch
# Fedora patches
Patch14: firefox-5.0-asciidel.patch