Update to 81.0
This commit is contained in:
parent
e6e3098b9d
commit
74f97a94b1
2
.gitignore
vendored
2
.gitignore
vendored
@ -415,3 +415,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-80.0-20200820.tar.xz
|
||||
/firefox-80.0.1.source.tar.xz
|
||||
/firefox-langpacks-80.0.1-20200901.tar.xz
|
||||
/firefox-81.0.source.tar.xz
|
||||
/firefox-langpacks-81.0-20200915.tar.xz
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -up firefox-80.0/dom/system/IOUtils.cpp.nspr-build firefox-80.0/dom/system/IOUtils.cpp
|
||||
--- firefox-80.0/dom/system/IOUtils.cpp.nspr-build 2020-08-19 17:38:00.895018639 +0200
|
||||
+++ firefox-80.0/dom/system/IOUtils.cpp 2020-08-19 17:38:09.965978725 +0200
|
||||
@@ -14,9 +14,9 @@
|
||||
#include "mozilla/Services.h"
|
||||
#include "mozilla/Span.h"
|
||||
#include "mozilla/TextUtils.h"
|
||||
-#include "nspr/prio.h"
|
||||
-#include "nspr/private/pprio.h"
|
||||
-#include "nspr/prtypes.h"
|
||||
+#include "prio.h"
|
||||
+#include "private/pprio.h"
|
||||
+#include "prtypes.h"
|
||||
#include "nsDirectoryServiceDefs.h"
|
||||
#include "nsIFile.h"
|
||||
#include "nsIGlobalObject.h"
|
||||
diff -up firefox-80.0/dom/system/IOUtils.h.nspr-build firefox-80.0/dom/system/IOUtils.h
|
||||
--- firefox-80.0/dom/system/IOUtils.h.nspr-build 2020-08-17 22:13:15.000000000 +0200
|
||||
+++ firefox-80.0/dom/system/IOUtils.h 2020-08-19 17:20:33.332711771 +0200
|
||||
@@ -14,7 +14,7 @@
|
||||
#include "mozilla/dom/TypedArray.h"
|
||||
#include "mozilla/ErrorResult.h"
|
||||
#include "mozilla/MozPromise.h"
|
||||
-#include "nspr/prio.h"
|
||||
+#include "prio.h"
|
||||
#include "nsIAsyncShutdown.h"
|
||||
#include "nsISerialEventTarget.h"
|
||||
#include "nsLocalFile.h"
|
@ -1,6 +1,6 @@
|
||||
diff -up firefox-79.0/config/system-headers.mozbuild.firefox-pipewire-0-3 firefox-79.0/config/system-headers.mozbuild
|
||||
--- firefox-79.0/config/system-headers.mozbuild.firefox-pipewire-0-3 2020-07-21 00:49:36.000000000 +0200
|
||||
+++ firefox-79.0/config/system-headers.mozbuild 2020-07-28 10:06:59.485481599 +0200
|
||||
diff -up firefox-81.0/config/system-headers.mozbuild.firefox-pipewire-0-3 firefox-81.0/config/system-headers.mozbuild
|
||||
--- firefox-81.0/config/system-headers.mozbuild.firefox-pipewire-0-3 2020-09-15 03:48:26.000000000 +0200
|
||||
+++ firefox-81.0/config/system-headers.mozbuild 2020-09-15 14:40:00.721481417 +0200
|
||||
@@ -314,6 +314,7 @@ system_headers = [
|
||||
'Gestalt.h',
|
||||
'getopt.h',
|
||||
@ -17,9 +17,9 @@ diff -up firefox-79.0/config/system-headers.mozbuild.firefox-pipewire-0-3 firefo
|
||||
'pixman.h',
|
||||
'pk11func.h',
|
||||
'pk11pqg.h',
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn.firefox-pipewire-0-3 2020-07-20 22:53:33.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn 2020-07-28 10:06:59.485481599 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn 2020-09-15 14:40:00.721481417 +0200
|
||||
@@ -158,7 +158,7 @@ if (rtc_include_tests) {
|
||||
if (is_linux) {
|
||||
if (rtc_use_pipewire) {
|
||||
@ -29,10 +29,10 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/BUILD.gn
|
||||
|
||||
defines = [ "WEBRTC_USE_PIPEWIRE" ]
|
||||
}
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire-0-3 2020-07-28 10:06:59.486481593 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build 2020-07-28 10:11:51.231907101 +0200
|
||||
@@ -174,6 +174,28 @@ if CONFIG["OS_TARGET"] == "Linux":
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire-0-3 2020-09-15 14:40:00.722481420 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build 2020-09-15 14:48:47.454733146 +0200
|
||||
@@ -193,6 +193,28 @@ if CONFIG["OS_TARGET"] == "Linux":
|
||||
"/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc"
|
||||
]
|
||||
|
||||
@ -58,12 +58,12 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_
|
||||
+ "/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc"
|
||||
+ ]
|
||||
+
|
||||
if CONFIG["OS_TARGET"] == "Darwin":
|
||||
if CONFIG["OS_TARGET"] == "NetBSD":
|
||||
|
||||
DEFINES["CR_XCODE_VERSION"] = "0920"
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire-0-3 2020-07-20 22:54:16.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h 2020-07-28 10:06:59.486481593 +0200
|
||||
DEFINES["USE_X11"] = "1"
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -141,7 +141,7 @@ class DesktopCaptureOptions {
|
||||
bool disable_effects_ = true;
|
||||
bool detect_updated_region_ = false;
|
||||
@ -73,9 +73,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_
|
||||
#endif
|
||||
};
|
||||
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc.firefox-pipewire-0-3 2020-07-20 22:54:27.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc 2020-07-28 10:06:59.500481514 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -15,8 +15,11 @@
|
||||
|
||||
#include <spa/param/format-utils.h>
|
||||
@ -670,9 +670,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/ba
|
||||
+}
|
||||
+
|
||||
} // namespace webrtc
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h.firefox-pipewire-0-3 2020-07-20 22:54:40.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h 2020-07-28 10:06:59.501481508 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.h 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -22,17 +22,13 @@
|
||||
|
||||
namespace webrtc {
|
||||
@ -784,9 +784,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/ba
|
||||
static void OnStreamProcess(void* data);
|
||||
static void OnNewBuffer(void* data, uint32_t id);
|
||||
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc.firefox-pipewire-0-3 2020-07-20 22:53:57.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc 2020-07-28 10:06:59.501481508 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
namespace webrtc {
|
||||
|
||||
@ -796,9 +796,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/sc
|
||||
ScreenCapturerPipeWire::~ScreenCapturerPipeWire() {}
|
||||
|
||||
// static
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc.firefox-pipewire-0-3 2020-07-20 22:54:18.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc 2020-07-28 10:06:59.501481508 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
namespace webrtc {
|
||||
|
||||
@ -808,9 +808,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/wi
|
||||
WindowCapturerPipeWire::~WindowCapturerPipeWire() {}
|
||||
|
||||
// static
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc.firefox-pipewire-0-3 2020-07-20 22:54:40.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc 2020-07-28 10:06:59.501481508 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_capturer_linux.cc 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -26,7 +26,7 @@ std::unique_ptr<DesktopCapturer> Desktop
|
||||
const DesktopCaptureOptions& options) {
|
||||
#if defined(WEBRTC_USE_PIPEWIRE)
|
||||
@ -820,9 +820,9 @@ diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/screen_c
|
||||
}
|
||||
#endif // defined(WEBRTC_USE_PIPEWIRE)
|
||||
|
||||
diff -up firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc.firefox-pipewire-0-3 firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc
|
||||
--- firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc.firefox-pipewire-0-3 2020-07-20 22:53:32.000000000 +0200
|
||||
+++ firefox-79.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc 2020-07-28 10:06:59.501481508 +0200
|
||||
diff -up firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc.firefox-pipewire-0-3 firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc
|
||||
--- firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc.firefox-pipewire-0-3 2020-09-15 03:48:32.000000000 +0200
|
||||
+++ firefox-81.0/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc 2020-09-15 14:40:00.722481420 +0200
|
||||
@@ -26,7 +26,7 @@ std::unique_ptr<DesktopCapturer> Desktop
|
||||
const DesktopCaptureOptions& options) {
|
||||
#if defined(WEBRTC_USE_PIPEWIRE)
|
||||
|
18
firefox.spec
18
firefox.spec
@ -119,13 +119,13 @@ ExcludeArch: armv7hl
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 80.0.1
|
||||
Release: 3%{?dist}
|
||||
Version: 81.0
|
||||
Release: 1%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20200901.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20200915.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source10: firefox-mozconfig
|
||||
@ -166,8 +166,6 @@ Patch47: fedora-shebang-build.patch
|
||||
Patch48: build-arm-wasm.patch
|
||||
Patch49: build-arm-libaom.patch
|
||||
#Patch50: Bug-1610814-Fix-NEON-compile-error-with-gcc-and-RGB-.patch
|
||||
Patch51: build-nspr.patch
|
||||
Patch52: mozilla-1875469.patch
|
||||
Patch53: firefox-gcc-build.patch
|
||||
|
||||
# Fedora specific patches
|
||||
@ -189,7 +187,6 @@ Patch575: firefox-pipewire-0-3.patch
|
||||
#VA-API patches
|
||||
Patch584: firefox-disable-ffvpx-with-vapi.patch
|
||||
Patch585: firefox-vaapi-extra-frames.patch
|
||||
Patch589: mozilla-1656436.patch
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -369,8 +366,6 @@ This package contains results of tests executed during build.
|
||||
%patch48 -p1 -b .build-arm-wasm
|
||||
%patch49 -p1 -b .build-arm-libaom
|
||||
#%patch50 -p1 -b .build-arm-SwizzleNEON
|
||||
%patch51 -p1 -b .build-nspr
|
||||
%patch52 -p1 -b .mozilla-1875469
|
||||
%patch53 -p1 -b .firefox-gcc-build
|
||||
|
||||
# Fedora patches
|
||||
@ -395,7 +390,6 @@ This package contains results of tests executed during build.
|
||||
|
||||
%patch584 -p1 -b .firefox-disable-ffvpx-with-vapi
|
||||
%patch585 -p1 -b .firefox-vaapi-extra-frames
|
||||
%patch589 -p1 -b .mozilla-1656436
|
||||
|
||||
# PGO patches
|
||||
%if %{build_with_pgo}
|
||||
@ -615,7 +609,8 @@ echo "export RANLIB=\"gcc-ranlib\"" >> .mozconfig
|
||||
%endif
|
||||
%if 0%{?build_with_pgo}
|
||||
echo "ac_add_options MOZ_PGO=1" >> .mozconfig
|
||||
echo "ac_add_options --enable-lto" >> .mozconfig
|
||||
# TODO - Enable when new gcc hits build roots
|
||||
#echo "ac_add_options --enable-lto" >> .mozconfig
|
||||
# PGO build doesn't work with ccache
|
||||
export CCACHE_DISABLE=1
|
||||
%endif
|
||||
@ -971,6 +966,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Sep 15 2020 Martin Stransky <stransky@redhat.com> - 81.0-1
|
||||
- Updated to 81.0
|
||||
|
||||
* Thu Sep 10 2020 Martin Stransky <stransky@redhat.com> - 80.0.1-3
|
||||
- Test build for all arches.
|
||||
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -up firefox-79.0/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp.mozilla-1656436 firefox-79.0/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp
|
||||
--- firefox-79.0/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp.mozilla-1656436 2020-08-04 13:31:49.476663242 +0200
|
||||
+++ firefox-79.0/dom/media/platforms/ffmpeg/FFmpegVideoDecoder.cpp 2020-08-04 13:32:28.201448682 +0200
|
||||
@@ -766,6 +766,11 @@ MediaResult FFmpegVideoDecoder<LIBAV_VER
|
||||
mDMABufSurfaces.EmplaceBack(surface, mLib);
|
||||
surfaceWrapper = &(mDMABufSurfaces[mDMABufSurfaces.Length() - 1]);
|
||||
} else {
|
||||
+ // Release VAAPI surface data before we reuse it.
|
||||
+ if (mVAAPIDeviceContext) {
|
||||
+ surfaceWrapper->ReleaseVAAPIData();
|
||||
+ }
|
||||
+
|
||||
surface = surfaceWrapper->GetDMABufSurface();
|
||||
bool ret;
|
||||
|
||||
diff -up firefox-79.0/widget/gtk/DMABufSurface.cpp.mozilla-1656436 firefox-79.0/widget/gtk/DMABufSurface.cpp
|
||||
--- firefox-79.0/widget/gtk/DMABufSurface.cpp.mozilla-1656436 2020-08-04 13:31:49.477663237 +0200
|
||||
+++ firefox-79.0/widget/gtk/DMABufSurface.cpp 2020-08-04 13:33:07.666230023 +0200
|
||||
@@ -744,7 +744,8 @@ bool DMABufSurfaceYUV::UpdateYUVData(con
|
||||
return false;
|
||||
}
|
||||
if (mDmabufFds[0] >= 0) {
|
||||
- ReleaseSurface();
|
||||
+ NS_WARNING("DMABufSurfaceYUV is already created!");
|
||||
+ return false;
|
||||
}
|
||||
|
||||
mSurfaceFormat = gfx::SurfaceFormat::NV12;
|
@ -1,72 +0,0 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Olivier Tilloy <olivier@tilloy.net>
|
||||
# Date 1598829330 0
|
||||
# Node ID 02a9269355fc257811aca4d0966d2f8d99e17732
|
||||
# Parent a8ca363a76ba63f62e364c3d6976ab5859d0a064
|
||||
Bug 1661715 - Move GTK function stubs to the correct section. r=karlt, a=RyanVM
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D88588
|
||||
|
||||
diff --git a/widget/gtk/mozgtk/mozgtk.c b/widget/gtk/mozgtk/mozgtk.c
|
||||
--- a/widget/gtk/mozgtk/mozgtk.c
|
||||
+++ b/widget/gtk/mozgtk/mozgtk.c
|
||||
@@ -524,21 +524,19 @@ STUB(gtk_window_resize)
|
||||
STUB(gtk_window_set_accept_focus)
|
||||
STUB(gtk_window_set_decorated)
|
||||
STUB(gtk_window_set_deletable)
|
||||
STUB(gtk_window_set_destroy_with_parent)
|
||||
STUB(gtk_window_set_focus_on_map)
|
||||
STUB(gtk_window_set_geometry_hints)
|
||||
STUB(gtk_window_set_icon_name)
|
||||
STUB(gtk_window_set_modal)
|
||||
-STUB(gdk_window_set_opaque_region)
|
||||
STUB(gtk_window_set_skip_taskbar_hint)
|
||||
STUB(gtk_window_set_startup_id)
|
||||
STUB(gtk_window_set_title)
|
||||
-STUB(gtk_window_set_titlebar)
|
||||
STUB(gtk_window_set_transient_for)
|
||||
STUB(gtk_window_set_type_hint)
|
||||
STUB(gtk_window_set_wmclass)
|
||||
STUB(gtk_window_unfullscreen)
|
||||
STUB(gtk_window_unmaximize)
|
||||
#endif
|
||||
|
||||
#ifdef GTK3_SYMBOLS
|
||||
@@ -549,16 +547,17 @@ STUB(gdk_device_manager_get_client_point
|
||||
STUB(gdk_disable_multidevice)
|
||||
STUB(gdk_device_manager_list_devices)
|
||||
STUB(gdk_display_get_device_manager)
|
||||
STUB(gdk_display_manager_open_display)
|
||||
STUB(gdk_error_trap_pop_ignored)
|
||||
STUB(gdk_event_get_source_device)
|
||||
STUB(gdk_screen_get_monitor_workarea)
|
||||
STUB(gdk_window_get_type)
|
||||
+STUB(gdk_window_set_opaque_region)
|
||||
STUB(gdk_x11_window_get_xid)
|
||||
STUB(gdk_x11_display_get_type)
|
||||
STUB(gdk_wayland_display_get_type)
|
||||
STUB(gdk_wayland_display_get_wl_compositor)
|
||||
STUB(gdk_wayland_display_get_wl_display)
|
||||
STUB(gdk_wayland_window_get_wl_surface)
|
||||
STUB(gtk_box_new)
|
||||
STUB(gtk_cairo_should_draw_window)
|
||||
@@ -629,16 +628,17 @@ STUB(gtk_widget_path_copy)
|
||||
STUB(gtk_widget_path_free)
|
||||
STUB(gtk_widget_path_iter_add_class)
|
||||
STUB(gtk_widget_path_get_object_type)
|
||||
STUB(gtk_widget_path_length)
|
||||
STUB(gtk_widget_path_new)
|
||||
STUB(gtk_widget_path_unref)
|
||||
STUB(gtk_widget_set_valign)
|
||||
STUB(gtk_widget_set_visual)
|
||||
+STUB(gtk_window_set_titlebar)
|
||||
STUB(gtk_app_chooser_dialog_new_for_content_type)
|
||||
STUB(gtk_app_chooser_get_type)
|
||||
STUB(gtk_app_chooser_get_app_info)
|
||||
STUB(gtk_app_chooser_dialog_get_type)
|
||||
STUB(gtk_app_chooser_dialog_set_heading)
|
||||
STUB(gtk_color_chooser_dialog_new)
|
||||
STUB(gtk_color_chooser_dialog_get_type)
|
||||
STUB(gtk_color_chooser_get_type)
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (cbindgen-vendor.tar.xz) = f0425020e2d43a3d28b03f82bdb9719728112a2c94b1d595da384d0674ca21d0940a6f729a690434d670e598fbc6bb5193c89da0a4633a734c70dd786222e711
|
||||
SHA512 (firefox-80.0.1.source.tar.xz) = 97a54e5f0ff0e34d0994b9ea67250fda1e9a51acb1129a5f6ce632ca5d15132ae4e5eb18c1a9a609a14f5012daf87c6e1a5049e096dd1c32cac9e2c981381d10
|
||||
SHA512 (firefox-langpacks-80.0.1-20200901.tar.xz) = 2cd2f67eba01cc9b6a86f3e4a2b7e2cebe705bdf6912c627d7735897d9305e8eb8e9b39174dca75cd3545a5d047ad2d0c3122b23180a6a389d07afa8de01ee37
|
||||
SHA512 (firefox-81.0.source.tar.xz) = 859ebc3f898b0f44681033f6b11c983ace5d4db1c6e813129025bdbefcbe444b985a4f922664cabf3d3f99f0b12be7505c127ca0ad7ea259c17eb7d415b8c67a
|
||||
SHA512 (firefox-langpacks-81.0-20200915.tar.xz) = 91f28ce3b05a92753b8729f02f4402f4dc55116761e5d61ad2269317869a800efb4fa82b0cba31942085baacabb9292bb3b2057a30842dbb994f6e405af1614b
|
||||
|
Loading…
Reference in New Issue
Block a user