Fixed rhbz#676183 - firefox -g is broken
This commit is contained in:
parent
d08397af70
commit
73632afa5b
38
firefox-stub.patch
Normal file
38
firefox-stub.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -up firefox-4.0.1/mozilla-2.0/browser/build.mk.stub firefox-4.0.1/mozilla-2.0/browser/build.mk
|
||||
--- firefox-4.0.1/mozilla-2.0/browser/build.mk.stub 2011-04-14 07:28:21.000000000 +0200
|
||||
+++ firefox-4.0.1/mozilla-2.0/browser/build.mk 2011-05-10 11:33:21.343196025 +0200
|
||||
@@ -53,7 +53,7 @@ ifdef MOZ_SERVICES_SYNC
|
||||
tier_app_dirs += services
|
||||
endif
|
||||
|
||||
-tier_app_dirs += browser
|
||||
+tier_app_dirs += browser xulrunner
|
||||
# Never add other tier_app_dirs after browser. They won't get packaged
|
||||
# properly on mac.
|
||||
|
||||
diff -up firefox-4.0.1/mozilla-2.0/xulrunner/Makefile.in.stub firefox-4.0.1/mozilla-2.0/xulrunner/Makefile.in
|
||||
--- firefox-4.0.1/mozilla-2.0/xulrunner/Makefile.in.stub 2011-04-14 07:28:50.000000000 +0200
|
||||
+++ firefox-4.0.1/mozilla-2.0/xulrunner/Makefile.in 2011-05-10 11:33:21.343196025 +0200
|
||||
@@ -44,10 +44,7 @@ VPATH = @srcdir@
|
||||
include $(DEPTH)/config/autoconf.mk
|
||||
|
||||
PARALLEL_DIRS = \
|
||||
- app \
|
||||
- setup \
|
||||
stub \
|
||||
- examples \
|
||||
$(NULL)
|
||||
|
||||
ifeq ($(OS_ARCH),WINNT)
|
||||
diff -up firefox-4.0.1/mozilla-2.0/xulrunner/stub/Makefile.in.stub firefox-4.0.1/mozilla-2.0/xulrunner/stub/Makefile.in
|
||||
--- firefox-4.0.1/mozilla-2.0/xulrunner/stub/Makefile.in.stub 2011-05-10 11:38:26.000000000 +0200
|
||||
+++ firefox-4.0.1/mozilla-2.0/xulrunner/stub/Makefile.in 2011-05-10 11:38:35.054399530 +0200
|
||||
@@ -101,7 +101,7 @@ WIN32_EXE_LDFLAGS += -ENTRY:wmainCRTStar
|
||||
endif
|
||||
endif
|
||||
|
||||
-LIBS += $(JEMALLOC_LIBS)
|
||||
+#LIBS += $(JEMALLOC_LIBS)
|
||||
|
||||
include $(topsrcdir)/config/rules.mk
|
||||
|
@ -48,7 +48,7 @@ case $MOZ_ARCH in
|
||||
;;
|
||||
esac
|
||||
|
||||
MOZ_FIREFOX_FILE="application.ini"
|
||||
MOZ_FIREFOX_FILE="firefox"
|
||||
|
||||
if [ ! -r $MOZ_LIB_DIR/firefox-FIREFOX_VERSION/$MOZ_FIREFOX_FILE ]; then
|
||||
if [ ! -r $SECONDARY_LIB_DIR/firefox-FIREFOX_VERSION/$MOZ_FIREFOX_FILE ]; then
|
||||
@ -64,7 +64,7 @@ MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox-FIREFOX_VERSION"
|
||||
MOZ_XUL_DIR="$MOZ_LIB_DIR/XULRUNNER_DIRECTORY"
|
||||
MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
|
||||
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
|
||||
MOZ_PROGRAM="/usr/bin/xulrunner $MOZ_DIST_BIN/$MOZ_FIREFOX_FILE"
|
||||
MOZ_PROGRAM="$MOZ_DIST_BIN/$MOZ_FIREFOX_FILE"
|
||||
MOZ_LAUNCHER="$MOZ_DIST_BIN/run-mozilla.sh"
|
||||
|
||||
##
|
||||
|
12
firefox.spec
12
firefox.spec
@ -45,7 +45,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 4.0.1
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
Release: 2%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -65,6 +65,7 @@ Source23: firefox.1
|
||||
Patch0: firefox-version.patch
|
||||
|
||||
# Fedora patches
|
||||
Patch12: firefox-stub.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch30: firefox-4.0-moz-app-launcher.patch
|
||||
@ -117,6 +118,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{firefox_dir_ver}/' %{P:%%PATCH0} \
|
||||
# For branding specific patches.
|
||||
|
||||
# Fedora patches
|
||||
%patch12 -p2 -b .stub
|
||||
|
||||
# Upstream patches
|
||||
%patch30 -p1 -b .moz-app-launcher
|
||||
@ -279,6 +281,10 @@ done
|
||||
sed -i -e "s/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/" $RPM_BUILD_ROOT/%{mozappdir}/application.ini
|
||||
%endif
|
||||
|
||||
# Install our xulrunner stub
|
||||
%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/firefox
|
||||
%{__cp} xulrunner/stub/xulrunner-stub $RPM_BUILD_ROOT/%{mozappdir}/firefox
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%preun
|
||||
@ -307,6 +313,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/firefox
|
||||
%{mozappdir}/firefox
|
||||
%doc %{_mandir}/man1/*
|
||||
%dir %{_datadir}/mozilla/extensions/%{firefox_app_id}
|
||||
%dir %{_libdir}/mozilla/extensions/%{firefox_app_id}
|
||||
@ -348,6 +355,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue May 10 2011 Martin Stransky <stransky@redhat.com> - 4.0.1-2
|
||||
- Fixed rhbz#676183 - "firefox -g" is broken
|
||||
|
||||
* Thu Apr 28 2011 Christopher Aillon <caillon@redhat.com> - 4.0.1-1
|
||||
- Update to 4.0.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user