Fix an issue with a stray glyph in the window title bar.

The ASCII DEL (127) character was appended to the end of every title bar.

This patch fixes the issue by properly assigning PRE_RELEASE_SUFFIX
to an empty string rather than a literal "".  The literal double-quotes
were getting defined to the preprocessor as -DPRE_RELEASE_SUFFIX=""""
and after preprocessing, browser.xul had ASCII DEL (127) characters
instead of the empty string.
This commit is contained in:
Christopher Aillon 2011-06-24 14:01:53 -07:00
parent c7b675230f
commit 703a267d1c
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,15 @@
Patch from: Bill Nottingham <notting@redhat.com>
diff -up mozilla-release/browser/base/Makefile.in.fu mozilla-release/browser/base/Makefile.in
--- mozilla-release/browser/base/Makefile.in.fu 2011-06-24 16:50:23.802042086 -0400
+++ mozilla-release/browser/base/Makefile.in 2011-06-24 16:50:42.324042096 -0400
@@ -62,7 +62,7 @@ EXTRA_JS_MODULES = \
include $(topsrcdir)/config/rules.mk
-PRE_RELEASE_SUFFIX := ""
+PRE_RELEASE_SUFFIX :=
DEFINES += \
-DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \

View File

@ -45,7 +45,7 @@
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 5.0
Release: 1%{?pre_tag}%{?dist}
Release: 2%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@ -68,6 +68,7 @@ Patch1: firefox-5.0-cache-build.patch
# Fedora patches
Patch12: firefox-stub.patch
Patch13: firefox-5.0-xulstub.patch
Patch14: firefox-5.0-asciidel.patch
# Upstream patches
Patch30: firefox-4.0-moz-app-launcher.patch
@ -125,6 +126,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{firefox_dir_ver}/' %{P:%%PATCH0} \
# Fedora patches
%patch12 -p2 -b .stub
%patch13 -p1 -R -b .xulstub
%patch14 -p1 -b .asciidel
# Upstream patches
%patch30 -p1 -b .moz-app-launcher
@ -361,6 +363,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
* Fri Jun 24 2011 Bill Nottingham <notting@redhat.com> - 5.0-2
- Fix an issue with a stray glyph in the window title
* Tue Jun 21 2011 Martin Stransky <stransky@redhat.com> - 5.0-1
- Update to 5.0