Removed unused patches

This commit is contained in:
Martin Stransky 2019-01-29 12:08:49 +01:00
parent 6ed7574285
commit 6ee98514e3
7 changed files with 0 additions and 13993 deletions

View File

@ -100,7 +100,6 @@ Source31: firefox-x11.desktop
Patch3: mozilla-build-arm.patch
Patch25: rhbz-1219542-s390-build.patch
Patch26: build-icu-big-endian.patch
Patch27: mozilla-1335250.patch
Patch32: build-rust-ppc64le.patch
Patch35: build-ppc-jit.patch
# Always feel lucky for unsupported platforms:
@ -124,21 +123,15 @@ Patch227: firefox-locale-debug.patch
# Upstream patches
Patch402: mozilla-1196777.patch
Patch406: mozilla-256180.patch
Patch410: mozilla-1321521.patch
Patch411: mozilla-1321521-2.patch
Patch412: mozilla-1337988.patch
Patch413: mozilla-1353817.patch
Patch414: mozilla-1435212-ffmpeg-4.0.patch
Patch415: Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
Patch416: mozilla-1424422.patch
Patch417: bug1375074-save-restore-x28.patch
# Wayland specific upstream patches
Patch574: firefox-pipewire.patch
# Debian patches
Patch500: mozilla-440908.patch
# PGO/LTO patches
Patch600: pgo.patch
Patch601: mozilla-1516081.patch

View File

@ -1,37 +0,0 @@
# HG changeset patch
# User Lars T Hansen <lhansen@mozilla.com>
# Date 1485506824 -3600
# Node ID 97c45b13a1654bce114ace1de67c5aacb12a75fd
# Parent 0fc3d0ffe71e44819c6ffaf3a41b781e50504576
Bug 1321521 - fix include order. r=me
diff --git a/js/src/jit/none/Architecture-none.h b/js/src/jit/none/Architecture-none.h
--- a/js/src/jit/none/Architecture-none.h
+++ b/js/src/jit/none/Architecture-none.h
@@ -2,22 +2,22 @@
* vim: set ts=8 sts=4 et sw=4 tw=99:
* This Source Code Form is subject to the terms of the Mozilla Public
* License, v. 2.0. If a copy of the MPL was not distributed with this
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
#ifndef jit_none_Architecture_none_h
#define jit_none_Architecture_none_h
-#include "jit/shared/Architecture-shared.h"
-
// JitSpewer.h is included through MacroAssembler implementations for other
// platforms, so include it here to avoid inadvertent build bustage.
#include "jit/JitSpewer.h"
+#include "jit/shared/Architecture-shared.h"
+
namespace js {
namespace jit {
static const bool SupportsSimd = false;
static const uint32_t SimdMemoryAlignment = 4; // Make it 4 to avoid a bunch of div-by-zero warnings
static const uint32_t WasmStackAlignment = 8;
// Does this architecture support SIMD conversions between Uint32x4 and Float32x4?

View File

@ -1,62 +0,0 @@
# HG changeset patch
# User Lars T Hansen <lhansen@mozilla.com>
# Date 1485504866 -3600
# Node ID 2c924fb664c18fb3c17bdbf6fc4d808b9107b87a
# Parent 505e39fbc5ed9857ba12c1c12608fc1cca5c43be
Bug 1321521 - register set adjustments for 'none' platform, r=me
diff --git a/js/src/jit/none/Architecture-none.h b/js/src/jit/none/Architecture-none.h
--- a/js/src/jit/none/Architecture-none.h
+++ b/js/src/jit/none/Architecture-none.h
@@ -2,16 +2,18 @@
* vim: set ts=8 sts=4 et sw=4 tw=99:
* This Source Code Form is subject to the terms of the Mozilla Public
* License, v. 2.0. If a copy of the MPL was not distributed with this
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
#ifndef jit_none_Architecture_none_h
#define jit_none_Architecture_none_h
+#include "jit/shared/Architecture-shared.h"
+
// JitSpewer.h is included through MacroAssembler implementations for other
// platforms, so include it here to avoid inadvertent build bustage.
#include "jit/JitSpewer.h"
namespace js {
namespace jit {
static const bool SupportsSimd = false;
@@ -126,16 +128,30 @@ struct FloatRegister
bool aliases(FloatRegister) const { MOZ_CRASH(); }
uint32_t numAliased() const { MOZ_CRASH(); }
void aliased(uint32_t, FloatRegister*) { MOZ_CRASH(); }
bool equiv(FloatRegister) const { MOZ_CRASH(); }
uint32_t size() const { MOZ_CRASH(); }
uint32_t numAlignedAliased() const { MOZ_CRASH(); }
void alignedAliased(uint32_t, FloatRegister*) { MOZ_CRASH(); }
SetType alignedOrDominatedAliasedSet() const { MOZ_CRASH(); }
+
+ static constexpr RegTypeName DefaultType = RegTypeName::Float64;
+
+ template <RegTypeName = DefaultType>
+ static SetType LiveAsIndexableSet(SetType s) {
+ return SetType(0);
+ }
+
+ template <RegTypeName Name = DefaultType>
+ static SetType AllocatableAsIndexableSet(SetType s) {
+ static_assert(Name != RegTypeName::Any, "Allocatable set are not iterable");
+ return SetType(0);
+ }
+
template <typename T> static T ReduceSetForPush(T) { MOZ_CRASH(); }
uint32_t getRegisterDumpOffsetInBytes() { MOZ_CRASH(); }
static uint32_t SetSize(SetType x) { MOZ_CRASH(); }
static Code FromName(const char* name) { MOZ_CRASH(); }
// This is used in static initializers, so produce a bogus value instead of crashing.
static uint32_t GetPushSizeInBytes(const TypedRegisterSet<FloatRegister>&) { return 0; }
};

View File

@ -1,30 +0,0 @@
diff -up firefox-53.0/dom/media/webrtc/MediaEngine.h.1335250 firefox-53.0/dom/media/webrtc/MediaEngine.h
--- firefox-53.0/dom/media/webrtc/MediaEngine.h.1335250 2017-04-11 06:15:22.000000000 +0200
+++ firefox-53.0/dom/media/webrtc/MediaEngine.h 2017-04-19 20:35:55.264741939 +0200
@@ -226,7 +226,7 @@ public:
~AllocationHandle() {}
public:
AllocationHandle(const dom::MediaTrackConstraints& aConstraints,
- const ipc::PrincipalInfo& aPrincipalInfo,
+ const mozilla::ipc::PrincipalInfo& aPrincipalInfo,
const MediaEnginePrefs& aPrefs,
const nsString& aDeviceId)
@@ -236,7 +236,7 @@ public:
mDeviceId(aDeviceId) {}
public:
NormalizedConstraints mConstraints;
- ipc::PrincipalInfo mPrincipalInfo;
+ mozilla::ipc::PrincipalInfo mPrincipalInfo;
MediaEnginePrefs mPrefs;
nsString mDeviceId;
};
@@ -327,7 +327,7 @@ public:
virtual nsresult Allocate(const dom::MediaTrackConstraints &aConstraints,
const MediaEnginePrefs &aPrefs,
const nsString& aDeviceId,
- const ipc::PrincipalInfo& aPrincipalInfo,
+ const mozilla::ipc::PrincipalInfo& aPrincipalInfo,
AllocationHandle** aOutHandle,
const char** aOutBadConstraint)
{

View File

@ -1,129 +0,0 @@
diff -up firefox-61.0/browser/base/content/browser.js.1424422 firefox-61.0/browser/base/content/browser.js
diff -up firefox-61.0/browser/base/content/browser-tabsintitlebar.js.1424422 firefox-61.0/browser/base/content/browser-tabsintitlebar.js
--- firefox-61.0/browser/base/content/browser-tabsintitlebar.js.1424422 2018-06-19 01:03:32.000000000 +0200
+++ firefox-61.0/browser/base/content/browser-tabsintitlebar.js 2018-06-20 14:59:44.121827553 +0200
@@ -36,6 +36,7 @@ var TabsInTitlebar = {
window.addEventListener("resize", this);
gDragSpaceObserver.init();
+ gLightThemeObserver.init();
this._initialized = true;
this.update();
@@ -302,6 +303,7 @@ var TabsInTitlebar = {
this._menuObserver.disconnect();
CustomizableUI.removeListener(this);
gDragSpaceObserver.uninit();
+ gLightThemeObserver.uninit();
}
};
@@ -343,3 +345,21 @@ var gDragSpaceObserver = {
TabsInTitlebar.update();
},
};
+
+var gLightThemeObserver = {
+ init() {
+ Services.obs.addObserver(this, "lightweight-theme-styling-update");
+ },
+
+ uninit() {
+ Services.obs.removeObserver(this, "lightweight-theme-styling-update");
+ },
+
+ observe(aSubject, aTopic, aData) {
+ switch (aTopic) {
+ case "lightweight-theme-styling-update":
+ TabsInTitlebar.updateAppearance(true);
+ break;
+ }
+ },
+};
diff -up firefox-61.0/browser/themes/linux/browser.css.1424422 firefox-61.0/browser/themes/linux/browser.css
--- firefox-61.0/browser/themes/linux/browser.css.1424422 2018-06-19 01:03:33.000000000 +0200
+++ firefox-61.0/browser/themes/linux/browser.css 2018-06-20 14:17:43.193681172 +0200
@@ -709,12 +709,20 @@ notification[value="translation"] menuli
}
@media (-moz-gtk-csd-maximize-button) {
- #titlebar-max {
+ #titlebar-max:not(:-moz-lwtheme) {
-moz-appearance: -moz-window-button-maximize;
}
- :root[sizemode="maximized"] #titlebar-max {
+ #titlebar-max:-moz-lwtheme {
+ -moz-appearance: none !important;
+ list-style-image: url(chrome://browser/skin/window-controls/maximize-themes.svg);
+ }
+ :root[sizemode="maximized"] #titlebar-max:not(:-moz-lwtheme) {
-moz-appearance: -moz-window-button-restore;
}
+ :root[sizemode="maximized"] #titlebar-max:-moz-lwtheme {
+ -moz-appearance: none !important;
+ list-style-image: url(chrome://browser/skin/window-controls/restore-themes.svg);
+ }
}
@media (-moz-gtk-csd-maximize-button: 0) {
#titlebar-max {
@@ -723,9 +731,13 @@ notification[value="translation"] menuli
}
@media (-moz-gtk-csd-close-button) {
- #titlebar-close {
+ #titlebar-close:not(:-moz-lwtheme) {
-moz-appearance: -moz-window-button-close;
}
+ #titlebar-close:-moz-lwtheme {
+ -moz-appearance: none !important;
+ list-style-image: url(chrome://browser/skin/window-controls/close-themes.svg);
+ }
}
@media (-moz-gtk-csd-close-button: 0) {
#titlebar-close {
diff -up firefox-61.0/browser/themes/linux/jar.mn.1424422 firefox-61.0/browser/themes/linux/jar.mn
diff -up firefox-61.0/browser/themes/linux/window-controls/close-themes.svg.1424422 firefox-61.0/browser/themes/linux/window-controls/close-themes.svg
--- firefox-61.0/browser/themes/linux/window-controls/close-themes.svg.1424422 2018-06-20 14:17:43.194681169 +0200
+++ firefox-61.0/browser/themes/linux/window-controls/close-themes.svg 2018-06-20 14:17:43.194681169 +0200
@@ -0,0 +1,7 @@
+<!-- This Source Code Form is subject to the terms of the Mozilla Public
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+<svg width="12" height="12" xmlns="http://www.w3.org/2000/svg">
+ <path stroke="black" stroke-width="3.6" stroke-opacity=".75" d="M1,1 l 10,10 M1,11 l 10,-10"/>
+ <path stroke="white" stroke-width="1.9" d="M1.75,1.75 l 8.5,8.5 M1.75,10.25 l 8.5,-8.5"/>
+</svg>
diff -up firefox-61.0/browser/themes/linux/window-controls/maximize-themes.svg.1424422 firefox-61.0/browser/themes/linux/window-controls/maximize-themes.svg
--- firefox-61.0/browser/themes/linux/window-controls/maximize-themes.svg.1424422 2018-06-20 14:17:43.194681169 +0200
+++ firefox-61.0/browser/themes/linux/window-controls/maximize-themes.svg 2018-06-20 14:17:43.194681169 +0200
@@ -0,0 +1,7 @@
+<!-- This Source Code Form is subject to the terms of the Mozilla Public
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+<svg width="12" height="12" xmlns="http://www.w3.org/2000/svg" shape-rendering="crispEdges" fill="none">
+ <rect stroke="black" stroke-width="3.6" stroke-opacity=".75" x="2" y="2" width="8" height="8"/>
+ <rect stroke="white" stroke-width="1.9" x="2" y="2" width="8" height="8"/>
+</svg>
diff -up firefox-61.0/browser/themes/linux/window-controls/minimize-themes.svg.1424422 firefox-61.0/browser/themes/linux/window-controls/minimize-themes.svg
--- firefox-61.0/browser/themes/linux/window-controls/minimize-themes.svg.1424422 2018-06-20 14:17:43.194681169 +0200
+++ firefox-61.0/browser/themes/linux/window-controls/minimize-themes.svg 2018-06-20 14:17:43.194681169 +0200
@@ -0,0 +1,7 @@
+<!-- This Source Code Form is subject to the terms of the Mozilla Public
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+<svg width="12" height="12" xmlns="http://www.w3.org/2000/svg" shape-rendering="crispEdges">
+ <line stroke="black" stroke-width="3.6" stroke-opacity=".75" x1="0" y1="6" x2="12" y2="6"/>
+ <line stroke="white" stroke-width="1.9" x1="1" y1="6" x2="11" y2="6"/>
+</svg>
diff -up firefox-61.0/browser/themes/linux/window-controls/restore-themes.svg.1424422 firefox-61.0/browser/themes/linux/window-controls/restore-themes.svg
--- firefox-61.0/browser/themes/linux/window-controls/restore-themes.svg.1424422 2018-06-20 14:17:43.194681169 +0200
+++ firefox-61.0/browser/themes/linux/window-controls/restore-themes.svg 2018-06-20 14:17:43.194681169 +0200
@@ -0,0 +1,8 @@
+<!-- This Source Code Form is subject to the terms of the Mozilla Public
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+<svg width="12" height="12" xmlns="http://www.w3.org/2000/svg" shape-rendering="crispEdges" fill="none" stroke="white">
+ <path stroke="black" stroke-width="3.6" stroke-opacity=".75" d="M2,4 l 6,0 l 0,6 l -6,0z M2.5,1.5 l 8,0 l 0,8"/>
+ <rect stroke-width="1.9" x="2" y="4" width="6" height="6"/>
+ <polyline stroke-width=".9" points="3.5,1.5 10.5,1.5 10.5,8.5"/>
+</svg>

File diff suppressed because it is too large Load Diff

View File

@ -1,40 +0,0 @@
diff -up firefox-62.0.3/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-62.0.3/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
diff -up firefox-62.0.3/media/webrtc/trunk/Makefile.old firefox-62.0.3/media/webrtc/trunk/Makefile
diff -up firefox-62.0.3/widget/gtk/nsClipboardWayland.cpp.old firefox-62.0.3/widget/gtk/nsClipboardWayland.cpp
--- firefox-62.0.3/widget/gtk/nsClipboardWayland.cpp.old 2018-10-05 12:52:40.067567770 +0200
+++ firefox-62.0.3/widget/gtk/nsClipboardWayland.cpp 2018-09-21 12:39:40.477095989 +0200
@@ -153,7 +153,7 @@ DataOffer::GetData(wl_display* aDisplay,
GIOChannel *channel = g_io_channel_unix_new(pipe_fd[0]);
GError* error = nullptr;
- char* clipboardData;
+ char* clipboardData = nullptr;
g_io_channel_set_encoding(channel, nullptr, &error);
if (!error) {
@@ -470,13 +470,17 @@ nsRetrievalContextWayland::SetClipboardD
// Delete existing clipboard data offer
mClipboardOffer = nullptr;
- DataOffer* dataOffer =
- static_cast<DataOffer*>(g_hash_table_lookup(mActiveOffers,
- aWaylandDataOffer));
- NS_ASSERTION(dataOffer, "We're missing clipboard data offer!");
- if (dataOffer) {
- g_hash_table_remove(mActiveOffers, aWaylandDataOffer);
- mClipboardOffer = dataOffer;
+ // null aWaylandDataOffer indicates that our clipboard content
+ // is no longer valid and should be release.
+ if (aWaylandDataOffer != nullptr) {
+ DataOffer* dataOffer =
+ static_cast<DataOffer*>(g_hash_table_lookup(mActiveOffers,
+ aWaylandDataOffer));
+ NS_ASSERTION(dataOffer, "We're missing stored clipboard data offer!");
+ if (dataOffer) {
+ g_hash_table_remove(mActiveOffers, aWaylandDataOffer);
+ mClipboardOffer = dataOffer;
+ }
}
}
diff -up firefox-62.0.3/widget/gtk/nsClipboardWayland.h.old firefox-62.0.3/widget/gtk/nsClipboardWayland.h