PGO build test
This commit is contained in:
parent
00f4c0352b
commit
6cd2d4351d
22
firefox.spec
22
firefox.spec
@ -14,12 +14,10 @@ ExcludeArch: armv7hl
|
|||||||
%global build_with_clang 0
|
%global build_with_clang 0
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%global build_with_pgo 0
|
%global build_with_pgo 1
|
||||||
%global use_bundled_cbindgen 1
|
%global use_bundled_cbindgen 1
|
||||||
%if 0%{?fedora} > 29
|
%if 0%{?fedora} > 29
|
||||||
%global wayland_backend_default 1
|
%global wayland_backend_default 1
|
||||||
%else
|
|
||||||
%global wayland_backend_default 0
|
|
||||||
%endif
|
%endif
|
||||||
# Big endian platforms
|
# Big endian platforms
|
||||||
%ifarch ppc64 s390x
|
%ifarch ppc64 s390x
|
||||||
@ -80,7 +78,7 @@ Summary: Mozilla Firefox Web browser
|
|||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 64.0
|
Version: 64.0
|
||||||
|
|
||||||
Release: 4%{?pre_tag}%{?dist}
|
Release: 5%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
@ -151,6 +149,8 @@ Patch586: firefox-wayland-crash-mozbz1507475.patch
|
|||||||
# Debian patches
|
# Debian patches
|
||||||
Patch500: mozilla-440908.patch
|
Patch500: mozilla-440908.patch
|
||||||
|
|
||||||
|
Patch501: pgo.patch
|
||||||
|
|
||||||
%if %{?system_nss}
|
%if %{?system_nss}
|
||||||
BuildRequires: pkgconfig(nspr) >= %{nspr_version}
|
BuildRequires: pkgconfig(nspr) >= %{nspr_version}
|
||||||
BuildRequires: pkgconfig(nss) >= %{nss_version}
|
BuildRequires: pkgconfig(nss) >= %{nss_version}
|
||||||
@ -268,7 +268,7 @@ debug %{name}, you want to install %{name}-debuginfo instead.
|
|||||||
%files -n %{crashreporter_pkg_name} -f debugcrashreporter.list
|
%files -n %{crashreporter_pkg_name} -f debugcrashreporter.list
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{?wayland_backend_default}
|
%if 0%{?wayland_backend_default}
|
||||||
%package x11
|
%package x11
|
||||||
Summary: Firefox X11 launcher.
|
Summary: Firefox X11 launcher.
|
||||||
Requires: %{name}
|
Requires: %{name}
|
||||||
@ -356,6 +356,9 @@ This package contains results of tests executed during build.
|
|||||||
%patch585 -p1 -b .mozbz1507475
|
%patch585 -p1 -b .mozbz1507475
|
||||||
%patch586 -p1 -b .crash-mozbz1507475
|
%patch586 -p1 -b .crash-mozbz1507475
|
||||||
|
|
||||||
|
%patch501 -p1 -b .pgo
|
||||||
|
|
||||||
|
|
||||||
%{__rm} -f .mozconfig
|
%{__rm} -f .mozconfig
|
||||||
%{__cp} %{SOURCE10} .mozconfig
|
%{__cp} %{SOURCE10} .mozconfig
|
||||||
echo "ac_add_options --enable-default-toolkit=cairo-gtk3-wayland" >> .mozconfig
|
echo "ac_add_options --enable-default-toolkit=cairo-gtk3-wayland" >> .mozconfig
|
||||||
@ -607,14 +610,14 @@ DESTDIR=%{buildroot} make -C objdir install
|
|||||||
%{__mkdir_p} %{buildroot}{%{_libdir},%{_bindir},%{_datadir}/applications}
|
%{__mkdir_p} %{buildroot}{%{_libdir},%{_bindir},%{_datadir}/applications}
|
||||||
|
|
||||||
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE20}
|
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE20}
|
||||||
%if %{?wayland_backend_default}
|
%if 0%{?wayland_backend_default}
|
||||||
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE31}
|
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE31}
|
||||||
%else
|
%else
|
||||||
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE29}
|
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE29}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# set up the firefox start script
|
# set up the firefox start script
|
||||||
%if %{?wayland_backend_default}
|
%if 0%{?wayland_backend_default}
|
||||||
%global x11_state false
|
%global x11_state false
|
||||||
%else
|
%else
|
||||||
%global x11_state true
|
%global x11_state true
|
||||||
@ -623,7 +626,7 @@ desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE29}
|
|||||||
%{__sed} -e 's/__DEFAULT_X11__/%{x11_state}/' %{SOURCE21} > %{buildroot}%{_bindir}/firefox
|
%{__sed} -e 's/__DEFAULT_X11__/%{x11_state}/' %{SOURCE21} > %{buildroot}%{_bindir}/firefox
|
||||||
|
|
||||||
%{__chmod} 755 %{buildroot}%{_bindir}/firefox
|
%{__chmod} 755 %{buildroot}%{_bindir}/firefox
|
||||||
%if %{?wayland_backend_default}
|
%if 0%{?wayland_backend_default}
|
||||||
%{__cat} %{SOURCE30} > %{buildroot}%{_bindir}/firefox-x11
|
%{__cat} %{SOURCE30} > %{buildroot}%{_bindir}/firefox-x11
|
||||||
%{__chmod} 755 %{buildroot}%{_bindir}/firefox-x11
|
%{__chmod} 755 %{buildroot}%{_bindir}/firefox-x11
|
||||||
%else
|
%else
|
||||||
@ -890,6 +893,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 21 2018 Martin Stransky <stransky@redhat.com> - 64.0-5
|
||||||
|
- Test PGO build.
|
||||||
|
|
||||||
* Wed Dec 12 2018 Martin Stransky <stransky@redhat.com> - 64.0-4
|
* Wed Dec 12 2018 Martin Stransky <stransky@redhat.com> - 64.0-4
|
||||||
- Use gcc on all platforms for official release.
|
- Use gcc on all platforms for official release.
|
||||||
|
|
||||||
|
10
pgo.patch
Normal file
10
pgo.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff -up firefox-64.0/extensions/spellcheck/src/moz.build.old firefox-64.0/extensions/spellcheck/src/moz.build
|
||||||
|
--- firefox-64.0/extensions/spellcheck/src/moz.build.old 2018-12-20 12:23:16.103206546 +0100
|
||||||
|
+++ firefox-64.0/extensions/spellcheck/src/moz.build 2018-12-20 12:23:44.077140279 +0100
|
||||||
|
@@ -28,3 +28,5 @@ EXPORTS.mozilla += [
|
||||||
|
|
||||||
|
if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
|
||||||
|
CXXFLAGS += ['-Wno-error=shadow']
|
||||||
|
+
|
||||||
|
+CXXFLAGS += ['-fno-devirtualize']
|
||||||
|
\ No newline at end of file
|
Loading…
Reference in New Issue
Block a user