Related: #1976278 Update to 78.9.0 build1
They upgraded the bundled thin-vec from 0.1.0 to 0.1.2 which we already replaced with 0.2.1 for thin-vec-big-endian, hence that patch is re-assembled. (cherry picked from commit 2f941f655537bd4ce2df23c336c3ae0af48f9ade) Partly from rhel-8.4.0 (cherry picked from commit f78641b1265da0f68acaef752d75da5467b7f212) Conflicts: .gitignore firefox.spec sources
This commit is contained in:
parent
c58f7105dc
commit
622df82b99
@ -1,24 +1,19 @@
|
||||
diff -up firefox-78.1.0/Cargo.lock.D87019-thin-vec-big-endian.diff firefox-78.1.0/Cargo.lock
|
||||
--- firefox-78.1.0/Cargo.lock.D87019-thin-vec-big-endian.diff 2020-07-22 19:56:54.000000000 +0200
|
||||
+++ firefox-78.1.0/Cargo.lock 2020-08-17 17:04:24.133598583 +0200
|
||||
@@ -4792,12 +4792,9 @@ checksum = "8eaa81235c7058867fa8c0e7314f
|
||||
--- firefox-78.9.0/Cargo.lock.D87019-thin-vec-big-endian.diff 2021-03-18 15:53:29.520861862 +0100
|
||||
+++ firefox-78.9.0/Cargo.lock 2021-03-18 15:56:14.193397228 +0100
|
||||
@@ -4792,9 +4792,9 @@ checksum = "8eaa81235c7058867fa8c0e7314f
|
||||
|
||||
[[package]]
|
||||
name = "thin-vec"
|
||||
-version = "0.1.0"
|
||||
-version = "0.1.2"
|
||||
+version = "0.2.1"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "73fdf4b84c65a85168477b7fb6c498e0716bc9487fba24623389ea7f51708044"
|
||||
-dependencies = [
|
||||
- "libc",
|
||||
-]
|
||||
-checksum = "3a93c9ade36a827a69257925808463db46ffcf193442fad01eb9bdc1d31aed81"
|
||||
+checksum = "dcc760ada4a9f56fc6d0e81bd143984ebc7bb1b875a6891aa2fa613ca7394fc0"
|
||||
|
||||
[[package]]
|
||||
name = "thiserror"
|
||||
diff -up firefox-78.1.0/gfx/webrender_bindings/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/gfx/webrender_bindings/Cargo.toml
|
||||
--- firefox-78.1.0/gfx/webrender_bindings/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-08-17 17:04:24.133598583 +0200
|
||||
+++ firefox-78.1.0/gfx/webrender_bindings/Cargo.toml 2020-08-17 17:05:26.984805590 +0200
|
||||
--- firefox-78.9.0/gfx/webrender_bindings/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:33.000000000 +0100
|
||||
+++ firefox-78.9.0/gfx/webrender_bindings/Cargo.toml 2021-03-18 15:53:29.522861856 +0100
|
||||
@@ -20,7 +20,7 @@ nsstring = { path = "../../xpcom/rust/ns
|
||||
bincode = "1.0"
|
||||
uuid = { version = "0.8", features = ["v4"] }
|
||||
@ -28,18 +23,16 @@ diff -up firefox-78.1.0/gfx/webrender_bindings/Cargo.toml.D87019-thin-vec-big-en
|
||||
swgl = { path = "../wr/swgl" }
|
||||
|
||||
[dependencies.webrender]
|
||||
diff -up firefox-78.1.0/intl/l10n/rust/fluent-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/intl/l10n/rust/fluent-ffi/Cargo.toml
|
||||
--- firefox-78.1.0/intl/l10n/rust/fluent-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:20.000000000 +0200
|
||||
+++ firefox-78.1.0/intl/l10n/rust/fluent-ffi/Cargo.toml 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/intl/l10n/rust/fluent-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:33.000000000 +0100
|
||||
+++ firefox-78.9.0/intl/l10n/rust/fluent-ffi/Cargo.toml 2021-03-18 15:53:29.524861850 +0100
|
||||
@@ -10,4 +10,4 @@ fluent-pseudo = "0.2"
|
||||
intl-memoizer = "0.4"
|
||||
unic-langid = "0.8"
|
||||
nsstring = { path = "../../../../xpcom/rust/nsstring" }
|
||||
-thin-vec = { version = "0.1.0", features = ["gecko-ffi"] }
|
||||
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
|
||||
diff -up firefox-78.1.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml
|
||||
--- firefox-78.1.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:20.000000000 +0200
|
||||
+++ firefox-78.1.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:33.000000000 +0100
|
||||
+++ firefox-78.9.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml 2021-03-18 15:53:29.525861847 +0100
|
||||
@@ -9,7 +9,7 @@ edition = "2018"
|
||||
nserror = { path = "../../../../xpcom/rust/nserror" }
|
||||
nsstring = { path = "../../../../xpcom/rust/nsstring" }
|
||||
@ -49,9 +42,8 @@ diff -up firefox-78.1.0/intl/locale/rust/fluent-langneg-ffi/Cargo.toml.D87019-th
|
||||
fluent-langneg = { version = "0.12.1", features = ["cldr"] }
|
||||
unic-langid = "0.8"
|
||||
unic-langid-ffi = { path = "../unic-langid-ffi" }
|
||||
diff -up firefox-78.1.0/intl/locale/rust/unic-langid-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/intl/locale/rust/unic-langid-ffi/Cargo.toml
|
||||
--- firefox-78.1.0/intl/locale/rust/unic-langid-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:20.000000000 +0200
|
||||
+++ firefox-78.1.0/intl/locale/rust/unic-langid-ffi/Cargo.toml 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/intl/locale/rust/unic-langid-ffi/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:33.000000000 +0100
|
||||
+++ firefox-78.9.0/intl/locale/rust/unic-langid-ffi/Cargo.toml 2021-03-18 15:53:29.526861844 +0100
|
||||
@@ -9,5 +9,5 @@ edition = "2018"
|
||||
nserror = { path = "../../../../xpcom/rust/nserror" }
|
||||
nsstring = { path = "../../../../xpcom/rust/nsstring" }
|
||||
@ -59,9 +51,8 @@ diff -up firefox-78.1.0/intl/locale/rust/unic-langid-ffi/Cargo.toml.D87019-thin-
|
||||
-thin-vec = { version = "0.1.0", features = ["gecko-ffi"] }
|
||||
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
|
||||
unic-langid = { version = "0.8", features = ["likelysubtags"] }
|
||||
diff -up firefox-78.1.0/netwerk/socket/neqo_glue/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/netwerk/socket/neqo_glue/Cargo.toml
|
||||
--- firefox-78.1.0/netwerk/socket/neqo_glue/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-08-17 17:04:24.134598587 +0200
|
||||
+++ firefox-78.1.0/netwerk/socket/neqo_glue/Cargo.toml 2020-08-17 17:05:10.352750807 +0200
|
||||
--- firefox-78.9.0/netwerk/socket/neqo_glue/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:37.000000000 +0100
|
||||
+++ firefox-78.9.0/netwerk/socket/neqo_glue/Cargo.toml 2021-03-18 15:53:29.527861842 +0100
|
||||
@@ -14,7 +14,7 @@ neqo-common = { tag = "v0.2.4", git = "h
|
||||
nserror = { path = "../../../xpcom/rust/nserror" }
|
||||
nsstring = { path = "../../../xpcom/rust/nsstring" }
|
||||
@ -71,9 +62,8 @@ diff -up firefox-78.1.0/netwerk/socket/neqo_glue/Cargo.toml.D87019-thin-vec-big-
|
||||
|
||||
[dependencies.neqo-crypto]
|
||||
tag = "v0.2.4"
|
||||
diff -up firefox-78.1.0/security/manager/ssl/cert_storage/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/security/manager/ssl/cert_storage/Cargo.toml
|
||||
--- firefox-78.1.0/security/manager/ssl/cert_storage/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 19:56:55.000000000 +0200
|
||||
+++ firefox-78.1.0/security/manager/ssl/cert_storage/Cargo.toml 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/security/manager/ssl/cert_storage/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:37.000000000 +0100
|
||||
+++ firefox-78.9.0/security/manager/ssl/cert_storage/Cargo.toml 2021-03-18 15:53:29.528861839 +0100
|
||||
@@ -18,6 +18,6 @@ rust_cascade = "0.6.0"
|
||||
sha2 = "^0.8"
|
||||
storage_variant = { path = "../../../../storage/variant" }
|
||||
@ -82,9 +72,8 @@ diff -up firefox-78.1.0/security/manager/ssl/cert_storage/Cargo.toml.D87019-thin
|
||||
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
|
||||
time = "0.1"
|
||||
xpcom = { path = "../../../../xpcom/rust/xpcom" }
|
||||
diff -up firefox-78.1.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml
|
||||
--- firefox-78.1.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-08-17 17:04:24.134598587 +0200
|
||||
+++ firefox-78.1.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml 2020-08-17 17:04:52.432691786 +0200
|
||||
--- firefox-78.9.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:38.000000000 +0100
|
||||
+++ firefox-78.9.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/Cargo.toml 2021-03-18 15:53:29.528861839 +0100
|
||||
@@ -20,5 +20,5 @@ nserror = { path = "../../../../xpcom/ru
|
||||
nsstring = { path = "../../../../xpcom/rust/nsstring" }
|
||||
xpcom = { path = "../../../../xpcom/rust/xpcom" }
|
||||
@ -92,9 +81,8 @@ diff -up firefox-78.1.0/services/fxaccounts/rust-bridge/firefox-accounts-bridge/
|
||||
-thin-vec = { version = "0.1", features = ["gecko-ffi"] }
|
||||
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
|
||||
fxa-client = { git = "https://github.com/mozilla/application-services", rev = "61dcc364ac0d6d0816ab88a494bbf20d824b009b", features = ["gecko"] }
|
||||
diff -up firefox-78.1.0/services/sync/golden_gate/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/services/sync/golden_gate/Cargo.toml
|
||||
--- firefox-78.1.0/services/sync/golden_gate/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:24.000000000 +0200
|
||||
+++ firefox-78.1.0/services/sync/golden_gate/Cargo.toml 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/services/sync/golden_gate/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:38.000000000 +0100
|
||||
+++ firefox-78.9.0/services/sync/golden_gate/Cargo.toml 2021-03-18 15:53:29.529861836 +0100
|
||||
@@ -19,5 +19,5 @@ sync15-traits = { git = "https://github.
|
||||
xpcom = { path = "../../../xpcom/rust/xpcom" }
|
||||
|
||||
@ -102,52 +90,28 @@ diff -up firefox-78.1.0/services/sync/golden_gate/Cargo.toml.D87019-thin-vec-big
|
||||
-version = "0.1.0"
|
||||
+version = "0.2.1"
|
||||
features = ["gecko-ffi"]
|
||||
diff -up firefox-78.1.0/third_party/rust/thin-vec/.cargo-checksum.json.D87019-thin-vec-big-endian.diff firefox-78.1.0/third_party/rust/thin-vec/.cargo-checksum.json
|
||||
--- firefox-78.1.0/third_party/rust/thin-vec/.cargo-checksum.json.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:29.000000000 +0200
|
||||
+++ firefox-78.1.0/third_party/rust/thin-vec/.cargo-checksum.json 2020-08-17 17:04:24.134598587 +0200
|
||||
--- firefox-78.9.0/third_party/rust/thin-vec/.cargo-checksum.json.D87019-thin-vec-big-endian.diff 2021-03-18 15:53:29.529861836 +0100
|
||||
+++ firefox-78.9.0/third_party/rust/thin-vec/.cargo-checksum.json 2021-03-18 15:57:43.631168890 +0100
|
||||
@@ -1 +1 @@
|
||||
-{"files":{"Cargo.toml":"fb96cad605ae48215811808c1cc1b9a50248f2b14542058094b23983e2f8d8a0","README.md":"c26d7101e3031e7dd8890ce938e50cad7a1e6adf7fc2f2b0d3c36b03afe68c0b","src/heap.rs":"fe84a4ff433568d5713685456d87597ac5dcdb9d5190061a3da8074240ba1bc3","src/lib.rs":"ce36db8e3464dddade7c1ddbe3ee1f5e525af5be492ea51a0d8a0776c1adfc28","src/range.rs":"bac59bcb6230367a39c7e28ac15263e4526f966cd8c72015873017f17c115aaa"},"package":"73fdf4b84c65a85168477b7fb6c498e0716bc9487fba24623389ea7f51708044"}
|
||||
-{"files":{"Cargo.toml":"7b164cc8a702a204a4732cb4da2940711b8e3be915c258e2a972d4874d767b4c","README.md":"c26d7101e3031e7dd8890ce938e50cad7a1e6adf7fc2f2b0d3c36b03afe68c0b","src/lib.rs":"9f2a087cabfe0b6f83818323bb9004b45fe7548c51376816fd8d4572256bd0e8","src/range.rs":"bac59bcb6230367a39c7e28ac15263e4526f966cd8c72015873017f17c115aaa"},"package":"3a93c9ade36a827a69257925808463db46ffcf193442fad01eb9bdc1d31aed81"}
|
||||
\ No newline at end of file
|
||||
+{"files":{"Cargo.toml":"754c05523d17eb7591c3ea2c9294e47c05fbb257fed04b78546fb2ec7cafa8b4","README.md":"c26d7101e3031e7dd8890ce938e50cad7a1e6adf7fc2f2b0d3c36b03afe68c0b","src/lib.rs":"627c6094c3f0286dba25bc73f5672c06c5061c25b01c513d213cbdda100673a2"},"package":"dcc760ada4a9f56fc6d0e81bd143984ebc7bb1b875a6891aa2fa613ca7394fc0"}
|
||||
\ No newline at end of file
|
||||
diff -up firefox-78.1.0/third_party/rust/thin-vec/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/third_party/rust/thin-vec/Cargo.toml
|
||||
--- firefox-78.1.0/third_party/rust/thin-vec/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:29.000000000 +0200
|
||||
+++ firefox-78.1.0/third_party/rust/thin-vec/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
@@ -3,7 +3,7 @@
|
||||
# When uploading crates to the registry Cargo will automatically
|
||||
# "normalize" Cargo.toml files for maximal compatibility
|
||||
# with all versions of Cargo and also rewrite `path` dependencies
|
||||
-# to registry (e.g. crates.io) dependencies
|
||||
+# to registry (e.g., crates.io) dependencies
|
||||
#
|
||||
# If you believe there's an error in this file please file an
|
||||
# issue against the rust-lang/cargo repository. If you're
|
||||
@@ -11,16 +11,17 @@
|
||||
--- firefox-78.9.0/third_party/rust/thin-vec/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/third_party/rust/thin-vec/Cargo.toml 2021-03-18 15:59:34.162886751 +0100
|
||||
@@ -11,8 +11,9 @@
|
||||
# will likely look very different (and much more reasonable)
|
||||
|
||||
[package]
|
||||
+edition = "2018"
|
||||
name = "thin-vec"
|
||||
-version = "0.1.0"
|
||||
-version = "0.1.2"
|
||||
+version = "0.2.1"
|
||||
authors = ["Alexis Beingessner <a.beingessner@gmail.com>"]
|
||||
description = "a vec that takes up less space on the stack"
|
||||
homepage = "https://github.com/gankro/thin-vec"
|
||||
readme = "README.md"
|
||||
license = "MIT/Apache-2.0"
|
||||
repository = "https://github.com/gankro/thin-vec"
|
||||
-[dependencies.libc]
|
||||
-version = "0.2"
|
||||
+
|
||||
+[dependencies]
|
||||
|
||||
[features]
|
||||
default = []
|
||||
diff -up firefox-78.1.0/third_party/rust/thin-vec/src/heap.rs.D87019-thin-vec-big-endian.diff firefox-78.1.0/third_party/rust/thin-vec/src/heap.rs
|
||||
diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big-endian.diff firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs
|
||||
--- firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:28.000000000 +0200
|
||||
+++ firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs 2020-08-17 17:04:24.135598590 +0200
|
||||
@@ -1,50 +1,252 @@
|
||||
--- firefox-78.9.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/third_party/rust/thin-vec/src/lib.rs 2021-03-18 16:08:47.212871917 +0100
|
||||
@@ -1,47 +1,252 @@
|
||||
-mod range;
|
||||
+//! ThinVec is exactly the same as Vec, except that it stores its `len` and `capacity` in the buffer
|
||||
+//! it allocates.
|
||||
@ -297,23 +261,19 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
-use std::ops::{Deref, DerefMut};
|
||||
+use std::ops::{Deref, DerefMut, RangeBounds};
|
||||
use std::marker::PhantomData;
|
||||
+use std::alloc::*;
|
||||
use std::alloc::*;
|
||||
use std::cmp::*;
|
||||
use std::hash::*;
|
||||
use std::borrow::*;
|
||||
-use range::RangeArgument;
|
||||
use std::ptr::NonNull;
|
||||
|
||||
-// Heap shimming because reasons. This doesn't unfortunately match the heap api
|
||||
-// right now because reasons.
|
||||
-mod heap;
|
||||
+use impl_details::*;
|
||||
|
||||
-#[cfg(not(feature = "gecko-ffi"))]
|
||||
-type SizeType = usize;
|
||||
-#[cfg(feature = "gecko-ffi")]
|
||||
-type SizeType = u32;
|
||||
-
|
||||
+use impl_details::*;
|
||||
|
||||
-#[cfg(feature = "gecko-ffi")]
|
||||
-const AUTO_MASK: u32 = 1 << 31;
|
||||
-#[cfg(feature = "gecko-ffi")]
|
||||
@ -407,7 +367,8 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
+ #[cfg(target_endian = "big")]
|
||||
+ pub fn is_auto(cap: SizeType) -> bool {
|
||||
+ (cap & 1) != 0
|
||||
+ }
|
||||
}
|
||||
- x as SizeType
|
||||
+
|
||||
+ #[inline]
|
||||
+ pub fn assert_size(x: usize) -> SizeType {
|
||||
@ -415,8 +376,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
+ panic!("nsTArray size may not exceed the capacity of a 32-bit sized int");
|
||||
+ }
|
||||
+ x as SizeType
|
||||
}
|
||||
- x as SizeType
|
||||
+ }
|
||||
+
|
||||
}
|
||||
|
||||
@ -427,7 +387,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
#[repr(C)]
|
||||
struct Header {
|
||||
_len: SizeType,
|
||||
@@ -56,38 +258,10 @@ impl Header {
|
||||
@@ -53,38 +258,10 @@ impl Header {
|
||||
self._len as usize
|
||||
}
|
||||
|
||||
@ -466,7 +426,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
fn data<T>(&self) -> *mut T {
|
||||
let header_size = mem::size_of::<Header>();
|
||||
let padding = padding::<T>();
|
||||
@@ -105,6 +279,41 @@ impl Header {
|
||||
@@ -102,6 +279,41 @@ impl Header {
|
||||
}
|
||||
}
|
||||
|
||||
@ -508,7 +468,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
/// Singleton that all empty collections share.
|
||||
/// Note: can't store non-zero ZSTs, we allocate in that case. We could
|
||||
/// optimize everything to not do that (basically, make ptr == len and branch
|
||||
@@ -121,9 +330,7 @@ extern {
|
||||
@@ -118,9 +330,7 @@ extern {
|
||||
|
||||
// TODO: overflow checks everywhere
|
||||
|
||||
@ -519,35 +479,20 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
|
||||
fn alloc_size<T>(cap: usize) -> usize {
|
||||
// Compute "real" header size with pointer math
|
||||
@@ -156,15 +363,22 @@ fn alloc_align<T>() -> usize {
|
||||
max(mem::align_of::<T>(), mem::align_of::<Header>())
|
||||
}
|
||||
|
||||
-fn header_with_capacity<T>(cap: usize) -> NonNull<Header> {
|
||||
- debug_assert!(cap > 0);
|
||||
+fn layout<T>(cap: usize) -> Layout {
|
||||
@@ -165,9 +375,10 @@ fn layout<T>(cap: usize) -> Layout {
|
||||
fn header_with_capacity<T>(cap: usize) -> NonNull<Header> {
|
||||
debug_assert!(cap > 0);
|
||||
unsafe {
|
||||
- let header = heap::allocate(
|
||||
+ Layout::from_size_align_unchecked(
|
||||
alloc_size::<T>(cap),
|
||||
alloc_align::<T>(),
|
||||
- ) as *mut Header;
|
||||
+ )
|
||||
+ }
|
||||
+}
|
||||
|
||||
- if header.is_null() { oom() }
|
||||
+fn header_with_capacity<T>(cap: usize) -> NonNull<Header> {
|
||||
+ debug_assert!(cap > 0);
|
||||
+ unsafe {
|
||||
- let header = alloc(layout::<T>(cap)) as *mut Header;
|
||||
+ let layout = layout::<T>(cap);
|
||||
+ let header = alloc(layout) as *mut Header;
|
||||
+
|
||||
|
||||
- if header.is_null() { oom() }
|
||||
+ if header.is_null() { handle_alloc_error(layout) }
|
||||
|
||||
// "Infinite" capacity for zero-sized types:
|
||||
(*header).set_cap(if mem::size_of::<T>() == 0 { MAX_CAP } else { cap });
|
||||
@@ -176,28 +390,8 @@ fn header_with_capacity<T>(cap: usize) -
|
||||
@@ -179,28 +390,8 @@ fn header_with_capacity<T>(cap: usize) -
|
||||
|
||||
|
||||
|
||||
@ -578,7 +523,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
pub struct ThinVec<T> {
|
||||
ptr: NonNull<Header>,
|
||||
boo: PhantomData<T>,
|
||||
@@ -627,15 +821,15 @@ impl<T> ThinVec<T> {
|
||||
@@ -630,15 +821,15 @@ impl<T> ThinVec<T> {
|
||||
}
|
||||
|
||||
pub fn drain<R>(&mut self, range: R) -> Drain<T>
|
||||
@ -597,35 +542,11 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
Bound::Included(&n) => n + 1,
|
||||
Bound::Excluded(&n) => n,
|
||||
Bound::Unbounded => len,
|
||||
@@ -666,9 +860,10 @@ impl<T> ThinVec<T> {
|
||||
@@ -688,11 +879,30 @@ impl<T> ThinVec<T> {
|
||||
alloc_size::<T>(new_cap),
|
||||
) as *mut Header;
|
||||
|
||||
unsafe fn deallocate(&mut self) {
|
||||
if self.has_allocation() {
|
||||
- heap::deallocate(self.ptr() as *mut u8,
|
||||
- alloc_size::<T>(self.capacity()),
|
||||
- alloc_align::<T>());
|
||||
+ dealloc(
|
||||
+ self.ptr() as *mut u8,
|
||||
+ layout::<T>(self.capacity()),
|
||||
+ )
|
||||
}
|
||||
}
|
||||
|
||||
@@ -678,15 +873,36 @@ impl<T> ThinVec<T> {
|
||||
debug_assert!(new_cap > 0);
|
||||
if self.has_allocation() {
|
||||
let old_cap = self.capacity();
|
||||
- let ptr = heap::reallocate(self.ptr() as *mut u8,
|
||||
- alloc_size::<T>(old_cap),
|
||||
- alloc_size::<T>(new_cap),
|
||||
- alloc_align::<T>()) as *mut Header;
|
||||
- if ptr.is_null() { oom() }
|
||||
+ let ptr = realloc(
|
||||
+ self.ptr() as *mut u8,
|
||||
+ layout::<T>(old_cap),
|
||||
+ alloc_size::<T>(new_cap),
|
||||
+ ) as *mut Header;
|
||||
+
|
||||
+ if ptr.is_null() { handle_alloc_error(layout::<T>(new_cap)) }
|
||||
(*ptr).set_cap(new_cap);
|
||||
self.ptr = NonNull::new_unchecked(ptr);
|
||||
@ -654,7 +575,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1087,10 +1303,7 @@ mod tests {
|
||||
@@ -1093,10 +1303,7 @@ mod tests {
|
||||
use std::mem::size_of;
|
||||
assert_eq!(size_of::<ThinVec<u8>>(), size_of::<&u8>());
|
||||
|
||||
@ -666,7 +587,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
}
|
||||
|
||||
#[test]
|
||||
@@ -1725,7 +1938,6 @@ mod std_tests {
|
||||
@@ -1731,7 +1938,6 @@ mod std_tests {
|
||||
assert_eq!(v, &[(), ()]);
|
||||
}
|
||||
|
||||
@ -674,7 +595,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
#[test]
|
||||
fn test_drain_inclusive_range() {
|
||||
let mut v = thin_vec!['a', 'b', 'c', 'd', 'e'];
|
||||
@@ -1755,6 +1967,7 @@ mod std_tests {
|
||||
@@ -1761,6 +1967,7 @@ mod std_tests {
|
||||
}
|
||||
|
||||
#[test]
|
||||
@ -682,7 +603,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
fn test_drain_max_vec_size() {
|
||||
let mut v = ThinVec::<()>::with_capacity(usize::max_value());
|
||||
unsafe { v.set_len(usize::max_value()); }
|
||||
@@ -1775,7 +1988,6 @@ mod std_tests {
|
||||
@@ -1781,7 +1988,6 @@ mod std_tests {
|
||||
let mut v = thin_vec![1, 2, 3, 4, 5];
|
||||
v.drain(5..=5);
|
||||
}
|
||||
@ -690,7 +611,7 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
|
||||
/* TODO: implement splice?
|
||||
#[test]
|
||||
@@ -2181,7 +2393,7 @@ mod std_tests {
|
||||
@@ -2187,7 +2393,7 @@ mod std_tests {
|
||||
assert!(v.capacity() >= 33)
|
||||
}
|
||||
|
||||
@ -699,10 +620,8 @@ diff -up firefox-78.1.0/third_party/rust/thin-vec/src/lib.rs.D87019-thin-vec-big
|
||||
#[test]
|
||||
fn test_try_reserve() {
|
||||
|
||||
diff -up firefox-78.1.0/third_party/rust/thin-vec/src/range.rs.D87019-thin-vec-big-endian.diff firefox-78.1.0/third_party/rust/thin-vec/src/range.rs
|
||||
diff -up firefox-78.1.0/toolkit/components/cascade_bloom_filter/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/toolkit/components/cascade_bloom_filter/Cargo.toml
|
||||
--- firefox-78.1.0/toolkit/components/cascade_bloom_filter/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:29.000000000 +0200
|
||||
+++ firefox-78.1.0/toolkit/components/cascade_bloom_filter/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
--- firefox-78.9.0/toolkit/components/cascade_bloom_filter/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/toolkit/components/cascade_bloom_filter/Cargo.toml 2021-03-18 15:54:35.137670977 +0100
|
||||
@@ -8,5 +8,5 @@ nserror = { path = "../../../xpcom/rust/
|
||||
nsstring = { path = "../../../xpcom/rust/nsstring" }
|
||||
rental = "0.5.5"
|
||||
@ -710,9 +629,8 @@ diff -up firefox-78.1.0/toolkit/components/cascade_bloom_filter/Cargo.toml.D8701
|
||||
-thin-vec = { version = "0.1.0", features = ["gecko-ffi"] }
|
||||
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
|
||||
xpcom = { path = "../../../xpcom/rust/xpcom" }
|
||||
diff -up firefox-78.1.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml
|
||||
--- firefox-78.1.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:30.000000000 +0200
|
||||
+++ firefox-78.1.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
--- firefox-78.9.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/toolkit/components/extensions/storage/webext_storage_bridge/Cargo.toml 2021-03-18 15:54:35.139670971 +0100
|
||||
@@ -13,7 +13,7 @@ moz_task = { path = "../../../../../xpco
|
||||
nserror = { path = "../../../../../xpcom/rust/nserror" }
|
||||
nsstring = { path = "../../../../../xpcom/rust/nsstring" }
|
||||
@ -722,9 +640,8 @@ diff -up firefox-78.1.0/toolkit/components/extensions/storage/webext_storage_bri
|
||||
xpcom = { path = "../../../../../xpcom/rust/xpcom" }
|
||||
serde = "1"
|
||||
serde_json = "1"
|
||||
diff -up firefox-78.1.0/toolkit/components/kvstore/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/toolkit/components/kvstore/Cargo.toml
|
||||
--- firefox-78.1.0/toolkit/components/kvstore/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:30.000000000 +0200
|
||||
+++ firefox-78.1.0/toolkit/components/kvstore/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
--- firefox-78.9.0/toolkit/components/kvstore/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/toolkit/components/kvstore/Cargo.toml 2021-03-18 15:54:35.141670966 +0100
|
||||
@@ -18,7 +18,7 @@ rkv = "0.10.2"
|
||||
storage_variant = { path = "../../../storage/variant" }
|
||||
xpcom = { path = "../../../xpcom/rust/xpcom" }
|
||||
@ -734,9 +651,8 @@ diff -up firefox-78.1.0/toolkit/components/kvstore/Cargo.toml.D87019-thin-vec-bi
|
||||
|
||||
# Get rid of failure's dependency on backtrace. Eventually
|
||||
# backtrace will move into Rust core, but we don't need it here.
|
||||
diff -up firefox-78.1.0/toolkit/components/places/bookmark_sync/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/toolkit/components/places/bookmark_sync/Cargo.toml
|
||||
--- firefox-78.1.0/toolkit/components/places/bookmark_sync/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:30.000000000 +0200
|
||||
+++ firefox-78.1.0/toolkit/components/places/bookmark_sync/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
--- firefox-78.9.0/toolkit/components/places/bookmark_sync/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/toolkit/components/places/bookmark_sync/Cargo.toml 2021-03-18 15:54:35.142670963 +0100
|
||||
@@ -19,5 +19,5 @@ url = "2.0"
|
||||
xpcom = { path = "../../../../xpcom/rust/xpcom" }
|
||||
|
||||
@ -744,9 +660,8 @@ diff -up firefox-78.1.0/toolkit/components/places/bookmark_sync/Cargo.toml.D8701
|
||||
-version = "0.1.0"
|
||||
+version = "0.2.1"
|
||||
features = ["gecko-ffi"]
|
||||
diff -up firefox-78.1.0/tools/profiler/rust-helper/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/tools/profiler/rust-helper/Cargo.toml
|
||||
--- firefox-78.1.0/tools/profiler/rust-helper/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:30.000000000 +0200
|
||||
+++ firefox-78.1.0/tools/profiler/rust-helper/Cargo.toml 2020-08-17 17:04:24.135598590 +0200
|
||||
--- firefox-78.9.0/tools/profiler/rust-helper/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:42.000000000 +0100
|
||||
+++ firefox-78.9.0/tools/profiler/rust-helper/Cargo.toml 2021-03-18 15:54:35.143670960 +0100
|
||||
@@ -23,7 +23,7 @@ features = ["endian_fd", "elf32", "elf64
|
||||
default-features = false
|
||||
|
||||
@ -756,9 +671,8 @@ diff -up firefox-78.1.0/tools/profiler/rust-helper/Cargo.toml.D87019-thin-vec-bi
|
||||
features = ["gecko-ffi"]
|
||||
|
||||
[features]
|
||||
diff -up firefox-78.1.0/xpcom/rust/xpcom/Cargo.toml.D87019-thin-vec-big-endian.diff firefox-78.1.0/xpcom/rust/xpcom/Cargo.toml
|
||||
--- firefox-78.1.0/xpcom/rust/xpcom/Cargo.toml.D87019-thin-vec-big-endian.diff 2020-07-22 17:56:30.000000000 +0200
|
||||
+++ firefox-78.1.0/xpcom/rust/xpcom/Cargo.toml 2020-08-17 17:04:24.136598593 +0200
|
||||
--- firefox-78.9.0/xpcom/rust/xpcom/Cargo.toml.D87019-thin-vec-big-endian.diff 2021-03-15 16:52:43.000000000 +0100
|
||||
+++ firefox-78.9.0/xpcom/rust/xpcom/Cargo.toml 2021-03-18 15:54:35.149670942 +0100
|
||||
@@ -9,4 +9,4 @@ nsstring = { path = "../nsstring" }
|
||||
nserror = { path = "../nserror" }
|
||||
threadbound = "0.1"
|
||||
|
Loading…
Reference in New Issue
Block a user