Updated to latest upstream (63.0.1 build 4)
This commit is contained in:
parent
dcfbd3d772
commit
615b2f4e37
2
.gitignore
vendored
2
.gitignore
vendored
@ -315,3 +315,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-63.0.source.tar.xz
|
/firefox-63.0.source.tar.xz
|
||||||
/firefox-langpacks-63.0-20181018.tar.xz
|
/firefox-langpacks-63.0-20181018.tar.xz
|
||||||
/cbindgen-vendor.tar.xz
|
/cbindgen-vendor.tar.xz
|
||||||
|
/firefox-langpacks-63.0.1-20181101.tar.xz
|
||||||
|
/firefox-63.0.1.source.tar.xz
|
||||||
|
10
firefox.spec
10
firefox.spec
@ -86,13 +86,13 @@
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 63.0
|
Version: 63.0.1
|
||||||
Release: 2%{?pre_tag}%{?dist}
|
Release: 1%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{with langpacks}
|
%if %{with langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20181018.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20181101.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
@ -138,7 +138,6 @@ Patch226: rhbz-1354671.patch
|
|||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
Patch406: mozilla-256180.patch
|
Patch406: mozilla-256180.patch
|
||||||
Patch407: mozilla-1348576.patch
|
|
||||||
Patch410: mozilla-1321521.patch
|
Patch410: mozilla-1321521.patch
|
||||||
Patch411: mozilla-1321521-2.patch
|
Patch411: mozilla-1321521-2.patch
|
||||||
Patch412: mozilla-1337988.patch
|
Patch412: mozilla-1337988.patch
|
||||||
@ -909,6 +908,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 1 2018 Martin Stransky <stransky@redhat.com> - 63.0.1-1
|
||||||
|
- Updated to latest upstream (63.0.1 build 4)
|
||||||
|
|
||||||
* Tue Oct 23 2018 Martin Stransky <stransky@redhat.com> - 63.0-2
|
* Tue Oct 23 2018 Martin Stransky <stransky@redhat.com> - 63.0-2
|
||||||
- Updated to latest upstream (63.0 build 2)
|
- Updated to latest upstream (63.0 build 2)
|
||||||
|
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
diff -up firefox-53.0/browser/extensions/e10srollout/bootstrap.js.1348576 firefox-53.0/browser/extensions/e10srollout/bootstrap.js
|
|
||||||
--- firefox-53.0/browser/extensions/e10srollout/bootstrap.js.1348576 2017-04-18 13:06:29.660860929 +0200
|
|
||||||
+++ firefox-53.0/browser/extensions/e10srollout/bootstrap.js 2017-04-18 13:07:34.804627469 +0200
|
|
||||||
@@ -9,6 +9,7 @@ const {classes: Cc, interfaces: Ci, util
|
|
||||||
Cu.import("resource://gre/modules/Preferences.jsm");
|
|
||||||
Cu.import("resource://gre/modules/Services.jsm");
|
|
||||||
Cu.import("resource://gre/modules/UpdateUtils.jsm");
|
|
||||||
+Cu.import("resource://gre/modules/AppConstants.jsm");
|
|
||||||
|
|
||||||
// The amount of people to be part of e10s
|
|
||||||
const TEST_THRESHOLD = {
|
|
||||||
@@ -23,6 +24,23 @@ const ADDON_ROLLOUT_POLICY = {
|
|
||||||
"esr" : "esrA", // WebExtensions and Addons with mpc=true
|
|
||||||
};
|
|
||||||
|
|
||||||
+if (AppConstants.RELEASE_OR_BETA) {
|
|
||||||
+ // Bug 1348576 - e10s is never enabled for non-official release builds
|
|
||||||
+ // This is hacky, but the problem it solves is the following:
|
|
||||||
+ // the e10s rollout is controlled by the channel name, which
|
|
||||||
+ // is the only way to distinguish between Beta and Release.
|
|
||||||
+ // However, non-official release builds (like the ones done by distros
|
|
||||||
+ // to ship Firefox on their package managers) do not set a value
|
|
||||||
+ // for the release channel, which gets them to the default value
|
|
||||||
+ // of.. (drumroll) "default".
|
|
||||||
+ // But we can't just always configure the same settings for the
|
|
||||||
+ // "default" channel because that's also the name that a locally
|
|
||||||
+ // built Firefox gets, and e10s is managed in a different way
|
|
||||||
+ // there (directly by prefs, on Nightly and Aurora).
|
|
||||||
+ TEST_THRESHOLD.default = TEST_THRESHOLD.release;
|
|
||||||
+ ADDON_ROLLOUT_POLICY.default = ADDON_ROLLOUT_POLICY.release;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
const PREF_COHORT_SAMPLE = "e10s.rollout.cohortSample";
|
|
||||||
const PREF_COHORT_NAME = "e10s.rollout.cohort";
|
|
||||||
const PREF_E10S_OPTED_IN = "browser.tabs.remote.autostart";
|
|
||||||
diff -up firefox-53.0/browser/extensions/e10srollout/install.rdf.in.1348576 firefox-53.0/browser/extensions/e10srollout/install.rdf.in
|
|
||||||
--- firefox-53.0/browser/extensions/e10srollout/install.rdf.in.1348576 2017-04-11 06:15:16.000000000 +0200
|
|
||||||
+++ firefox-53.0/browser/extensions/e10srollout/install.rdf.in 2017-04-18 13:06:29.660860929 +0200
|
|
||||||
@@ -10,7 +10,7 @@
|
|
||||||
|
|
||||||
<Description about="urn:mozilla:install-manifest">
|
|
||||||
<em:id>e10srollout@mozilla.org</em:id>
|
|
||||||
- <em:version>1.14</em:version>
|
|
||||||
+ <em:version>1.15</em:version>
|
|
||||||
<em:type>2</em:type>
|
|
||||||
<em:bootstrap>true</em:bootstrap>
|
|
||||||
<em:multiprocessCompatible>true</em:multiprocessCompatible>
|
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (firefox-langpacks-63.0-20181018.tar.xz) = 340d4b40181cfe8aa0c0a5988651d982836dc5292b70e9942235219497ce36af099a733b00934d5c494134b29a971752da30166472e1e919d9419025f4cc5f94
|
|
||||||
SHA512 (cbindgen-vendor.tar.xz) = 6d1a6ef48e77920bccd51af27c836d66aed49a571a0f5298df9cc87724467a5542e382485aa6c5ed2b516277086ffe4d5360b9eb4c0ab62ef6e3e027fc736ead
|
SHA512 (cbindgen-vendor.tar.xz) = 6d1a6ef48e77920bccd51af27c836d66aed49a571a0f5298df9cc87724467a5542e382485aa6c5ed2b516277086ffe4d5360b9eb4c0ab62ef6e3e027fc736ead
|
||||||
SHA512 (firefox-63.0.source.tar.xz) = a206ea2968a6feec11eb4d03c294de29478f2f586145235c3beeba1f1233f0de13a50a20f56933eff6d4dd3729ad5aa8c89342638c8dd80b4642c579a0585b12
|
SHA512 (firefox-langpacks-63.0.1-20181101.tar.xz) = 7f197e5df57f9287bcdaf014049244fec8989f563899eeb29501a073321e7d55910020e426722be9d91865f20690ab0ea74b5518a2bcbc47d63b3e1eeaa601ce
|
||||||
|
SHA512 (firefox-63.0.1.source.tar.xz) = 29acad70259d71a924cbaf4c2f01fb034cf8090759b3a2d74a5eabc2823f83b6508434e619d8501d3930702e2bbad373581a70e2ce57aead9af77fc42766fbe2
|
||||||
|
Loading…
Reference in New Issue
Block a user