- Firefox 3 Final
This commit is contained in:
parent
e530b2e416
commit
5fe54d7035
@ -1 +1,2 @@
|
||||
mozilla-20080516.tar.bz2
|
||||
firefox-3.0-source.tar.bz2
|
||||
firefox-langpacks-3.0-20080617.tar.bz2
|
||||
|
@ -25,6 +25,7 @@ ac_add_options --enable-canvas
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-libxul
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --enable-safe-browsing
|
||||
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
||||
|
@ -3,6 +3,7 @@ pref("app.update.enabled", false);
|
||||
pref("app.update.autoInstallEnabled", false);
|
||||
pref("browser.backspace_action", 2);
|
||||
pref("browser.display.use_system_colors", true);
|
||||
pref("browser.download.folderList", 1);
|
||||
pref("browser.link.open_external", 3);
|
||||
pref("browser.shell.checkDefaultBrowser", false);
|
||||
pref("general.smoothScroll", true);
|
||||
|
102
firefox.spec
102
firefox.spec
@ -1,25 +1,26 @@
|
||||
%define homepage http://start.fedoraproject.org/
|
||||
%define firstrun http://fedoraproject.org/static/firefox/
|
||||
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
|
||||
%define desktop_file_utils_version 0.9
|
||||
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
|
||||
|
||||
%define version_internal 3.0pre
|
||||
%define mozappdir %{_libdir}/%{name}-%{version_internal}
|
||||
%define version_internal 3.0
|
||||
%define mozappdir %{_libdir}/%{name}-%{version_internal}
|
||||
|
||||
%define gecko_version 1.9
|
||||
%define gecko_version 1.9
|
||||
|
||||
%define official_branding 0
|
||||
%define build_langpacks 0
|
||||
%define official_branding 1
|
||||
%define build_langpacks 1
|
||||
|
||||
%if ! %{official_branding}
|
||||
%define cvsdate 20080416
|
||||
%define cvsdate 20080327
|
||||
%define nightly .cvs%{cvsdate}
|
||||
%endif
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 3.0
|
||||
Release: 0.65%{?nightly}%{?dist}
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -29,7 +30,9 @@ Group: Applications/Internet
|
||||
%define tarball mozilla-%{cvsdate}.tar.bz2
|
||||
%endif
|
||||
Source0: %{tarball}
|
||||
#Source2: firefox-langpacks-20080104.tar.bz2
|
||||
%if %{build_langpacks}
|
||||
Source2: firefox-langpacks-%{version}-20080617.tar.bz2
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source11: firefox-mozconfig-branded
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -40,11 +43,13 @@ Source23: firefox.1
|
||||
Source100: find-external-requires
|
||||
|
||||
|
||||
# other patches
|
||||
Patch43: firefox-2.0-getstartpage.patch
|
||||
Patch1: firefox-2.0-getstartpage.patch
|
||||
|
||||
# Upstream patches
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
Patch10: mozilla-firstrun.patch
|
||||
|
||||
|
||||
%else
|
||||
@ -90,14 +95,13 @@ compliance, performance and portability.
|
||||
%setup -q -c
|
||||
cd mozilla
|
||||
|
||||
%patch43 -p1 -b .getstartpage
|
||||
|
||||
%patch1 -p1 -b .getstartpage
|
||||
|
||||
# For branding specific patches.
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
|
||||
%patch10 -p1 -b .firstrun
|
||||
|
||||
%else
|
||||
# Not yet approved by Mozilla Corporation
|
||||
@ -173,8 +177,8 @@ desktop-file-install --vendor mozilla \
|
||||
# set up our default homepage
|
||||
%{__cat} >> rh-default-prefs << EOF
|
||||
pref("browser.startup.homepage", "%{homepage}");
|
||||
pref("startup.homepage_override_url", "%{homepage}");
|
||||
pref("startup.homepage_welcome_url", "%{homepage}");
|
||||
pref("startup.homepage_override_url", "%{firstrun}");
|
||||
pref("startup.homepage_welcome_url", "%{firstrun}");
|
||||
EOF
|
||||
|
||||
# place the preferences
|
||||
@ -204,9 +208,9 @@ ln -s %{default_bookmarks_file} $RPM_BUILD_ROOT/%{mozappdir}/defaults/profile/bo
|
||||
%{__cp} other-licenses/branding/%{name}/default16.png \
|
||||
$RPM_BUILD_ROOT/%{mozappdir}/icons/
|
||||
|
||||
echo > ../%{name}.lang
|
||||
%if %{build_langpacks}
|
||||
# Install langpacks
|
||||
touch ../%{name}.lang
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/extensions
|
||||
%{__tar} xjf %{SOURCE2}
|
||||
for langpack in `ls firefox-langpacks/*.xpi`; do
|
||||
@ -223,7 +227,8 @@ for langpack in `ls firefox-langpacks/*.xpi`; do
|
||||
unzip $jarfile -d $langtmp
|
||||
|
||||
sed -i -e "s|browser.startup.homepage.*$|browser.startup.homepage=%{homepage}|g;" \
|
||||
-e "s|startup.homepage_override_url.*$|startup.homepage_override_url=%{homepage}|g;" \
|
||||
-e "s|startup.homepage_override_url.*$|startup.homepage_override_url=%{firstrun}|g;" \
|
||||
-e "s|startup.homepage_welcome_url.*$|startup.homepage_welcome_url=%{firstrun}|g;" \
|
||||
$langtmp/locale/browser-region/region.properties
|
||||
|
||||
find $langtmp -type f | xargs chmod 644
|
||||
@ -240,21 +245,20 @@ done
|
||||
%{__rm} -rf firefox-langpacks
|
||||
%endif # build_langpacks
|
||||
|
||||
%if ! %{build_langpacks}
|
||||
touch ../%{name}.lang
|
||||
%endif
|
||||
|
||||
# System extensions
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{firefox_app_id}
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{firefox_app_id}
|
||||
|
||||
# Copy over the LICENSE
|
||||
install -c -m 644 LICENSE $RPM_BUILD_ROOT/%{mozappdir}
|
||||
%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT/%{mozappdir}
|
||||
|
||||
# ghost files
|
||||
touch $RPM_BUILD_ROOT/%{mozappdir}/components/compreg.dat
|
||||
touch $RPM_BUILD_ROOT/%{mozappdir}/components/xpti.dat
|
||||
|
||||
# jemalloc shows up sometimes, but it's not needed here, it's in XR
|
||||
%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/libjemalloc.so
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%clean
|
||||
@ -288,7 +292,7 @@ fi
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/firefox
|
||||
%{_mandir}/man1/*
|
||||
%doc %{_mandir}/man1/*
|
||||
%dir %{_datadir}/mozilla/extensions/%{firefox_app_id}
|
||||
%dir %{_libdir}/mozilla/extensions/%{firefox_app_id}
|
||||
%{_datadir}/applications/mozilla-%{name}.desktop
|
||||
@ -315,52 +319,48 @@ fi
|
||||
%{mozappdir}/application.ini
|
||||
%dir %{mozappdir}/modules
|
||||
%{mozappdir}/modules/distribution.js
|
||||
%{mozappdir}/removed-files
|
||||
%{mozappdir}/.autoreg
|
||||
# XXX See if these are needed still
|
||||
%{mozappdir}/updater*
|
||||
%exclude %{mozappdir}/removed-files
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.65
|
||||
- Revert to 2008-04-16 trunk
|
||||
* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 3.0-1
|
||||
- Firefox 3 Final
|
||||
|
||||
* Fri Apr 16 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.63
|
||||
- Update to latest trunk (2008-05-16)
|
||||
* Thu May 08 2008 Colin Walters <walters@redhat.com> 3.0-0.61
|
||||
- Rebuild to pick up new xulrunner (bug #445543)
|
||||
|
||||
* Wed Apr 16 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.61
|
||||
- Update to latest trunk (2008-04-16)
|
||||
* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.60
|
||||
- Rebuild
|
||||
|
||||
* Mon Apr 14 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.60
|
||||
- Update to latest trunk (2008-04-14)
|
||||
* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.59
|
||||
- Zero out the lang file we generate during builds
|
||||
|
||||
* Tue Apr 8 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.59
|
||||
- Update to latest trunk (2008-04-08)
|
||||
* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.58
|
||||
- Bounce a few unneeded items from the spec and clean up some tabs
|
||||
|
||||
* Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.58
|
||||
- Update to latest trunk (2008-04-07)
|
||||
* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 3.0-0.57
|
||||
- Enable anti-pishing protection (#443403)
|
||||
|
||||
* Sun Apr 6 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.57
|
||||
- Update to latest trunk (2008-04-06)
|
||||
* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 3.0-0.55
|
||||
- Don't show an welcome page during first browser start (#437065)
|
||||
|
||||
* Sat Apr 5 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.56
|
||||
- Update to latest trunk (2008-04-05)
|
||||
* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.54
|
||||
- Remove the broken Macedonian (mk) langpack
|
||||
- Download to Download/
|
||||
|
||||
* Fri Apr 4 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.55
|
||||
- Update to latest trunk (2008-04-04)
|
||||
* Mon Apr 7 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.53
|
||||
- Add langpacks, marked with %%lang
|
||||
- Translate the .desktop file
|
||||
|
||||
* Thu Apr 3 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.54
|
||||
- Update to latest trunk (2008-04-03)
|
||||
|
||||
* Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.53
|
||||
- Update to latest trunk (2008-04-02)
|
||||
|
||||
* Tue Apr 1 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.52
|
||||
- Update to latest trunk (2008-04-01)
|
||||
* Wed Apr 2 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.52
|
||||
- Beta 5
|
||||
|
||||
* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.51
|
||||
- Update to latest trunk (2008-03-31)
|
||||
- Beta 5 RC2
|
||||
|
||||
* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 3.0-0.50
|
||||
- Update to latest trunk (2008-03-27)
|
||||
|
51
mozilla-firstrun.patch
Normal file
51
mozilla-firstrun.patch
Normal file
@ -0,0 +1,51 @@
|
||||
diff -up mozilla/browser/base/jar.mn.firstrun mozilla/browser/base/jar.mn
|
||||
--- mozilla/browser/base/jar.mn.firstrun 2008-06-15 12:39:28.000000000 -0700
|
||||
+++ mozilla/browser/base/jar.mn 2008-06-15 12:39:34.000000000 -0700
|
||||
@@ -21,9 +21,6 @@ browser.jar:
|
||||
* content/browser/browser.js (content/browser.js)
|
||||
* content/browser/browser.xul (content/browser.xul)
|
||||
* content/browser/credits.xhtml (content/credits.xhtml)
|
||||
-* content/browser/EULA.js (content/EULA.js)
|
||||
-* content/browser/EULA.xhtml (content/EULA.xhtml)
|
||||
-* content/browser/EULA.xul (content/EULA.xul)
|
||||
* content/browser/metaData.js (content/metaData.js)
|
||||
* content/browser/metaData.xul (content/metaData.xul)
|
||||
* content/browser/pageinfo/pageInfo.xul (content/pageinfo/pageInfo.xul)
|
||||
diff -up mozilla/browser/components/nsBrowserGlue.js.firstrun mozilla/browser/components/nsBrowserGlue.js
|
||||
--- mozilla/browser/components/nsBrowserGlue.js.firstrun 2008-06-15 11:28:29.000000000 -0700
|
||||
+++ mozilla/browser/components/nsBrowserGlue.js 2008-06-15 11:28:36.000000000 -0700
|
||||
@@ -175,34 +175,6 @@ BrowserGlue.prototype = {
|
||||
// profile startup handler (contains profile initialization routines)
|
||||
_onProfileStartup: function()
|
||||
{
|
||||
- // Check to see if the EULA must be shown on startup
|
||||
-
|
||||
- // Global override for tinderbox machines
|
||||
- var prefBranch = Cc["@mozilla.org/preferences-service;1"].
|
||||
- getService(Ci.nsIPrefBranch);
|
||||
- var mustDisplayEULA = true;
|
||||
- try {
|
||||
- mustDisplayEULA = !prefBranch.getBoolPref("browser.EULA.override");
|
||||
- } catch (e) {
|
||||
- // Pref might not exist
|
||||
- }
|
||||
-
|
||||
- // Make sure it hasn't already been accepted
|
||||
- if (mustDisplayEULA) {
|
||||
- try {
|
||||
- var EULAVersion = prefBranch.getIntPref("browser.EULA.version");
|
||||
- mustDisplayEULA = !prefBranch.getBoolPref("browser.EULA." + EULAVersion + ".accepted");
|
||||
- } catch(ex) {
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- if (mustDisplayEULA) {
|
||||
- var ww2 = Cc["@mozilla.org/embedcomp/window-watcher;1"].
|
||||
- getService(Ci.nsIWindowWatcher);
|
||||
- ww2.openWindow(null, "chrome://browser/content/EULA.xul",
|
||||
- "_blank", "chrome,centerscreen,modal,resizable=yes", null);
|
||||
- }
|
||||
-
|
||||
this.Sanitizer.onStartup();
|
||||
// check if we're in safe mode
|
||||
var app = Cc["@mozilla.org/xre/app-info;1"].getService(Ci.nsIXULAppInfo).
|
Loading…
Reference in New Issue
Block a user