Added rust config
This commit is contained in:
parent
adddd87658
commit
5a87c5b32c
13
firefox.spec
13
firefox.spec
@ -56,9 +56,9 @@ ExcludeArch: ppc64le ppc64 s390x
|
||||
|
||||
%define build_with_rust 1
|
||||
|
||||
%ifarch ppc64 ppc64le s390x
|
||||
%define build_with_rust 0
|
||||
%endif
|
||||
#%ifarch ppc64 ppc64le s390x
|
||||
#%define build_with_rust 0
|
||||
#%endif
|
||||
|
||||
# Build as a debug package?
|
||||
%define debug_build 0
|
||||
@ -89,7 +89,6 @@ ExcludeArch: ppc64le ppc64 s390x
|
||||
%global mozappdir %{_libdir}/%{name}
|
||||
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
||||
%global langpackdir %{mozappdir}/langpacks
|
||||
%global tarballdir %{name}-%{version}
|
||||
|
||||
%define official_branding 1
|
||||
%define build_langpacks 1
|
||||
@ -146,6 +145,7 @@ Patch225: mozilla-1005640-accept-lang.patch
|
||||
Patch226: rhbz-1354671.patch
|
||||
Patch227: rhbz-1400293-fix-mozilla-1324096.patch
|
||||
Patch229: firefox-nss-version.patch
|
||||
Patch230: mozilla-rust-config.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch304: mozilla-1253216.patch
|
||||
@ -292,8 +292,7 @@ This package contains results of tests executed during build.
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%prep
|
||||
%setup -q -c
|
||||
cd %{tarballdir}
|
||||
%setup -q
|
||||
|
||||
# Build patches, can't change backup suffix from default because during build
|
||||
# there is a compare of config and js/config directories and .orig suffix is
|
||||
@ -327,6 +326,7 @@ cd %{tarballdir}
|
||||
%endif
|
||||
%patch227 -p1 -b .rh1400293
|
||||
%patch229 -p1 -b .nss-version
|
||||
%patch230 -p1 -b .rust
|
||||
|
||||
%patch304 -p1 -b .1253216
|
||||
%patch402 -p1 -b .1196777
|
||||
@ -584,7 +584,6 @@ rm -f objdir/dist/bin/pk12util
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%install
|
||||
cd %{tarballdir}
|
||||
|
||||
# set up our default bookmarks
|
||||
%{__cp} -p %{default_bookmarks_file} objdir/dist/bin/browser/chrome/en-US/locale/browser/bookmarks.html
|
||||
|
22
mozilla-rust-config.patch
Normal file
22
mozilla-rust-config.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -up firefox-53.0.2/build/moz.configure/rust.configure.powerpc-rust firefox-53.0.2/build/moz.configure/rust.configure
|
||||
--- firefox-53.0.2/build/moz.configure/rust.configure.powerpc-rust 2017-05-25 13:07:00.041331688 +0200
|
||||
+++ firefox-53.0.2/build/moz.configure/rust.configure 2017-05-25 13:59:49.692189995 +0200
|
||||
@@ -131,6 +131,9 @@ def rust_triple_alias(host_or_target):
|
||||
('sparc64', 'Linux'): 'sparc64-unknown-linux-gnu',
|
||||
('x86', 'Linux'): 'i686-unknown-linux-gnu',
|
||||
('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
|
||||
+ ('ppc64le', 'Linux'): 'powerpc64le-unknown-linux-gnu',
|
||||
+ ('ppc64', 'Linux'): 'powerpc64-unknown-linux-gnu',
|
||||
+ ('s390x', 'Linux'): 's390x-unknown-linux-gnu',
|
||||
# OS X
|
||||
('x86', 'OSX'): 'i686-apple-darwin',
|
||||
('x86_64', 'OSX'): 'x86_64-apple-darwin',
|
||||
@@ -151,7 +154,7 @@ def rust_triple_alias(host_or_target):
|
||||
}.get((host_or_target.cpu, os_or_kernel), None)
|
||||
|
||||
if rustc_target is None:
|
||||
- die("Don't know how to translate {} for rustc".format(host_or_target.alias))
|
||||
+ die("Don't know how to translate {} for rustc, cpu: {}, os: {}".format(target.alias, target.cpu, os_or_kernel))
|
||||
|
||||
# Check to see whether our rustc has a reasonably functional stdlib
|
||||
# for our chosen target.
|
Loading…
Reference in New Issue
Block a user