Merge
This commit is contained in:
commit
51c2280ec1
@ -54,6 +54,6 @@
|
|||||||
<screenshot>https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/firefox/c.png</screenshot>
|
<screenshot>https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/firefox/c.png</screenshot>
|
||||||
</screenshots>
|
</screenshots>
|
||||||
<releases>
|
<releases>
|
||||||
<release version="__VERSION__"/>
|
<release version="__VERSION__" date="__DATE__"/>
|
||||||
</releases>
|
</releases>
|
||||||
</component>
|
</component>
|
||||||
|
16
firefox.spec
16
firefox.spec
@ -7,7 +7,8 @@
|
|||||||
%global create_debuginfo 1
|
%global create_debuginfo 1
|
||||||
%global system_nss 1
|
%global system_nss 1
|
||||||
|
|
||||||
# Disabled due to https://bugzilla.redhat.com/show_bug.cgi?id=1886672
|
# There are still build problems on s390x, see
|
||||||
|
# https://koji.fedoraproject.org/koji/taskinfo?taskID=55048351
|
||||||
ExcludeArch: s390x
|
ExcludeArch: s390x
|
||||||
|
|
||||||
%ifarch armv7hl
|
%ifarch armv7hl
|
||||||
@ -190,6 +191,7 @@ Patch414: mozilla-1656727.patch
|
|||||||
Patch415: mozilla-1670333.patch
|
Patch415: mozilla-1670333.patch
|
||||||
Patch416: mozilla-1673202.patch
|
Patch416: mozilla-1673202.patch
|
||||||
Patch417: mozilla-1673313.patch
|
Patch417: mozilla-1673313.patch
|
||||||
|
Patch418: mozilla-1556931-s390x-hidden-syms.patch
|
||||||
|
|
||||||
# Wayland specific upstream patches
|
# Wayland specific upstream patches
|
||||||
Patch574: firefox-pipewire-0-2.patch
|
Patch574: firefox-pipewire-0-2.patch
|
||||||
@ -403,6 +405,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch416 -p1 -b .1673202
|
%patch416 -p1 -b .1673202
|
||||||
%endif
|
%endif
|
||||||
%patch417 -p1 -b .1673313
|
%patch417 -p1 -b .1673313
|
||||||
|
%patch418 -p1 -b .1556931-s390x-hidden-syms
|
||||||
|
|
||||||
# Wayland specific upstream patches
|
# Wayland specific upstream patches
|
||||||
%if 0%{?fedora} > 31 || 0%{?eln}
|
%if 0%{?fedora} > 31 || 0%{?eln}
|
||||||
@ -858,7 +861,9 @@ sed -i -e "s/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/" %{buildroot}/%{moz
|
|||||||
|
|
||||||
# Install appdata file
|
# Install appdata file
|
||||||
mkdir -p %{buildroot}%{_datadir}/metainfo
|
mkdir -p %{buildroot}%{_datadir}/metainfo
|
||||||
%{__sed} -e 's/__VERSION__/%{version}/' %{SOURCE33} > %{buildroot}%{_datadir}/metainfo/firefox.appdata.xml
|
%{__sed} -e "s/__VERSION__/%{version}/" \
|
||||||
|
-e "s/__DATE__/$(date '+%F')/" \
|
||||||
|
%{SOURCE33} > %{buildroot}%{_datadir}/metainfo/firefox.appdata.xml
|
||||||
|
|
||||||
# Install Gnome search provider files
|
# Install Gnome search provider files
|
||||||
mkdir -p %{buildroot}%{_datadir}/gnome-shell/search-providers
|
mkdir -p %{buildroot}%{_datadir}/gnome-shell/search-providers
|
||||||
@ -980,6 +985,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
* Tue Nov 9 2020 Martin Stransky <stransky@redhat.com> - 82.0.3-1
|
* Tue Nov 9 2020 Martin Stransky <stransky@redhat.com> - 82.0.3-1
|
||||||
- Updated to 82.0.3
|
- Updated to 82.0.3
|
||||||
|
|
||||||
|
* Mon Nov 09 2020 Kalev Lember <klember@redhat.com> - 82.0.2-7
|
||||||
|
- Include date in appdata release tags
|
||||||
|
|
||||||
|
* Fri Nov 6 2020 Tomas Popela <tpopela@redhat.com> - 82.0.2-6
|
||||||
|
- Re-enable s390x buils by backporting a change from Thunderbird
|
||||||
|
https://src.fedoraproject.org/rpms/thunderbird/c/5f0bec1b5b79e117cc469710afbfa4d008af9c29?branch=master
|
||||||
|
|
||||||
* Tue Nov 3 2020 Martin Stransky <stransky@redhat.com> - 82.0.2-5
|
* Tue Nov 3 2020 Martin Stransky <stransky@redhat.com> - 82.0.2-5
|
||||||
- Added mozilla-openh264 dependency to play H264 clips out of the box
|
- Added mozilla-openh264 dependency to play H264 clips out of the box
|
||||||
- Updated Firefox tests
|
- Updated Firefox tests
|
||||||
|
25
mozilla-1556931-s390x-hidden-syms.patch
Normal file
25
mozilla-1556931-s390x-hidden-syms.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff --git a/gfx/angle/checkout/src/compiler/translator/tree_util/IntermTraverse.cpp b/gfx/angle/checkout/src/compiler/translator/tree_util/IntermTraverse.cpp
|
||||||
|
index c38baa12bffa8..2858a7bb4d319 100644
|
||||||
|
--- a/gfx/angle/checkout/src/compiler/translator/tree_util/IntermTraverse.cpp
|
||||||
|
+++ b/gfx/angle/checkout/src/compiler/translator/tree_util/IntermTraverse.cpp
|
||||||
|
@@ -45,16 +45,20 @@ void TIntermTraverser::traverse(T *node)
|
||||||
|
++childIndex;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (visit && postVisit)
|
||||||
|
node->visit(PostVisit, this);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+// Instantiate template for RewriteAtomicFunctionExpressions.
|
||||||
|
+template
|
||||||
|
+void TIntermTraverser::traverse(TIntermNode *);
|
||||||
|
+
|
||||||
|
void TIntermNode::traverse(TIntermTraverser *it)
|
||||||
|
{
|
||||||
|
it->traverse(this);
|
||||||
|
}
|
||||||
|
|
||||||
|
void TIntermSymbol::traverse(TIntermTraverser *it)
|
||||||
|
{
|
||||||
|
TIntermTraverser::ScopedNodeInTraversalPath addToPath(it, this);
|
Loading…
Reference in New Issue
Block a user