Fixing pipewire 0.3
This commit is contained in:
parent
73252a50c5
commit
504b2911e3
@ -1,64 +0,0 @@
|
|||||||
diff -up firefox-68.0/config/system-headers.mozbuild.firefox-pipewire firefox-68.0/config/system-headers.mozbuild
|
|
||||||
--- firefox-68.0/config/system-headers.mozbuild.firefox-pipewire 2019-07-01 22:30:26.000000000 +0200
|
|
||||||
+++ firefox-68.0/config/system-headers.mozbuild 2019-07-08 15:26:15.397161627 +0200
|
|
||||||
@@ -314,6 +314,7 @@ system_headers = [
|
|
||||||
'Gestalt.h',
|
|
||||||
'getopt.h',
|
|
||||||
'gio/gio.h',
|
|
||||||
+ 'gio/gunixfdlist.h',
|
|
||||||
'glibconfig.h',
|
|
||||||
'glib.h',
|
|
||||||
'glib-object.h',
|
|
||||||
@@ -607,6 +608,7 @@ system_headers = [
|
|
||||||
'Pgenerr.h',
|
|
||||||
'PGenErr.h',
|
|
||||||
'Ph.h',
|
|
||||||
+ 'pipewire/pipewire.h',
|
|
||||||
'pixman.h',
|
|
||||||
'pk11func.h',
|
|
||||||
'pk11pqg.h',
|
|
||||||
diff -up firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build
|
|
||||||
--- firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build.firefox-pipewire 2019-07-01 22:30:33.000000000 +0200
|
|
||||||
+++ firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_generic_gn/moz.build 2019-07-08 15:26:15.397161627 +0200
|
|
||||||
@@ -194,6 +194,29 @@ if CONFIG["OS_TARGET"] == "Linux":
|
|
||||||
"/media/webrtc/trunk/webrtc/modules/desktop_capture/window_capturer_linux.cc"
|
|
||||||
]
|
|
||||||
|
|
||||||
+# PipeWire specific files
|
|
||||||
+if CONFIG["OS_TARGET"] == "Linux":
|
|
||||||
+
|
|
||||||
+ DEFINES["WEBRTC_USE_PIPEWIRE"] = "1"
|
|
||||||
+
|
|
||||||
+ OS_LIBS += [
|
|
||||||
+ "rt",
|
|
||||||
+ "pipewire-0.3",
|
|
||||||
+ "glib-2.0",
|
|
||||||
+ "gio-2.0",
|
|
||||||
+ "gobject-2.0"
|
|
||||||
+ ]
|
|
||||||
+
|
|
||||||
+ CXXFLAGS += CONFIG['TK_CFLAGS']
|
|
||||||
+ CXXFLAGS += [ "-I/usr/include/pipewire-0.3" ]
|
|
||||||
+
|
|
||||||
+ UNIFIED_SOURCES += [
|
|
||||||
+ "/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc",
|
|
||||||
+ "/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/screen_capturer_pipewire.cc",
|
|
||||||
+ "/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/window_capturer_pipewire.cc"
|
|
||||||
+ ]
|
|
||||||
+
|
|
||||||
+
|
|
||||||
if CONFIG["OS_TARGET"] == "NetBSD":
|
|
||||||
|
|
||||||
DEFINES["USE_X11"] = "1"
|
|
||||||
diff -up firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h
|
|
||||||
--- firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h.firefox-pipewire 2019-07-08 16:42:13.936254926 +0200
|
|
||||||
+++ firefox-68.0/media/webrtc/trunk/webrtc/modules/desktop_capture/desktop_capture_options.h 2019-07-08 16:42:17.509264974 +0200
|
|
||||||
@@ -141,7 +141,7 @@ class DesktopCaptureOptions {
|
|
||||||
bool disable_effects_ = true;
|
|
||||||
bool detect_updated_region_ = false;
|
|
||||||
#if defined(WEBRTC_USE_PIPEWIRE)
|
|
||||||
- bool allow_pipewire_ = false;
|
|
||||||
+ bool allow_pipewire_ = true;
|
|
||||||
#endif
|
|
||||||
};
|
|
||||||
|
|
13
firefox.spec
13
firefox.spec
@ -184,7 +184,6 @@ Patch430: mozilla-1605795-popup-parent-fix.patch
|
|||||||
|
|
||||||
# Wayland specific upstream patches
|
# Wayland specific upstream patches
|
||||||
Patch574: firefox-pipewire.patch
|
Patch574: firefox-pipewire.patch
|
||||||
Patch575: firefox-pipewire-0.3.patch
|
|
||||||
|
|
||||||
# PGO/LTO patches
|
# PGO/LTO patches
|
||||||
Patch600: pgo.patch
|
Patch600: pgo.patch
|
||||||
@ -230,7 +229,13 @@ BuildRequires: clang-libs
|
|||||||
%if 0%{?build_with_clang}
|
%if 0%{?build_with_clang}
|
||||||
BuildRequires: lld
|
BuildRequires: lld
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?fedora} < 32
|
||||||
BuildRequires: pipewire-devel
|
BuildRequires: pipewire-devel
|
||||||
|
%else
|
||||||
|
BuildRequires: pipewire02-devel
|
||||||
|
%endif
|
||||||
|
|
||||||
%if !0%{?use_bundled_cbindgen}
|
%if !0%{?use_bundled_cbindgen}
|
||||||
BuildRequires: cbindgen
|
BuildRequires: cbindgen
|
||||||
%endif
|
%endif
|
||||||
@ -390,11 +395,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch430 -p1 -b .1605795-popup-parent-fix
|
%patch430 -p1 -b .1605795-popup-parent-fix
|
||||||
|
|
||||||
# Wayland specific upstream patches
|
# Wayland specific upstream patches
|
||||||
%if 0%{?fedora} < 32
|
|
||||||
%patch574 -p1 -b .firefox-pipewire
|
%patch574 -p1 -b .firefox-pipewire
|
||||||
%else
|
|
||||||
%patch575 -p1 -b .firefox-pipewire
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# PGO patches
|
# PGO patches
|
||||||
%patch600 -p1 -b .pgo
|
%patch600 -p1 -b .pgo
|
||||||
@ -972,7 +973,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Feb 24 2020 Martin Stransky <stransky@redhat.com> - 73.0.1-4
|
* Mon Feb 24 2020 Martin Stransky <stransky@redhat.com> - 73.0.1-4
|
||||||
- Update pipewire patch for Fedora 32
|
- Using pipewire-0.2 as buildrequire
|
||||||
- Added armv7hl fixes by Gabriel Hojda
|
- Added armv7hl fixes by Gabriel Hojda
|
||||||
|
|
||||||
* Mon Feb 24 2020 Martin Stransky <stransky@redhat.com> - 73.0.1-2
|
* Mon Feb 24 2020 Martin Stransky <stransky@redhat.com> - 73.0.1-2
|
||||||
|
Loading…
Reference in New Issue
Block a user